Results 1 to 2 of 2

Thread: /etc/TZ with custom firmware and optware packages

  1. #1

    /etc/TZ with custom firmware and optware packages

    The customized Asus firmware offers a lot of possibilites of expansion via the optware set of packages. This suite installs into /opt which may be mapped to internal HD or storage attached to the wl700ge.

    I've tried to install a few of these including packages like mysql and PHP. These install fine, however won't run properly. After running them via strace, I discovered there is a reliance on the file /etc/TZ by many of the optware packages. Unfortunately with the custom firmware, you can't write to the /etc directory.

    How hard would it be to make a new firmware that also includes a symbolic link from /TZ to /tmp/TZ? This could then further be linked to /opt/etc/TZ in much the same way as /etc/shells, for example, works now.

  2. #2
    You're right, I came across the same problem. Maybe one of the following can help:

    1. You could follow the directions on my web site and add your own TZ symlink into /etc. I detailed every step of my modifications to the released asus code.

    2. Use "mount -o bind" to mount over the existing /etc with another one located somewhere on the HDD. One warning if you do this, you may have to pull some tricks to get your router to shut down properly. I can post details if you're interested.

    3. Try adding something similar to this to rc.local prior to launching the sensitive applications:

    export TZ

    I think #3 is the easiest/safest.

    - K.C.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts