Results 1 to 5 of 5

Thread: Is this useful for WL700ge?

  1. #1

    Is this useful for WL700ge?

    This article says X-Wrt works with OpenWrt White Russian, but the OpenWrt site says the latest release is Kamikaze 7.06, June 2007.

    Kamikaze is supposed to run on the Wl700ge.

    Is this worth investigation? OpenWrt has a lot of packages built for it.

  2. #2
    It definitly is :-)

    I'm running the latest build 7660 with X-Wrt for Kamikaze.

    X-Wrt is usable but not finished yet.

    The rest is highly flexible but you need linux experience for the console based configuration.

  3. #3
    Quote Originally Posted by DaNawq View Post
    It definitly is :-)

    I'm running the latest build 7660 with X-Wrt for Kamikaze.

    X-Wrt is usable but not finished yet.

    The rest is highly flexible but you need linux experience for the console based configuration.
    I can do console based configuration, and I can use a linux command line to some extent.

    However, having said that, there is a lot of process to go through there that is not clearly & explicitly defined step by step. I think I can follow it, but ... I have to say, it looks very, shall we say, "risky"?

    I have to reformat the disk. That means I have to move all of my user's data off it to another disk ... perhaps archive to DVD's or something. Then I have to install Kamikaze, and then configure it "by hand" (I can't find any good instructions on how to connect via ADSL modem to my ISP BTW), and then re-instate my users accounts and put their data back, and then I have to setup X-wrt (which isn't fully finished yet).

    X-wrt doesn't seem to have a "download manager" equivalent, and I'd have to work out once again how to set up a mail server.

    It looks like a lot of trouble with an uncertain outcome.

    OTOH, OpenWrt would open up the device. It does not rely on Asus, and it does not seem to suffer from the limitations where Asus code "inteferes" with the open applications as it does with other firmwares which attempt to open the code.

    OpenWrt seems to have a much larger community.

    ... and apparently optware ddtwrt packages are the go:

    the web interface is open and extensible:

    ... it looks like CUPS will work ... and Shorewall firewall configuration ...

    ... so it looks as if the effort might be worth it, but it still looks very risky.

    I'm afraid of bricking my WL700ge box before I get it set up. But I am tempted.

    I might wait a little while and see if a step by step easier setup method ever eventuates.

  4. #4

    I've locked myself out of the WL700ge

    No ssh connection any more.

    Not even the telnet hack works. I think some of the files on the router have gone missing, because telnet says I have no home directory, and it also says the /opt/bin/bash doesn't exits.

    This all started after DNS lookup started playing up again!

    It looks like a good opportunity to try a switch to openwrt.

    I'm backing up my files right now.

  5. #5

    It took a lot of effort, and there was a catch 22 ...

    ... but eventually I got OpenWrt installed.

    (1) the catch 22 was that I needed ppp working to connect with the internet, and ppp was not part of the initial firmware trx. The instructions assumed an internet connection independent of the router. The instructions say to install ppp stuff by doing 'ipkg install ...' but of course you can't do that if your internet connection is via ppp. I solved this one by downloading all of the ppp-related ipkg files directly (using another computer) and placing the .ipk files on a USB stick.

    (2) I recommend using the install root to USB ... with a caveat that the swap file should be made some place on the hdd instead of on the USB stick. I actually moved all of the /var/ directory on to the hdd. If you do this you can get away with a USB stick of only 256MB capacity, and they can be had very cheaply.

    (3) I had a lot of false starts. About 6 times I managed to crash it to the point the router would not re-boot. At one point I had to use the failsafe. Eventually I figured a way to get it back again without a full panic and a lot of typing.

    (4) samba 3 actually works now ... at least for Windows clients and cifs on linux clients. I can't get nfs to work, and smbfs chokes over file permissions.

    (5) I had a lot of trouble configuring dnsmasq. I wanted to have IP addresses assigned to machines according to the mac addresses. Eventually I did a 'logread' and saw that the dnsmasq start-up could not read the /etc/ethers file I had created. I made /etc/ethers and /etc/hosts files readable by all (chmod a+r /etc/hosts) and I placed the mac address and IP address of each machine per line in /etc/ethers, and the IP address and hostname I wanted for each machine per line in /etc/hosts. After that dnsmasq did what I wanted.

    (6) I haven't got appweb working yet, so for the moment I am using lighttpd. I still have yet to get xmail and dovecot running.

    Once you get it running and stable, OpenWrt is a lot faster than anything based on ASUS firmware (although this might be due to the fact that OpenWrt is running from a USB drive and it doesn't have to spin up the disk to run something, and the swap file may also help a great deal). The trick is to get it running. OpenWrt is a lot more open and flexible, but it also is a lot harder to install and it is far less user-friendly to configure and manage.

    The X-wrt web interface sort-of works, but it is incomplete.

    System Information
    Firmware OpenWrt Kamikaze - With X-Wrt Extensions r6772
    Kernel Linux 2.4.34 #23 Thu Mar 29 20:27:18 CEST 2007
    MAC <redacted>
    Device ASUS WL-700gE
    Board Broadcom BCM4704 chip rev 8
    Username root

    Web mgt. console Webif2
    Version r2801
    Not recommended for beginners, but a far better performer if you are an advanced user who is familiar with the Linux command line and you are prepared to take a bit of a risk.

    root@OpenWrt:~# mount
    rootfs on / type rootfs (rw)
    /dev/root on /rom type squashfs (ro)
    none on /dev type devfs (rw)
    none on /proc type proc (rw)
    none on /tmp type tmpfs (rw)
    none on /dev/pts type devpts (rw)
    /dev/scsi/host0/bus0/target0/lun0/part1 on / type ext3 (rw)
    /dev/ide/host0/bus0/target0/lun0/part1 on /hdd type ext3 (rw)
    root@OpenWrt:~# ls -l /
    drwxr-xr-x    2 root     root         1024 Jan  1 00:08 bin
    drwxr-xr-x    1 root     root            0 Jan  1  1970 dev
    drwxr-xr-x   13 root     root         1024 Jan  1 00:08 etc
    drwxr-xr-x   15 root     root         1024 Jan  1 00:07 hdd
    lrwxrwxrwx    1 root     root           10 Jan  1  2000 home -> /hdd/home/
    drwxr-xr-x    6 root     root         1024 Jan  1 00:08 lib
    drwx------    2 root     root        12288 Jan  1 00:01 lost+found
    drwxr-xr-x    3 root     root         1024 Jan  1 00:03 mnt
    drwxr-xr-x   15 root     root         1024 Jan  1  2000 opt
    dr-xr-xr-x   52 root     root            0 Jan  1 00:00 proc
    drwxr-xr-x   15 root     root          136 Mar 29  2007 rom
    drwxr-xr-x    2 root     root         1024 Jan  1 00:10 root
    drwxr-xr-x    2 root     root         1024 Jan  1 00:08 sbin
    drwxrwxrwt    2 root     root          220 Jan  1 01:35 tmp
    drwxr-xr-x    6 root     root         1024 Jun 30  2007 usr
    lrwxrwxrwx    1 root     root            8 Jan  1  2000 var -> /hdd/var
    drwxr-xr-x    7 root     root         1024 Jan  1 00:08 www
    Last edited by hal2k1; 02-07-2007 at 07:02.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts