Results 1 to 2 of 2

Thread: Freetype not working with ImageMagick

  1. #1

    Question Freetype not working with ImageMagick

    I am trying to generate some Jepgs with text using ImageMagick. On my Linux System (Suse) it works flawless.
    So I installed on my WL-HDD with Olegs latest firmware ( thanks for that graet work) first freetype-2.1.10-4 and than ImageMagick-6.3.4-0-1.
    Install went well, basic ImageMagick functions were ok.
    When I tried to generate text images, ImageMagick complained about missing fonts for freetype. No matter what fonts I supplied.
    So I also installed ghostscript and adjusted ImageMagick paths to these fonts although I had no ghostscript on my Suse system.
    No I got a changed errormessage :
    convert -background blue -fill white -sampling-factor 2x1 -size 3872x2592 -pointsize 8 label:@test.txt test.jpg
    AFPL Ghostscript 8.50: ./src/interp.c(295): Fatal error -20 in gs_interp_init!AFPL Ghostscript 8.50: ./src/interp.c(295): Fatal error -20 in gs_interp_init!convert: FreeType library is not available `/opt/share/ghostscript/fonts/n019003l.pfb'
    The font is exactly there.
    So I started thinking it is an issue with freetype support.
    I set up the toolchain according to your wiki.
    Days later I made a working freetype and ImageMagick package. And I got the same error.

    If I look into the make.log file of Imagemagick I find this lines:
    -------------------------------------------------------------
    configure:34786: result: Checking for FreeType 2.0 support
    configure:34788: result: -------------------------------------------------------------
    configure:34802: checking for freetype-config
    configure:34832: result: no
    ......
    configure:35095: result: no
    configure:35111: checking if FreeType package is complete
    configure:35116: result: no -- some components failed test
    configure:35182: result: -------------------------------------------------------------
    So Imagemagick is compiled without freetype.
    Configure looks for a lot of files of the freetype package, which are now at a different location as it suspects.
    I can't fix this.
    Any help is appreciated.

    Martin

  2. #2

    Solved

    Imagemagick compiles correctly with a simple change in the makefile
    imagemagick.mk

    change line

    IMAGEMAGICK_CPPFLAGS=

    to

    IMAGEMAGICK_CPPFLAGS=$(STAGING_CPPFLAGS)/freetype2

Similar Threads

  1. EXT2 formatting - anyone have it working?
    By Verme in forum WL-500w Q&A
    Replies: 6
    Last Post: 20-07-2007, 20:35
  2. ImageMagick package NOK
    By kokoro in forum WL-500g Custom Development
    Replies: 10
    Last Post: 07-04-2007, 16:11
  3. Anybody installed ImageMagick on WL500-g?
    By ikerstges in forum WL-500g Q&A
    Replies: 16
    Last Post: 21-02-2006, 14:10
  4. Replies: 1
    Last Post: 09-12-2005, 23:29
  5. Trying to get IDE working on Oleg's Firmware
    By hugo in forum WL-HDD Custom Development
    Replies: 34
    Last Post: 01-11-2004, 19:06

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •