Page 6 of 8 FirstFirst ... 45678 LastLast
Results 76 to 90 of 108

Thread: SANE (Scanner server) - Any chance for WL-500g?

  1. #76
    unfortenatly, either sane-find-scanner and scanimage -L found the scanner...

    PcTv

  2. #77
    Join Date
    Jun 2005
    Location
    Slovenia
    Posts
    736
    I suggest, that You first try to get a running sane/xsane on some linux box. Eventualy You could also try virtualbox or some vmware-server product that is free. Try USB key to prove USB functionality. Then proceed with scanner.

  3. #78
    I found this HowTo and aparentely the printer and scanner should work with the sane-backend we are using on Oleg firmware...

    http://gentoo-wiki.com/HOWTO_EPSON_C..._configuration

    Do we have any kind o debuging or logging we can activate to determine why the scanner is not being found?



    PCTV
    Last edited by PCTV; 19-03-2008 at 15:34.

  4. #79
    Activated some debug flags and got the following return from scanimage -T

    Code:
    [dll] sane_init: SANE dll backend version 1.0.12 from sane-backends 1.0.18-cvs
    ....
    [dll] load: searching backend `epson' in `/opt/lib/sane'
    [dll] load: trying to load `/opt/lib/sane/libsane-epson.so.1'
    [dll] load: dlopen()ing `/opt/lib/sane/libsane-epson.so.1'
    [dll] init: initializing backend `epson'
    [dll] init: backend `epson' is version 1.0.247
    [dll] sane_get_devices: found 0 devices
    From the info on http://www.sane-project.org/sane-mfgs.html#API i believe we need a more recent backend like the one (libsane-epson.so.1.0.4) i found on this site http://khk.net/sane/news.html

    How can i deploy it? Is just a copy to /opt/lib/saned ? What configuration changes should be done?

    I also found this one http://khk.net/sane/download.html but i don't know how to compile it... Can anyone do it, please?


    Thanks in advance,
    PCTV
    Last edited by PCTV; 19-03-2008 at 20:42.

  5. #80
    Join Date
    Mar 2008
    Location
    Russia
    Posts
    4
    I use 1.9.2.7-9 Oleg Firmware on Asus wl-500gP
    My Printer-Scanner is HP LJ M1120 MFP
    Printer work Excellent, but scanner didn't

    I setup all like in alex_g's post
    Version of sane is 1.0.19+cvs from repository

    'sane-find-scanner' output:

    PHP Code:
      # sane-find-scanner will now attempt to detect your scanner. If the
      # result is different from what you expected, first make sure your
      # scanner is powered up and properly connected to your computer.

      # No SCSI scanners found. If you expected something different, make sure that
      # you have loaded a kernel SCSI driver for your SCSI adapter.
      # Also you need support for SCSI Generic (sg) in your operating system.
      # If using Linux, try "modprobe sg".

    found USB scanner (vendor=0x03f0product=0x5617at libusb:003:002
      
    # Your USB scanner was (probably) detected. It may or may not be supported by
      # SANE. Try scanimage -L and read the backend's manpage.

      # Not checking for parallel port scanners.

      # Most Scanners connected to the parallel port or other proprietary ports
      # can't be detected by this program. 
    'scanimage -L' output

    PHP Code:
    device `hpljm1005:libusb:003:002' is a Hewlett-Packard LaserJet M1120 multi-function peripheral 
    But 'scanimage -T' command tell me this:
    PHP Code:
    scanimagecan't resolve symbol 'round
    When use scanner through network, all windows sane frontends is hanging.
    Saned process on router is starting and finish shortly.

    i don't know what to do next.
    Can the scanimage message be an error in source of sane?

  6. #81
    Join Date
    Mar 2008
    Location
    Russia
    Posts
    4
    I additionaly search sane sources for 'round' and found this in 'hpljm1005.c' file

    PHP Code:
    /*
     * List of pointers to devices - will be dynamically allocated depending
     * on the number of devices found. 
     */
    static SANE_Device **devlist NULL;

    static 
    void
    update_img_size 
    (struct device_s *dev)
    {
      
    int dxdy;

      
    /* Only update the width when not scanning, 
       * otherwise the scanner give us the correct width */
      
    if (dev->status == STATUS_SCANNING)
        {
          
    dev->height = -1;
          return;
        }

      
    dx dev->optionw[X2_OFFSET] - dev->optionw[X1_OFFSET];
      
    dy dev->optionw[Y2_OFFSET] - dev->optionw[Y1_OFFSET];

      switch (
    dev->optionw[RES_OFFSET])
        {
        case 
    75:
          
    dev->width round ((dx / ((double) MAX_X_S)) * 640);
          
    dev->height round ((dy / ((double) MAX_Y_S)) * 880);
          break;
        case 
    100:
          
    dev->width round ((dx / ((double) MAX_X_S)) * 848);
          
    dev->height round ((dy / ((double) MAX_Y_S)) * 1180);
          break;
        case 
    150:
          
    dev->width round ((dx / ((double) MAX_X_S)) * 1264);
          
    dev->height round ((dy / ((double) MAX_Y_S)) * 1775);
          break;
        case 
    200:
          
    dev->width round ((dx / ((double) MAX_X_S)) * 1696);
          
    dev->height round ((dy / ((double) MAX_Y_S)) * 2351);
          break;
        case 
    300:
          
    dev->width round ((dx / ((double) MAX_X_S)) * 2528);
          
    dev->height round ((dy / ((double) MAX_Y_S)) * 3510);
          break;
        case 
    600:
          
    dev->width round ((dx / ((double) MAX_X_S)) * 5088);
          
    dev->height round ((dy / ((double) MAX_Y_S)) * 7020);
          break;
        case 
    1200:
          
    dev->width round ((dx / ((double) MAX_X_S)) * 10208);
          
    dev->height round ((dy / ((double) MAX_Y_S)) * 14025);
          break;
        }
        
        
    DBG(2,"New image size: %dx%d\n",dev->widthdev->height);


    May be i lack some type of program from repo to solve this trouble?
    anybody knows?
    thnx

  7. #82
    Join Date
    Jun 2005
    Location
    Slovenia
    Posts
    736
    Try
    PHP Code:
    LD_TRACE_LOADED_OBJECTS=1 scanimage -
    and post output here.

  8. #83
    Join Date
    Mar 2008
    Location
    Russia
    Posts
    4
    Thats my output of 'LD_TRACE_LOADED_OBJECTS=1 scanimage -T' command

    PHP Code:
    libsane.so.1 => /opt/lib/libsane.so.1 (0x2aaaa000)
    libdl.so.0 => /opt/lib/libdl.so.0 (0x2aad7000)
    libusb-0.1.so.4 => /opt/lib/libusb-0.1.so.4 (0x2ab01000)
    libpthread.so.0 => /opt/lib/libpthread.so.0 (0x2ab19000)
    libm.so.0 => /opt/lib/libm.so.0 (0x2ab3c000)
    libjpeg.so.62 => /opt/lib/libjpeg.so.62 (0x2ab5b000)
    libtiff.so.3 => /opt/lib/libtiff.so.3 (0x2ab90000)
    libgcc_s.so.1 => /opt/lib/libgcc_s.so.1 (0x2abfd000)
    libc.so.0 => /opt/lib/libc.so.0 (0x2ac1c000)
    libz.so => /opt/lib/libz.so (0x2acd1000)
    ld-uClibc.so.0 => /opt/lib/ld-uClibc.so.0 (0x2aac0000

  9. #84
    Join Date
    Mar 2008
    Location
    Russia
    Posts
    4
    I still can't bring to work Sane with my HP LJ 1120 MFP

    I think i should rewrite 'hpljm1005.c' without 'round' function, and then recompile sane.

    Maybe error 'scanimage: can't resolve symbol 'round' appears because of bad or old system librarys (uclibs, glibc or something else) but all my movements to resolve this didn't lead to success.

  10. #85
    Hello all,

    Sorry to dig up this old thread but it seemed the most appropriate one for my questions...........
    I have an ASUS WL520GU & Epson Stylus CX3100 printer-scanner
    Stock Asus firmware does not detect my Epson.
    BTW, all linux distros detect CX3100 & I can use both printer +scanner with no problem at all.
    I flashed the firmware to ddwrt.v.24_mini_generic & followed their wiki to add usb base drivers, printer, & scanner. In the end I managed to get printer working (but there is no info on the web UI about my printer). The info on the wiki about scanner is practically nothing (I only picked "ipkg -force-depends install kmod-usb-scanner) but still I managed to do "insmod /jffs/lib/modules/2.4.30/scanner.o" and "dmesg | grep usb" showed some info about scanner.
    Google leads me to this thread & "ipkg -force-depends install xinetd" is a success but ipkg can not find sane-backends.

    Then I flashed to Oleg firmware wl520gu-1.9.2.7-10.trx. Web UI detect my printer & I can use it (wired or wireless) with no problem at all.

    My questions are:
    - is the procedure indicated on page 2 of this thread still valid & can be applied to the firmware version that I am currently using??
    - is there still any space left in my 4MB router? oleg fw = 3.6MB with usb storage, printer, camera,etc... vs ddwrt_mini= 2.8MB with no USB at all

    Of course, it would be best if somebody can write up a new detail howto.
    But still some leads and clues are highly appreciated as well

    Thank you

  11. #86
    Join Date
    Jun 2005
    Location
    Slovenia
    Posts
    736
    Sane backends are available for oleg and dd'wrt firmware through Nslu2 Optware feeds. It should work if your scanner is supported. With additional USB key for software, maybe.

  12. #87
    Greetings. Has read, but has not understood, how to me to connect the scanner to Asus wl-500gp? Help. Stick with a nose.

  13. it doesn't mount

    Hi all, thanks for the thread. Trying to follow, but the scanner simply would not mount.

    Code:
    Oct 23 23:58:34 kernel: usb.c: registered new driver usbscanner
    Oct 23 23:58:34 kernel: scanner.c: 0.4.16:USB Scanner Driver
    Oct 23 23:58:34 kernel: scanner.c: probe_scanner: User specified USB scanner -- Vendor:Product - 924:4265
    What I'm missing here is a row that says "mounted to scanner0".

    sane-find-scanner sees the MFD (Xerox 3119), but scanimage -L wouldn't work.

    Possible reasons:
    1. I put my username in the xinetd config, but ommited group (simply don't know how to find out what it should be)
    2. Xerox 3119 is not supported by Sane (however I saw people working with it in Ubuntu)

    If you know what's the problem, thanks in advance for helping me here. Best.

  14. #89

    Unhappy

    Hi everyone!
    Could somebody give me correct /opt/etc/xinetd.d/saned file for samsung 4200 ?
    Right now I have this one
    Code:
    service saned
    {
    port = 6566
    socket_type = stream
    server = /opt/sbin/saned
    protocol = tcp
    user = root
    group = root
    wait = no
    disable = no
    }
    But it's incorrect, because of errors

    Code:
    Nov 30 10:32:42 xinetd[296]: Bad socket type: stream^M [file=/opt/etc/xinetd.d/saned] [line=4]
    Nov 30 10:32:42 xinetd[296]: Error parsing attribute socket_type - DISABLING SERVICE [file=/opt/etc/xinetd.d/saned] [line=4]
    Nov 30 10:32:42 xinetd[296]: Server /opt/sbin/saned^M is not executable [file=/opt/etc/xinetd.d/saned] [line=5]
    Nov 30 10:32:42 xinetd[296]: Error parsing attribute server - DISABLING SERVICE [file=/opt/etc/xinetd.d/saned] [line=5]
    Nov 30 10:32:42 xinetd[296]: Protocol tcp^M not in /etc/protocols [file=/opt/etc/xinetd.d/saned] [line=6]
    Nov 30 10:32:42 xinetd[296]: Error parsing attribute protocol - DISABLING SERVICE [file=/opt/etc/xinetd.d/saned] [line=6]
    Nov 30 10:32:42 xinetd[296]: Unknown user: root^M [file=/opt/etc/xinetd.d/saned] [line=7]
    Nov 30 10:32:42 xinetd[296]: Error parsing attribute user - DISABLING SERVICE [file=/opt/etc/xinetd.d/saned] [line=7]
    Nov 30 10:32:42 xinetd[296]: Unknown group: root^M [file=/opt/etc/xinetd.d/saned] [line=8]
    Nov 30 10:32:42 xinetd[296]: Error parsing attribute group - DISABLING SERVICE [file=/opt/etc/xinetd.d/saned] [line=8]
    Nov 30 10:32:42 xinetd[296]: Bad value for wait: no^M [file=/opt/etc/xinetd.d/saned] [line=9]
    Nov 30 10:32:42 xinetd[296]: Error parsing attribute wait - DISABLING SERVICE [file=/opt/etc/xinetd.d/saned] [line=9]
    Nov 30 10:32:42 xinetd[296]: Bad value: no^M [file=/opt/etc/xinetd.d/saned] [line=10]
    Nov 30 10:32:42 xinetd[296]: Error parsing attribute disable - DISABLING SERVICE [file=/opt/etc/xinetd.d/saned] [line=10]
    Nov 30 10:32:42 xinetd[296]: 296 {init_services} no services. Exiting...
    I understand, that i have incorrect values, but i don't have true parameters
    Advise me somebody!!

  15. #90
    Can anyone help? =(

Page 6 of 8 FirstFirst ... 45678 LastLast

Similar Threads

  1. wl-500g / ftp-server
    By tthen in forum WL-500g Q&A
    Replies: 2
    Last Post: 06-11-2006, 17:52
  2. Chance for RADIUS Server on the router itself!
    By Dante_ in forum WL-500g Custom Development
    Replies: 50
    Last Post: 17-05-2006, 12:06
  3. Replies: 11
    Last Post: 17-08-2004, 09:22
  4. Sharing USB scanner or multifunction device
    By monnier in forum WL-500g Q&A
    Replies: 0
    Last Post: 22-07-2004, 23:42
  5. Use Scanner on Parallel port
    By bysoftie in forum WL-500g Q&A
    Replies: 1
    Last Post: 01-05-2004, 21:45

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •