Page 2 of 20 FirstFirst 123412 ... LastLast
Results 16 to 30 of 298

Thread: Как установить и настроить Midnight Commander ?

  1. #16
    Quote Originally Posted by TVadim View Post
    на месте лежит: http://ipkg.nslu2-linux.org/feeds/unslung/wl500g/
    как скачать и поставить с диска: была тема, в поиск
    Спасибо - нашел, буду пытаться устанавливать

  2. #17
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    ipkg update забыли сказать?

  3. #18
    Не ставится МС просто так, нет его в списке.
    Code:
    ipkg install http://ipkg.nslu2-linux.org/feeds/unslung/wl500g/mc_4.1.35-3_mipsel.ipk
    решает проблему.

  4. #19
    Join Date
    Oct 2006
    Location
    St. Petersburg
    Posts
    126

    Как установить Midnight Commander без интернета?

    Как можно установить Midnight Commander без подключения к интернету?
    Точнее как его установить я знаю, у меня все стопориться на ipkg.sh update? Мне не установить ipkg а без него не установить МС
    Объясните пожалуйста.

  5. #20
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Почему? Откачайте пакет ipkg, далее ipkg.sh install имя_файла_на_диске

  6. #21
    Join Date
    Oct 2006
    Location
    St. Petersburg
    Posts
    126
    Quote Originally Posted by Oleg View Post
    Почему? Откачайте пакет ipkg, далее ipkg.sh install имя_файла_на_диске
    А какой из двух ipkg-web_4-4_mipsel.ipk или ipkg-web_5-5_mipsel.ipk качать? Или я не так понял?

  7. #22
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353

  8. #23

    Как установить Midnight Commander?

    Нигде не могу найти, как установить MC.

    Нашел, где лежит, дал команду:
    [admin@asusrouter root]$ ipkg.sh install http://www.ibiblio.org/pub/Linux/utils/
    file/managers/mc/mc-4.5.55.tar.gz
    Downloading http://www.ibiblio.org/pub/Linux/uti...c/mc-4.5.55.ta
    r.gz ...
    Connecting to www.ibiblio.org[152.46.7.80]:80
    mc-4.5.55.tar.gz 100% |*****************************| 4736 KB 00:00 ETA
    Done.
    ipkg_install_file: ERROR: File //opt/tmp/ipkg/mc-4.5.55.tar.gz has unknown exten
    sion gz (not .ipk or .deb)

  9. #24
    Там в сообщении об ошибке все написано:
    ERROR: File //opt/tmp/ipkg/mc-4.5.55.tar.gz has unknown exten
    sion gz (not .ipk or .deb)
    ipkg не понимает файлы tar.gz - архив надо распаковать

    Хотя в данном случае не поможет и распаковка файла mc-4.5.55.tar.gz потому что там не ipkg пакет.

    Как ставить правильно:

    1) Настроить репозитарий ipkg как написано тут:
    http://wl500g.info/showpost.php?p=48747&postcount=7

    2) ipkg install mc

  10. #25

    Терминал "кривится" после обновления репозитория

    Обновил ipkg.conf в репозиторий
    Code:
    src/gz optware http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable
    и терминалка стала ругаться
    Code:
    [ajax@homeart-rtr /tmp]$ clear
    'linux': unknown terminal type.
    [ajax@homeart-rtr /tmp]$
    Посмотрел - все файлы термкапа на местах. Попробовал его переустановить - без толку. В нете нигде ничего похожего для embedded-девайсов не нашел. помогите, что делать?

  11. #26
    Join Date
    Aug 2006
    Location
    Moscow, Russia
    Posts
    788
    А новый uclibc-opt установил?(ipkg update && ipkg install uclibc-opt) Все ранее установленные пакеты переустановил из нового репозитария? (ipkg update && awk '/^Package:/{system("ipkg install -force-reinstall -force-defaults " $2)}' /opt/lib/ipkg/status)
    Насчет терминала то в ~/.profiles у меня так
    Code:
    export TERMINFO="/opt/share/terminfo"
    export TERM="xterm"
    alias mc="mc -c"
    И без проблем. Даже мышь работает.

  12. #27
    Да думал что не всё скопом обновлять: термкап, либы обновил... В общем всё обновил - стало всё на места.

    Спасибо за хелп

    PS Зато теперь mc не стартует с руганью на отсутствие либы "mc: can't load library 'libext2fs.so.2'"
    Кто знает где либу достать?
    Last edited by Ajax; 31-05-2007 at 19:39. Reason: PS

  13. #28
    Join Date
    Aug 2006
    Location
    Moscow, Russia
    Posts
    788
    Quote Originally Posted by Ajax View Post
    Да думал что не всё скопом обновлять
    В том репозитарии все пакеты скомпилированы под новую библиотеку uclibc и по этому необходимо установить новую версию uclibc (uclibc-opt - 0.9.28-12). А у пакетов, которые скомпилированы под старую uclibc, которая в прошивке, от новой uclibc сносит башню и по этому необходимо все пакеты переустановить.
    Quote Originally Posted by Ajax View Post
    PS Зато теперь mc не стартует с руганью на отсутствие либы "mc: can't load library 'libext2fs.so.2'"
    Странно. У меня такой либы нет и mc нормально пашет. Можно попробовать стереть настройки mc (rm -r ~/.mc)

  14. #29
    Quote Originally Posted by Mam(O)n View Post
    Странно. У меня такой либы нет и mc нормально пашет. Можно попробовать стереть настройки mc (rm -r ~/.mc)
    Да пробовал, префы стереть это первое дело. Я вот что думаю - я mc поставил из нового репозитария... Может в старом порыться и оттуда поставить...

  15. #30
    Join Date
    Aug 2006
    Location
    Moscow, Russia
    Posts
    788
    mc из старого репозитария с новой uclibc работать не будет.

Page 2 of 20 FirstFirst 123412 ... LastLast

Similar Threads

  1. Установка и настройка torrent на RT-N16 (2.6)
    By valerakvb in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 207
    Last Post: 22-08-2017, 15:05
  2. Asus WL-500gP: как проверить WAN-порт ?
    By jmur in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 105
    Last Post: 07-07-2013, 15:02
  3. Replies: 16
    Last Post: 12-04-2010, 10:12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •