Page 1 of 2 12 LastLast
Results 1 to 15 of 16

Thread: My stupid mistake!

  1. #1

    My stupid mistake!

    Hi!

    I have been really smart and delete by telnet in /shares/MYVOLUME1/ file __share_list.txt and now i cant see my shares! Can i get back this file?? I tray to copy file __share_MYSHARE1_vars.txt to __share_list.txt and modify it with command "vi" but this command don't exist on that system. What else can i do?! PLS, PLS

    P.S. just one more think! What can i do if i get that ansver on deleting my own shares:

    ERROR: Unable to delete share
    The attempt to remove share PRIVAT faild because the attempt to create marker file '/shares/MYVOLUME1/__deleting/PRIVAT' FAILD: iNPUT/OUTPUT ERROR.


    I cant also use this command on upgrading costom ASUS firmware:

    wget http://ipkg.nslu2-linux.org/feeds/op...8-1_mipsel.ipk
    tar xvzf uclibc_0.9.28-1_mipsel.ipk; tar xvzf data.tar.gz

    because on command tar xvzf data.tar.gz let me know again on iNPUT/OUTPUT error.

    THX folks for help!!!

  2. #2
    Quote Originally Posted by Fico View Post
    wget http://ipkg.nslu2-linux.org/feeds/op...8-1_mipsel.ipk
    tar xvzf uclibc_0.9.28-1_mipsel.ipk; tar xvzf data.tar.gz

    because on command tar xvzf data.tar.gz let me know again on iNPUT/OUTPUT error.
    INPUT/OUTPUT error messages come from a disk or filesystem error. Did you "mount -o bind /shares/MYVOLUME1/opt /opt"? However, given the fact that you're seeing I/O errors from other commands, you might have a corrupt filesystem or bad hardware.

    - K.C.
    Last edited by kfurge; 30-03-2007 at 01:02.

  3. #3
    Yes i mount -o bind /shares/MYVOLUME1/opt /opt

    Now tells me on "wget http://ipkg.nslu2-linux.org/feeds/op...8-1_mipsel.ipk"

    wget: uclibc_0.9.28-1_mipsel.ipk: Permission denied

    ???

    kfurge thx for post! P.S. do you know what to do for my shares in .txt file?!

  4. #4
    Forget on wget: uclibc_0.9.28-1_mipsel.ipk: Permission denied now works but look what tels me now:

    # tar xvzf uclibc_0.9.28-1_mipsel.ipk; tar xvzf data.tar.gz; tar xvzf data.tar.gz
    ./debian-binary
    ./data.tar.gz
    ./control.tar.gz
    .
    ./opt
    ./opt/sbin
    ./opt/sbin/ldconfig
    tar: Cannot create directory `./opt/sbin': Input/output error
    tar: ./opt/sbin/ldconfig: No such file or directory
    .
    ./opt
    ./opt/sbin
    ./opt/sbin/ldconfig
    tar: Cannot create directory `./opt/sbin': Input/output error
    tar: ./opt/sbin/ldconfig: No such file or directory


    thx!

  5. #5
    Can you please post all of your steps leading up to this? You shouldn't ever see an input/output error.

    - K.C.

  6. #6
    When i update a custom ASUS firmware and rc.local script (and move it on /shares/MYVOLUME1) on my WL-700gE i reset my router and write this in telnet:

    => cd /shares/MYVOLUME1
    => mkdir -p opt/etc
    => mount -o bind /shares/MYVOLUME1/opt /opt
    => wget http://ipkg.nslu2-linux.org/feeds/op...s/1_mipsel.ipk
    => tar xvzf uclibc_0.9.28-1_mipsel.ipk; tar xvzf data.tar.gz

    and then i get that error:
    tar: Cannot create directory `./opt/sbin': Input/output error
    tar: ./opt/sbin/ldconfig: No such file or directory

  7. #7
    kfurge do u know how can i enable ssh for transferring txt with my shares??

  8. #8
    Hmmm... Your steps are OK.

    Please post the output of dmesg and showlog, if available, following this error.

    - K.C.

  9. #9
    kfurge can u tell me how to do that (im not that much expert )

    P.S. at firs i would really like to get back my working __share_list.txt file! PLS

  10. #10
    I could do that if i would know how to enable ssh but i don't!

  11. #11
    Quote Originally Posted by Fico View Post
    kfurge can u tell me how to do that (im not that much expert )

    P.S. at firs i would really like to get back my working __share_list.txt file! PLS
    This file should work Ok for you for MYSHARE1/MYVOLUME1.

    - K.C.
    Attached Files Attached Files

  12. #12
    kfurge thx really!!!

    But can u tell me how can i now transfer that file to my router? I hear that only way is ssh! Is this true??

  13. #13
    Quote Originally Posted by Fico View Post
    kfurge thx really!!!

    But can u tell me how can i now transfer that file to my router? I hear that only way is ssh! Is this true??
    Yeah.... You've got a problem. No share to drop it onto and no way in or out with the basic network i/o.

    I'd recommend putting the file on a usb flash stick, sticking it into your router, mounting it, and copying the file off from there.

    The router might even mount it for you automagically if you haven't killed watchdog and friends. Use 'cat /proc/mounts' to find where it's mounted.

    - K.C.

  14. #14
    kfurge u know what?? U ARE GOD ON THIS THINGS! Thanx man now works to my shares!

    Now i must just fix to working torrents when im not using my PC

    Can u helping me here to PLS, PLS!

    P.S. aha how can i delete my shares if i dont need it anymore (like torrents)? And how can i secure my telnet?

    HTX again 100 times!

  15. #15
    If u remember that problem:

    # tar xvzf uclibc_0.9.28-1_mipsel.ipk; tar xvzf data.tar.gz; tar xvzf data.tar.gz
    ./debian-binary
    ./data.tar.gz
    ./control.tar.gz
    .
    ./opt
    ./opt/sbin
    ./opt/sbin/ldconfig
    tar: Cannot create directory `./opt/sbin': Input/output error
    tar: ./opt/sbin/ldconfig: No such file or directory

    .
    ./opt
    ./opt/sbin
    ./opt/sbin/ldconfig
    tar: Cannot create directory `./opt/sbin': Input/output error
    tar: ./opt/sbin/ldconfig: No such file or directory


    i work by this guide:

    http://wl500g.info/attachment.php?at...5&d=1169583182

    I dont know what down work!

Page 1 of 2 12 LastLast

Similar Threads

  1. Stupid FTP not working since 1.9.2.7-3c
    By vb_fan in forum WL-500g Q&A
    Replies: 1
    Last Post: 29-12-2007, 01:00
  2. ports von stupid ftp
    By _H_o_L_E_ in forum German Discussion - Deutsch (DE)
    Replies: 1
    Last Post: 14-11-2006, 09:18
  3. stupid ftp passive PASV ports
    By _H_o_L_E_ in forum WL-500g Q&A
    Replies: 1
    Last Post: 14-11-2006, 09:17
  4. WL500g stupid problem :(
    By nrdl in forum WL-500g Q&A
    Replies: 12
    Last Post: 30-05-2006, 13:28
  5. I did something stupid, I think.
    By zainka in forum WL-500g Q&A
    Replies: 0
    Last Post: 28-05-2006, 19:49

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •