Results 1 to 5 of 5

Thread: browse master problem

  1. #1

    browse master problem

    Hello,

    something I've been unable to solve since I switched to ASUS router... previously I had 1 PC via internet connection sharing with 2 NICs and it worked fine.

    I replaced it with 700gE and since that time I'm unable to browse the network neighbourhood (workgroup). All PCs are able to ping each other, I can SEARCH for all PCs and they're found, I can map drives on all shares across the PCs and all PCs can access the internet.

    So I thought that it could be the problem with browse master, and I did nbtstat on all IP adresses in my LAN, and boy was I surprised to find out that the 700gE was the browse master...

    Can anyone offer any resolution to this? Is it OK for 700gE to be browse master, and why doesn't it work? It's driving me crazy! :-)

    Thanx for any help!

    D.

  2. #2
    You could modify /tmp/samba/lib/smb.conf and kill -HUP nmbd. The offending lines in smb.conf are:

    preferred master = auto
    local master = yes

    Change them to no,no. If you're running the custom firmware, add this to your rc.local startup script.

    - K.C.

  3. #3
    I have had the same problem, I could not work out why network places would not show any computers. Also browser errors recorded in the event log.

    When I run "browstat status" I was surprised to see the browser master was indeed the wl700ge. It was browser master but was not doing its self elected job.

    No matter what I tried with XP registry settings the wl700ge had a higher priority and took control.

    I tried your idea of changing smb.conf but found that smb.conf in /tmp/samba/lib/ and also in /usr/local/samba/lib were both being rewritten after boot.

    So forcing nmbd to reread the config file by killall -HUP nmbd was not making any difference.

    What I did in the end was to copy the smb.conf file to /opt/etc and modify it there;

    preferred master = no
    local master = no

    as you suggested.

    And then in rc.local killed nmbd and restarted it pointing it to my modified smb.conf file.

    # try and stop master browser
    killall nmbd
    /usr/local/samba/sbin/nmbd -s /opt/etc/smb.conf

    The new problem is of course that if you for example change the share settings in the web menu they will not be copied to the config file that is now being used. So it has to be edited manually if needed.

    I am sure there is a much better way of doing it, but for the time being this is working for me.

    Chris.

  4. #4
    Quote Originally Posted by Chris Thompson View Post
    I am sure there is a much better way of doing it, but for the time being this is working for me.
    Sounds like a pretty good solution. I think you could streamline it a little further.

    Rc.local is called with nearly every configuration change. So to make it a little more automatic, use sed to modify the updated smb.conf file then restart nmbd.

    Be sure to put this script code outside of the if statement that protects one-time startup items from multiple executions.

    - K.C.

  5. #5
    Very good idea.

    Just done as you sugested works fine. Am happy with it now, thanks.

    In rc.local:

    # try and stop master browser
    killall nmbd
    sed -f /opt/etc/smb.sed /tmp/samba/lib/smb.conf > /opt/etc/smb.conf
    /usr/local/samba/sbin/nmbd -s /opt/etc/smb.conf

    smb.sed:

    s/os level = 20/os level = 64/
    s/preferred master = auto/preferred master = no/
    s/local master = yes/local master = no/

Similar Threads

  1. WL-500gP and Asus support experience
    By Blezi in forum WL-500gP Q&A
    Replies: 6
    Last Post: 03-12-2006, 13:59

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •