Page 1 of 2 12 LastLast
Results 1 to 15 of 19

Thread: Trouble Flashing Router

  1. #1

    Trouble Flashing Router

    I'm trying to use the firmware restore tool. I hold the EZSETUP button down while powering it on, the blue ready LED blinks almost immediately when I power on the device with the power button. So I let the button go when I see the ready led start to flash. After a few seconds the router boots up, but the blue ready led never stays lit. It turns off. I just have the orange power led on and the led for the port that I have my ethernet cable plugged in. When I try to run the firmware restore tool, it never gets a request from the router to download the new firmware. any ideas?

  2. #2
    I've had instances where no matter what I try, the router refuses to connect to the flashing tool. Eventually it works, but I haven't been able to figure out the true root cause as to what causes the router to become confused.

    Four things to try:

    1. Make sure to start from a power cycle by unplugging power from the back of the unit.

    2. Try flashing from the WAN port instead of a LAN port. I think there's a relationship between GATEWAY / AP mode and flashing over the LAN / WAN ports. GATEWAY = LAN, AP = WAN.

    3. Finally, if you're flashing from a wifi laptop, make sure to disable the wifi interface and only enable the wired ethernet port. If both are present, the asus flasher might be broadcasting and listening on the wrong interface.

    4. Finally, try rebooting windoze.

    - K.C.

  3. #3
    Which lights should be on the router in order for the flash to work? I thought I read somewhere that the blue ready light had to be on. For me, it's off. Just the power led stays on and the light for wherever my ethernet cable is plugged into. I have a fresh install of windows with no firewall or antivirus running and my wireless is disabled.

  4. #4
    Hmmm... Does the ready light blink if you continue hold the ez-setup button after powering up the router?

    If not, either your router is totally hosed, or it's in tftp mode waiting for a kernel to be sent to it.

    - K.C.

  5. #5
    yeah, it blinks. when i let go of ezsetup, the ready light goes solid for 5 seconds, then i hear the router boot up. once the router boots up, the ready light goes off completely

  6. #6
    I have a WL500gp and I had a similar problem the first time. You have to hold the RESTORE button and not the EZSetup button.

  7. #7
    I don't have a wl500g

  8. #8
    I've tried holding the ezsetup button, i've tried holding the reset button, i've tried the firmware update tool, i've tried the ezsetup tool, i've tried tftp... Nothing seems to work. Which lights exactly are supposed to be on when i use the firmware restore tool? If my box is completely shot, I want to stop wasting my time with it.

  9. #9
    Quote Originally Posted by doliam View Post
    yeah, it blinks. when i let go of ezsetup, the ready light goes solid for 5 seconds, then i hear the router boot up. once the router boots up, the ready light goes off completely
    Blinking is good, that means the bootloader is intact which means there's nearly 100% probability you'll be able to save your router.

    The bootloader counts down, and blinks the ready LED, for up to 10 seconds while ez-setup button is pressed.

    If 10 seconds elapses, the bootloader enters tftp mode where it expects a kernel to be transferred to it. It will stay in this state as long as it is powered up or ctrl-c is hit on the serial console.

    If the ez-setup is released within 10 seconds, the kernel boots with a minimal filesystem image. This image waits for 30 seconds to contact the asus flash tool. After 30 seconds, the router times out and tries to boot normally.

    What troubles me is that your router is timing out early which means the flashing tool never gets the opportunity to do its job.

    To fix your router, I think you'll have to install a serial console. Additionally, I think you'll need the serial console to troubleshoot any further.

    http://www.tiedyedfreaks.org/eric/WL-700gE/index.html

    Be prepared to void your warranty to save your router...

    - K.C.

  10. #10
    I really can't do all that hardware stuff.

    Is there a reason why the tftp wouldn't work? When I hold down the ezsetup for 10 seconds, the light stops blinking and no other LED's are on. My computer acts like it is connected thru ethernet and has a static ip, but i can't ping or tftp to the router. I get a timeout error from tftp.

  11. #11
    Well, without a serial console, this will be difficult... So, let's start from the beginning... What led to the router getting to this state? What's the static IP address and netmask on your PC? Please provide, in detail, your setup and what you've already tried.

    Regarding tftp, you can't tftp a .nas file. You can only send the segment that normally resides in flash. I put the 1.0.4.6 flash.trx file here for you to try:

    http://wl500g.info/files/asus/custom/kfurge/flash.trx

    - K.C.
    Last edited by kfurge; 29-03-2007 at 00:20. Reason: Added flash.trx

  12. #12
    Well, i'm not really sure what I did. I was messing around with openwrt a while back and at some point the router stopped working and I wasn't able to use the reset button to restore it. I didn't have much time to mess around with it, so i put the router down and haven't touched it until a few days ago.

    I have a static ip set on my local laptop, 192.168.1.50. The subnet is 255.255.255.0. I have 192.168.1.1 for the gateway and dns. I disable my wireless network connection and I don't have windows firewall, anti spyware or anti virus of any nature running.

    When I try to do the firmware restore tool method. I hold down ezsetup and plug the cord into the back of the router. The power comes on immediately and the blue light starts flashing, so i let go of ezsetup. The box sits idle for about 2-3 seconds, then power's up. The ready light is on constantly as it turns on, then once it's on the ready light goes out. I've tried doing the firmware flash tool, but it never finds the router. I know i've tried it within 30 seconds.

    With tftp, it seems to go into tftp mode... but my local computer can't ping the router and tftp gives a timeout error.

  13. #13
    I seem to recall others who have tried switching to/from OpenWrt having similar problems. Did you try pressing and holding the reset button during power up to clear the nvram?

    - K.C.

  14. #14
    yeah, i've tried the reset button. How long are u supposed to hold it down for? No matter how long I hold it down for, the ready light keeps blinking. When I let go, the ready light comes on and it boots up... the ready light goes off once it's booted up. Will Asus help me with this? I haven't opened it up at all.

  15. #15
    holy crap, i just fixed it. I was trying nas files before on the tftp. When I tried your .trx file, I still had the ethernet cable plugged into the wan port. As soon as I switched cables, it was able to load the .trx file. I can't thank you enuf for your help, i was beginning to think I had a really expensive 160 gig hard drive.

Page 1 of 2 12 LastLast

Similar Threads

  1. How-to: Use your router as a BitTorrent Client
    By GerardNL in forum WL-700g Tutorials
    Replies: 28
    Last Post: 24-10-2007, 19:38
  2. router cannot reconnect with PPPoE
    By gstadler in forum WL-500gP Q&A
    Replies: 1
    Last Post: 11-06-2007, 19:51
  3. Replies: 0
    Last Post: 24-01-2007, 02:54
  4. Completely new WL700gE router crashed after firmware update - plz help!
    By ClaudeX in forum WL-700g Firmware Discussion
    Replies: 4
    Last Post: 20-07-2006, 00:03

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •