Page 1 of 3 123 LastLast
Results 1 to 15 of 35

Thread: How to setup and get Dropbear ssh working?

  1. #1

    How to setup and get Dropbear ssh working?

    Hi

    I have installed dropbear using "ipkg install dropbear" and configure the rc.local to start up dropbear with "-s" option.

    However, when I tried to ssh to it using putty, the system just prompt for my user id, and after that the putty window just closed automatically.

    Is there anyway I could setup dropbear properly to enable ssh?

  2. #2
    One thing that trips people up is not having their user shell listed in /etc/shells. I can't remember if this dropbear looks at /opt/etc/shells or /etc/shells. Adding this to rc.local will make it not matter:

    ln -s /opt/etc/shells /tmp/shells

    My /opt/etc/shells file has one line in it:

    /opt/bin/bash

    - K.C.

  3. #3
    Hi

    Thanks for the advice but my current configuration has already included the "ln -s /opt/etc/shells /tmp/shells" in the rc.local. Also my etc/shells contains the single line of /opt/bin/bash as well

    Is there any other configuration that I should look at? Thanks.

  4. #4
    Any clues sitting in your log files? Can you post the output of 'logread' after a failed login attempt.

    - K.C.

  5. #5
    Hi

    I have executed the logread command after a failed dropbear login. Here's the output:


    Mar 17 23:36:05 dropbear[4628]: exit before auth: Disconnect received


    Any clue on what has gone wrong?

  6. #6
    I'm running out of ideas. Any chance your user home directory does not exist or is not owned by the user with perms of 755?

    - K.C.

  7. #7
    i have modified the port (to another port) and then dropbear won't worked.

    then i used the command chmod 755 /opt/home/yourusername and it worked.

    this was the solution for me.

    grat182

  8. #8

    Dropbear

    Hello, i have installed the Firmware successfully and got enhanced-ctorrent/ screen program to work perfectly. Although i have little knowledge what dropbear is and how to use it. I have installed dropbear although when i type in "opt/bin/dropbear" in putty i get the following output, "
    #
    # opt/bin/Dropbear
    opt/bin/Dropbear: not found" Can someone please give a good guide on what dropbear is and how to install, configure it correctly. My objective is that i would like to share my files over vis the internet , and connect to my router via telnet, from the internet so i can download torrents when i am not at home. Thank you for all your help, and i must say a great guide on how to set up enhanced-ctorrent it works great for me !

  9. #9
    Join Date
    Feb 2007
    Location
    Moscow, Russia
    Posts
    3,805
    in my case it is sitting in /usr/sbin/dropbear
    if your one is in /opt/bin run it as /opt/bin/dropbear (start with / and dont use capital letters)

  10. #10

    dropbear help

    hey thanks for the help! although unfortunately i am still stuck at the same error as before, "
    # opt/bin/dropbear
    opt/bin/dropbear: not found
    #
    # usr/sbin/dropbear
    usr/sbin/dropbear: not found
    #
    # /opt/bin/dropbear
    /opt/bin/dropbear: not found
    #
    "
    it is still telling me that dropbear cannot be found, and i did install it, " opt/bin/ipkg install dropbear
    Package dropbear (0.48.1-1) installed in root is up to date.
    Nothing to be done
    Successfully terminated." so i know it is installed. but i have no idea what to do now... lol

  11. #11
    Join Date
    Feb 2007
    Location
    Moscow, Russia
    Posts
    3,805
    ipkg install findutils
    find / -name dropbear

  12. #12

    Dropbear help

    Hey thanks for the help aging!! unfortunitly now i get another error installing the "findutils"
    # opt/bin/ipkg install findutils
    Installing findutils (4.2.30-1) to root...
    Nothing to be done
    An error ocurred, return value: 1.
    Collected errors:
    ERROR: The following packages conflict with findutils:
    busybox-links
    #
    """ THANK FOR YOUR HELP AGING!

  13. #13
    No offence Fullback, but did you even try to figure this out on your own before giving up?

    All I needed to do was type 'ipkg' and experiment with the different option combinations for about 2 minutes to get findutils to install:

    ipkg -force-depends -force-overwrite install findutils

    - K.C.

  14. #14

    hey sorry

    Hey thanks sorry i am not to good with the linux command line yet, i do apologize. Can you please show me how to use dropbear works or point me out a link to a step by step instruction? "# opt/bin/find -name dropbear
    ./opt/etc/dropbear
    ./opt/sbin/dropbear
    ./proc/7/fd: No such file or directory
    ./shares/MYVOLUME1/opt/etc/dropbear
    ./shares/MYVOLUME1/opt/sbin/dropbear
    " thanks for the help kfurge.
    p.s I got dropbear to work, it starts up and ask me "login as" and i input "root" and then it says "root@192.168.1.1's password:" and i typed in root as well it did not work. how can i configure dropbear to work with my wan ip address or set up dns on it.? thanks aging guys sorry for bear rude
    Last edited by Fullback; 13-04-2007 at 08:19. Reason: More info needed to be added

  15. #15
    Join Date
    Feb 2007
    Location
    Moscow, Russia
    Posts
    3,805
    Using find you identified location of the dropbear on your system. Now you can run it as /opt/sbin/dropbear . After that you can connect to the box from outside by ssh client.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •