Results 1 to 6 of 6

Thread: How to get Photo Album viewable via Internet

  1. #1

    How to get Photo Album viewable via Internet

    Hi

    I have enabled the default photo album and I am able to browse it from LAN using http://192.168.1.1:8081 . However when I tried to assess the photo album from the WAN using http://58.xx.xx.xx address, it is always returning "Internet Explorer cannot display the webpage" error.

    I have checked the port forwarding in the router and there is an entry mapping port 80 from WAN to 192.168.1.1 added automatically after I enabled the photo album.

    Is there any other steps which I missed to get the photo album working?

  2. #2
    Are there any alternative photo package that can be installed in 700ge?

  3. #3
    If the three lines below are all present, then you should be able to view your web content on port WAN port 80:

    From 'iptables -n -t nat --list':

    DNAT tcp -- 0.0.0.0/0 <your ip> tcp dpt:80 to:192.168.1.1:8081

    You said this one was already present...

    From 'iptables -n --list':

    Chain INPUT
    ACCEPT tcp -- 0.0.0.0/0 192.168.1.1 tcp dpt:8081

    Chain FORWARD
    ACCEPT tcp -- 0.0.0.0/0 192.168.1.1 tcp dpt:8081

    - K.C.

  4. #4
    Hi

    I have executed the following iptables command and here's the output:

    # iptables -n -t nat --list
    DNAT tcp -- 0.0.0.0/0 xx.xx.xx.xx tcp dpt:80 to:10.0.1.1:8081

    # iptables -n --list
    Chain INPUT (policy ACCEPT)
    ACCEPT tcp -- 0.0.0.0/0 10.0.1.1 tcp dpt:8081

    Chain FORWARD (policy ACCEPT)
    There is no entry that reference 10.0.1.1 ip addresss under this section.


    There seem to be a missing line in my configuration. How can I configure that missing line into the router? THanks

  5. #5
    Try this as root:

    iptables -I FORWARD -p tcp --dport 8081 -j ACCEPT

    I have a little script tucked into the bottom of my rc.local, outside of the clause that checks to see it it's already been run, that inserts a similar line into my iptables config to enable ssh over the wan. You'll definitely have to tweak it a little bit, but maybe it can help:

    #!/opt/bin/bash

    lines=`/usr/sbin/iptables --list | /opt/bin/grep dpt:ssh | /opt/bin/wc -l`

    if test $lines -eq "1"; then
    iptables -I INPUT -p tcp --dport 22 -j ACCEPT
    fi

    - K.C.

  6. #6
    Hi

    I have executed the command to add FORWARD entry into the iptables:

    iptables -I FORWARD -p tcp -d 10.0.1.1 --dport 8081 -j ACCEPT

    After the entry was added, I tried to access it via the WAN address again. However I am still not able to access the photo album from the WAN. The IE reported "Unable to open page" error.

    Any idea what else should I check or configure to get the album working? Thanks.

Similar Threads

  1. Default Photo Album upload problems
    By Korpse in forum WL-700g Q&A
    Replies: 11
    Last Post: 22-08-2007, 10:29
  2. How to share photo album via Internet
    By kopi_bean in forum WL-700g Q&A
    Replies: 1
    Last Post: 12-03-2007, 01:01
  3. slow speed when connected to internet
    By palle1 in forum WL-500gP Q&A
    Replies: 4
    Last Post: 15-01-2007, 21:09
  4. 100mbit Internet connection not working
    By Aresz in forum WL-500g Q&A
    Replies: 8
    Last Post: 27-02-2006, 17:39

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •