Results 1 to 8 of 8

Thread: Problem with flashing custom firmware

  1. #1

    Problem with flashing custom firmware

    Hi

    I tried to flash my 700ge with the kc custom firmware but encountered problem on the 8th step of the flashing instruction. I have changed my local IP to 192.168.1.50 as per the instruction and started the Firmware-Restore tools to upload the images.

    However, the screen just displayed "Attempting to download firmware to local subnet. Use control-c to exit." for a long time (more than 5 min) without further action.

    Can anyone advised if I missed any step, or how should I get the downloading going ? Thanks

  2. #2
    you have to plug out the router. plug in the router and hold the ezsetup button for 2-3 seconds until the ready the led begins to blink.

    then you can upload the firmware with the restoration tool.

    you can also upload the firmware over the webui ( = http://192.168.1.1/administration.asp) that should also work!

    grat182

  3. #3
    Thanks for the help. I have managed to flash the custom firmware and proceed with the installation until step 4 "Closing the telnet hole".

    I have made a terrible mistakes here by manually editing the "/etc/passwd" file to add the password to the root account. I have changed as follows:

    root:asdf83208c:0:42002:root:/dev/null:/bin/sh

    The mistake I think I have made is to redirect the home directory to /dev/null instead of the original "/".

    Now when I tried to telnet into the system with root, the telnet client will just closed with the error message:

    "Warning: cannot change to home directory
    Connection to host lost."

    Can someone help me on how to restore from this situation? WIll reflashing the firmware works? or is there any method where I can reset the /etc/passwd file given that my telnet is gone now

    HELP HELP !!

  4. #4
    I have managed to reset the password using the web interface THanks

  5. #5
    My router is dead now!!

    Here's it the event that lead to the dead router ....

    I have stopped at "Step #4 Closing the Telnet hole" after messed up with the /etc/passwd for root. I was able to reset the /etc/passwd using the web interface by changing the user based to password based permission and changed it back to user based permission. After the /etc/passwd file was resetted, I am able to telnet into the router again.

    But while still trying to figure out how to install the bash shell, the router suddenly dead! The "Ready" ligh is off, but the IDE, WAN and AIR lights is flashing. However I am not able to connect to the router via wireless or even wired connection. The router is simply not responding and not assigning IP to my machine.

    I have further tried to re-setup using the EZSetup by pressing the "RESET" button for 5 sec until the "Ready" light blink, but after a few second, the connection lost again and router went back to dead state.

    Now I am not able to use the router for anything else except seeing the IDE, WAN and AIR light flashing...

    Anyone can help? Otherwise I will need to send it back to ASUS for revival already.. (

  6. #6
    Reset your router to default settings (hold reset for more than ~5sec.)

    After that you can start from the begining.

    just search the forum for usba, there are more people with problem like this, when you fool around with /etc/passwd /share/MYVOLUME/__pdc/passwd.
    The later contains a copy of /etc/passwd when in usba mode.

    I have testet a solution for real password protected root accounts, using a simple C-program which calls crypt() to encrypt a pssword the same way the router does, so you can encrypt your password for root and copy it into /etc/passwd.

    I suggest get rid of the original samba and install a new version. using ipkg

    but first good luck for your "white brick"

    cu Harald

  7. #7
    Thanks... I have finally revived my router and re-flashed the custom firmware.

    But there some things that I am unable to get it work still

    1. Dropbear ssh - I have installed dropbear using "ipkg install dropbear" and configure the rc.local to start up dropbear with "-s" option.

    However, when I tried to ssh to it using putty, the system just prompt for my user id, and the putty window just closed automatically.

    Is there anyway I could setup dropbear properly to enable ssh?

    2. Bit Torrent Client - I didnt installed additional package for bit torrent except the flashing the custom firmware. But my bit torrent doesnt seem to work with download manager. I have upload the torrent file via download manager to the router but it seem that there is no movement at all. In some cases, the file just get removed from the list after I refreshed the download manager web page several times. Is there anything wrong with the bit torrent client?

    3. Photo Album - I have enabled the default photo album and I am able to browse it from LAN using http://192.168.1.1:8081 . However when I tried to assess the photo album from the WAN using http://58.xx.xx.xx address, it is always returning "Internet Explorer cannot display the webpage" error.

    I have checked the port forwarding in the router and there is an entry mapping port 80 from WAN to 192.168.1.1 added automatically after I enabled the photo album.

    Is there any other steps which I missed to get the photo album working?

    Thanks so much for all your help. Thanks Thanks

  8. #8
    The -s option on dropbear indicates you want to use an ssh key and not a password, seeing as the session is closing automatically, I assume you don't have an ssh key setup. Remove the -s extension from the dropbear command in rc.local to allow you to login using a password.


    The bit-torrent client you downloaded unfortunately won't work with the download manager. The download manager is designed to work specifically with the ASUS torrent client (which as we know doesn't work properly )

    There is a lot of information on these forums of what you can do to download torrents. Most involve a bit of command line work, but there are a couple of web-frontend programs you could use.

Similar Threads

  1. Quickguide installing custom firmware?
    By Grandmaster in forum WL-700g Firmware Discussion
    Replies: 28
    Last Post: 05-03-2007, 15:46
  2. WL-500gP and Asus support experience
    By Blezi in forum WL-500gP Q&A
    Replies: 6
    Last Post: 03-12-2006, 13:59
  3. Problem flashing with custom Firmware
    By eggy in forum WL-HDD Q&A
    Replies: 2
    Last Post: 11-04-2005, 12:09
  4. Custom Firmware v1.1.2.7
    By JOCKYW2001 in forum WL-HDD Firmware Releases
    Replies: 59
    Last Post: 11-12-2004, 13:26
  5. Flashing Oleg's Firmware in WL HDD
    By hugo in forum WL-HDD Custom Development
    Replies: 29
    Last Post: 21-10-2004, 15:55

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •