Page 2 of 3 FirstFirst 123 LastLast
Results 16 to 30 of 34

Thread: Netatalk for Apple Shares?

  1. I got it working with AFP (Netatalk).

    Apparently you (the original poster) are trying to use it through Samba, which I haven't got working.

    However I wanted to use some more direct mechanism that wasn't limited by Windows conventions, and got some connection with FTP from the Finder: Command-K and use "" will mount the drive. The problem is that in my case it disconnects after a while.
    I also tried NFS, and got it working only unreliably, with disconnections after a while like with FTP. Apart from that, you have to mount it from the shell with a rather ugly command.

    Just now I got AFP working through netatalk, which is why I'm writing this reply.
    The problem I had was that it did not accept my login.
    In the log files I've seen that Netatalk (afpd) was refusing to let the root user to login, so I created a new user, set the password, and with those it works.
    I'm using Oleg's firmware, version (the current one as I write this), and installed the package netatalk.

    I'm afraid this is not easy to do, so perhaps it's not what you want, but if it works I think it's the best way to connect from MacOS X.

    What I did was to set things up as specified in this thread:
    Once you can install things in /opt (your USB hard disk) with ipkg, you can install netatalk.
    There is more information about this here:

    I removed avahi as it did not work anyway and it caused some conflicts because it needs the library, which AFAIK can only be installed with the package buildroot that conflicts with other packages I wanted.
    I guess that it would work after solving the main issue as explained below.

    Apparently Netatalk only supports plain text passwords, and Leopard requires encrypted passwords:

    As noted there, the way to make Leopard accept plain text passwords is:
    defaults write afp_cleartext_allow -bool true
    I would really prefer if this was not necessary. You might want to try first without it, and if it works please tell us here.
    I just tried to set it back to disallow plain text passwords with:
    defaults write afp_cleartext_allow -bool false
    and it seems to work fine. So if you try to follow this, please try first without setting this property and tell me if it worked.

    The final thing I had to do was to create the new user that could log in through AFP.
    For that I installed the package adduser, but since /home is read-only anyway, it could be enough to add a line to /etc/passwd like:
    normaluser:x:1000:1000:Linux User,,,:/home/normaluser:/bin/sh
    and then set the password with "passwd normaluser" from root. The user name "normaluser" is of course arbitrary: you can use other name and it would work the same.

    If you want the volume to mount a specific directory of your hard disk instead of the home directory of the user (which I think would not work at all as the directory does not exist), replace the last line (the tilde) of the file /opt/etc/netatalk/AppleVolumes.default with:
    /tmp/harddisk "Disco"
    You can put any volume name you want instead of "Disco".

    Now, I can mount my USB disk at /tmp/harddisk by hitting Command-K in the Finder, using "afp://" as the server address, and logging in as "normaluser".

  2. #17
    I cannot create Samba users on my CDMA supported firmware.
    On WIndows it does not ask for authentification, but under MacOSX leopard, I need user & password

    How can I create user & password ?
    Attached Images Attached Images  

  3. #18

    mDNSProxy/rendezvous package for wl-500gp, Oleg fw

    I want to run a rendezvous/bonjour proxy on wl-500gp so I can connect from my home itunes to the itunes share running in my office (something like this but on asus wl-500gp instead on PC or Mac).

    Do anyone know about the mDNSProxy/rendezvous/bonjour package for ASUS wl-500gp with olegs firmware?

    Updated Jun 2008
    I found the package avahi. But it does not work with my Asus. You can try to install it
    but I end up with the error message
    ipkg avahi
    /opt/sbin/avahi-daemon: can't load library ''
    I found this solution but avahi is still failing. I installed buildroot, created missing user avahi and finally obtained following error:
    Found user 'avahi' (UID 1002) and group 'avahi' (GID 1002).
    Successfully dropped root privileges.
    avahi-daemon 0.6.22 starting up.
    WARNING: No NSS support for mDNS detected, consider installing nss-mdns!
    dbus_bus_get_private(): Failed to connect to socket /opt/var/run/dbus/system_bus_socket: Connection refused
    WARNING: Failed to contact D-Bus daemon.
    [admin@my root]$ avahi-daemon --debug -D
    Timeout reached while wating for return value
    Could not receive return value from daemon process.
    But my ipkg does not know nss-mdns: I found it by but not in the oleg's optware section.
    Last edited by tlustoch; 20-06-2008 at 16:22. Reason: update

  4. #19
    Join Date
    Jun 2007
    Braga / Portugal

    Trying to run a binary file

    I've installed the package netatalk, which provide the binary afpd. But when I try to run this binary, I get the message -sh: afpd: not found. Even if I use the full path, I get the same message. This happens with almost all binaries provided by this package.

    Anybody knows what is the problem and/or hot to solve it?

    Last edited by Rui_Carlos; 27-07-2008 at 14:03.

  5. #20
    Join Date
    Jun 2007
    Braga / Portugal
    Quote Originally Posted by matmota View Post
    Apparently you (the original poster) are trying to use it through Samba, which I haven't got working.
    You can try this:
    I'm using Samba, and it works!

    PS: I've tried AFP, but I couldn't put Netatalk working :\

  6. #21
    just follow this post
    working for me (read/write allowed on EXT3) I have the same HD

  7. #22

    slow HTTPS

    I'm running out of ideas here, so I have to ask, even though it may has been already discussed before (I extensively searched the forum, but sorry, couldnt find anything).

    I have installed oleg's firmware and followed pretty much wengi's tutorial to get everything beautifully running on my asus router, incl transmission and netatalk (for TimeMachine backups). So far, so good.

    However, all https sites, are incredibly slow or even timeout, but on the other hand, I do not have any problems whatsoever with any other site. (This is particular annoying for gmail, etc.)

    First I thought about a port problem, but I can't figure out (or prob I don't understand it at all) any reason why particularly secure sites are not working? https uses 443, right? Any collisions possible with transmissiond? Though I'm using transmissiond -p 65534... etc.
    So can this be related? Or am I just stupid?

    Any help, any ideas? I'm willing to give any further information on my settings, if needed.

    I would really appreciate any feedback, I'm getting nuts here Thanks a lot!

  8. #23
    Thanks for your reply. But I dont think anything is wrong with the settings of my browser, since this problem occurs on various different computers and browsers (and with the same settings, in another network, everything is fine).

    Somehow, I believe, I tracked it down to the transmission client being the cause of this. If transmission is 'paused' or stopped, speed is up to normal.

    That maybe helps to access https sites, but I still don't understand it. It simply makes NO SENSE !!!

    I could understand, if the whole network would slow down, due to heavy CPU consumption on the router (which is NOT the case) or something like that. But why only https sites?
    ... like I said: I'm getting crazy!

  9. #24
    Join Date
    Apr 2005
    Vienna, Austria
    Does transmission-daemon consume all available bandwidth? Does it help to reduce the maximum upload/download rate of transmission?
    Did you try do use a different port for transmission?
    Maybe you should take a look at the wan traffice with tcpdump, with transmission running and stopped.

  10. #25
    Try lowering the MTU on your pc from 1500 to 1400.
    I had the same issue (https timing out) a while ago, and in my case there were a few bad routers between me and the rest of the world.
    These routers dropped anything bigger than 1400.

    (you can check it with mturoute.exe -t)

  11. #26
    Join Date
    Jun 2008


    i have the same problem and i fixed this morning starting service "dbus" :

    root@OpenWrt:~# /opt/etc/init.d/S20dbus start
    root@OpenWrt:~# avahi-daemon
    Found user 'avahi' (UID 1000) and group 'avahi' (GID 1000).
    Successfully dropped root privileges.
    avahi-daemon 0.6.24 starting up.
    WARNING: No NSS support for mDNS detected, consider installing nss-mdns!
    Loading service file /opt/etc/avahi/services/daapd.service.
    Loading service file /opt/etc/avahi/services/sftp-ssh.service.
    Loading service file /opt/etc/avahi/services/ssh.service.
    Joining mDNS multicast group on interface br-lan.IPv4 with address
    New relevant interface br-lan.IPv4 for mDNS.
    Network interface enumeration completed.
    Registering new address record for on br-lan.IPv4.
    Registering HINFO record with values 'MIPS'/'LINUX'.
    Server startup complete. Host name is OpenWrt.local. Local service cookie is 4021731059.
    Service "OpenWrt" (/opt/etc/avahi/services/ssh.service) successfully established.
    Service "SFTP File Transfer on OpenWrt" (/opt/etc/avahi/services/sftp-ssh.service) successfully established.
    Service "OpenWrt" (/opt/etc/avahi/services/daapd.service) successfully established.
    and then i start my daapd server

    root@OpenWrt:~# mt-daapd -c /etc/mt-daapd.conf

    sorry for my english, i´m spanish
    Last edited by DVB; 03-02-2009 at 19:41.

  12. #27

    Create a startup script for avahi

    For those who want to start avahi when the device start I have wrote this little startup script.

    Create startup script by typing:
    nano -w /opt/etc/init.d/S90avahi-daemon
    and paste this:
    # Startup script for avahi-daemon

    case $1 in
    /opt/sbin/avahi-daemon -D

    /opt/sbin/avahi-daemon -k

    $0 stop
    $0 start

    echo "Usage: $0 (start|stop|restart)"
    exit 1
    Save the file by closing nano.
    Make it executable and start it:
    chmod 755 /opt/etc/init.d/S90avahi-daemon
    /opt/etc/init.d/S90avahi-daemon start
    Avahi is now running, you can check the process with:
    ps ax | grep avah[i]
    If you have follow the part 5 of this How to, the post-mount script will automaticaly call this script at start.

  13. #28

    Easier fix - for me anyway

    Rather than have Your Mac send unencrypted passswords, edit your samba config to allow encrypted passwords.

    $ nano /etc/smb.conf
    $ cat /etc/smb.conf
    interfaces = br0
    bind interfaces only = yes
    workgroup = Workgroup
    server string = WLHDD
    guest account = nobody
    security = share
    browseable = yes
    guest ok = yes
    guest only = yes
    log level = 1
    max log size = 100
    encrypt passwords = yes
    preserve case = yes
    short preserve case = yes

    path = /opt/share/share
    writable = yes
    force user = admin

    $ flashfs save && flashfs commit && flashfs enable

  14. #29
    Join Date
    Jan 2009

    may you show, how to install/configure AFP for usage with mac?

    I am using SMB/CIFS, and had no problem until now. It is only slow :-)


  15. #30
    Join Date
    Jan 2009

    Installing Netatalk - need help

    Quote Originally Posted by Barron View Post
    just install the package "ipkg install netatalk"
    I tried this, but got this error:
    [Du@PooWL700gE /]$ sudo ipkg install netatalk
    Installing netatalk (2.0.3-5) to /opt/...
    Installing libdb (4.2.52-3) to /opt/...
    Configuring libdb
    Configuring netatalk
    Configuring vsftpd
    You'll need to add line like
    echo "ftp stream tcp nowait root /opt/sbin/vsftpd /opt/etc/vsftpd.conf" >>/etc/inetd.conf
    to your /unslung/rc.xinetd file -- see the wiki at for more info
    postinst script returned status 1
    ERROR: vsftpd.postinst returned 1
    Successfully terminated.
    May s.o. pleeeaase help me :-)
    THANK U!

    EDIT: Got it working, but how to delete this posting?
    Last edited by pooz; 06-11-2009 at 15:25.

Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. Shares disk (Samba) afschermen met firewall.
    By Ikke in forum Dutch Discussion - Nederlands
    Replies: 3
    Last Post: 15-01-2007, 11:18
  2. Can't delete shares/ erase disk
    By dome in forum WL-700g Q&A
    Replies: 3
    Last Post: 03-01-2007, 19:40
  3. Replies: 0
    Last Post: 28-10-2006, 10:29
  4. Edit Samba Shares
    By Chellenger in forum WL-500g Q&A
    Replies: 1
    Last Post: 19-03-2006, 19:47
  5. Samba shares only accessable from LAN
    By Arnoldm in forum WL-500g Q&A
    Replies: 2
    Last Post: 28-03-2005, 07:26

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts