Page 1 of 2 12 LastLast
Results 1 to 15 of 24

Thread: Mediatomb

  1. #1


    Has anyone already tried to install Mediatomb on a WL-500g?

    the package is easy to install and to start, but i don't have a clue how to get the web interface up running.
    Tried to follow the documentation at:
    but that seems more for linux gurus.

    A quick install guide would be nice

  2. #2

    first of all - this was reported to us by a WL500g user - there was a problem with automatic database creation. It's difficult for me to debug this, because I do not own a WL500g so I can not test it myself; if you have this problem (that would happen on startup, you would get some error message from sqlite and then the server would terminate) - create the databse manually.

    This is quite easy to do, you just need the sqlite version 3 command line client, then enter the following:

    cat /opt/share/mediatomb/sqlite3.sql | sqlite3 mediatomb.db

    This will create the database, copy the database file into your ~/.mediatomb/ or make sure that the ~/.mediatomb/config.xml file points to the correct database location. I just realized that I forgot to put that into the documentation...

    Alternatively, you can enter a fixed port in the config.xml, simply put <port>50000</port> in the server section - after the launch of the server you will be able to connect to the UI via http://your-router-ip:50000/

    Upon server startup the link to the UI is also printed in the console.

    Let me know how it went :) If you get stuck you can visit us on IRC: #mediatomb on for realtime support.


    P.S. if you use a DSM-320 or similar D-Link renderer you may need some special options in your config.xml, just check the docs :>

  3. #3
    Hi Jin,

    Great news! Got it to work!

    This was the error after starting 'mediatomb'
    terminate called after throwing an instance of 'StorageException'

    This is how it was solved: (your oneliner didn't produce the mediatomb.db)
    - cd /opt/share/mediatomb
    - cat sqlite3.sql | sqlite3 mediatomb.db
    - I then moved the mediatomb.db (17408 bytes) to /usr/local/root/.mediatomb

    and finally started 'mediatomb' from the commandline, which now starts correctly on default port 49152.

    My configuration:
    -Wl-500g running lighttpd at the moment.
    -Didn't make ANY changes to the default installation other than above!
    Last edited by avberk; 08-03-2007 at 12:08.

  4. #4

    Well, this was exactly the problem that was also reported by an other WL500g user. Somehow automatic database creation fails on this device, we have to investigate why. Would be nice to have this feature working to further simplify the installation.

    Anyway, great to hear that it works :)


  5. #5

    i search mediaserver for my wlhdd

    do you explain exactly how to install mediatomb


  6. #6
    Quote Originally Posted by fennec View Post

    i search mediaserver for my wlhdd

    do you explain exactly how to install mediatomb

    Well.. in the meantime it turned out that things are much more complicated.
    There are various problems on the WL500g, mainly - it seems that uclibc++ does not catch C++ exceptions. I am still investigating that, but this issue makes the server unusable.

    If you want to try some debugging - packages are available here:


  7. #7
    ok great

    i try this


  8. #8

    i try to install package but i have the error and nothing install

    [admin@WLHDD etc]$ ipkg install mediatomb
    Installing mediatomb (0.9.0-pre-1) to root...
    Nothing to be done
    An error ocurred, return value: 1.
    Collected errors:
    ERROR: Cannot satisfy the following dependencies for mediatomb:
    [admin@WLHDD etc]$
    i find nothing in folder opt/share

  9. #9

    i add

    in ipkg.conf

    and ipkg install libstdc++

    and install ok

    i continu

  10. #10

    i do ipkg install libuclibc++

    and all is ok

    very great thanks !!!!!!!!!!!!!!

  11. #11
    Join Date
    Jun 2005
    With now includes libuclibc++ depend although libuclibc++ provides libstdc++ functionality.

  12. #12

    how to make Mediatomb running ?

    Hi Guys

    Could you please explain how to start up MediaTomb ?

    I installed it via ipkg, but when trying to run, I've got the message: "can't load library '".

    Should I install uclibc-opt or libstdc++ (from ?

    Or how to make a use of oleo's script(?) from a previous post ?


  13. #13

    Mediatomb and mysql

    My mediatomb has a little bit problems with the database (SQLITE on asuswl500gp).
    I tried mysql (like in the doc). But I always get the error:

    terminate called after throwing an instance of 'zmm::Exception'

    Is this mediatomb compiled to run with mysql?

  14. #14

    sorry, but it turned out it does not yet work. Unfortunately I lost sight of Oleo, so we have not made much progress yet. From what I know the exception problem is solved in the optware unstable branch, but some problems related to id3lib still remain.

    I hope that we can follow up on this at some point, and finally provide a working solution for the WL500g


  15. #15
    Hi everyone,

    it's been a while :>

    I am currently working on static packages that should run as an addon to any existing vendor firmware. If anyone is interested - here is more info:

    Kind regards,

Page 1 of 2 12 LastLast

Similar Threads

  1. MediaTomb - установка и настройка медиа-сервера
    By dfayruzov in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 207
    Last Post: 12-12-2012, 08:06

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts