Page 2 of 18 FirstFirst 123412 ... LastLast
Results 16 to 30 of 269

Thread: Проблемы установки пакетов ipkg и запуска программ

  1. #16
    Join Date
    Aug 2006
    Location
    Moscow, Russia
    Posts
    788
    Quote Originally Posted by _ab_ View Post
    Почему ошибка file not found? Или это об uclibc?
    Да.
    Quote Originally Posted by _ab_ View Post
    Интересно, а будет ли работать MySql из http://ipkg.nslu2-linux.org/feeds/op.../cross/stable/
    Работать может и будет, но всеж ИМХО для роутера это тяжеловато.

  2. #17
    Решил попробовать честно сменить репозитарий.
    Не ставится uclibc

  3. #18
    Join Date
    Aug 2006
    Location
    Moscow, Russia
    Posts
    788
    Quote Originally Posted by _ab_ View Post
    Не ставится uclibc
    Хм. Смотрю, что из репозитария пропал пакет uclibc. Теперь вместо него uclibc-opt.

    В общем, насколько я помню, для перехода на правильный репозитарий http://ipkg.nslu2-linux.org/feeds/op.../cross/stable/ надо выполнить следующие действия:
    Code:
    # Прописываем новый репозитарий
    /bin/echo "src unslung http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable" > /opt/etc/ipkg.conf
    /bin/echo "dest root /" >> /opt/etc/ipkg.conf
    # Обновляем базу пакетов && Устанавливаем обновленную uclibc && Переустанавливаем все раннее установленные пакеты, которые были скомпилированны под старую uclibc 
    ipkg update && ipkg install uclibc-opt && /usr/bin/awk '/^Package:/{system("ipkg install -force-reinstall -force-defaults " $2)}' /opt/lib/ipkg/status
    Переустановить все раннее установленные пакеты нужно обязательно! У программ, скомпилированных под старую uClibc с новой версией башню сносит.

    P.S. Еще я вспомнил, чтоб никто немучался, есть некоторые проблемы с пакетом rrdtool из того репозитария с прошивкой 1.9.2.7-7f. Лечится установкой прошивки 1.9.2.7-7g-pre1 (http://oleg.wl500g.info/7g/)
    Last edited by Mam(O)n; 27-08-2007 at 13:20.

  4. #19
    Тогда лучше подождать последней 7g. Мало ли что еще и в репозитарии поменяется.

  5. #20
    Join Date
    Aug 2006
    Location
    Moscow, Russia
    Posts
    788
    Кстати проблемы не в rrdtool из того репозитария а в ошибке эмуляции функций математического сопроцессора (функций с плавующей точкой, kernel fpemu) в прошивке 7f. (трэд, решение)
    А переход на этот репозитарий желателен ввиду того, что пакеты там скомпилированы под новую библиотеку uclibс.

    Вот мой перевод выдержки из статьи на www.nslu2-linux.org/wiki/FAQ/Optware-uClibcBuild
    Почему нужно установить новую версию uclibc?

    Текущая версия uClibc, которая поставляется вместе с прошивкой Олега, имеет некоторые проблемы. Прежде всего это - довольно старая версия. Следующая проблема заключается в том, то что есть множество программ, которые не компилируются со старой библиотекой. Например, нужная мне программа, которая не компилировалась, это - "unrar", но есть и множество других примеров.

    Я не могу сказать Вам точно, почему эти программы не компилируются с uClibc (является ли это проблемой старой версией uClibc, или это кое-что специфическое для WL-500g - если Вы знаете, не стесняйтесь сообщить мне) Что я действительно знаю, это на WL500g.info (это первое место, куда Вы должны заглянуть для получения полезной информации по WL500g!) гарнi хлопiц Oleo написал, что он преуспел в том, что использовал более новую версию библиотеки uClibc v0.9.28, которая решает множество проблем, которые были найдены в оригинально-поставляемой Олегом версии uClibc v0.9.19.

    Это значит, что Вы можете использовать намного больше пакетов на вашем WL-500g чем ранее, и это также дает Вам больший шанс, что вы сможете создать собственный пакет, откомилировав код без проблем.

  6. #21
    Я все же уговорился
    Сменил прошивку и репозитарий - работает Спасибо!
    Все пока не проверял - не стал делать force-reinstal - ручками переставлю.

  7. #22
    я их до переустановки прошивки все снес - ext3 переформатировал (диск подглючивал)

  8. #23

    bind

    Доброго времени суток!
    Пишу с такой непоняткой.
    Прошивка 1.9.2.7-7g-pre1 для asus wl500gp. Установил bind_9.3.4-1_mipsel.ipk c репозитория http://ipkg.nslu2-linux.org/feeds/op...g/cross/stable . В процессе потребовался openssl, который я установил с того репозитория. named.conf я написал и положить его в /opt/etc/named/named.conf .
    Code:
    acl "corpnets" {192.168.123.0/24; 192.168.0.0/24; 127.0.0.1};
    options {
        directory "/opt/etc/named";
        pid-file "/opt/var/run/named.pid";
        allow-query {"corpnets"};
        forwarders {192.168.0.2};
    	 };
    zone "." {
        type hint;
        file "named.root";
        };
    zone "localdomain" {
        notify no;
        type master;
        file "named.localdomain";
        };
    zone "123.168.192.in-addr.arpa" {
        type master;
        file "named.192.168.123.rev";
        };
    zone "localhost" {
        type master;
        file "named.localhost";
        };
    zone "0.0.127.in-addr.arpa" {
        type master;
        file "localhost.rev";
        notify no; 
        };
    Есть также файлы зон.

    При запуска /opt/etc/init.d/s09named start выдаётся сообщение:
    Code:
    Starting DNS Services: /opt/sbin/named: /opt/sbin/named: 1: Syntax error: "(" unexpected started
    Вопрос - что не нравиться named ? На FreeBSD подобный конфиг нормально работает.

    Удаляю всё из конфига - результат тот-же => дело не в конфиге.
    Удалил эту версию, поставил bind_9.3.3-1_mipsel.ipk . Тоже самое.
    Кто-нибудь поднимал на роутере успешно bind из репозитариев? Какой бубен использовался?

    Прояснилось в мозгах. Перечитал эту тему чуть выше и пришло решение.
    Поставил пакет uclibc-opt и жизнь стала налаживаться, пришлось переставить mc. Кстати поставился он обычным способом - ipkg install mc.
    Last edited by Omega; 17-01-2011 at 23:48. Reason: 2 post merged

  9. #24
    Еще о преимуществах этого репозитария - MySql действительно работает хоть и неспешно...
    При смене глючного php-thttpd на lighttpd (http://wl500g.info/showthread.php?t=...light=lighttpd) заработал и phpmyadmin. Кстати lighttpd вообще работает стабильнее чем php-thttpd

  10. #25

    Проблема с установкой пакетов (ipkg)

    Проблема в следующем:
    Провайдер раздает инет через http проксик. И на компах он работает.
    А как настроить ipkg для работы через прокси я немогу найти
    Подскажите, плз, возможно это впринцыпе и если да ту куда и чё писать

  11. #26
    Join Date
    Aug 2006
    Location
    Moscow, Russia
    Posts
    788
    Вот выдержка из ipkg.conf из первоисточника.
    Code:
    # Proxy support:
    #
    #option http_proxy http://proxy.tld:3128
    #option ftp_proxy http://proxy.tld:3128
    #option proxy_username <username>
    #option proxy_password <password>
    Попробуй прописать эти опции

  12. #27

    Установка программ в роутер

    Читал что во флехе даже после прошивки от Олега остаеться немного места - туда можно поставить какуюнить программу(меня интересует прокси) или нужен обязательно внешний накопитель?

  13. #28
    Join Date
    Jan 2006
    Location
    Moscow
    Posts
    85
    Quote Originally Posted by TDA View Post
    Читал что во флехе даже после прошивки от Олега остаеться немного места - туда можно поставить какуюнить программу(меня интересует прокси) или нужен обязательно внешний накопитель?
    Насколько я помню, flashfs имеет размер 64 кб, так что туда вряд ли что-то влезет. Проксик, например старенький nylon, занимает около 50, + конфиги....
    Вряд ли влезет и будет работать.

    Проще воткнуть любую флешку, хоть на 32 метра, и на нее все поставить.
    Last edited by Omega; 15-04-2011 at 19:34. Reason: fixed

  14. #29
    Quote Originally Posted by SergeyVl View Post
    Проще воткнуть любую флешку, хоть на 32 метра, и на нее все поставить.
    Проще, если есть куда втыкать, в WL-550gE просто так не воткнуть, если только распаивать разъем самому.
    Интересный вопрос, кстати. Мне бы хоть MC поставить.
    Router: ASUS WL-550gE
    Firmware (Oleg): 1.9.2.7-10

  15. #30
    Join Date
    Jan 2006
    Location
    Moscow
    Posts
    85
    Quote Originally Posted by Alex Kud View Post
    Проще, если есть куда втыкать, в WL-550gE просто так не воткнуть, если только распаивать разъем самому.
    Интересный вопрос, кстати. Мне бы хоть MC поставить.
    Да, если нет разъема, то это уже проблема...
    Но mc в память роутера не воткнуть, бинарка весит больше метра, и еще библиотеки нужны.

Page 2 of 18 FirstFirst 123412 ... LastLast

Similar Threads

  1. Проблемы с установкой пакетов OptWare & EntWare
    By djserg-minyar in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 64
    Last Post: 06-05-2015, 15:08
  2. Кросскомпиляция пакетов
    By dfayruzov in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 123
    Last Post: 05-11-2014, 21:08
  3. ipkg en wl-500gp v2
    By Nzmeuo in forum Spanish Discussion - Espaсol (ES)
    Replies: 4
    Last Post: 23-08-2012, 15:05
  4. ipkg update error too
    By rosemarie321 in forum WL-500gP Q&A
    Replies: 0
    Last Post: 21-04-2012, 16:14
  5. Install softs even you can't install ipkg
    By once in forum SL-1000 Q&A
    Replies: 0
    Last Post: 21-06-2007, 06:50

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •