Results 1 to 6 of 6

Thread: vsftpd.conf Kfurge Help!!!

  1. #1

    vsftpd.conf Kfurge Help!!!

    Kfurge,

    I need your help. Can you add the following lines into /etc/vsftpd.conf:

    Code:
    pasv_enable=YES
    pasv_min_port=65000
    pasv_max_port=65535
    I hope this will enable pasv support into the wl-700ge. Which mean, windows xp's explorer can view the content.

    Sollie.

  2. #2
    Sollie, you could also use optware to install a new ftp server and use that instead of the one included with the ASUS firmware.

  3. #3
    I like to use the webinterface
    So i thought to use the default one.
    Sollie.

  4. #4
    No problem. At a minimum I can re-route the conf file through /tmp allowing it to be redirected elsewhere at startup.

    - K.C.

  5. #5
    K, thank you. Let me know if i can test something.

    Sollie.

  6. #6
    Do this:

    Step1: Copy vsftpf conf
    "cp /etc/vsftpd.conf /opt/etc"

    Step 2: add pasv-mode support to vsftpd.conf
    "nano /opt/etc/vsftpd.conf"

    Add the following lines to the end of this file:
    pasv_enable=YES
    pasv_min_port=65000
    pasv_max_port=65535
    pasv_address=85.145.44.81
    (WAN-ip)

    Step 3: (re)start vsftpd with the new vsftpd.conf file at boot. Add the following lines to your rc.local file:
    #Enable pasv-mode for vsftpd
    killall vsftpd
    /sbin/vsftpd /opt/etc/vsftpd.conf &

    Thats all.

    Sollie.

    PS: the WAN-ip setting in vsftp.conf breaks pasv-mode support for local users.

Similar Threads

  1. How-to : install kfurge 1.0.4.6_kc_02a custom firmware
    By jeromv in forum WL-700g Tutorials
    Replies: 5
    Last Post: 16-02-2008, 23:49

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •