Results 1 to 15 of 21

Thread: Openwrt On Wl700ge Update Book

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    Jan 2007
    Location
    Netherlands
    Posts
    190

    Openwrt On Wl700ge Update Book

    We are setting up a book on how to update and set up the asus wl700ge firmware to openwrt
    This book will eventualy be a detailed instruction guide on how to set up every component of openwrt
    It can be modifyed by registerd users ,so feel free to participate in it
    installing custom asus firmware is also in here

    http://wl700g.homelinux.net
    Last edited by back2basic; 07-09-2007 at 10:49.

    Openwrt or Custom Firmware on asus? - http://wl700ge.hezik.nl/ - Http://wl700g.homelinux.net

    My ASUS collection: WL500gp(80GB usb-hdd - Running OpenWrt Kamikaze 7.09) | WL700gE(250GB - Running OpenWrt Kamikaze 8.09rc1)

  2. #2
    Join Date
    Jan 2007
    Location
    Cph, Denmark
    Posts
    38
    Quote Originally Posted by back2basic View Post
    We are setting up a book on how to update and set up the asus wl700ge firmware to openwrt
    This book will eventualy be a detailed instruction guide on how to set up every component of openwrt
    It can be modifyed by registerd users ,so feel free to participate in it

    http://back2basic.shacknet.nu/WL700Ge/

    Thank you very much, this proved very useful to me!

  3. #3
    Forgive my ignorance, but does this firmware require everything to be setup and run through a command line? In other words, there is no GUI?

  4. #4
    Join Date
    Jan 2007
    Location
    Netherlands
    Posts
    190
    Quote Originally Posted by umonster View Post
    Forgive my ignorance, but does this firmware require everything to be setup and run through a command line? In other words, there is no GUI?
    there is no GUI atm x-wrt is builing one but it is still in develepment

    Openwrt or Custom Firmware on asus? - http://wl700ge.hezik.nl/ - Http://wl700g.homelinux.net

    My ASUS collection: WL500gp(80GB usb-hdd - Running OpenWrt Kamikaze 7.09) | WL700gE(250GB - Running OpenWrt Kamikaze 8.09rc1)

  5. #5
    Join Date
    Jan 2007
    Location
    Netherlands
    Posts
    190

    name of the site has changed

    The name of the site has changed into

    http://wl700g.homelinux.net

    Openwrt or Custom Firmware on asus? - http://wl700ge.hezik.nl/ - Http://wl700g.homelinux.net

    My ASUS collection: WL500gp(80GB usb-hdd - Running OpenWrt Kamikaze 7.09) | WL700gE(250GB - Running OpenWrt Kamikaze 8.09rc1)

  6. #6

    my thoughts

    I tried openwrt on my wl-700ge. It is decently fast compared to asus firmware but the lack of a gui for making quick configuration changes is a big disadvantage. I use pppoe adsl and never could get it shared to wireless clients. When I went through my old router into the asus with DHCP everything was fine but pppoe would just work on the router and wouldn't share to clients.

    I will go back to this firmware as soon as X-WRT is available on kamikaze and wl-700ge.

    Just my 2 cents.

    mecheng

  7. #7
    Join Date
    Jan 2007
    Location
    Netherlands
    Posts
    190
    Quote Originally Posted by mecheng View Post
    I tried openwrt on my wl-700ge. It is decently fast compared to asus firmware but the lack of a gui for making quick configuration changes is a big disadvantage. I use pppoe adsl and never could get it shared to wireless clients. When I went through my old router into the asus with DHCP everything was fine but pppoe would just work on the router and wouldn't share to clients.

    I will go back to this firmware as soon as X-WRT is available on kamikaze and wl-700ge.

    Just my 2 cents.

    mecheng

    x-wrt is availble and working but still in development so it isn't 100%

    Openwrt or Custom Firmware on asus? - http://wl700ge.hezik.nl/ - Http://wl700g.homelinux.net

    My ASUS collection: WL500gp(80GB usb-hdd - Running OpenWrt Kamikaze 7.09) | WL700gE(250GB - Running OpenWrt Kamikaze 8.09rc1)

  8. #8
    I couldn't get any of the X-wrt versions to work on my router. I tried install from the firmware on their website and installing it on top of kamakazi install from your guide b2b. Please help me with a link to some info on this or lets chat so I can pick your brain as to what works and what doesn't.

    Kfurge's firmware seems to work good lately!!

    15:29:13 up 19 days, 20:02, load average: 0.09, 0.09, 0.08

    pppoe adsl
    and 3 linux laptops on wlan

    Just to Update I had OpenWRT Kamikaze and a very nice web interface (X-WRT Webif^2) running on the router. The only hitch was that I was never able to connect to the wireless. Wired was fine. I am going to try to reflash.
    Last edited by mecheng; 27-06-2007 at 05:38.

  9. #9
    PPTP is not working on Austrian AON provider!
    If someone is willing to provide me with support I am willing to make the eval on the entire PPTP interface.

  10. #10
    Quote Originally Posted by mecheng View Post
    I tried openwrt on my wl-700ge. It is decently fast compared to asus firmware but the lack of a gui for making quick configuration changes is a big disadvantage. I use pppoe adsl and never could get it shared to wireless clients. When I went through my old router into the asus with DHCP everything was fine but pppoe would just work on the router and wouldn't share to clients.
    I have an ethernet ADSL modem and a wl700ge unit for my home networking equipment. It was a bit tricky to get these working together with wireless enabled.

    Use your old router first, login and install every package with either "pppoe" or "ppp" alone as part of the package name. At least one ppp-related package is not included in the default firmware image, but I forget which one it was. You can find the packages you need by using the command: 'ipkg list | grep ppp'. You can find the ones you have already installed using the command: 'ipkg list_installed | grep ppp'.

    Also, install the wirless-related packages as described here:
    http://wl700g.homelinux.net/portal/content/view/37/30/

    OK, now you need to set your modem to "bridging" mode, to allow the wl700ge to do the pppoe login. Do not let the modem login and connect the wan interface of the wl700ge using dhcp, as this interferes somehow with the dhcp part of dnsmasq in the wl700ge serving the lan ports.

    With the modem set to bridging mode, and all of the ppp and pppoe related packages previously installed, edit /etc/config/network and set the wan section as described in post #3 on this thread:
    http://forum.openwrt.org/viewtopic.php?id=11451
    Code:
    For PPOE/DSL connection try the following settings in /etc/config/network :
    
    config interface        wan
            option ifname   "eth0.1"
            option proto    pppoe
            option username "your-userid@isp-name"
            option password "your-password"
            option keepalive 10
            option mtu      1492
    AFAIK, the wireless configuration at either reference is correct, but the wan section must be set as per the code box above.

    This combination works for pppoe and for wireless, and dnsmasq also works properly.
    Last edited by hal2k1; 08-11-2007 at 01:03.

  11. #11
    This combination works for pppoe and for wireless, and dnsmasq also works properly.
    Not stable, I'm afraid. The kam7.09 version and pppoe somehow can't live with each other for mor than a few days, it would seem.

    Back to the drawing board!

    Quote Originally Posted by hal2k1 View Post
    OK, now you need to set your modem to "bridging" mode, to allow the wl700ge to do the pppoe login. Do not let the modem login and connect the wan interface of the wl700ge using dhcp, as this interferes somehow with the dhcp part of dnsmasq in the wl700ge serving the lan ports.
    I tried this again, and this time I seem to have got it working with the ADSL modem doing the pppoe login, and the wl700ge using dhcp.

    I'm not sure how it is configured differently now compared with before, but it does now seem to be working.

    So ... mea culpa, I was wrong. Don't use pppoe on the wl700ge box while running kamikaze. Get another router, or your ADSL mode, to do the pppoe login instead.

  12. #12
    Join Date
    Jan 2007
    Location
    Netherlands
    Posts
    190

    Powerfailure Host offline (temporary)

    Due to a powerfailure my host got kicked offline .
    It's the second faillure today, I don't know how long its gonne take until power is restored.
    I'm sitting now here in the dark with a few candles, logged in over my mobile phone line.

    As soon as power is restored I'll post a message,I hope it will be in a few hours.

    Sorry for the problem......

    Openwrt or Custom Firmware on asus? - http://wl700ge.hezik.nl/ - Http://wl700g.homelinux.net

    My ASUS collection: WL500gp(80GB usb-hdd - Running OpenWrt Kamikaze 7.09) | WL700gE(250GB - Running OpenWrt Kamikaze 8.09rc1)

  13. #13
    Join Date
    Jan 2007
    Location
    Netherlands
    Posts
    190
    Its back online

    Openwrt or Custom Firmware on asus? - http://wl700ge.hezik.nl/ - Http://wl700g.homelinux.net

    My ASUS collection: WL500gp(80GB usb-hdd - Running OpenWrt Kamikaze 7.09) | WL700gE(250GB - Running OpenWrt Kamikaze 8.09rc1)

  14. #14

    Software repository for open wrt

    I've just installed open wrt on my ASUS-wl700ge using your link: http://wl700ge.hezik.nl (OpenWrt - BackFire - 10.03.1 - Asus WL700gE)
    Now I need to install software.

    Can somebody please advice sowtware repository and package to be used with that version. Since now there is no any package manager installed (ipkg or opkg).

    Thanks, Pavel

Similar Threads

  1. OpenWrt on WL700gE
    By MoD in forum WL-700g Firmware Discussion
    Replies: 1
    Last Post: 30-10-2006, 17:18
  2. Completely new WL700gE router crashed after firmware update - plz help!
    By ClaudeX in forum WL-700g Firmware Discussion
    Replies: 4
    Last Post: 20-07-2006, 01:03
  3. WL700GE openwrt or Oleg firmware
    By lewislin in forum WL-700g Q&A
    Replies: 7
    Last Post: 30-06-2006, 17:50
  4. ELF 32-bit errors, port openwrt package to WL700gE
    By lewislin in forum WL-500g Q&A
    Replies: 0
    Last Post: 08-03-2006, 22:30
  5. newly installed openwrt, ipkg update error...
    By mutejute in forum WL-HDD Q&A
    Replies: 2
    Last Post: 13-02-2006, 11:23

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •