Results 1 to 3 of 3

Thread: Cannot mount using NFS between 500g & 500gP

  1. #1

    Red face Cannot mount using NFS between 500g & 500gP

    I have a 500g(oleg1.9.2.7-7c) and a 500gP(oleg 1.9.2.7-7f). In this setup, my 500gP is the main internet & LAN router/gateway/media server. The 500g is solely used for usb-audio. 500g is in router mode & WDS mode and gets an ip from 500gP. The 500gP is in home gateway & hybrid mode. Hybrid is needed to have the 500g act as a 'client'.

    The 500gP has a 300GB usb harddisk attached. I want the 500g to connect to this harddisk to have an /opt mount and use ipkg etc. Therefore I'd thought I should use NFS for this.

    I enabled NFS on both the 500g & 500gP through the webinterface. I edited the /etc/exports on the 500gp like this:

    Code:
    # automagically generated from web settings
    /opt/wl500g_opt 192.168.3.99(rw,async,no_root_squash)
    /tmp 192.168.3.99(rw,async,no_root_squash)
    IP of 500gP = 192.169.3.1 ('cadillac')
    IP of 500g = 192.168.3.99 ('spirit')

    On the 500g, I try:
    Code:
    mount -t -nfs 192.168.3.1:/opt/wl500g_opt /opt
    The return is:
    Code:
    [prive@spirit root]$ mount -t nfs 192.168.3.1:/opt/wl500g_opt /opt
    mount: 192.168.3.1:/opt/wl500g_opt failed, reason given by server: Permission denied
    mount: nfsmount failed: Bad file descriptor
    mount: Mounting 192.168.3.1:/opt/wl500g_opt on /opt failed: No such device
    So it seems that permissions are still not set right. I searched this forum for 2 hours and tried everyting, but I am really stuck now. I have the feeling that nfs should easily work since it is true linux sharing! But the only thing I have working at the moment is samba which is working like a champ. Can someone put me in the right direction?

    Edit:
    showmount and showmount -e do not give the nfs shares in /etc/exports:
    Code:
    [prive@spirit root]$ showmount 192.168.3.1
    Hosts on 192.168.3.1:
    [prive@spirit root]$ showmount -e 192.168.3.1
    Export list for 192.168.3.1:
    [prive@spirit root]$
    Last edited by shoot; 07-01-2007 at 10:37.

  2. #2
    Join Date
    Aug 2005
    Location
    Paris
    Posts
    10
    Hello

    I've a similar issue, my NFS share is on a Nas (ss4000-e from intel)
    I've no issue mounting NFS share from my other linux boxes (Debian 2.6.x)

    But the Wl500g cannot mount the NFS share see error message

    Code:
    [root@intranet root]$ mount -t nfs 10.10.128.235:/nas/NASDisk-00002/wl500_85 /opt/NasServer/
    mount: Mounting 10.10.128.235:/nas/NASDisk-00002/wl500_85 on /opt/NasServer failed: No such device
    But on my NAS log it should be ok

    Code:
    Feb 15 20:04:23 (none) user.notice rpc.mountd: authenticated mount request from intranet.mynetwork.net:863 for /nas/NASDisk-00002/wl500_85 (/nas/NASDisk-00002/wl500_85)
    Could it be the Nas serveur using NFS V4 ?

  3. #3
    I had simillar problem on my wl-500gp. Restarting of the mountd deamon solved it.

    Code:
    killall mountd
    /usr/sbin/mountd
    I've put these lines to post-boot script and nfs works very well now.

Similar Threads

  1. Problems with sharing USB disc over NFS
    By Jean-Fabrice in forum WL-500g Custom Development
    Replies: 53
    Last Post: 18-10-2006, 18:33
  2. How to mount second usb disk on WL 500g deluxe
    By ROBBY in forum WL-500g Q&A
    Replies: 1
    Last Post: 13-09-2006, 12:24

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •