Page 1 of 2 12 LastLast
Results 1 to 15 of 30

Thread: New Custom Firwmare...

  1. #1

    Thumbs up New Custom Firwmare...

    When it will be made available?
    For some time now I look at this forum in a dally basis... hopping, maybe is today, maybe is today.

    It's true, I don't have the right knowledge to make my custom firmware, and fix all that bugs, not all maybe some ones, like BT that never worked with me, the harddisk always spinning, etc..

    I'm selling it on Ebay

    Thanks for your effort, in my name and in the name of all others like me, who don't have the right knowledge in UNIX/LINUX programing.
    Last edited by IMM22; 08-11-2006 at 12:33.

  2. #2
    Quote Originally Posted by IMM22 View Post
    When it we be available?
    For some time now I look at this forum in a dally basis... hopping, maybe is today, maybe is today.

    It's true, I don't have the right knowledge to make my custom firmware, and fix all that bugs, not all maybe some ones, like BT that never worked on me, the harddisk always spinning, etc..

    I'm selling it on Ebay

    Thanks for your effort, in my name and in the name of all others like me, who don't have the right knowledge in UNIX/LINUX programing.
    Sorry to hear your selling the wl 700GE, I understand your frustration, I myself have no clue how to use Linux/Unix and I was hoping a member who has knowledge would make a custom firmware that can be updated like the normal one but it hasn't happen.

  3. #3
    I'm working on some of these items myself right now (HDD spinning down, custom startup scripts, running wl500 executables, etc.).

    As of right now, I've gotten the software recompiled and reflashed and have cross compiled 'top' and 'bash' and they're both working.

    As soon as I have confirmed I can spin down the HDD, I'll post an image. Give me a week or two, I think I'm pretty close.

    - K.C.

  4. #4
    Quote Originally Posted by kfurge View Post
    I'm working on some of these items myself right now (HDD spinning down, custom startup scripts, running wl500 executables, etc.).

    As of right now, I've gotten the software recompiled and reflashed and have cross compiled 'top' and 'bash' and they're both working.

    As soon as I have confirmed I can spin down the HDD, I'll post an image. Give me a week or two, I think I'm pretty close.

    - K.C.
    That's good news. I'm gonna wait some days more, and see what happen. who have waited 6 months certainly can wait a few more days...

    By the way what port does the wl700 uses to connect to BT?

    Thanks

  5. The real solution would be to finish porting openwrt on our router : http://wiki.openwrt.org/OpenWrtDocs/...e/Asus/WL700gE

    That way we'll could run plenty of apps without any problem

  6. #6
    I managed to create password protected utelnetd shell witch uses web UI credentials. If I'll have enought time I'll add ssh daemon and ipkg and release an image.
    Last edited by MoD; 05-11-2006 at 11:33.

  7. #7
    Quote Originally Posted by IMM22 View Post
    That's good news. I'm gonna wait some days more, and see what happen. who have waited 6 months certainly can wait a few more days...

    By the way what port does the wl700 uses to connect to BT?

    Thanks
    I've confirmed spin down works OK. I can't claim credit, though. I found the solution on another posting... Once I permanently integrate the changes into an image, I'll post it.

    Regarding the BT port, I really don't know.

    - K.C.

  8. #8
    Quote Originally Posted by Gregoire.Favre View Post
    The real solution would be to finish porting openwrt on our router : http://wiki.openwrt.org/OpenWrtDocs/...e/Asus/WL700gE

    That way we'll could run plenty of apps without any problem
    I agree that would be nice, but I'm not ready to completely ditch the Asus firmware just yet. A few tweaks will make me happy.

    Someone else will have to pick this one up....

    - K.C.

  9. #9
    Quote Originally Posted by MoD View Post
    I managed to create password protected utelnetd shell witch uses web UI credentials. If I'll have enought time I'll add ssh daemon and ipkg and release an image.
    Do you have the wl500 binaries working or are you compiling these yourself? The various libs are OK. I can link against them and run the resulting executables just fine.

    However, trying to run one of the executables results in a 'not found' message. I'm assuming it's because they're linked against uClibc and not gcc. I tried adding the uClibc libs but it didn't make any difference.

    - K.C.

  10. #10

    Looks good

    Quote Originally Posted by MoD View Post
    I managed to create password protected utelnetd shell witch uses web UI credentials. If I'll have enought time I'll add ssh daemon and ipkg and release an image.
    That is fantastic!

    With an ssh daemon (perhaps dropbear? http://matt.ucc.asn.au/dropbear/dropbear.html) and ipkg, then other programs can be added at will.

    It would be good also if you can include the solution for HDD spindown.

    #####

    killall -STOP watchdog
    mount -o remount,noatime,nodiratime /dev/se/2 /shares/MYVOLUME1
    hdparm -S 50 /dev/ide/host2/bus0/target0/lun0/disc

    ####

    This was suggested by this post:
    http://wl500g.info/showpost.php?p=39213&postcount=5

    If all that works, the only remaining problem is the weak bitorrent client.

    Perhaps the enhanced ctorrent? http://www.rahul.net/dholmes/ctorrent/
    for which source is available?

  11. #11
    Quote Originally Posted by hal2k1 View Post
    That is fantastic!

    With an ssh daemon (perhaps dropbear? http://matt.ucc.asn.au/dropbear/dropbear.html) and ipkg, then other programs can be added at will.

    It would be good also if you can include the solution for HDD spindown.

    #####

    killall -STOP watchdog
    mount -o remount,noatime,nodiratime /dev/se/2 /shares/MYVOLUME1
    hdparm -S 50 /dev/ide/host2/bus0/target0/lun0/disc

    ####

    This was suggested by this post:
    http://wl500g.info/showpost.php?p=39213&postcount=5

    If all that works, the only remaining problem is the weak bitorrent client.

    Perhaps the enhanced ctorrent? http://www.rahul.net/dholmes/ctorrent/
    for which source is available?
    I'm thinking to incude only:
    1) enable password protected telnet from web UI
    2) boot script and tutorial how to enable ipkg.

    By implementing that all other things can be set up by ipkg (including dropbear).


    but any suggestions are welcome.

  12. #12
    Quote Originally Posted by MoD View Post
    I'm thinking to incude only:
    1) enable password protected telnet from web UI
    2) boot script and tutorial how to enable ipkg.

    By implementing that all other things can be set up by ipkg (including dropbear).


    but any suggestions are welcome.
    I think this is the best way, keep it simple and allow people to experiment according to their personal preference. I really looking forward to seeing this.

    Two questions...
    1) As a precaution do we have a robust way of debricking the 700gE in case of any problems?
    2) Is the data eg music videos at risk when we switch to the custom firmware I 'm guessing no, but I'd like to be sure!

    LK

  13. #13
    Join Date
    Sep 2006
    Location
    NL
    Posts
    22
    I'm very happy to read that there is progress with this routers firmware.
    I wish I was able to do Linux, but I only program in Visual Basic so I can't help...
    I like the concept of the Asus router but the bad torrent client and the reiserfs wasn't the best [maybe worst] choice Asus could make I think.
    I would already be happy with a better torrent client
    keep up the good work.

    The openWRT project would be nice, but it almost looks like there is no progress on the WL-700 router. Is the hardware so much different then the other broadcom routers?
    The limitation of the NVRAM [2MB?] shouldn't be a problem since there is a hdd to boot from, at least that is my simple thought

  14. #14
    Quote Originally Posted by kfurge View Post
    I've confirmed spin down works OK. I can't claim credit, though. I found the solution on another posting... Once I permanently integrate the changes into an image, I'll post it.

    Regarding the BT port, I really don't know.

    - K.C.
    Ok, thank you very much.

    Can you post the image file?

    JR

  15. #15

    ext3

    isn't it possible to format the disk to ext3 or something?

    or devide the disk in 2 partitions, one say 100mb reiser fs for the software and stuff, and the rest as ext3 for downloading and file storage.

    that would eliminate the 2gb bug right?

    I don't have much experience with linux, but I think it's very interesting and i want to learn to make firmware for devices as the wl700gE.

    another idea, how about a 2.6 kernel?

    I don't own a 700gE yet, but i think it's a cool gadget, so i might buy it in the near future

Page 1 of 2 12 LastLast

Similar Threads

  1. WL-500g custom firmware tutorial for beginners (norwegian)
    By Bertie in forum WL-500g/WL-500gx Tutorials
    Replies: 5
    Last Post: 05-09-2006, 14:47
  2. Any luck using custom firmware on WL-700gE?
    By hernidez in forum WL-700g Firmware Discussion
    Replies: 0
    Last Post: 05-06-2006, 15:11
  3. Custom firmware
    By menno in forum Dutch Discussion - Nederlands
    Replies: 0
    Last Post: 02-04-2006, 15:32
  4. Custom Firmware v1.1.2.7
    By JOCKYW2001 in forum WL-HDD Firmware Releases
    Replies: 59
    Last Post: 11-12-2004, 13:26
  5. Custom user programs
    By Randale91 in forum WL-500g Custom Development
    Replies: 1
    Last Post: 20-10-2004, 15:22

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •