Page 1 of 15 12311 ... LastLast
Results 1 to 15 of 222

Thread: Подключение WL-500gP по PPTP

  1. #1

    Question Подключение WL-500gP по PPTP

    была прошивка 1.9.2.7-4 все работало стабильно более 2 месяцев.
    вчера поставил 1.9.2.7-5a. изменил едиственную настройку Idle Disconnect Time in seconds(option): 0 (было 7200) чтобы не отсоединятся.
    сегодня возникла проблема при большой загрузке канала сязи теряется. было раз пять.

  2. #2
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Наличие номеров версий прошивок хорошо, но из этого пока никакой полезной информации не получишь. Нужно хотя бы лог и примерное время, когда происходила беда. Оно потом само поднималось? Или перегружался роутер? Если перегружался - в следующий раз, перед перезагрузкой, сохраните лог.

  3. #3
    1. По своей глупости лог не сохранил.
    2. Откатился на предыдущую прошивку, еще раз посмотрю.
    3. Лог обязательно вышлю.
    4. Соединение само не восстанавливается.
    5. Надо нажимать кнопку connect
    6. Соедиение теряется очень быстро 1-2 минуты
    7. В 1.9.2.7-5a ислользовал Route (см пост Скорость VPN WL-500g ) скорость была до 2 мбайт/сек в 1.9.2.7-4 скорость 100-150 кбайт/сек, может в этом дело?

    1. Выкладываю лог файл
    Code:
    May 17 00:13:23 kernel: mppe_decomp_alloc: options rejected: o[0]=12, o[1]=06, o[2]=00, o[3]=00, o[4]=00, o[5]=00
    May 17 00:13:23 pppd[82]: Received bad configure-ack: 
    May 17 00:13:26 kernel: mppe_decomp_alloc: options rejected: o[0]=12, o[1]=06, o[2]=00, o[3]=00, o[4]=00, o[5]=00
    May 17 00:13:26 pppd[82]: Received bad configure-ack: 
    May 17 00:13:29 kernel: mppe_decomp_alloc: options rejected: o[0]=12, o[1]=06, o[2]=00, o[3]=00, o[4]=00, o[5]=00
    May 17 00:13:29 pppd[82]: Received bad configure-ack: 
    May 17 00:13:32 kernel: mppe_decomp_alloc: options rejected: o[0]=12, o[1]=06, o[2]=00, o[3]=00, o[4]=00, o[5]=00
    May 17 00:13:32 pppd[82]: Received bad configure-ack: 
    May 17 00:13:35 pptp[97]: anon log[logecho:pptp_ctrl.c:670]: Echo Reply received.
    May 17 00:13:35 pppd[82]: CCP: timeout sending Config-Requests 
    May 17 00:14:35 pptp[97]: anon log[logecho:pptp_ctrl.c:670]: Echo Reply received.
    В этот раз для восстановления соединения пришлось перегрузится.

    Еще один лог файл проблемы начались после 00.39.44
    Code:
    May 17 00:38:07 pppd[82]: No response to 6 echo-requests
    May 17 00:38:07 pppd[82]: Serial link appears to be disconnected.
    May 17 00:38:07 dnsmasq[52]: read /etc/hosts - 4 addresses
    May 17 00:38:07 dnsmasq[52]: read /etc/ethers - 4 addresses
    May 17 00:38:07 dnsmasq[52]: reading /tmp/resolv.conf
    May 17 00:38:07 dnsmasq[52]: using nameserver 213.33.170.11#53
    May 17 00:38:07 dnsmasq[52]: using nameserver 213.33.170.30#53
    May 17 00:38:07 PPTP: Disconnected
    May 17 00:38:13 pppd[82]: Connection terminated.
    May 17 00:38:13 pppd[82]: Connect time 18604598.0 minutes.
    May 17 00:38:13 pppd[82]: Sent 16386228 bytes, received 66032509 bytes.
    May 17 00:38:13 pptp[97]: anon log[pptp_read_some:pptp_ctrl.c:537]: read returned zero, peer has closed
    May 17 00:38:13 pptp[97]: anon log[callmgr_main:pptp_callmgr.c:253]: Closing connection
    May 17 00:38:13 pptp[97]: anon log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 12 'Call-Clear-Request' 
    May 17 00:38:13 pptp[97]: anon log[pptp_read_some:pptp_ctrl.c:537]: read returned zero, peer has closed
    May 17 00:38:13 pptp[97]: anon log[pptp_read_some:pptp_ctrl.c:537]: read returned zero, peer has closed
    May 17 00:38:15 pptp[97]: anon log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 12 'Call-Clear-Request' 
    May 17 00:38:15 pptp[97]: anon log[pptp_conn_close:pptp_ctrl.c:433]: Closing PPTP connection
    May 17 00:38:15 pptp[97]: anon log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 3 'Stop-Control-Connection-Request' 
    May 17 00:38:15 pptp[97]: anon log[pptp_read_some:pptp_ctrl.c:537]: read returned zero, peer has closed
    May 17 00:38:17 pptp[97]: anon log[call_callback:pptp_callmgr.c:77]: Closing connection
    May 17 00:38:43 pptp[122]: anon log[main:pptp.c:267]: The synchronous pptp option is NOT activated 
    May 17 00:38:43 pppd[82]: Serial connection established.
    May 17 00:38:43 pppd[82]: Using interface ppp0
    May 17 00:38:43 pppd[82]: Connect: ppp0 <--> /dev/pts/0
    May 17 00:38:43 pptp[126]: anon log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 1 'Start-Control-Connection-Request' 
    May 17 00:38:43 pptp[126]: anon log[ctrlp_disp:pptp_ctrl.c:732]: Received Start Control Connection Reply
    May 17 00:38:43 pptp[126]: anon log[ctrlp_disp:pptp_ctrl.c:766]: Client connection established.
    May 17 00:38:44 pptp[126]: anon log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 7 'Outgoing-Call-Request' 
    May 17 00:38:44 pptp[126]: anon log[ctrlp_disp:pptp_ctrl.c:851]: Received Outgoing Call Reply.
    May 17 00:38:45 pptp[126]: anon log[ctrlp_disp:pptp_ctrl.c:890]: Outgoing call established (call ID 0, peer's call ID 0). 
    May 17 00:38:48 kernel: mppe_decomp_alloc: options rejected: o[0]=12, o[1]=06, o[2]=00, o[3]=00, o[4]=00, o[5]=00
    May 17 00:38:48 pppd[82]: Received bad configure-ack: 
    May 17 00:38:48 pppd[82]: local  IP address 10.22.96.21
    May 17 00:38:48 pppd[82]: remote IP address 192.168.0.7
    May 17 00:38:48 dnsmasq[52]: read /etc/hosts - 4 addresses
    May 17 00:38:48 dnsmasq[52]: read /etc/ethers - 4 addresses
    May 17 00:38:48 dnsmasq[52]: reading /tmp/resolv.conf
    May 17 00:38:48 dnsmasq[52]: using nameserver 213.33.170.11#53
    May 17 00:38:48 dnsmasq[52]: using nameserver 213.33.170.30#53
    May 17 00:38:48 PPTP: connect to ISP
    May 17 00:38:51 kernel: mppe_decomp_alloc: options rejected: o[0]=12, o[1]=06, o[2]=00, o[3]=00, o[4]=00, o[5]=00
    May 17 00:38:51 pppd[82]: Received bad configure-ack: 
    May 17 00:38:54 kernel: mppe_decomp_alloc: options rejected: o[0]=12, o[1]=06, o[2]=00, o[3]=00, o[4]=00, o[5]=00
    May 17 00:38:54 pppd[82]: Received bad configure-ack: 
    May 17 00:38:57 kernel: mppe_decomp_alloc: options rejected: o[0]=12, o[1]=06, o[2]=00, o[3]=00, o[4]=00, o[5]=00
    May 17 00:38:57 pppd[82]: Received bad configure-ack: 
    May 17 00:39:00 kernel: mppe_decomp_alloc: options rejected: o[0]=12, o[1]=06, o[2]=00, o[3]=00, o[4]=00, o[5]=00
    May 17 00:39:00 pppd[82]: Received bad configure-ack: 
    May 17 00:39:03 kernel: mppe_decomp_alloc: options rejected: o[0]=12, o[1]=06, o[2]=00, o[3]=00, o[4]=00, o[5]=00
    May 17 00:39:03 pppd[82]: Received bad configure-ack: 
    May 17 00:39:06 kernel: mppe_decomp_alloc: options rejected: o[0]=12, o[1]=06, o[2]=00, o[3]=00, o[4]=00, o[5]=00
    May 17 00:39:06 pppd[82]: Received bad configure-ack: 
    May 17 00:39:09 kernel: mppe_decomp_alloc: options rejected: o[0]=12, o[1]=06, o[2]=00, o[3]=00, o[4]=00, o[5]=00
    May 17 00:39:09 pppd[82]: Received bad configure-ack: 
    May 17 00:39:12 kernel: mppe_decomp_alloc: options rejected: o[0]=12, o[1]=06, o[2]=00, o[3]=00, o[4]=00, o[5]=00
    May 17 00:39:12 pppd[82]: Received bad configure-ack: 
    May 17 00:39:15 kernel: mppe_decomp_alloc: options rejected: o[0]=12, o[1]=06, o[2]=00, o[3]=00, o[4]=00, o[5]=00
    May 17 00:39:15 pppd[82]: Received bad configure-ack: 
    May 17 00:39:18 pppd[82]: CCP: timeout sending Config-Requests 
    May 17 00:39:44 pptp[126]: anon log[logecho:pptp_ctrl.c:670]: Echo Reply received.
    May 17 00:40:44 pptp[126]: anon log[logecho:pptp_ctrl.c:670]: Echo Reply received.
    May 17 00:41:45 pptp[126]: anon log[logecho:pptp_ctrl.c:670]: Echo Reply received.
    May 17 00:43:08 pppd[82]: No response to 6 echo-requests
    May 17 00:43:08 pppd[82]: Serial link appears to be disconnected.
    May 17 00:43:08 dnsmasq[52]: read /etc/hosts - 4 addresses
    May 17 00:43:08 dnsmasq[52]: read /etc/ethers - 4 addresses
    May 17 00:43:08 dnsmasq[52]: reading /tmp/resolv.conf
    May 17 00:43:08 dnsmasq[52]: using nameserver 213.33.170.11#53
    May 17 00:43:08 dnsmasq[52]: using nameserver 213.33.170.30#53
    May 17 00:43:08 PPTP: Disconnected
    May 17 00:43:14 pppd[82]: Connection terminated.
    May 17 00:43:14 pppd[82]: Connect time 4.5 minutes.
    May 17 00:43:14 pppd[82]: Sent 3345038 bytes, received 3556238 bytes.
    May 17 00:43:14 pptp[122]: anon warn[decaps_hdlc:pptp_gre.c:197]: short read (-1): Input/output error
    May 17 00:43:14 pptp[122]: anon warn[decaps_hdlc:pptp_gre.c:209]: pppd may have shutdown, see pppd log
    May 17 00:43:14 pptp[126]: anon log[callmgr_main:pptp_callmgr.c:230]: Closing connection
    May 17 00:43:14 pptp[126]: anon log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 12 'Call-Clear-Request' 
    May 17 00:43:16 pptp[126]: anon log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 12 'Call-Clear-Request' 
    May 17 00:43:16 pptp[126]: anon log[pptp_conn_close:pptp_ctrl.c:433]: Closing PPTP connection
    May 17 00:43:16 pptp[126]: anon log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 3 'Stop-Control-Connection-Request' 
    May 17 00:43:16 pptp[126]: anon log[pptp_read_some:pptp_ctrl.c:544]: read error: Connection reset by peer
    Last edited by Omega; 08-03-2013 at 03:05. Reason: 2 posts merged

  4. #4
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    В поле Additional pppd options было что-нибудь забито в момент получения лога?
    Ещё, насчёт сам не соединяется - это не должно происходить немедленно - после отсоединения должно пройти не менее 30 секунд (это значение по умолчанию). Далее, он будет пытаться соединиться 10 раз и если не сможет, то больше пытаться не будет (чтобы он делал это до бесконечности в поле additional pppd options впишите "maxfail 0").
    Далее, то что помогает кнопка Connect, говорит либо о том, что эти 10 раз уже прошли, либо не прошла пауза в 30 секунд.
    И ещё - попробуйте в поле additional options также добавить (через пробел) - nomppe-stateful, это возможно улучшит ситуацию со стабильностью соединения.

  5. #5
    Да 30 секунд не проходит.
    поле Additional pppd options было пустым.
    Вопрос зачем роутер отсоединяется и как с эти боротся ? Я начинаю скачивать файл с большой скоростью и происходит отсоединение. В 1.9.2.7-4 этого не было.
    Причем отсоедение происходит только при скачивании из локальной сети провайдера на больших скоростях.
    eMule работает сутками с интерентом (скорость 34 кбайта/сек) все ОК
    Мне нужно чтобы соединение было постоянным.
    Что мне делать?

  6. #6
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    У меня вопрос - в момент, когда теряется соединение, в локальной сети всё по-прежнему работает?
    Если нет, то следующий шаг - запуск telnet на роутер и ping для default gateway. Сможете?
    Я опасаюсь, что это всё таки вылазит проблема с "умирающим" WAN портом, хотя вроде шансов я ему не оставил.

  7. #7
    У меня вопрос - в момент, когда теряется соединение, в локальной сети всё по-прежнему работает?
    Если нет, то следующий шаг - запуск telnet на роутер и ping для default gateway. Сможете?
    Я опасаюсь, что это всё таки вылазит проблема с "умирающим" WAN портом, хотя вроде шансов я ему не оставил.
    1. сегодня еще раз проверил в 1.9.2.7-4 все работает стабильно. Гонял более 5 часов. Правда неработает IP Config | Route ,
    10.0.0.0 255.0.0.0 10.9.1.1 0 MAN (как Вы советовали) скорость для 10 адресов не выше 150 кбатй/сек.
    2. 1.9.2.7-5а вылетела черз 2-4 минуты. Лог файл приведен ниже:

    Code:
    May 18 22:42:05 pppd[82]: No response to 6 echo-requests
    May 18 22:42:05 pppd[82]: Serial link appears to be disconnected.
    May 18 22:42:05 dnsmasq[52]: read /etc/hosts - 4 addresses
    May 18 22:42:05 dnsmasq[52]: read /etc/ethers - 4 addresses
    May 18 22:42:05 dnsmasq[52]: reading /tmp/resolv.conf
    May 18 22:42:05 dnsmasq[52]: using nameserver 213.33.170.11#53
    May 18 22:42:05 dnsmasq[52]: using nameserver 213.33.170.30#53
    May 18 22:42:05 PPTP: Disconnected
    May 18 22:42:07 login[118]: root login  on `pts/1' 
    May 18 22:42:11 pppd[82]: Connection terminated.
    May 18 22:42:11 pppd[82]: Connect time 18607361.9 minutes.
    May 18 22:42:11 pppd[82]: Sent 5580755 bytes, received 1554652 bytes.
    May 18 22:42:11 pptp[86]: anon warn[decaps_hdlc:pptp_gre.c:197]: short read (-1): Input/output error
    May 18 22:42:11 pptp[86]: anon warn[decaps_hdlc:pptp_gre.c:209]: pppd may have shutdown, see pppd log
    May 18 22:42:11 pptp[92]: anon log[callmgr_main:pptp_callmgr.c:230]: Closing connection
    May 18 22:42:11 pptp[92]: anon log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 12 'Call-Clear-Request' 
    May 18 22:42:11 pptp[92]: anon log[pptp_read_some:pptp_ctrl.c:537]: read returned zero, peer has closed
    May 18 22:42:11 pptp[92]: anon log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 12 'Call-Clear-Request' 
    May 18 22:42:11 pptp[92]: anon log[pptp_conn_close:pptp_ctrl.c:433]: Closing PPTP connection
    May 18 22:42:11 pptp[92]: anon log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 3 'Stop-Control-Connection-Request' 
    May 18 22:42:11 pptp[92]: anon log[pptp_read_some:pptp_ctrl.c:537]: read returned zero, peer has closed
    May 18 22:42:13 pptp[92]: anon log[call_callback:pptp_callmgr.c:77]: Closing connection
    May 18 22:42:41 pppd[82]: Starting link
    May 18 22:42:41 pppd[82]: Serial connection established.
    May 18 22:42:41 pppd[82]: Connect: ppp0 <--> /dev/pts/0
    May 18 22:42:42 pptp[123]: anon log[main:pptp.c:267]: The synchronous pptp option is NOT activated 
    May 18 22:42:42 pptp[126]: anon log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 1 'Start-Control-Connection-Request' 
    May 18 22:42:42 pptp[126]: anon log[ctrlp_disp:pptp_ctrl.c:732]: Received Start Control Connection Reply
    May 18 22:42:42 pptp[126]: anon log[ctrlp_disp:pptp_ctrl.c:766]: Client connection established.
    May 18 22:42:43 pptp[126]: anon log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 7 'Outgoing-Call-Request' 
    May 18 22:42:43 pptp[126]: anon log[ctrlp_disp:pptp_ctrl.c:851]: Received Outgoing Call Reply.
    May 18 22:42:43 pptp[126]: anon log[ctrlp_disp:pptp_ctrl.c:890]: Outgoing call established (call ID 0, peer's call ID 0). 
    May 18 22:42:46 kernel: mppe_decomp_alloc: options rejected: o[0]=12, o[1]=06, o[2]=00, o[3]=00, o[4]=00, o[5]=00
    May 18 22:42:46 pppd[82]: Received bad configure-ack: 
    May 18 22:42:46 pppd[82]: Remote IP address changed to 192.168.0.24
    May 18 22:42:46 dnsmasq[52]: read /etc/hosts - 4 addresses
    May 18 22:42:46 dnsmasq[52]: read /etc/ethers - 4 addresses
    May 18 22:42:46 dnsmasq[52]: reading /tmp/resolv.conf
    May 18 22:42:46 dnsmasq[52]: using nameserver 213.33.170.11#53
    May 18 22:42:46 dnsmasq[52]: using nameserver 213.33.170.30#53
    May 18 22:42:46 PPTP: connect to ISP
    May 18 22:42:49 kernel: mppe_decomp_alloc: options rejected: o[0]=12, o[1]=06, o[2]=00, o[3]=00, o[4]=00, o[5]=00
    May 18 22:42:49 pppd[82]: Received bad configure-ack: 
    May 18 22:42:52 kernel: mppe_decomp_alloc: options rejected: o[0]=12, o[1]=06, o[2]=00, o[3]=00, o[4]=00, o[5]=00
    May 18 22:42:52 pppd[82]: Received bad configure-ack: 
    May 18 22:42:55 kernel: mppe_decomp_alloc: options rejected: o[0]=12, o[1]=06, o[2]=00, o[3]=00, o[4]=00, o[5]=00
    May 18 22:42:55 pppd[82]: Received bad configure-ack: 
    May 18 22:42:58 kernel: mppe_decomp_alloc: options rejected: o[0]=12, o[1]=06, o[2]=00, o[3]=00, o[4]=00, o[5]=00
    May 18 22:42:58 pppd[82]: Received bad configure-ack: 
    May 18 22:43:01 kernel: mppe_decomp_alloc: options rejected: o[0]=12, o[1]=06, o[2]=00, o[3]=00, o[4]=00, o[5]=00
    May 18 22:43:01 pppd[82]: Received bad configure-ack: 
    May 18 22:43:04 kernel: mppe_decomp_alloc: options rejected: o[0]=12, o[1]=06, o[2]=00, o[3]=00, o[4]=00, o[5]=00
    May 18 22:43:04 pppd[82]: Received bad configure-ack: 
    May 18 22:43:07 kernel: mppe_decomp_alloc: options rejected: o[0]=12, o[1]=06, o[2]=00, o[3]=00, o[4]=00, o[5]=00
    May 18 22:43:07 pppd[82]: Received bad configure-ack: 
    May 18 22:43:10 kernel: mppe_decomp_alloc: options rejected: o[0]=12, o[1]=06, o[2]=00, o[3]=00, o[4]=00, o[5]=00
    May 18 22:43:10 pppd[82]: Received bad configure-ack: 
    May 18 22:43:13 kernel: mppe_decomp_alloc: options rejected: o[0]=12, o[1]=06, o[2]=00, o[3]=00, o[4]=00, o[5]=00
    May 18 22:43:13 pppd[82]: Received bad configure-ack: 
    May 18 22:43:16 pppd[82]: CCP: timeout sending Config-Requests 
    May 18 22:43:43 pptp[126]: anon log[logecho:pptp_ctrl.c:670]: Echo Reply received.
    May 18 22:44:43 pptp[126]: anon log[logecho:pptp_ctrl.c:670]: Echo Reply received.
    May 18 22:45:43 pptp[126]: anon log[logecho:pptp_ctrl.c:670]: Echo Reply received.
    May 18 22:46:43 pptp[126]: anon log[logecho:pptp_ctrl.c:670]: Echo Reply received.
    May 18 22:47:43 pptp[126]: anon log[logecho:pptp_ctrl.c:670]: Echo Reply received.
    В этот момент запускаю телнет кажется пакеты ходят. Лог файл привожу:
    Code:
    (none) login: admin
    Password:
    Login incorrect
    (none) login: admin
    Password:
    [admin@(none) root]$ ping 10.9.1.1
    PING 10.9.1.1 (10.9.1.1): 56 data bytes
    64 bytes from 10.9.1.1: icmp_seq=0 ttl=64 time=68.3 ms
    64 bytes from 10.9.1.1: icmp_seq=1 ttl=64 time=62.2 ms
    64 bytes from 10.9.1.1: icmp_seq=2 ttl=64 time=2.2 ms
    64 bytes from 10.9.1.1: icmp_seq=3 ttl=64 time=1.1 ms
    64 bytes from 10.9.1.1: icmp_seq=4 ttl=64 time=1.1 ms
    64 bytes from 10.9.1.1: icmp_seq=5 ttl=64 time=2.2 ms
    64 bytes from 10.9.1.1: icmp_seq=6 ttl=64 time=41.9 ms
    64 bytes from 10.9.1.1: icmp_seq=7 ttl=64 time=33.1 ms
    
    64 bytes from 10.9.1.1: icmp_seq=8 ttl=64 time=13.4 ms
    64 bytes from 10.9.1.1: icmp_seq=9 ttl=64 time=50.4 ms
    64 bytes from 10.9.1.1: icmp_seq=10 ttl=64 time=1.1 ms
    
    --- 10.9.1.1 ping statistics ---
    11 packets transmitted, 11 packets received, 0% packet loss
    round-trip min/avg/max = 1.1/25.1/68.3 ms
    [admin@(none) root]$
    Last edited by Omega; 08-03-2013 at 03:07. Reason: 2 posts merged

  8. #8
    Quote Originally Posted by Oleg
    Я опасаюсь, что это всё таки вылазит проблема с "умирающим" WAN портом, хотя вроде шансов я ему не оставил.
    Если не трудно, можешь описать, что это за проблема с умирающим WAN-портом? Есть подозрение, что у меня как раз такой случай. Выглядит так - включаю роутер, сначала все прекрасно работает, потом начинают теряться пакеты, потом перестают бегать совсем. В статусе пишет connected, лампочка WAN при этом часто-часто мигает.
    Перезагрузка роутера не помогает - WAN порт не оживает. Если выключить, подождать какое-то время и включить опять работает до очередного затыка.
    Пробовал и на оригинальной прошивке и на твоей, результат один. То ли нести в сервис, то ли это баг в прошивке и ждать пока поправят.

  9. #9
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Quote Originally Posted by Vitaly_k
    Если не трудно, можешь описать, что это за проблема с умирающим WAN-портом? Есть подозрение, что у меня как раз такой случай. Выглядит так - включаю роутер, сначала все прекрасно работает, потом начинают теряться пакеты, потом перестают бегать совсем. В статусе пишет connected, лампочка WAN при этом часто-часто мигает.
    Перезагрузка роутера не помогает - WAN порт не оживает. Если выключить, подождать какое-то время и включить опять работает до очередного затыка.
    Пробовал и на оригинальной прошивке и на твоей, результат один. То ли нести в сервис, то ли это баг в прошивке и ждать пока поправят.
    В данном случае менять роутер - это явно аппаратные проблемы.

    Когда он умирает "штатно", то зайдя на роутер пинг наружу не идёт, а после выполнения команды
    Code:
    et -i eth1 promisc 0
    всё оживает (смысл не в том, чтобы поставить promisc в 0, а в том, что это команда в качестве побочного эффекта переинициализирует ethernet контроллер на WAN порту). Естественно при перезагрузке это происходит, поэтому если она не помогает, то в морг.

    Если есть возможность поменять - попытайтесь получить Deluxe версию, у неё железных проблем с WAN портом нет.

  10. #10
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Quote Originally Posted by Pavel
    1. сегодня еще раз проверил в 1.9.2.7-4 все работает стабильно. Гонял более 5 часов. Правда неработает IP Config | Route ,
    10.0.0.0 255.0.0.0 10.9.1.1 0 MAN (как Вы советовали) скорость для 10 адресов не выше 150 кбатй/сек.
    Судя по логу, WAN порт живее всех живых.
    Павел, тогда ещё одна просьба - уберите с 5a маршрут, который Вы добавили. Если после этого заработает (пусть с меньшей скоростью), то возможно, что Вам всё таки стоит уточнить правильные маски подсетей у Вашего провайдера, поскольку смесь 10-х адресов, как внутренних, так и внешних не очень хороша...

  11. #11
    1.После убирания маршрута работает стабильно. Такой режим был у меня до того как Вы посоветовали поставить маршрут.
    2. Проблему отключения я обнаружил по другому. Когда я хочу скачать фильмы из локальной сети провайдера я настраиваю wan как static IP при этом скорость до 3 мбайт/сек. В четвером релизе Вашей прошивки все было ОК, а вот в 5а связь обрывалась как и при VPN с маршрутом. Мне кажется тут одна и таже проблема.

  12. #12
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Да, возможно, что действительно проблема одна и таже. А 1.9.2.7-5 не пробовали? Она здесь: http://wl500g.dyndns.org/1.9.2.7-5/
    Только в ней проблемы с печатью, поэтому если подключен принтер, то её лучше в работе не использовать.

  13. #13
    Quote Originally Posted by Oleg
    Если есть возможность поменять - попытайтесь получить Deluxe версию, у неё железных проблем с WAN портом нет.
    Самое интересное, что проблема как раз в Deluxe. До этого стоял обычный - горя не знал. Лучшее - враг хорошего
    Понесу в сервис. Проблема как мне кажется в автоопределении прямой шнурок - кросс. Если воткнуть WAN-порт в девайс который имеет автоопределение, то все оживает. Если аплинк его не понимает, то начинается моргание лампочкой и затыки.

  14. #14
    Поведение прошивки 1.9.2.7-5 по моей проблеме аналогично 1.9.2.7-4 т.е.
    static IP связь не рвется и скорость высокая
    при VPN добавление маршрута ничего не дает связь также не рвется.

  15. #15
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Павел -5 точно поддерживает маршруты. В этой части она ничем не отличается от -5а, проверьте ещё раз таблицу маршрутизации.

Page 1 of 15 12311 ... LastLast

Similar Threads

  1. Подключение USB HDD для новичков
    By NinJah in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 262
    Last Post: 26-03-2016, 09:33
  2. Подключение USB модема 3G/CDMA к роутеру Asus
    By buka2 in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 796
    Last Post: 22-10-2014, 20:29
  3. Подключение IP web-камеры к роутеру Asus
    By Asmadei in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 133
    Last Post: 04-07-2014, 17:18
  4. Владельцам RT-N13U: увеличение скорости PPTP
    By theMIROn in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 104
    Last Post: 17-01-2013, 14:31
  5. Подключение USB принтера HP к WL-500gP
    By toto in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 152
    Last Post: 08-05-2012, 22:09

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •