Results 1 to 8 of 8

Thread: Bad system call with samba-3.0.14a

  1. #1

    Angry Bad system call with samba-3.0.14a


    I installed samba - 3.0.14a using ipkg on WL500gp- But when i ran it i get bad system call message. Has anyone had this problem?
    I got WD 160G external drive formated in ext3.

    Filesystem 1k-blocks Used Available Use% Mounted on
    /dev/root 2944 2944 0 100% /
    /dev/discs/disc0/part1 153700384 623292 145269504 0% /tmp/harddisk
    /dev/discs/disc0/part1 153700384 623292 145269504 0% /opt

    This is my smb.conf

    interfaces = br0
    bind interfaces only = yes
    workgroup = VDV
    guest account = nobody
    security = share
    browseable = yes
    guest ok = yes
    guest only = no
    log level = 1
    max log size = 100
    encrypt passwords = yes
    dns proxy = no

    writeable = yes
    browseable = yes
    force user = admin

    Partial strace output:

    read(3, "\237\226\252,-\3\341\364\261x\21~", 12) = 12
    fcntl64(4, F_SETLKW64, {type=F_WRLCK, whence=SEEK_SET, start=224, len=1}, 0x7fff7908) = 0
    fcntl64(4, F_SETLKW64, {type=F_WRLCK, whence=SEEK_SET, start=164, len=1}, 0x7fff78b0) = 0
    fstat64(4, {st_mode=S_IFREG|0600, st_size=16384, ...}) = 0
    munmap(0x2ab00000, 16384) = 0
    ftruncate64(4, 105553116266496) = 0
    pwrite(4, "BBBBBBBBBBBBBBBBBBBBBBBBBBBBBBBB"..., 1024, 4398046511104) = -1 EFBIG (File too large)
    --- SIGXFSZ (Bad system call) @ 0 (0) ---
    +++ killed by SIGXFSZ +++
    Process 535 detached

  2. #2
    Join Date
    Jun 2005
    Try new distribution for oleg firmware at

    See for more info

  3. #3

    Am I missing something?

    I cant install any of the packages from here.

    This is my ipkg.conf
    src wl500g
    src unslug
    dest root /

    When i do ipkg update it works fine, but when i am doind ipkg list i see old versions only.
    if i manualy download packages they change name and i cant do anything with it.
    Last edited by demonv; 07-10-2006 at 00:35.

  4. #4

    I found my problem

    I installed /opt on USB stick and reformated it in ext3.

    Problem solved thanks so much.

  5. #5
    Quote Originally Posted by oleo View Post
    Hello, I had the same problem with Samba installed from the former unslung repository (3.0.14). But everytime i called a command like "net groupmap" or "pdbedit -a -u <username>", i had a "Bad system call" message.

    So I updated the repository ( to get the 3.0.23 but now i have another problem, when I call any tool from samba (like net, wbinfo etc...) i have the message.

    [root@routeur /tmp]$ net
    -sh: net: not found
    [root@routeur /tmp]$ ls /opt/bin/
    addgroup             ldapwhoami           smbcquotas
    adduser              less                 smbget
    adduser-su           lp                   smbmnt
    cancel               lpoptions            smbmount
    cups-config          lppasswd             smbpasswd
    cupstestdsc          lpq                  smbspool
    cupstestppd          lpr                  smbstatus
    dbclient             lprm                 smbtar
    delgroup             lpstat               smbtree
    deluser              net                  smbumount
    eventlogadm          nmblookup            ssh
    findsmb              ntlm_auth            su
    ipkg                 openssl              tdbbackup
    ldapadd              pdbedit              tdbdump
    ldapcompare          profiles             tdbtool
    ldapdelete           rpcclient            testparm
    ldapmodify           scp                  update-alternatives
    ldapmodrdn           smbcacls             wbinfo
    ldappasswd           smbclient
    ldapsearch           smbcontrol
    [root@routeur /tmp]$ /opt/bin/net
    -sh: /opt/bin/net: not found
    [root@routeur /tmp]$

  6. #6
    Join Date
    Jun 2005
    ipkg install uclibc

  7. #7
    Thanks a lot

  8. #8
    Thanks a lot again now i dont need Debian anymore to run samba 3 and to make my WL500Gx a PDC

Similar Threads

  1. habe keine berechtigung in die mit samba freigegebenen Verzeichnisse zu schreiben
    By protorix in forum German Discussion - Deutsch (DE)
    Replies: 4
    Last Post: 08-10-2006, 10:26
  2. Gameserver
    By blingbling in forum WL-500gP Q&A
    Replies: 2
    Last Post: 17-07-2006, 16:37
  3. WebDAV und externen FTP via Samba für Win zur Verfügung stellen
    By rj.2001 in forum German Discussion - Deutsch (DE)
    Replies: 2
    Last Post: 01-06-2006, 22:39
  4. Samba fail to start
    By mururoa in forum WL-500g Q&A
    Replies: 6
    Last Post: 29-05-2006, 11:02

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts