Results 1 to 5 of 5

Thread: Mounting of NAS drives with Oleg's

  1. #1

    Mounting of NAS drives with Oleg's

    My installed firmware is Oleg's and tried a long time to mount some folders of my external NAS drive to the router (because of using of a Upnp server). But unfortunately everything failed ...

    I tried to use:
    "mount /mnt -t nfs"
    But I've got the error: "no such device". The drive itself supports nfs as well as cif (it's a WD NetCenter). But I found no working way ...

    The NAS drive has the following shares:
    [admin@pustewlan root]$ showmount -e
    Export list for
    /shares/Main/test *
    /shares/Main/Movies *
    /shares/Main/Bilder *
    /shares/Main/Shared Files *
    /shares/Main/Audio (everyone)

    And currently do I have the following mounting:
    [admin@pustewlan root]$ mount
    /dev/root on / type squashfs (ro)
    none on /dev type devfs (rw)
    proc on /proc type proc (rw)
    ramfs on /tmp type ramfs (rw)
    usbfs on /proc/bus/usb type usbfs (rw)
    /dev/discs/disc0/part2 on /opt type ext3 (rw)

    Does anyone has an idea how do I get it running?? Or do I have to use openwrt for these required functionalities??

    Thanks a lot!

  2. #2
    hi all,
    seems that oleg's firmware doesn't have the necessary packages to use a nas drive via nfs. therefore i replaced the firmware with openwrt. a good german "howto" is to find on: <<-- sorry ENGLISH howto!
    pls. see also an english "howto", that explains something about fdisk etc.:
    (for fdisk package itself you have to google ... - it's available on a openwrt-test drive) and install it via ipkg "install http://<YOUR LINK TO PACKAGE>".

    my configuration allows to use a nas drive as well as to use a usb-printer (all that i needed).
    but please note: this version is more complicate (or more command line) ...
    furthermore: if you want to run some scripts on start, ensure that you create your startup file on: "/etc/init.d" the filename has to start with "S" for an automatic execution!!!

    my current status is:
    - using of usb-stick for enhance space (working)
    - using of usb-stick to enhance the swap drive (working)
    - using of nas drives (working)
    - using of twonky to share media files (must be still installed)

    both will be enabled on startup by my script (filename as above):

    # sleep a moment to ensure that usb-drive is working
    sleep 30
    # mount usb swap partition for enhanced memory
    swapon /dev/discs/disc0/part5
    # mount drives to local path - these paths have been create once before
    mount /usr/drives/movies
    mount /usr/drives/audio
    Last edited by upcuser:-(; 26-09-2006 at 00:05.

  3. #3
    So upnp-server is now also running! ;-)
    I use the gmediaserver as upnp-server from a openwrt-ipk.
    Think this way could be a good alternative for someone who wants to use:

    - external harddrive
    - wl500gp
    - simple usb-stick
    - upnp client e.g. noxon
    Last edited by upcuser:-(; 26-09-2006 at 00:21.

  4. #4
    I replaced gmediaserver with Twonky (because of more functionality) - here a small howto, that I wrote:

  5. #5
    should you want to use a pinnacle showcenter 200 (sc200) as your media device, so read this before you buy one - here is a summary:

    for further information, just contact me.

Similar Threads

  1. internal hd not mounting?!
    By hullahulla in forum WL-HDD Q&A
    Replies: 14
    Last Post: 24-08-2006, 10:01
  2. sources?
    By jlangston in forum WL-HDD Q&A
    Replies: 0
    Last Post: 17-08-2006, 03:27
  3. NAS reporting "no export entry"
    By Xerxiz in forum WL-500gP Q&A
    Replies: 1
    Last Post: 31-07-2006, 12:37
  4. Trying to get IDE working on Oleg's Firmware
    By hugo in forum WL-HDD Custom Development
    Replies: 34
    Last Post: 01-11-2004, 19:06
  5. Flashing Oleg's Firmware in WL HDD
    By hugo in forum WL-HDD Custom Development
    Replies: 29
    Last Post: 21-10-2004, 15:55

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts