Page 3 of 3 FirstFirst 123
Results 31 to 40 of 40

Thread: Use an USB-serial port converter

  1. #31
    I'm not sure if I should post on this thread or create a new thread. My goal is to use a Belkin USB to Serial adapter with my WL-500g (not the Deluxe model) to create a PPP connection for my DirecTiVo. I admit that I'm a novice when it comes to Linux. I know how to create the connection on a Windows based system, though I haven't found instructions yet on how to do it via Linux. My main question for this forum is: Has anyone tried using the USB to Serial adapter to create a PPP connection via the WL-500g?



  2. #32

    USB Problems Hub and PL2303 problem.


    I'm not sure if this is the correct forum for this but....

    I'm running the latest Oleg firmware on a WL-500gd, I've recently purchased three pl2303 based usb to serial adapters and a Belkin usb 2 four port hub.

    When a pl2303 is plugged into either of the two onboad usb ports it is detected and I can use it, when plugged in via the hub I get these messages in dmesg...

    hub.c: new USB device 01:02.2-2.3, assigned address 5
    usb.c: unable to get device descriptor (error=-32)
    hub.c: new USB device 01:02.2-2.3, assigned address 6
    usb.c: unable to get device descriptor (error=-32)

    lsusb returns the following before the list of devices:
    Unknown line at line 1809
    Duplicate HUT Usage Spec at line 2650

    and the pl2303 is not listed.

    I'm going to try to get my hands on another usb hub to eliminate that from the process, but I'm faily sure the hub is fine as my memory card is working fine via it.

    Does anyone have any help/advice/ideas on how to proceded

    Many thanks,


  3. #33
    Well testing with a USB 1.1 hub and everything works fine.

    Strangly enough the usb 2 hub works perfectly on my Debian machine, with the serial devices being detected correctly.

    So to overview;
    The hub works on Debian Kernel 2.6.8-2-686-smp.
    It works with the memory stick, but not with the serial adapters on Olegs firmware.

    The serial devices work on an older usb 1.1 hub so there is probably nothing wrong with the pl2303 drivers.

    So now if I can find another usb 2 hub I'll be able to tell if it's the hub or the fact it's a usb2 hub that's the problem.

  4. #34
    Well I think I've discovered the answer, apparently the linux kernel and the pl2303 module included in Olegs firmware can not work with certain usb 1 devices via a usb 2 hub.

    The pl2303 driver for the current 2.4 kernel is especially broken in this regard.

    So I will buy a usb 1 hub to replace the usb 2 hub.

    Thanks for your help...

  5. #35

    Problem: USB2Serial (pl2303) with USB hub


    I have the following problem:

    I use a Prolific PL2303 based USB2Serial adapter on my WL500gP.
    If I connect it directly to my box everything works fine.


    usbserial.c: PL-2303 converter detected
    usbserial.c: PL-2303 converter now attached to ttyUSB0 (or usb/tts/0 for devfs)
    But if I use this device with a USB hub connected to my box I get the following error message.


    hub.c: new USB device 01:03.2-2.1, assigned address 4
    usb.c: unable to get device descriptor (error=-32)
    hub.c: new USB device 01:03.2-2.1, assigned address 5
    usb.c: unable to get device descriptor (error=-32)
    It seems that the USB2Serial adapter is only be identified correctly if I connect it directly to the USB port of the WL500gP, but fails if I use it with an USB hub.

    The USB hub itself seems to work correctly:


    hub.c: new USB device 01:03.2-2, assigned address 3
    hub.c: USB hub found
    hub.c: 4 ports detected
    I also tested this hub with my USB memory stick with no problems at all.


    * Is there anyone else out there having the same problem and probably a solution too?

    * Is there anyone using a PL2303 based USB2Serial adapter successfully in combination with an USB hub?

    * Does someone know a working solution for another USB2serial adapter, which is supported by the WL500gP firmware and works with an USB hub?

    Any help is higly appreciated.



  6. #36
    Join Date
    Feb 2007
    Moscow, Russia
    I can answer only a half of your first question . Yesterday I also tried to attach PL2303 based usb-com converter to the wl500gP. The results are exactly the same (I tested with two devices from different manufacturers). Failure with similar response while connecting through the usb hub, success when connected straight to the router. The other devices (hdd and printer) normally work through the hub flawlessly. So, it seems, that's a bug.

  7. #37

    Oleg and pl2303 usb > serial converter


    I've the Asus WL500Gp with the newest oleg firmware and if i connect a usb to serial cable the drivers install well. It say's everything is well.
    But wenn i try to use my mastera 3 phoenix cardreader i became error's and the cardreader software (newcs) says reset failed.
    This what i become in the System Log:

    Jan  1 01:29:27 kernel: usb-uhci.c: ENXIO 40408580, flags 0, urb 81a45d20, burb 81a45d20
    Jan  1 01:29:27 kernel: pl2303.c: pl2303_read_int_callback - usb_submit_urb failed with result -6
    I use the default and the pl2303.o drivers in the firmware, this is v1.4 from the serialusb driver and v0.11 from the pl2303 driver.
    The usb to serial converter is from conceptronic.

    Somebody can help me fix this problem?

  8. #38
    @GWL - these modules are what I am looking for let's see if I can get things running on oleg "". I assume it is for kernel "2.4.20"?. -- it looks good dmesg:

    usb.c: registered new driver serial
    usbserial.c: USB Serial support registered for Generic
    usbserial.c: USB Serial Driver core v1.4
    usbserial.c: USB Serial support registered for FTDI SIO
    usbserial.c: USB Serial support registered for FTDI 8U232AM Compatible
    usbserial.c: USB Serial support registered for FTDI FT232BM Compatible
    usbserial.c: USB Serial support registered for USB-UIRT Infrared Receiver/Transmitter
    usbserial.c: USB Serial support registered for Home-Electronics TIRA-1 IR Transceiver
    ftdi_sio.c: v1.3.5:USB FTDI Serial Converters Driver
    Last edited by dolphs; 04-09-2007 at 21:03.

  9. #39
    Join Date
    Feb 2005
    Germany - Frankfurt a.M.

    im using this driver, but i cant read data, can you help me?

    See this thread:
    WL-500gP => (2007-04-06)
    Running: thttpd, php 5.1, vsftp, rrdtool

  10. #40

    Oleg's FW and usbserial/pl2303 not working

    I have found my solution:
    Had to :
    -tar modules-
    -modprobe works !!!!!!!
    My adapter is now attached

    I'm using Oleg's FW on a WL-HDD. I'm sorry for posting in this area but it seems that the use of wl-hdd has died a little.

    From what I have found the usbserial en pl2303 module should work on this firmware. I have tried different commands that I found on different places. The last I tried was #insmod pl2303.0 which resulted in:

    pl2303.o: pl2303.o: unresolved symbol usb_serial_deregister
    pl2303.o: pl2303.o: unresolved symbol usb_serial_register
    and on usbserial:
    segmentation fault

    Also tried modprobe what must work:
    modprobe: Can't open dependencies file //opt/lib/modules/2.4.20/modules.dep (No such file or directory)

    Or do I have to compile my own kernel with this drivers? As my question markes out I'm a novice, so would it be wise to go compiling my own kernel? Or is it just asking for more trouble.........

    This forum is my last resort, if I can't solve this I have to give up :-( (I also tried this on a TonidoPlug2 with no success)
    Last edited by ebk71; 24-04-2012 at 11:29.

Page 3 of 3 FirstFirst 123

Similar Threads

  1. Howto add serial port to WL-500gx/gp
    By Josephus in forum WL-500g/WL-500gx Tutorials
    Replies: 50
    Last Post: 05-11-2012, 11:32
  2. Serial port for WL-500g
    By sveasoft in forum WL-500g Pics & Specs
    Replies: 6
    Last Post: 08-03-2005, 21:39

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts