Results 1 to 2 of 2

Thread: Problem: Outside access to Router-ftp: port 21-only - other port needed!

  1. #1

    Problem: Outside access to Router-ftp: port 21-only - other port needed!

    Hello! First iīd like to say thx for all this support here. It helped me out quite a few times. But by searching the board, no thread helped me out with my "newest" problem, so I have to make my first posting now

    Basic Problem is:
    Iīm running the wl500g-internal USB-FTP with my external HDD, inside my LAN-Network it can be accessed from any port I filled out in the config menu of the usb-FTP. But from outside (WAN / Internet) FTP-Acces only runs via Port 21.
    BUT: I need another port! And no other port seems to run - e.g. taking Port 666 for USB-FTP: checking it with "Shields Up!" tells me, this port is stealthed. So, FTP Ports other then Port 21 seem to be closed.

    to clear any potential special question, hereīs my config and the detailed Problem:

    my Configuration:
    Iīm living at a studentsīhostel, the whole Appartments are connected via 10mbit ethernet, hosted by a server running Debian, and this Server is connected via a radio bridge to the computer center of our university, which is providing Internet access. Every Appartment has its static IP. So the Server at our students hostel has a routing function and is connected to my wl500gīs WAN Port, which takes this static ip.
    My 80gb external HDD is properly connected and mounted and it works without problems. It is internally using the Servers LAN IP (, externally it uses the static IP (the router seems to "translate" the ips on his own).
    The wl500g ist running firmware RC 3. "Web Access from WAN" and "Respond Ping Request from WAN?" are unchecked (=shut down). Iīm NOT running any port Triggers or Virtual Server (No NAT at all...)

    Why another Port then Port 21?:
    Because inside the University Net, some ports have been shut down - also port 21 - so outside our Studentīs hostle itīs not possible to ftp via Port 21. = acces via Port 21 is useless to me.
    If someone inside our wan (at another appartment / static ip) tries to access my ftp, it only works via port 21 and this without any problems. But switching the port of my USB-ftp results that no one from WAN can access the ftp anymore (as i mentioned: from inside my wl5oogīs lanīs computers, it is possible at any port).

    my opinion of the problem: using the normal web-interface configuration, makes it impossible to open another port then port 21 - changing to another ports does not also affect the opening of this port.

    My question:
    Is it possible to manually (via Script, command line, ect.) switch the internal ftp Port of the wl500g AND to OPEN this port to wan, also?
    Or is there a way to fix it by modifiing the NAT Setting (in my Opinion NAT seems to not affect the USB-FTP function, but maybe Iī, wrong).
    Or is there ANY other way, iīm to dumb to think about...

    pheeeeeewwwww, thatīs a lot of text, iīm sorry for this - but i tried to explain this problem more precisely. From other Threads it seemed to me that there are other persons, too, who are having a problem with non-port-21-usb-ftp, but the answers werenīt 100% helpful.

    I appreciate any answers from you, especially if it can help me and any other person who has this prob.

  2. #2
    Have you tried assigning another port through "NAT Setting -> Virtual Server"?

Similar Threads

  1. Replies: 24
    Last Post: 27-10-2005, 10:43
  2. Replies: 4
    Last Post: 10-10-2005, 22:09
  3. Replies: 5
    Last Post: 03-09-2005, 17:05
  4. Port trigger problem?
    By Tamadite in forum WL-500g Q&A
    Replies: 0
    Last Post: 07-12-2004, 21:11
  5. Port 9101 is difficult to access
    By monnier in forum WL-500g Custom Development
    Replies: 3
    Last Post: 11-08-2004, 21:14

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts