Page 5 of 9 FirstFirst ... 34567 ... LastLast
Results 61 to 75 of 123

Thread: [HowTo] Part One - WL-500g Premium

  1. #61
    Quote Originally Posted by WVR View Post
    Well on my web gui, On lefthand menu:
    IP Config -> LAN
    Then get box "Host Name:"

    A big thanks man
    The "myasus" thing in the setup is that

    Should edit the tutorial and put this informatios, since there are a lot of people, having the same problem
    Last edited by zzzpt; 04-05-2007 at 16:14.

  2. #62
    Join Date
    May 2007
    thank you very much for that tutorial!

    but I have 3 questions about the post-boot file.

    1 -> can somebody explain what actually this code does ? :
    #Wait for /opt to mount
    mount /dev/discs/disc0/part1 /opt
    while [ $i -le 30 ]
    if [ -d /opt/etc ]
    sleep 1
    i=`expr $i + 1`
    2->and this ?
    # Run all active services - active means starts with S
    my partition of my harddrive is mounted in /opt
    so I guess the directory "init.d" does not exist ?
    and the file "rc.unslung" does not exist?

    3-> how can we check that EVERYTHING that is in the post-boot file has been executed correctly?

    Thanks for your precious help!

  3. #63
    Join Date
    Feb 2007
    Moscow, Russia
    1. it waits for some time until /opt is really mounted. Otherwise the last line will not be executed

    2. actually it runs all active services located in /opt/etc/init.d --- active means starts with S
    /opt/etc/init.d/SXX* files are installed when you install packages which require to be started during boot
    Both unslung.rc and SXX* files are just scripts, so you can check their content and what they are doing

    3. put line
    echo "blah" > /tmp/log
    mount > /tmp/log
    or whatever you want to check in any place of the post-boot file and check the result

  4. #64


    tried to follow the manual
    Samba is working I can browse the drives from windows. But I cannot acces the torrent.cgi script through the web interface.
    gives unable to connect (gave a pink screen with file not found before)
    for Samba also does not work
    I gave the hostname in the web interface the name: myasus

    /dev/root on / type squashfs (ro)
    none on /dev type devfs (rw)
    proc on /proc type proc (rw)
    ramfs on /tmp type ramfs (rw)
    usbfs on /proc/bus/usb type usbfs (rw)
    /dev/discs/disc0/part1 on /opt type ext3 (rw)

    total used free shared buffers
    Mem: 30116 27468 2648 0 5524
    Swap: 524276 0 524276
    Total: 554392 27468 526924

    I also have the idea that torrent is not working, do I have to set open a NAT port ? How do I do this for the modem itself ?
    torrent_admin -l does list my torrents, but nld says everything zero

    I have noticed that manually executing the line in post-mount does give me acces to the torrent web interface cgi. Torrent also downloads, but is ver slow, I expect it is working in passive mode
    Samba does work, but is not configureable through the web interface. netstat -nl also indicates nothing is listening on port 901
    Last edited by modelamark; 19-05-2007 at 14:49.

  5. #65
    Quote Originally Posted by View Post
    great tutorial!!!

    everything works almost fine, one thing i have troubles with.

    [admin@paco sbin]$ post-mount

    that command i must manually start, when i reboot the router i must login with ssh and run that command before the web interface for the torrent is working.

    do you have any suggest/idea?
    I have the same problem. Did you manage to fix that ? I also cannot control samba through a web interface.
    Does your torrents also run slow ? Did you have to open a port to get it in active mode ? did you have to fill in your IP address somewhere ?
    Copying a set of files to ext3 mount (mounted with ext2volume manager) directly to my PC I get frequent messages that insufficient resources are available. DOcs says 255 bytes is the maximum file namesize, but is that including or excluding the path ?
    Last edited by modelamark; 20-05-2007 at 17:17.

  6. #66

    torrent doesn't work


    I have a problem with torrent.
    The download does not start.
    Everytime i got the following message in the log:
    Unable to find recent transfer stats in syslog
    10:26:20 up 12 min, load average: 0.00, 0.02, 0.00

    Is there anybody who can help me out?

    Last edited by Fox_Green; 28-05-2007 at 09:28.

  7. #67

    Prepare USB-HDD - new mounting script

    I modyfied the orginal HDD mounting script because it not work correct.
    This is my post-boot file:
    #loop for /opt to mount
    while [ $i -le 30 ]
    # waiting to detect hdd
    if [ -b /dev/scsi/host0/bus0/target0/lun0/part1 ]
    sleep 1
    echo "${i}" >> /tmp/mount_ticks
    i=$((i + 1))
    # Mount partition 1 as /opt
    mount /dev/scsi/host0/bus0/target0/lun0/part1 /opt 2>/tmp/mount_opt
    # # Mount partition 5 as swap
    swapon /dev/scsi/host0/bus0/target0/lun0/part5 2>/tmp/mount_swap
    In /tmp directory are created additionally logs files

  8. #68
    I noticed that as soon as you put the post-boot in with the mounts, stupid_ftp dies, both with this latest post-boot as the original
    harddisk seems to be mounted on /tmp/harddisk before post-boot remounting it probably causing the problem
    trying to connect with ftp gives the message
    500 OOPS:vsftpd: not found: directory given in 'secure_chroot_dir':/opt/usr/share/empty
    500 OOPS: child died
    vsftpd is on the expected place and the secure_chroot_dir var points to directory that seems to exist
    strange, fixed the problem by first using directory /opt followed by /opt/usr and it kept working all the way up to the empty.

    I have a low drive speed (usb 2.0, ext3, 700 kbyte/s). I first thought it was Samba, but it also turned up with ftp and while connecting the drive directly to my PC and mounting it with ext2 linux partition mounting program. The disk speed mentioned is 480Mbps, limited by USB2.0 60 MB/s
    Last edited by modelamark; 31-05-2007 at 20:17.

  9. #69



    I've installed Oleg's latest firmware with Transmission. I have several problems.

    1) Internet speed to my clients will be slow within 1 hr. I discovered that this can be solved by removing all torrents in Transmission. So I suppose that this is a Transmisson problem.

    2) The max speed of downloading torrents I achieved with Transmission is only 10kB/s. Can anyone tell me where I've gone wrong ? Perhaps this is because Transmission does not have protocol encryption and my ISP throttle BT speed.

    3) I cannot connect to internet if I turn off and turn on wl-500gP no matter what I do. I've tried using the web-based connect button, rebooting the router, turn off and on my modem, etc. Nothing works, unless I reflash the firmware.

    4) My wireless client cannot connect to the internet. It says IP address cannot be refreshed.

    If anyone knows the answers to my problems, please help.

    Thanks !


  10. #70
    Quote Originally Posted by modelamark View Post
    I have a low drive speed (usb 2.0, ext3, 700 kbyte/s). I first thought it was Samba, but it also turned up with ftp and while connecting the drive directly to my PC and mounting it with ext2 linux partition mounting program. The disk speed mentioned is 480Mbps, limited by USB2.0 60 MB/s
    As well as there is no DMA, all data must be copied by the CPU. I think the limitation of speed comes with slow CPU in the router.

  11. #71

    Unhappy read only

    It is my first time that I write in a forum. I do not possess great knowledge in Linux. But when I executed the following command gave the following error. If to be able to help me it was thankful.

    $ mkdir /opt/tmp
    mkdir: Cannot create directory `/opt/tmp': Read-only file system

  12. #72

    yet another samba problem


    New to forum, linux-type things, etc.


    I set up Oleg, HDD, Samba - everything OK

    Then I set up ctorrent -> I suddenly lost access to "muzik"-folder on my HDD. RW-rights just vanished, and the strangest thing, I can still access my "video"-folder. I've tried to regain the rights but folder stays in "permission denied"-mode. I tried searching & googling, but no real results since I'm new to linux.

    Could someone show me some pointers as I'm getting desperate: that USB-HDD is the only place I have that music!

    Thanks in advance,


  13. #73
    I have everything working except torrent. It explains
    btget: can't load library ''
    can't find a package that is in the ipkg list

    ipkg install -force-reinstall openssl
    seems to solve this
    Last edited by modelamark; 12-07-2007 at 22:06.

  14. #74
    hello i'm trying to install last oleg firmware but i have too heavy problem

    mkdir /opt/tmp
    mkdir /opt/tmp/ipkg update install ipkg
    ipkg update update
    when i try to make this command i received an error. can't download the content. why? where is the file to edit and convert dns to specify ip. thanks.

    i make every passage before this, is normal that, if i put free on telnet result

    0 on swap ?

    strange, i make 500 mb of swap file.

    thanks for help.

  15. #75
    Join Date
    Aug 2007
    Boxmeer, The Netherlands

    Question Where is Transmission?

    Great tutorial, I've used it with success up to the part where Samba and Transmission needed to be installed.

    I get an error when trying to install Transmission (ipkg install Transmission), saying the file is not found. Where is it? And how do I install it then?


Page 5 of 9 FirstFirst ... 34567 ... LastLast

Similar Threads

  1. Asus WL-500g Premium и шлюз
    By Grig_oriy in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 106
    Last Post: 15-05-2012, 20:43
  2. Установка svn на Asus WL-500g Premium
    By aka_mev in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 63
    Last Post: 19-03-2012, 20:01
  3. Сборка пакетов под WL-500g Premium
    By angel_il in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 127
    Last Post: 24-11-2011, 12:28
  4. WL-500g Premium died After Upgrading Firmware
    By acidbrain in forum WL-500gP Firmware Discussion
    Replies: 166
    Last Post: 17-06-2011, 07:59
  5. HOWTO use your WL-500g as IPv6 router
    By phedny in forum WL-500g/WL-500gx Tutorials
    Replies: 8
    Last Post: 17-02-2008, 07:19

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts