Page 3 of 9 FirstFirst 12345 ... LastLast
Results 31 to 45 of 123

Thread: [HowTo] Part One - WL-500g Premium

  1. #31
    Join Date
    Nov 2006
    First you have to mount a harddisk/pendrive's partition to /opt. Check it with 'df' command.
    Last edited by gorion; 04-01-2007 at 00:46.
    Powered by 2 Asus wl500g Premium :-)

  2. #32
    Join Date
    Jan 2007

    Question Stupid-ftp problem

    Hello everybody!

    I've read the two tutorials, and managed to get samba and almost all the other stuff working except stupid-ftp.
    I've tried to find the config file necessary to run stupid-ftp (stupid-ftp.conf) but I can't find it anywhere.
    I have enabled FTP sever on the web interface, but still nothing. What can I do in such a case... when should this stupid-ftp.conf be created, and by who?

    If nobody can tell me, at least could someone please copy/paste a config file, so I could at least see how do they look like.

    Thanks guys!


  3. #33
    thanks for the help gorion, i got the hard drive set up and all the apps installed correctly but for some reason i cant get samba to work,
    also i have to type post-boot after a restart, it doesnt do it automatically

    after i do run post-boot ctorrent starts, but when i click links like source and work, they dont go anywhere 404 error,
    also i cant get into my samba shares

    any ideas?
    most people have been saying set hostname, i do have it set in the web gui and a post-boot line as MyAsus,


  4. #34
    Quote Originally Posted by africamagical View Post
    thanks for the help gorion, i got the hard drive set up and all the apps installed correctly but for some reason i cant get samba to work,
    also i have to type post-boot after a restart, it doesnt do it automatically

    after i do run post-boot ctorrent starts, but when i click links like source and work, they dont go anywhere 404 error,
    also i cant get into my samba shares

    any ideas?
    most people have been saying set hostname, i do have it set in the web gui and a post-boot line as MyAsus,

    I have the same problems with post-boot! have you tried looking in 'ls -all' to see if its in there? (mine isnt btw) i cant seem to get it running... even with the chmod +x... ARGH!

  5. #35

    error message when installing screen

    I was following the instructions in the HOWTO, and it was fine until I got to installing screen, at which point it complained:

    [admin@(none) /opt]$ ipkg install screen
    Installing screen (4.0.3-2) to root...
    Installing termcap (1.3.1-2) to root...
    Configuring screen
    chown: unknown user name: root
    Configuring termcap
    Successfully terminated.

    It looks like it tried to chown something to user 'root', but the only user I have is 'admin'.

    I uninstalled screen:

    [root@(none) root]$ ipkg remove screen
    Removing package screen from root...
    Successfully terminated.

    Then used the web interface to change the user's name to root using System Setup > Change Name, then tried installing screen again and it worked that time.

    So should the HOWTO be changed to tell people to change the username to 'root' instead of 'admin', if that's what the packages expect to find? Or did I do the wrong thing?

  6. #36


    I'm kinda new to this router linux world, but I've decided to take out the parts I need from the guide.
    and start with dropbear, cuz ssh would be nice to use when out in the world
    when I have folowed the instruction, made the key, and the script.
    the thing is, that I can't just start dropbear.. nothing happens (I expect something to happen, since you made the remark with playing with it)

    Anything I need to do before this guide (use

  7. #37
    Quote Originally Posted by KingGuru View Post
    the thing is, that I can't just start dropbear.. nothing happens (I expect something to happen, since you made the remark with playing with it)
    Do a ps and if dropbear is running then thats it.
    Then use e.g. putty from a PC to ssh into it.

    The first time you connect putty should ask you if you want to save the key from the ssh server (dropbear) on your Asus.

  8. #38
    Got it.. apperently I forgot to save

    but anyway.. I have trouble with the transmission for torrent. I get a file not found when I try to access the page /cgi-bin/trans....

    I have installet it with the ipkg system..
    Last edited by KingGuru; 23-02-2007 at 17:40.

  9. #39
    I'am a newbie with Linux. (Yes anotherone...)

    I use the following firmware from Oleg: WL500gp-

    During this manual i have 3 errors.

    ipkg install mc cannot find package mc
    ipkg install ctorrent ERROR: cannot satisfy the following dependencies
    for ctorrent: libstdc++
    ipkg install nload ERROR: cannot satisfy the following dependencies
    for nload: libstdc++

    Can anyone help me?
    Last edited by pinkpanther; 10-02-2007 at 22:46.

  10. #40

    Some things aren't as difficult as they seem.

    I did -ipkg install libstdc++- and now ctorrent and nload installed correctly.

    Leaves one question: How to get MC?

  11. #41

    My experiences

    I had the same problems as most people here

    When you make your partionstions make 2 primary partiotions, do not make any extrended ones. MC wont install since it has been removed from the repository, just skip it unless you know what you are doing. As pinkpanter said, you have to install libstdc++ before you try to install ctorrent.

    Instead of putting
    /usr/sbin/busybox_httpd -p 8008 -h /opt/share/www
    in post-mount, put it in post-firewall and you should be fine!

    Regards to the samba problem the solutions has already been described,
    if your content of /opt/etc/init.d/S97Samba is:

    #!/bin/sh /usr/sbin/smbd -D -l /opt/var/log/smbd.log -s /opt/etc/samba/smb.conf /usr/sbin/nmbd -D -n myasus -o -l /tmp -s /opt/etc/samba/smb.conf

    then you should set you hostname in the webinterface (IP config / WAN & LAN / Hostname) to myasus

    From what I can tell samba and bittorrent works much better now then with the original asus firmware, many thanks to oleg and to marcnesium!!

  12. #42
    Join Date
    Nov 2006

    Update for Oleg with Samba2 and Transmission

    This guide is written supposing that your PC runs Windows, and you want to use your router as file server and Torrent client. My objective was to setup Oleg with Transmission and Samba2.

    Step 1 - Install required HW and SW
    1) Connect your PC to the wl-500gP using an ethernet cable (you should not use wireless during Step 1), and make sure that you can connect to the Ethernet
    2) Download and install putty and ASUS fw restoration utility
    3) Download Oleg firmware
    4) Unplug all USB devices from the router, and disconnect the modem cable
    5) Using the web interface, reset the router to factory settings
    6) Put the router in restoration mode
    7) Start ASUS firmware restoration utility and load Oleg fw into the router. Do not interrupt this step, the router may have to be repaired or replaced if you interrupt the load. The router will reboot automatically
    8) Connect modem to router, and parametrize it using web interface (at this stage userid/password is admin/admin). Here are some of my parameters:
    - Maintain as the router's IP address, and limit DHCP to
    - Activate Telnet and DDNS
    - Deactivate ftp and samba
    - Allow ping from WAN side
    - If you use wireless, select 32mW as the transmission power and activate the maximum possible security supported by your PC's (in my case WEP128 + mac access + hide SSID)
    - In LAN IP Setting / Host name specify a hostname of your choice (mine is MyASUS)
    9) Reboot the router (using web interface)
    You may have to calibrate the wireless part (it took me about 2 weeks to reach an acceptable setup). You can use NetStumbler to help you.

    Step 2 - Prepare disk
    1) Connect disk to router
    2) Start putty in Windows (all the remaining actions should be performed in line mode, not web interface). Point it to, telnet, keyboard with Linux function keys. You can save 3 profiles in putty, one for Telnet (from LAN), and two for SSH (from LAN and WAN). Paste lines in putty with right click on mouse.
    3) Format the disk with 3 primary partitions, first with +512M for swap (select type 82), second with +1G (for /opt), and 3rd with the rest. Use fdisk help to guide you.
    insmod scsi_mod && insmod sd_mod && insmod usb-storage && sleep 5s
    fdisk /dev/discs/disc0/disc
    4) Reboot
    5) Format and mount the disk
    insmod scsi_mod && insmod sd_mod && insmod usb-storage && sleep 5s
    mkswap /dev/discs/disc0/part1
    swapon /dev/discs/disc0/part1
    mke2fs -j /dev/discs/disc0/part2
    mount /dev/discs/disc0/part2 /opt
    mke2fs -j /dev/discs/disc0/part3
    6) Install base packages (ignore errors regarding wl500g):
    cd /opt/
    mkdir /opt/tmp
    mkdir /opt/tmp/ipkg
    wget install ipkg-opt_0.99.163-9_mipsel.ipk
    wget install uclibc-opt_0.9.28-12_mipsel.ipk 
    ipkg update
    ipkg install nano
    rm *.ipk
    7) Create startup scripts and install dropbear
    mkdir -p /usr/local/etc/dropbear
    dropbearkey -t dss -f /usr/local/etc/dropbear/dropbear_dss_host_key
    dropbearkey -t rsa -f /usr/local/etc/dropbear/dropbear_rsa_host_key
    mkdir -p /usr/local/sbin
    nano /usr/local/sbin/post-boot
    Here is my post-boot file:
    # Start SSH service
    # test if USB disc has been attached
    # if not - then insert needed modules
    if [ ! -d /dev/discs ]
    insmod scsi_mod && insmod sd_mod && insmod usb-storage && sleep 5s
    # Wait for /opt to mount
    mount /dev/discs/disc0/part2 /opt
    mount /dev/discs/disc0/part3 /tmp/harddisk
    while [ $i -le 30 ]
    if [ -d /opt/etc ]
    sleep 1
    i=`expr $i + 1`
    # Activate swap
    swapon /dev/discs/disc0/part1
    #to let midnight commander run on terminals, make alias for colored mc
    echo "export TERMINFO=/opt/share/terminfo">>/etc/profile
    echo "alias mc=\"mc -c\"">>/etc/profile
    # Run all active services - active means starts with S
    Next let's create the post-firewall file
    nano /usr/local/sbin/post-firewall
    Here is my post-firewall
    ## set default policy
    iptables -P INPUT DROP
    ## deny ftp access from WAN
    iptables -I INPUT 1 -p tcp -i "$1" --syn --dport 21 -j DROP
    ## Allow access to various router services from WAN
    ## Ports 22 and 65534 are required by dropbear and transmission
    for P in 65534 22; do
      iptables -I INPUT 1 -p tcp --syn -i "$1" --dport $P -j ACCEPT
    Create remaining files:
    touch /usr/local/sbin/post-mount
    touch /usr/local/sbin/pre-shutdown
    chmod +x /usr/local/sbin/*
    8) Save to flash and reboot
    flashfs save && flashfs commit && flashfs enable && reboot
    At the end of this Step2 the router should be able to boot, mount the disk, and use the swap. You can verify this with
    This should produce an output similar to
    [xxxx@MyASUS root]$ mount
    /dev/root on / type squashfs (ro)
    none on /dev type devfs (rw)
    proc on /proc type proc (rw)
    ramfs on /tmp type ramfs (rw)
    usbfs on /proc/bus/usb type usbfs (rw)
    /dev/discs/disc0/part2 on /opt type ext3 (rw)
    /dev/discs/disc0/part3 on /tmp/harddisk type ext3 (rw)
    [xxxx@MyASUS root]$ free
                  total         used         free       shared      buffers
      Mem:        30140        13744        16396            0         4148
     Swap:       500712            0       500712
    Total:       530852        13744       517108
    Step3 - Install samba2
    Samba2 comes with a web interface from where you can parametrize and restart the service without rebooting the router.
    ipkg install mc
    ipkg install xinetd
    ipkg install samba2
    Create folder for samba shares
    mkdir /tmp/harddisk/share
    chmod ugoa+w /tmp/harddisk/share
    Create rc.unslung (to start all your services automatically after each reboot)
    nano /opt/etc/init.d/rc.unslung
    Here is my rc.unslung file:
    # Start all init scripts in /opt/etc/init.d
    # executing them in numerical order.
    for i in /opt/etc/init.d/S??* ;do
        # Ignore dangling symlinks (if any).
        [ ! -f "$i" ] && continue
        case "$i" in
               # Source shell script for speed.
                   trap - INT QUIT TSTP
                   set start
                   . $i
               # No sh extension, so fork subprocess.
               $i start
    Edit /opt/etc/xinetd.d/swat file (with nano or mc) to update the "user = root" line with your userid (such as "user = admin").
    Make rc.unslung executable, and execute it to start xinetd and samba2
    chmod +x /opt/etc/init.d/rc.unslung
    Open your browser to and parametrize samba at your will. I have removed all shares and created two new ones:
    - Share (pointing to /tmp/harddisk/share)
    - Torrent (pointing to /tmp/harddisk/torrent)

    Step4 - Install Tranmission
    This was my choice for torrent client. It's easy to use. You can either store .torrent files in //myasus/torrent/source or use Transmission's fetch button. At the moment transmission is going through changes, so what follows may not apply in the near future.
    ipkg install cron
    ipkg install gnuplot
    ipkg install logrotate
    ipkg install transmission
    Create torrent directories
    cd /tmp/harddisk
    mkdir torrent
    mkdir torrent/source
    mkdir torrent/target
    mkdir torrent/work
    chmod ugoa+w torrent
    chmod ugoa+w torrent/source
    chmod ugoa+w torrent/target
    If your administration userid has been renamed from admin to something else, use mc to replace admin in /opt/etc/transmission.conf and /opt/share/www/cgi-bin/transmission.cgi.
    Using mc, edit /opt/etc/transmission.conf to update TIMEZONE.
    Edit opt/etc/crontab file. Mine is (replace xxxx with your admin userid):
    # ---------- ---------- Default is Empty ---------- ---------- #
    */30 * * * * xxxx nice /opt/sbin/transmission_watchdog
    0 0 * * * xxxx /opt/sbin/logrotate -f /opt/etc/logrotate.conf &>/dev/null
    Create S05syslogd, this is necessary to replace logging on memory by logging on disk, and make it available for gnuplot.
    nano /opt/etc/init.d/S05syslogd
    Here is mine:
    # Startup script for syslogd
    # Stop myself if running
    if [ -n "`pidof syslogd`" ]; then
    killall syslogd 2>/dev/null
    /sbin/syslogd -m 0 -O /opt/var/log/messages -S -l 7
    Make it executable:
    chmod +x /opt/etc/init.d/S05syslogd
    Go to web interface, deactivate telnet and reboot. After that, you can access Transmission from Windows pointing your browser to

    Next Steps (optional)
    1) Here are some suggestions
    2) Activate ftp in web interface (to share /tmp/harddisk)
    Last edited by Moody Blue; 01-04-2007 at 13:42. Reason: Updated to include dropbear and ftp

  13. #43
    Same problem over here!

    Quote Originally Posted by africamagical View Post
    im doing fine untill the ipkg setup,

    when i type:
    mkdir /opt/tmp

    I get the following error:
    mkdir: cannot create directory '/opt/tmp' :Read-only file system

    any help is appreciated, i neeeed to get the ctorrent working as the asus download manager blows

  14. #44

    Unhappy Web interface for SAMBA 2 not active ...

    Hi there ...
    Thanks a lot for the excellent tutorials ... for a linux beginner as me is this perfect.

    I followed MoodyBlue's tutorial but can not get SAMBA working.
    I can not connect to for the web interface. The router webinterface is working and accessible.

    The services are started and running, did not get any error messages.

    Does any one know how to solve this.
    Thanks in advance!

  15. #45
    Join Date
    Feb 2005
    Germany - Frankfurt
    Try "netstat -ln"

    Is there something listening on port 901?

    Using "ps axf":

    Is xinetd running?
    Is swat running?

Page 3 of 9 FirstFirst 12345 ... LastLast

Similar Threads

  1. Asus WL-500g Premium и шлюз
    By Grig_oriy in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 106
    Last Post: 15-05-2012, 20:43
  2. Установка svn на Asus WL-500g Premium
    By aka_mev in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 63
    Last Post: 19-03-2012, 20:01
  3. Сборка пакетов под WL-500g Premium
    By angel_il in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 127
    Last Post: 24-11-2011, 12:28
  4. WL-500g Premium died After Upgrading Firmware
    By acidbrain in forum WL-500gP Firmware Discussion
    Replies: 166
    Last Post: 17-06-2011, 07:59
  5. HOWTO use your WL-500g as IPv6 router
    By phedny in forum WL-500g/WL-500gx Tutorials
    Replies: 8
    Last Post: 17-02-2008, 07:19

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts