Page 1 of 2 12 LastLast
Results 1 to 15 of 26

Thread: How-to: Avoid those crazy feelings when you have messed up your router :)

  1. #1

    How-to: Avoid those crazy feelings when you have messed up your router :)

    While still trying to get the new version of busybox on it I brought my unit to a status where it doesn't boot anymore. No ping no reset nothing.

    But I didn't give up so when everything fails:

    1. Give you a static IP like
    2. Unplug the router for about 10-20 seconds (power cord)
    3. Hold the orange EZSetup-button while plugging power on
    4. Now the blue ready LED will shine
    5. Use Firmware-Restore tool to upload a working firmware
    6. Press Reset for about 10 seconds


  2. #2
    Thanks for the guide I can imagine how you actually felt. I've been there.

    On another note, this looks like a good post to also put in the Tutorial sub forum. It's such a sad little forum, it feels so alone with not a single post in it. Perhaps this is the post to lighten its suffering


  3. #3
    I also have a problem after updating the firmware.
    The READY led just keep blinking and nothing more happens!
    Anyway, I can ping to the router.
    I'll try what DaNawq is says to see if this solves the problem.

    I think that this stuff is the kind of stuff to put in the tutorial forum!
    Very important and usefull.

  4. #4
    Sorry, but this didn't solve my problem.
    How many time did you waited for the Firmware-Restoring tool to upload the firmware? I only see a message saying something like this "Discovering.... Pres Ctrl+c to cancel".
    I used ethereal to see what is happening but the router didn't answer to any packet. Anyway, the router was replying ping commands.
    This happened after I tryed to upgrade the firmware to a new version. How do you do this, upgrading a firmware?

  5. #5
    Join Date
    Apr 2004
    A lot of tutorials for the WL-500g (Deluxe) are also often applicable to the WL-700g....

  6. #6
    xvibe just take a look to the other help thread. I think you only did the timing with releasing the ez-setup button while pluggin power in wrong.

  7. #7
    Sorry DaNawq, but I figure out how to make the READY led just shine and not blinking. You just have to release the ez-setup button in the right time.
    Anyway, anything more happens and it didn't solve the problem.
    So, i returned my wl700 to the store and they give me a new one. Now i'm affraid of updating the firmware.
    Any tutorial on how to update the firmware of wl700? this is very frustating....

    And Styno, could you tell me where is some informationg regarding this problem that is in the wl500g forum? Thanx!

  8. #8
    Thx m8. Just turned a big white brick back into a router thx to your little guide

    One thing that took me a few minutes to figure out is that you have to let go of the ezsetup button as soon as the power comes on and the blue ready led lights up. This leaves the router in a semi-booted state, where you can run the firmware restoration tool successfully.

  9. #9

    Solving the flash issue

    If flashing has failed and the WL-700ge has only a blinking <ready> light this will solve the issue:

    1. Download and unzip the latest working firmware for the WL-700gE
    2. Download tftp32 (
    3. Download the tool AsusTrxExtract. (
    Running this beautiful tool will split the WL700gE_1.0.4.2.nas file in:
    - WL700gE_1.0.4.2_disk.trx
    - WL700gE_1.0.4.2_flash.trx
    4. Power on the WL-700ge
    5. Use tftp32 to upload WL700gE_1.0.4.2_flash.trx to the WL-700ge
    6. When transfer is succesfull remove powercable, wait 20 seconds and insert powercable.
    7. Use the Asus Firmware restoration tool to upload the WL700gE_1.0.4.2.nas file.

    Took me a day to figure out, but the white brick is up and running again!!!
    Last edited by e-motion; 19-09-2006 at 18:00.

  10. #10

    why doesnt this work for me?

    The firmware restoration tool always fails, saying it cant find the file.

    Any ideas? I ordered mine online and it sucks to return it and as well had uploaded a ton to the harddrive already.


  11. #11
    I've tried everything what is told, but I can't ping the router.. Only the blue light stays on, ready. Or do I need to put a cross cable into the wan port of the router? If I can ping it, then I understand that these things help..
    I hope somebody has a clue..

    greetz Rob

  12. #12
    Join Date
    Oct 2006
    Norway, Oslo

    Me, realy new to fix firmware :-D

    DaNawq: Thanx for the info. I also thougt my brick was down for good. To Extract the trx file and upload that made the brick accessible. Then I only did go the the web config and upload the .nas file again and then the upgrade was running as it should.


  13. #13


    Hi Guys,

    since all the common instruction, however they are ment to be useful for the community or not, are poor beacause you need to be pro to understand what they mean (Danawq included). Just look for the restauration of the router by using the search function and you will find a post about restoring the router.
    I also got feedback that it was working fine.


    I did following to get it back running:
    1) Set local IP Adress to

    2) I used a network cable which is "straight through". As both cable types will show a connection to the router on the PC, with the crossed cable nothing will happen.

    3) Ping the adress --> should be possible, and check with "arp -a" if the IP adress is found in the arp table

    4) Now i used the ASUSTRX (Search for link) tool to split the NSA file into two TRX files. In my case I already uesed the file!!! USE LATEST FROM ASUS PAGE!!!!

    5) Connect the network cable on port "LAN 1" !!!

    6) Power Up the router

    7) Start tftp32

    8) Click on TFTP Client and put in following info
    Host: Port: 69
    File: C:\xxxxxxxxx.trx
    Press the Button PUT
    After a second the blue indicator will start running

    9) Then the power button on the router will lite (yellow/orange, depending on your meaning about colours ;-))

    10) Press the power off button

    11) Turn Router On

    12) Make a update with the latest firmware through the Internet Explorer function -> explorer wont hang after this upgrade

    13) if router hangs, repeat from step 1 and use EZ Button Update Restauration for updating firmware (flash+image)


  14. #14

    Cool The miracle of turning bricks into routers

    Thanks for the tips, I got mine working.

    Here are some hints:

    1. If you can't ping the router then turn it off, and hold the ezsetup button only until the ready light lights up... pretty much right way. Then you should be able to plug into port 1 and set your ip to and then ping the router. When I first crashed I could still ping, so if you're able to then just leave it alone.

    2. The AsusTrxExtract.exe tool worked on the firmware .nas file but it requires the latest dot net update so I had to install that first:

    3. emotion posted links to the other software you need, but tftp.exe I had to get from here:

    4. tftp.exe asked for Server (the router -, Password, and File. I didn't need to input a password. I told it to use the WL700gE_1.0.4.6_flash.trx file.

    5. After it was done I just had to unplug the router and plug it back in and it started working again.

    I'm curious why I didn't need to do anything with WL700gE_1.0.4.6_disk.trx when that's most of what was in the .nas file.

    Good luck,

  15. #15
    I would like to thank everyone who contributed info here. I just had the same situation as DaNawq.

    It was solved by info posted here. Thanks again!

Page 1 of 2 12 LastLast

Similar Threads

  1. Acessing the router in Access point Mode (AP)
    By IMM22 in forum WL-700g Firmware Discussion
    Replies: 6
    Last Post: 06-10-2006, 09:45
  2. Router Online?
    By SpeziAlex in forum German Discussion - Deutsch (DE)
    Replies: 10
    Last Post: 12-04-2006, 02:20
  3. Hoe map ik een poort van de router naar de computer.
    By Dokus in forum Dutch Discussion - Nederlands
    Replies: 1
    Last Post: 05-03-2006, 18:16
  4. Help krijg geen contact met Router!!!!!
    By NdK in forum Dutch Discussion - Nederlands
    Replies: 4
    Last Post: 10-02-2006, 09:04
  5. connecting to router administration
    By hejlemann in forum WL-500g Q&A
    Replies: 0
    Last Post: 21-12-2005, 21:16

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts