Results 1 to 9 of 9

Thread: How to automatically start post-boot?

  1. #1

    How to automatically start post-boot?

    Hi,

    I tried to search for solution but I didn't succeed.

    My firmware is 1.9.2.7-7e.

    My post-boot script is /tmp/local/sbin/post-boot, and it is executable.

    Now it contains:
    Code:
    #/bin/sh
    echo ize
    /usr/local/no-ip/noip2
    When I try to run it, it says:
    -sh: post-boot: not found

    What am I doing wrong?

    See this: http://wl500g.info/showthread.php?t=...ighlight=no-ip

    I hope you can help me.

  2. #2
    What am I doing wrong?

  3. #3
    Join Date
    Nov 2003
    Location
    Eindhoven
    Posts
    2,407
    Quote Originally Posted by VaZso
    What am I doing wrong?
    well what are you doing?

    you say you execute it.. but how do you execute it?
    and in which path do you reside at that moment

    My little Asus Collection: Too much to fit inhere, my 2 babies:WL500w 1.9.2.7-10(OLEG) VX2SE Yellow Lamborghini notebook



    WL500g Forum Asus Files OpenDir

    Asusforum.NL -- Asusforum.DE -- Asusforum.RU -- Asusforum.PL -- Asusforum.NET -- Asusforum.EU -- Asusforum.BE -- Asusforum.ES -- Asusforum.INFO

  4. #4
    So I have created a file called boot-script in /usr/local/sbin/

    It contains:
    Code:
    #/bin/sh
    echo ize
    /usr/local/no-ip/noip2
    then
    chmod +x post-boot

    and try to run:
    ./post-boot (In /usr/local/sbin)

    The result is:
    Code:
    -sh: ./post-boot: not found
    If the post-boot only contains:
    Code:
    echo ize
    /usr/local/no-ip/noip2
    (So, without #/bin/sh)

    then after
    ./post-boot

    The result is:
    Code:
    ize
    : not found: 2: /usr/local/no-ip/noip
    For
    ls -l /usr/local/no-ip

    The result is:
    Code:
    -rwxr-sr-x      1 vazso    root    70008  Jun 20 22:19 noip2
    So, the file is there.

    I have modified the user name at the web interface, so at login I have to type vazso instead of root. May it be a problem?

    I think it is a good idea renaming back to root...
    Last edited by VaZso; 02-07-2006 at 16:47.

  5. #5
    I've tried to rename it back to root but it didn't help.

    Any idea?

  6. #6
    Join Date
    Nov 2003
    Location
    Eindhoven
    Posts
    2,407
    yeah well..
    it should be

    #!/bin/sh

    note the exclamation mark

    My little Asus Collection: Too much to fit inhere, my 2 babies:WL500w 1.9.2.7-10(OLEG) VX2SE Yellow Lamborghini notebook



    WL500g Forum Asus Files OpenDir

    Asusforum.NL -- Asusforum.DE -- Asusforum.RU -- Asusforum.PL -- Asusforum.NET -- Asusforum.EU -- Asusforum.BE -- Asusforum.ES -- Asusforum.INFO

  7. #7
    Sorry, I've mistyped it.

    My post-boot file have #!/bin/sh in the first row.

    So, this was not the problem.

    Maybe I'll try to reset the router if you think the post-boot script is ok.
    Have you got any other ideas?

    Sorry again about my mistype.

  8. #8
    I tryed a factory reset from the router's web interface.

    Then I didn't modified anything just enabled flashfs, but it didn't work.
    I still can't run the script when it starts with #!/bin/sh
    (Now I see, the original "user name" was not root but admin.)

    Anyway, I don't know why can I run an other script from /sbin (/sbin/wshaper)
    And why can I run it from elsewhere (if I copy it to another directory):
    Code:
    #!/bin/sh
    # Wonder Shaper
    
    DOWNLINK=$3
    UPLINK=$4
    DEV=$2
    
    NOPRIOHOSTSRC="$5"
    
    NOPRIOHOSTDST="$6"
    
    NOPRIOPORTSRC="$7"
    
    NOPRIOPORTDST="$8"
    
    if [ "$1" = "status" ]
    then
    	tc -s qdisc ls dev $DEV
    	tc -s class ls dev $DEV
    	exit
    fi
    
    tc qdisc del dev $DEV root    2> /dev/null > /dev/null
    tc qdisc del dev $DEV ingress 2> /dev/null > /dev/null
    
    if [ "$1" = "stop" ] 
    then 
    	exit
    fi
    
    
    ###### uplink
    
    tc qdisc add dev $DEV root handle 1: htb default 20
    
    tc class add dev $DEV parent 1: classid 1:1 htb rate ${UPLINK}kbit burst 6k
    
    # high prio class 1:10:
    
    tc class add dev $DEV parent 1:1 classid 1:10 htb rate ${UPLINK}kbit \
       burst 6k prio 1
    
    
    tc class add dev $DEV parent 1:1 classid 1:20 htb rate $((9*$UPLINK/10))kbit \
       burst 6k prio 2
    
    tc class add dev $DEV parent 1:1 classid 1:30 htb rate $((8*$UPLINK/10))kbit \
       burst 6k prio 2
    
    tc qdisc add dev $DEV parent 1:10 handle 10: sfq perturb 10
    tc qdisc add dev $DEV parent 1:20 handle 20: sfq perturb 10
    tc qdisc add dev $DEV parent 1:30 handle 30: sfq perturb 10
    
    tc filter add dev $DEV parent 1:0 protocol ip prio 10 u32 \
          match ip tos 0x10 0xff  flowid 1:10
    
    tc filter add dev $DEV parent 1:0 protocol ip prio 10 u32 \
            match ip protocol 1 0xff flowid 1:10
    
    tc filter add dev $DEV parent 1: protocol ip prio 10 u32 \
       match ip protocol 6 0xff \
       match u8 0x05 0x0f at 0 \
       match u16 0x0000 0xffc0 at 2 \
       match u8 0x10 0xff at 33 \
       flowid 1:10
    
    for a in $NOPRIOPORTDST
    do
    	tc filter add dev $DEV parent 1: protocol ip prio 14 u32 \
    	   match ip dport $a 0xffff flowid 1:30
    done
    
    for a in $NOPRIOPORTSRC
    do
     	tc filter add dev $DEV parent 1: protocol ip prio 15 u32 \
    	   match ip sport $a 0xffff flowid 1:30
    done
    
    for a in $NOPRIOHOSTSRC
    do
     	tc filter add dev $DEV parent 1: protocol ip prio 16 u32 \
    	   match ip src $a flowid 1:30
    done
    
    for a in $NOPRIOHOSTDST
    do
     	tc filter add dev $DEV parent 1: protocol ip prio 17 u32 \
    	   match ip dst $a flowid 1:30
    done
    
    # rest is 'non-interactive' ie 'bulk' and ends up in 1:20
    
    tc filter add dev $DEV parent 1: protocol ip prio 18 u32 \
       match ip dst 0.0.0.0/0 flowid 1:20
    
    
    ########## downlink #############
    
    tc qdisc add dev $DEV handle ffff: ingress
    
    tc filter add dev $DEV parent ffff: protocol ip prio 50 u32 match ip src \
       0.0.0.0/0 police rate ${DOWNLINK}kbit burst 10k drop flowid :1
    And I don't know why can't I run this script (myshaper):
    Code:
    #!/bin/sh
    #
    # myshaper - DSL/kabelmodem kimeno forgalmanak szabalyozasa.
    # Irta: Dan Singletary (8/7/02)
    minden   nem-TCP
    nem-TCP
    mast  nem
    DEV=ppp0
    RATEUP=120
    RATEDN=1000  
    
    if [ "$1" = "status" ]
    then
            echo "[qdisc]"
            tc -s qdisc show dev $DEV
            tc -s qdisc show dev imq0
            echo "[class]"
            tc -s class show dev $DEV
            tc -s class show dev imq0
            echo "[filter]"
            tc -s filter show dev $DEV
            tc -s filter show dev imq0
            echo "[iptables]"
            iptables -t mangle -L MYSHAPER-OUT -v -x 2> /dev/null
            iptables -t mangle -L MYSHAPER-IN -v -x 2> /dev/null
            exit
    fi
    
    tc qdisc del dev $DEV root    2> /dev/null > /dev/null
    tc qdisc del dev imq0 root 2> /dev/null > /dev/null
    iptables -t mangle -D POSTROUTING -o $DEV -j MYSHAPER-OUT 2> /dev/null > /dev/null
    iptables -t mangle -F MYSHAPER-OUT 2> /dev/null > /dev/null
    iptables -t mangle -X MYSHAPER-OUT 2> /dev/null > /dev/null
    iptables -t mangle -D PREROUTING -i $DEV -j MYSHAPER-IN 2> /dev/null > /dev/null
    iptables -t mangle -F MYSHAPER-IN 2> /dev/null > /dev/null
    iptables -t mangle -X MYSHAPER-IN 2> /dev/null > /dev/null
    ip link set imq0 down 2> /dev/null > /dev/null
    rmmod imq 2> /dev/null > /dev/null
    
    if [ "$1" = "stop" ] 
    then 
            echo "Shaping removed on $DEV."
            exit
    fi
    
    ip link set dev $DEV qlen 30
    
    
    ip link set dev $DEV mtu 1000
    
    tc qdisc add dev $DEV root handle 1: htb default 26
    
    tc class add dev $DEV parent 1: classid 1:1 htb rate ${RATEUP}kbit
    
    tc class add dev $DEV parent 1:1 classid 1:20 htb rate $[$RATEUP/7]kbit ceil ${RATEUP}kbit prio 0
    tc class add dev $DEV parent 1:1 classid 1:21 htb rate $[$RATEUP/7]kbit ceil ${RATEUP}kbit prio 1
    tc class add dev $DEV parent 1:1 classid 1:22 htb rate $[$RATEUP/7]kbit ceil ${RATEUP}kbit prio 2
    tc class add dev $DEV parent 1:1 classid 1:23 htb rate $[$RATEUP/7]kbit ceil ${RATEUP}kbit prio 3
    tc class add dev $DEV parent 1:1 classid 1:24 htb rate $[$RATEUP/7]kbit ceil ${RATEUP}kbit prio 4
    tc class add dev $DEV parent 1:1 classid 1:25 htb rate $[$RATEUP/7]kbit ceil ${RATEUP}kbit prio 5
    tc class add dev $DEV parent 1:1 classid 1:26 htb rate $[$RATEUP/7]kbit ceil ${RATEUP}kbit prio 6
    
    tc qdisc add dev $DEV parent 1:20 handle 20: sfq perturb 10
    tc qdisc add dev $DEV parent 1:21 handle 21: sfq perturb 10
    tc qdisc add dev $DEV parent 1:22 handle 22: sfq perturb 10
    tc qdisc add dev $DEV parent 1:23 handle 23: sfq perturb 10
    tc qdisc add dev $DEV parent 1:24 handle 24: sfq perturb 10
    tc qdisc add dev $DEV parent 1:25 handle 25: sfq perturb 10
    tc qdisc add dev $DEV parent 1:26 handle 26: sfq perturb 10
    
    
    tc filter add dev $DEV parent 1:0 prio 0 protocol ip handle 20 fw flowid 1:20
    tc filter add dev $DEV parent 1:0 prio 0 protocol ip handle 21 fw flowid 1:21
    tc filter add dev $DEV parent 1:0 prio 0 protocol ip handle 22 fw flowid 1:22
    tc filter add dev $DEV parent 1:0 prio 0 protocol ip handle 23 fw flowid 1:23
    tc filter add dev $DEV parent 1:0 prio 0 protocol ip handle 24 fw flowid 1:24
    tc filter add dev $DEV parent 1:0 prio 0 protocol ip handle 25 fw flowid 1:25
    tc filter add dev $DEV parent 1:0 prio 0 protocol ip handle 26 fw flowid 1:26
    
    iptables -t mangle -N MYSHAPER-OUT
    iptables -t mangle -I POSTROUTING -o $DEV -j MYSHAPER-OUT
    
    20-26 
    
    iptables -t mangle -A MYSHAPER-OUT -p tcp --sport 0:1024 -j MARK --set-mark 23 # Alapertek az 
    iptables -t mangle -A MYSHAPER-OUT -p tcp --dport 0:1024 -j MARK --set-mark 23 # "" 
    iptables -t mangle -A MYSHAPER-OUT -p tcp --dport 20 -j MARK --set-mark 26     # ftp-data port, alacsony prioritas
    iptables -t mangle -A MYSHAPER-OUT -p tcp --dport 5190 -j MARK --set-mark 23   # aol instant messenger
    iptables -t mangle -A MYSHAPER-OUT -p icmp -j MARK --set-mark 20               # ICMP (ping) - magas prioritas, baratok ismertetojegye
    iptables -t mangle -A MYSHAPER-OUT -p udp -j MARK --set-mark 21                # DNS nevfeloldas (kis csomagok)
    iptables -t mangle -A MYSHAPER-OUT -p tcp --dport ssh -j MARK --set-mark 22    # secure shell
    iptables -t mangle -A MYSHAPER-OUT -p tcp --sport ssh -j MARK --set-mark 22    # secure shell
    iptables -t mangle -A MYSHAPER-OUT -p tcp --dport telnet -j MARK --set-mark 22 # telnet (ew...)
    iptables -t mangle -A MYSHAPER-OUT -p tcp --sport telnet -j MARK --set-mark 22 # telnet (ew...)
    iptables -t mangle -A MYSHAPER-OUT -p ipv6-crypt -j MARK --set-mark 24         # IPSec - viszont nem tudjuk, mi a "hasznos teher"...
    iptables -t mangle -A MYSHAPER-OUT -p tcp --sport http -j MARK --set-mark 25   # helyi webszerver
    iptables -t mangle -A MYSHAPER-OUT -p tcp -m length --length :64 -j MARK --set-mark 21 # kis csomagok (valoszinuleg csak ACK-k)
    iptables -t mangle -A MYSHAPER-OUT -m mark --mark 0 -j MARK --set-mark 26      # redundans- jeloljunk minden nem jelolt csomagot 26-tal (alacsony prioritas)
    
    echo "Outbound shaping added to $DEV.  Rate: ${RATEUP}Kbit/sec."
    
    # tavolitsd el a megjegyzest a kovetkezo sor elol, ha csak kimeno forgalomszabalyozast akarsz
    # exit
    
    modprobe imq numdevs=1
    
    ip link set imq0 up
    
    tc qdisc add dev imq0 handle 1: root htb default 21
    
    tc class add dev imq0 parent 1: classid 1:1 htb rate ${RATEDN}kbit
    
    tc class add dev imq0 parent 1:1 classid 1:20 htb rate $[$RATEDN/2]kbit ceil ${RATEDN}kbit prio 0
    tc class add dev imq0 parent 1:1 classid 1:21 htb rate $[$RATEDN/2]kbit ceil ${RATEDN}kbit prio 1
    
    tc qdisc add dev imq0 parent 1:20 handle 20: sfq perturb 10
    tc qdisc add dev imq0 parent 1:21 handle 21: red limit 1000000 min 5000 max 100000 avpkt 1000 burst 50
    
    tc filter add dev imq0 parent 1:0 prio 0 protocol ip handle 20 fw flowid 1:20
    tc filter add dev imq0 parent 1:0 prio 0 protocol ip handle 21 fw flowid 1:21
    
    iptables -t mangle -N MYSHAPER-IN
    iptables -t mangle -I PREROUTING -i $DEV -j MYSHAPER-IN
    
    iptables -t mangle -A MYSHAPER-IN -p ! tcp -j MARK --set-mark 20              iptables -t mangle -A MYSHAPER-IN -p tcp -m length --length :64 -j MARK --set-mark 20 # rovid TCP csomagok, valoszinuleg ACK-k
    iptables -t mangle -A MYSHAPER-IN -p tcp --dport ssh -j MARK --set-mark 20    # secure shell
    iptables -t mangle -A MYSHAPER-IN -p tcp --sport ssh -j MARK --set-mark 20    # secure shell
    iptables -t mangle -A MYSHAPER-IN -p tcp --dport telnet -j MARK --set-mark 20 # telnet (ew...)
    iptables -t mangle -A MYSHAPER-IN -p tcp --sport telnet -j MARK --set-mark 20 # telnet (ew...)
    iptables -t mangle -A MYSHAPER-IN -m mark --mark 0 -j MARK --set-mark 21              # redundans- minden nem jelolt csomagot 21-el jelolunk (alacsony prioritas)
    
    iptables -t mangle -A MYSHAPER-IN -j IMQ
    
    echo "Inbound shaping added to $DEV.  Rate: ${RATEDN}Kbit/sec."
    I tryed to remove the comments because of the length.
    I hope it will not be too long, sorry.


    Why is there working with everybody else except me? I don't know what I have to do to get it work.

    Please help me.

    Ps: Is there any restrictions in the newest firmware?

    Ps2: I don't have USB disk attached. Is there a problem?
    Last edited by VaZso; 03-07-2006 at 22:49.

  9. #9
    Now it works for me.

    The problem was that I created the file using win.
    After opened it with vi, I saw "^M"s in the end of every row...

    Sorry about this and thank you very much to tryed to help me.

Similar Threads

  1. let samba start on boot
    By MHz in forum WL-500g Q&A
    Replies: 5
    Last Post: 29-05-2006, 10:47
  2. Post lost?
    By ikerstges in forum WL-500g Q&A
    Replies: 3
    Last Post: 15-02-2006, 13:41
  3. Boot the Router over Network TFTP+NFS
    By tomekmik in forum WL-500g Custom Development
    Replies: 7
    Last Post: 14-01-2006, 22:11
  4. web interface loads only occasionally during boot
    By oferlaor in forum WL-500g Q&A
    Replies: 5
    Last Post: 18-10-2004, 11:48

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •