Page 2 of 3 FirstFirst 123 LastLast
Results 16 to 30 of 42

Thread: How do I solder a JTAG connector to Asus WL-500

  1. #16

    Bricked WL-500W Need JTAG Loyout


    It seems that I managed to brick my Asus WL-500W. Now I'd like to build JTAG cable but I can't find anywhere layout of the possible JTAG connections for this router. Can anybody help me with this?

    You can answer also in German or Russian.

    Thanks in advance!

  2. #17
    Join Date
    Dec 2007
    The Netherlands - Eindhoven
    Never opened up my router, but I tought the wl500w would be almoast the same as the gP

    I found something in this post that might help you:
    and the thread:

  3. #18

    WL500g Premium V2 and JTAG

    Hi, is there a way to connect JTAG to the WL500g Premium V2?

  4. #19
    Join Date
    Dec 2003
    Russian Federation

    Lightbulb JTAG WL-500gP v2

    Yes, just use JTAG header on the PCB.

    Name:  v2-jtag.jpg
Views: 2559
Size:  131.9 KB Name:  v2-jtag1.jpg
Views: 3237
Size:  146.3 KB
    Last edited by Omega; 11-06-2013 at 04:26. Reason: fixed

  5. #20
    Great, do you have a image that shows where on the PCB to find it?
    Does also the V1 version have a JTAG header?

  6. #21

    I had a similar issue, and I did the following:

    - unplug your router
    - open the box
    - connect your router to the PC using a cable connection
    - on your PC you have to set the IP:; SUBNET:, Default gateway:, Preffered DNS:
    - you have to make a temporar connection between the grount connector and the R56 pin of the router
    - plug the power cord to the router, wait about 2 seconds and then remove the connection between the ground and the R56 pin
    - the power led on the router will start to blink
    - using the firmware restoration tool from the asus software upload to the router your desired firmware

    And now it works
    Attached Images Attached Images  

  7. #22
    Join Date
    Jul 2007
    Be so kind and don't do the pin 9 trick or any kind of grounding......
    it's too dangerous to finally brick your router.
    I've done the following procedures several times:

    read the section: Asus WL500G (Original)
    from here (somewhere in the middle):
    just use your firmware instead of ddwrt

    the needed files from oleg:
    Hint: wait after each flashing min. 5 Minutes

    If you need more infos, let me know....
    have fun with your router again.

    edit: if you wanna use windows, open a dos box (start,run,cmd), and cd to the directory with your routerfirmware.
    then use windows-tftp: tftp -i PUT name_of_your_firmware
    Last edited by newbiefan; 09-03-2009 at 20:23.
    Alle HowTo's, all howto's

    RT-N16, Samba, VSFTP, Lightthpd, PHP, Perl, MySQL, Serendipity, Aria2web, HDD 640GB
    RT-N66U, 16GB MicroSD/ 2 Partitions, 2,5" HDD 1TB, running with Merlin's FW and Entware, 16 Mbit A1,
    Netgear DGND 3700V2, QNAP TS119PII 4 TB, QNAP TS209 2 TB Raid1, Backup Synology DS107+ 1 TB, HP CP1515n

  8. #23
    Hi bogd_A,

    Unfortunatelly your router is 500gP V2, and our is 1.1 (pcb 1.14)

    And hi newbiefan,

    sorry, but our router doesn't respond for tftp, ping , nothing . .

    Thank you anyway... and i wait, maybe Oleg will help us.


  9. #24
    Join Date
    Feb 2007
    Moscow, Russia
    actually, you have the two possibilities: either you already killed CFE (in other words bootloader located in separate partition of the flash), or not yet.

    In the first case --- for 500gPv1 there is no other way, but searching for somebody who is able to desolder flash chip, put the CFE in it by external programmer, and soldering it back again. May be if you have somewhere around asus service center this could be not the worst idea.

    If it is not yet the case you have to get response from your router somehow.

    I think you are close to the chance #1 (especially in the first case), however, I can't say for sure.

  10. #25

    Unbricking WL500gpv2


    I bricked my wl500gpv2 messing with nvram (didn't know if I could increase ram, so I tried it). All 5 ethernet lights go solid (with nothing plugged into them) but the air and power lights are all off.

    So researching the pin 9/10/12 trick I noticed the chip was a mx29lv320ab for the deluxe version, and a very similar chip for the wl500gpv2. They all had the same pinout. Knowing that my device was already bricked I went for grounding the reset and address pins on power up.

    I was actually successful when grounding pin 9 on power up, getting it into restore mode with the power led flashing, pingable, and tftp uploads clearly occuring. However, after trying the clear and restore nvram images, as well as 2 different dd-wrt images that worked previously, the unit always goes back into "brick mode" after a power cycle.

    I've tried the following images to no avail
    I even waited a full 5 minutes after each flash ( wait?)

    Any ideas? I feel so close!


  11. #26
    Join Date
    Feb 2007
    Moscow, Russia
    good idea would be to connect the system console. If CFE is still alive, you can change some nvram values from its command prompt, and overall see about what it complains. If it is already dead... Hm... in this case you are anyway in advantageous state relative to the users of v1. You can put new CFE using JTAG without desoldering of the flash chip.

  12. #27

    Lightbulb How to JTAG and another trick

    Thanks for the idea...I was considering that but haven't figured out the right hardware and connections to either serial or JTAG the hardware.
    All I can find is that it does have a serial connection and (?) a JTAG in the compatibility spreadsheet for openwrt or dd-wrt.

    But while I was looking for how to JTAG/serial I found someone with the identical problem who said
    the "pin-9-pin-16-trick combined with a vcc-to-ground-hack" did the trick for him.

    So I'm going to try that first. But if you can point me to a howto on serial or JTAG connection I'd still like to try that.

    Name:  Jtag.jpg
Views: 2959
Size:  39.0 KB

    Last edited by Omega; 11-06-2013 at 00:30. Reason: fixed

  13. #28
    Join Date
    Feb 2007
    Moscow, Russia

    Thumbs up Serial & JTAG

    vcc-to-ground-hack? I guess it may result in failure of PSU...

    I suggest serial first: You have 4-pin linear connector on the boards corner.
    That's serial.

    (WL-500gP V1):
    GND 	 	3.3V_OUT
    Pin 1 (with the square solder pad) is RX0.

    For (WL-500gP V2) tts/0 is on the J4 connector:
    The header probably is not soldered, so you have to do it. +3.3V and GND are at the ends of the connector.
    You can identify them either visually or by multimeter. RX and TX are the two middle pins.
    If you have an oscilloscope, you identify it so --- on TX pin during power up there should be some activity --- console output.
    If none you can skip to JTAG directly ,because console and pin 9 already not helpful. If you don't have scope then trial and error is ok.

    Next you have to make level convertor. Router's rs232 uses 3.3/0V logics while PC uses +12/-12V. It's 1 chip and 5 capacitors.
    Look in the datasheet of max3232 at for connection. On my experience max232 also works fine despite it's 5V chip.

    Finally, you connect router through converter to rs232 of PC, set 115200 as speed and if it is alive you should get console output
    which may help to diagnose what is wrong.

    Pinout of JTAG I've seen somewhere on the openwrt site.

    There should be probably description of JTAG-LPT connector and what is needed to do, but I don't have experience with this.
    Last edited by Omega; 11-06-2013 at 00:17. Reason: fixed

  14. #29

    serial info and vcc scaryness

    I agree, vcc to ground sounds like an excellent way to overload PS, not something I want to do. I can only assume it power cycles the chip, which we have a reset for anyway.

    No oscope anymore, but I'm sure I can figure out the TX/RX. Thanks for all the good info. Hope to try as soon as I order the max3232!


  15. #30
    Join Date
    Jun 2006

    Question Need wl-500GP v1 JTAG pinout

    Hi everyone,

    I need jtag pinout for wl-500gp v1,
    The CFE is corrupt or deleted, and the RS232 console does not show anything when connected, and I do not have acces to a Flash programer or AVR.

    Thanks in advance,


Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. Serial, JTAG, CFE, nvram ... и кнопка Reset
    By Alien_V in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 251
    Last Post: 15-03-2016, 08:37
  2. JTAG WL-500W????
    By dreKion in forum WL-500w Pics & Specs
    Replies: 6
    Last Post: 28-09-2009, 00:07
  3. jtag connection
    By reubenhwk in forum WL-700g Pics & Specs
    Replies: 2
    Last Post: 21-03-2007, 02:08

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts