Page 3 of 3 FirstFirst 123
Results 31 to 42 of 42

Thread: How do I solder a JTAG connector to Asus WL-500

  1. #31
    Join Date
    Nov 2006
    Russia, Moscow


    Unfortunately, JTAG on 500gP V1 didn't routed on board.
    You have to desolder flash chip or try to find CPU pinout.

    Name:  jtag-wl500w.jpg
Views: 6995
Size:  16.0 KB
    Last edited by Omega; 14-09-2014 at 12:08. Reason: fixed

  2. #32
    Join Date
    Jun 2006

    Red face wl-500gp jtag

    Quote Originally Posted by lly View Post
    Unfortunately, JTAG on 500gP V1 didn't routed on board. You have to desolder flash chip or try to find CPU pinout.
    I guess there is only one solution for my little friend ..... to put him in the trash can

  3. #33

    JTAG next??

    I've tried console, and if I just start it up, there is no output at all to console. If I do the pin 9 trick (ground pin 9 on flash on powerup) it goes into tftp upload mode and the console shows this repeatedly...

    > Reading :: TFTP Server.
    > Failed.: Timeout occured

    Then if I send a flash image it shows the following...

    Reading :: TFTP Server.
    Done. 3088384 bytes read
    Download of 0x2f2000 bytes completed
    Write kernel and filesystem binary to FLASH (0xbfc20000)
    copysize=3088384, amtcopy=3088384
    done. 3088384 bytes written

    I've tried tftp'ing the nvram clear, the nvram recover, and finally an image (dd-wrt.v24_mini_generic.bin) separately in a row and all with the pin 9 trick, but after the final power cycle, the box still comes up with no console output, and all lights on solid.

    The reset button won't put it into re-flash mode still either. And I made sure to wait 10 minutes between each load although the "Programming" appears to be done within 20-30 seconds.

    I think it may be time for JTAG. Can someone point me to some JTAG docs, or give me a brief howto for the box?


  4. #34

    WL-500g Premium V1 turned into a vegetable

    I recently acquired a WL-500gP. Yesterday I finally got the time to update the default firmware. The Asus Tool didn't work for me, so I used the TFTP method described here:
    The basic idea of this method is to clear the NVRAM with dummy-firmwares(?) and then install a mini-DD-WRT and then use that to update to other 3rd party firmwares.

    So I tried to update to Oleg's firmware with DD-WRT. I think it was a success (however at that time I thought the original Asus firmware had mysteriously returned and only later I found out that web guis looks exactly the same).

    Then I installed DD-WRT again and then updated to basic Tomato through DD-WRT updater. This almost bricked the router. 30/30/30-reset didn't help, recovery mode didn't work, but then I found a thread where someone described that he managed to unbrick his asus by pressing the EZSetup while powering the router. This solved the problem (don't ask how) and now I had a working Tomato.

    Next I wanted to have Tomato with USB, so I updated to Teddy Bear's mod through the Tomato updater. Well this made the router almost completely unresponsive, and I still haven't found a way to fix it.

    Current situation:
    • some kind of a Tomato should be inside
    • the 30/30/30-reset doesn't work
    • the router does not respond to ping, thus no telnet/web access or any other way to control it. Ping responds "no route to host".
    • However after pressing the EZSetup when powering on, ping almost "works". It still doesn't create any replies, however the router is there because ping doesn't say "no route to host" like above. Also Wireshark sees the Asus sends "gratuoius ARP" packets...
    • I cannot get the router to recovery mode by the usual method of "1. power off, 2. press the reset while plugging power back on". The power LED does not blink slowly like it used to when it was in recovery mode. (Well actually there is one way it goes into recovery mode, and that's when I power the router while pressing the reset button AND when there are no ethernet cables plugged in... but this is quite useless as I can't send any firmwares without ethernet cables. And as soon as I attach an ethernet cable the led stops blinking -> router exits recovery mode.... )

    What could be wrong? I'm seriously losing my nerves!

    I'm already preparing to short pin 9. I've opened the box and the tedious tin box covering pin 9... But I would not want to do this. I hope there's another solution.

    Oh boy... flashing a firmware to WL-500gP is a real pain in the ass... So far I've used Buffalos and had almost no problems flashing them...

  5. #35
    Join Date
    Nov 2004
    have you thought about using the jtag to see what's going on?

  6. #36
    Quote Originally Posted by Tamadite View Post
    have you thought about using the jtag to see what's going on?
    Hi, I have understood that there's no JTAG option with wl-500gP V1.

  7. #37

    Question how to easy unbrick WL-500gpv1 - pwr blink ??

    I have a wl-500gp v1 and i had a special dd-wrt_mini-usb with some 3G modem support.
    I tried to put back oleg's d-1222.trx version for gpv1 through restoration mode (power led blinking)
    But after the d-1222 version flashed i waited about 2-3 minutes and it was no reset - just power blinking.
    I've power cycled the router - but the power keeps blinking.
    i still have ping and tftp access to .1.1 but no web - just power blinking and lan.
    I've tried uploading the recover-trx and clear-nvram-trx but no result.
    I've also read about the pin 9 trick but I don't have a screwdriver here - I have to wait till the evening to reach home and get one.
    Do any of you have an idea how to unbrick ?

  8. #38
    Join Date
    Apr 2008
    try tftp
    if fail to upload the firmware
    try jtag
    some information on how to recover the router by jtag
    on ddwrt forum

  9. #39
    Join Date
    Sep 2007
    czech republic
    pin 9 trick put router to the restoration mode (power led blinking) nothing more. It can be used if clasic restore button (during power on) not working.
    RT-N13u dd-wrt | Toshiba 2.5" 160GB | pxe boot server

  10. #40
    Join Date
    Aug 2010

    WL500gP JTAG

    Hi All,
    I have a question to Hggomes: You have JTAG on Asus WL-500GP(WL-500g Premium)??
    Pls post some foto or description about it.I am looking for it on many forums,but without result.(Generally WL-500GP have no JTAG routed on board ... by Ily on

    Quote Originally Posted by hggomes View Post
    In that case, good holes But it was not a critic, my WL500GP was worst than yours (wires,memory mod,jtag,serial,4xusb mod) ...
    Thank You very much and sorry for my English.

  11. #41
    Hi, sorry my mistake. My old WL-500GP v2 had a JTAG not V1, it had a serial port.

  12. #42
    Join Date
    Jun 2011

    No solution is yet given!

    Dear friends,
    This post concerns a practical and step by step tutorial to either flash the hardware by programming the chipset externally or through JTAG like interfaces. Please do not deviate from subject and comment if you only know how to do so. Thank you for your understanding.
    Behnam Rahnama

Page 3 of 3 FirstFirst 123

Similar Threads

  1. Serial, JTAG, CFE, nvram ... и кнопка Reset
    By Alien_V in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 251
    Last Post: 15-03-2016, 09:37
  2. JTAG WL-500W????
    By dreKion in forum WL-500w Pics & Specs
    Replies: 6
    Last Post: 28-09-2009, 01:07
  3. jtag connection
    By reubenhwk in forum WL-700g Pics & Specs
    Replies: 2
    Last Post: 21-03-2007, 03:08

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts