Results 1 to 4 of 4

Thread: Samba won't handle too much files

  1. #1

    Samba won't handle too much files

    Hi,
    I have got the latest (1.9.2.7-7c) Oleg's firmware on WL500gX router and 300GB Maxtor external USB HDD.
    I configured my Samba so I have one FAT32 300GB share (I need to be able exchanging files with both wl500gx and Win machines and without installing an EXT driver). Everything has worked fine until I copied my entire 9300+ mp3 files archive on the HDD. Now everytime I try to browse to it (using TotalCommander, but tried also Windows Explorer) everything locks up. When I run Putty and "top" I see usb-storage-0 and smbd together taking up about 60% of CPU
    97 admin RW 0 1 43.3 0.0 usb-storage-0
    170 admin DW 0 121 19.2 0.0 smbd
    and although it indicates they're using 0% of memory, the memory is almost completely full.
    Mem: 28720K used, 1420K free, 0K shrd, 18780K buff, 1792K cached
    From now, I amnot able to browse the shared folders at all. (And I tried even waiting for few hours) Now I have to reboot the router, which is not good because I have an IRC bot running there (but it is certainly not caused by it)

    Please, how can I avoid this? Having my MP3 archive there is essential for me.

    I've had this exact configuration working one time, byt there were some files with a czech language characteristic symbols and so they were unusable. Now I renamed them to english symbol set and copied them back. That is the only change I have made.
    Last edited by kopec; 08-05-2006 at 16:13.

  2. #2
    I've tried to "ipkg install samba" and use that one (newer version v3 - in the firmware there is v2) but i am not able to run it, it says "Bad system call" when starting the smbd daemon. Please could anybody help me????
    Last edited by kopec; 09-05-2006 at 18:35.

  3. #3
    Join Date
    Jun 2005
    Location
    Slovenia
    Posts
    736
    You should format partition into ext3 system and shorten the USB cable to about 40cm. And maybe some capacitor 200uF near the HD supply. I have WD 3200 320GB disk running for at least a year w/o problems.

  4. #4
    Well, I NEED fat32 filesystem, and my USB is short enough. the problem, which I have now fixed, was that on some error during writing a nonsense named subfolders appeared. The folders that made samba crash, my widows machine it was OK, but couldn't delete them. So I made linux to delete it and for now it is ok, although slow (3 and more secondes accesing this folder), but ok.

    And why is it not possible to install (&use) Samba-3??? Some collision with the firmware-included Samba?

Similar Threads

  1. Samba: Grosse Files können nicht kopiert werden
    By Trebron in forum German Discussion - Deutsch (DE)
    Replies: 2
    Last Post: 07-06-2006, 11:14
  2. Quick how-to: Running Samba and a webserver from a USB stick
    By SuperB in forum WL-500g/WL-500gx Tutorials
    Replies: 0
    Last Post: 17-04-2006, 14:32
  3. Traffic shaping script
    By smeto in forum WL-500g Q&A
    Replies: 0
    Last Post: 17-12-2005, 23:46
  4. Big files using samba with 1.9.2.7-6a
    By Ulyss62 in forum WL-500g Custom Development
    Replies: 6
    Last Post: 25-09-2005, 19:20
  5. Samba, files >50 mb
    By double j in forum Dutch Discussion - Nederlands
    Replies: 4
    Last Post: 26-07-2005, 20:42

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •