Page 84 of 84 FirstFirst ... 3474828384
Results 1,246 to 1,257 of 1257

Thread: Домовые сети, DHCP + PPPoE/PPTP/L2TP

  1. #1246
    Quote Originally Posted by tempik View Post
    при маске 255.255.255.255 в сети может быть только один адрес ... ИМХО Бред
    я не с потолка маску брал...
    Last edited by Omega; 15-12-2011 at 19:43. Reason: попробуйте забить mac-адрес компа в роутер ... ;)

  2. #1247
    Quote Originally Posted by gorvic View Post
    я не с потолка маску брал...
    Да верю я ... вывод
    Code:
    ipconfig /all
    из работающей винды приведите (только без правок и можно в ЛС чтоб адреса не светить)

  3. #1248
    Quote Originally Posted by omega
    Причина: попробуйте забить mac-адрес компа в роутер ...

    привязки к мак адресу нет, пробовал вбить мак адрес, провайдер указывает что возможно роутер не умеет работать с данной маской, якобы у них на тесте уже несколько так не работают))) однако сегодня видел wl520gu точно также маска 255.255.255.255 и сволочь инет раздает)))
    Last edited by Omega; 15-12-2011 at 19:56. Reason: логи подключения с роутера в студию ... :)

  4. #1249
    Quote Originally Posted by gorvic View Post
    привязки к мак адресу нет, пробовал вбить мак адрес, провайдер указывает что возможно роутер не умеет работать с данной маской, якобы у них на тесте уже несколько так не работают))) однако сегодня видел wl520gu точно также маска 255.255.255.255 и сволочь инет раздает)))
    при маске 255.255.255.255 адрес в сети один и даже шлюза быть не может ... Конечно я могу ошибаться ...
    Last edited by Omega; 15-12-2011 at 22:05. Reason: можно ещё попробовать забить ip-адрес статикой ... ;)

  5. #1250
    Quote Originally Posted by Omega
    Причина: можно ещё попробовать забить ip-адрес статикой ...
    забивал вручную, но опять же вопрос как тогда маску вбивать)))

    Логи позже чуть прикреплю...

    логи сразу после сброса - режим автомат

    PHP Code:
    Jan  1 00:00:04 syslogd startedBusyBox v1.19.2
    Jan  1 00
    :00:04 kernelklogd startedBusyBox v1.19.2 (2011-10-22 20:06:56 MSK)
    Jan  1 00:00:04 kernelLinux version 2.6.22.19 (root@localhost) (gcc version 4.4.6 (GCC) ) #2 Sat Oct 22 20:28:56 MSK 2011
    Jan  1 00:00:04 kernelCPU revision is: 00029006
    Jan  1 00:00:04 kernelSetting the PFC to its default value
    Jan  1 00
    :00:04 kernelDetermined physical RAM map:
    Jan  1 00:00:04 kernel:  memory02000000 00000000 (usable)
    Jan  1 00:00:05 dnsmasq[206]: startedversion 2.59 cachesize 512
    Jan  1 00
    :00:05 dnsmasq[206]: compile time optionsIPv6 GNU-getopt no-RTC no-DBus no-i18n DHCP no-scripts no-TFTP no-conntrack no-IDN
    Jan  1 00
    :00:05 dnsmasq-dhcp[206]: DHCPIP range 192.168.1.101 -- 192.168.1.254lease time 1d
    Jan  1 00
    :00:05 dnsmasq[206]: read /etc/hosts 2 addresses
    Jan  1 00
    :00:05 miniupnpd[207]: version 1.6 started
    Jan  1 00
    :00:05 miniupnpd[207]: HTTP listening on port 46667
    Jan  1 00
    :00:05 miniupnpd[207]: Listening for NAT-PMP traffic on port 5351
    Jan  1 00
    :00:05 kernelusbcoreregistered new interface driver usbfs
    Jan  1 00
    :00:05 kernelusbcoreregistered new interface driver hub
    Jan  1 00
    :00:06 kernelusbcoreregistered new device driver usb
    Jan  1 00
    :00:06 kernelehci_hcdUSB 2.0 'Enhanced' Host Controller (EHCIDriver
    Jan  1 00
    :00:06 kernelPCIEnabling device 0000:01:03.2 (0000 -> 0002)
    Jan  1 00:00:06 kernelehci_hcd 0000:01:03.2EHCI Host Controller
    Jan  1 00
    :00:06 kernelehci_hcd 0000:01:03.2: new USB bus registeredassigned bus number 1
    Jan  1 00
    :00:06 kernelehci_hcd 0000:01:03.2irq 12io mem 0x40004000
    Jan  1 00
    :00:06 kernelehci_hcd 0000:01:03.2USB 2.0 startedEHCI 1.00
    Jan  1 00
    :00:06 kernelusb usb1configuration #1 chosen from 1 choice
    Jan  1 00:00:06 kernelhub 1-0:1.0USB hub found
    Jan  1 00
    :00:06 kernelhub 1-0:1.04 ports detected
    Jan  1 00
    :00:06 kerneluhci_hcdUSB Universal Host Controller Interface driver
    Jan  1 00
    :00:06 kernelPCIEnabling device 0000:01:03.0 (0000 -> 0001)
    Jan  1 00:00:06 kerneluhci_hcd 0000:01:03.0UHCI Host Controller
    Jan  1 00
    :00:06 kerneluhci_hcd 0000:01:03.0: new USB bus registeredassigned bus number 2
    Jan  1 00
    :00:06 kerneluhci_hcd 0000:01:03.0irq 12io base 0x00000100
    Jan  1 00
    :00:06 kernelusb usb2configuration #1 chosen from 1 choice
    Jan  1 00:00:06 kernelhub 2-0:1.0USB hub found
    Jan  1 00
    :00:06 kernelhub 2-0:1.02 ports detected
    Jan  1 00
    :00:06 kernelPCIEnabling device 0000:01:03.1 (0000 -> 0001)
    Jan  1 00:00:06 kerneluhci_hcd 0000:01:03.1UHCI Host Controller
    Jan  1 00
    :00:06 kerneluhci_hcd 0000:01:03.1: new USB bus registeredassigned bus number 3
    Jan  1 00
    :00:06 kerneluhci_hcd 0000:01:03.1irq 12io base 0x00000120
    Jan  1 00
    :00:06 kernelusb usb3configuration #1 chosen from 1 choice
    Jan  1 00:00:06 kernelhub 3-0:1.0USB hub found
    Jan  1 00
    :00:06 kernelhub 3-0:1.02 ports detected
    Jan  1 00
    :00:06 kernelusbcoreregistered new interface driver usblp
    Jan  1 00
    :00:07 kernelSCSI subsystem initialized
    Jan  1 00
    :00:07 kernelInitializing USB Mass Storage driver...
    Jan  1 00:00:07 kernelusbcoreregistered new interface driver usb-storage
    Jan  1 00
    :00:07 kernelUSB Mass Storage support registered.
    Jan  1 00:00:07 kernelNTFS driver 2.1.28 [FlagsR/O MODULE].
    Jan  1 00:00:08 dnsmasq[206]: read /etc/hosts 2 addresses
    Jan  1 00
    :00:08 dhcp clientdeconfiglease is lost
    Jan  1 00
    :00:08 dnsmasq[206]: read /etc/hosts 2 addresses
    Jan  1 00
    :00:08 dnsmasq[206]: using nameserver 91.211.63.254#53
    Jan  1 00:00:08 dnsmasq[206]: using nameserver 91.211.60.211#53
    Jan  1 00:00:09 miniupnpd[207]: received signal 15good-bye
    Jan  1 00
    :00:09 miniupnpd[295]: version 1.6 started
    Jan  1 00
    :00:09 miniupnpd[295]: HTTP listening on port 51647
    Jan  1 00
    :00:09 miniupnpd[295]: Listening for NAT-PMP traffic on port 5351
    Jan  1 00
    :00:09 kernelvlan1dev_set_allmulti(master1)
    Jan  1 00:00:09 kernelemf:Invalid interface identifier
    Jan  1 00
    :00:09 dhcp clientbound IP 176.XX.0.XX from 176.XX.0.1
    Jan  1 00
    :00:10 kerneleth1received packet with own address as source address
    Jan  1 00
    :00:43 kerneleth1received packet with own address as source address 
    Last edited by Omega; 21-02-2012 at 16:14. Reason: fixed

  6. #1251
    Join Date
    Mar 2009
    Location
    Default City
    Posts
    2,695
    Blog Entries
    4
    Quote Originally Posted by tempik View Post
    при маске 255.255.255.255 адрес в сети один и даже шлюза быть не может ... Конечно я могу ошибаться ...
    Code:
    ppp0      Link encap:Point-to-Point Protocol  
              inet addr:95.24.61.47  P-t-P:85.21.0.250  Mask:255.255.255.255
    для тунеля такое вполне возможно )
    для IPv4-сетей маска /32 (255.255.255.255) позволяет указать единичный узел сети...
    Last edited by TReX; 16-12-2011 at 10:48.

  7. #1252

    Домашний интернет "Киевстар" и RT-N16

    С недавних пор я подключился к провайдеру Киевстар. Использую RT-N16 и прошивку RT-N16-1.9.2.7-rtn-r3497. Провайдер на WAN интерфейс по DHCP отдают белый айпи. Но периодически по интерфейсу перестают передаваться пакеты. Может несколько раз в день, может раз в месяц. Если бутнуть роутер из шелла командой reboot, сетевуха адрес не получает. Вернее получает zeroconf вида 169.254.х.х.
    Продолжается это до тех пор, пока маршрутизатор провайдера не увидит что клиент отключился
    (для этого нужно либо выключить мой роутер, либо не выключая его отключить кабель локальной сети от гнезда WAN. После таких манипуляций все работает как положено.

    Можно ли программно полностью отключить nic, чтобы погасла лампочка коннекта на сетевой? Поставить в крон и выкл\вкл когда нет интернета...

    Может есть другие варианты решения проблемы?

  8. #1253
    Quote Originally Posted by rualex View Post
    С недавних пор я подключился к провайдеру Киевстар. Использую RT-N16 и прошивку RT-N16-1.9.2.7-rtn-r3497. Провайдер на WAN интерфейс по DHCP отдают белый айпи. Но периодически по интерфейсу перестают передаваться пакеты. Может несколько раз в день, может раз в месяц. Если бутнуть роутер из шелла командой reboot, сетевуха адрес не получает. Вернее получает zeroconf вида 169.254.х.х.
    Продолжается это до тех пор, пока маршрутизатор провайдера не увидит что клиент отключился
    (для этого нужно либо выключить мой роутер, либо не выключая его отключить кабель локальной сети от гнезда WAN. После таких манипуляций все работает как положено.

    Можно ли программно полностью отключить nic, чтобы погасла лампочка коннекта на сетевой? Поставить в крон и выкл\вкл когда нет интернета...

    Может есть другие варианты решения проблемы?
    Возникла точно такая же проблема на подмосковном провайдере Комсайт. Ситуация 1 в 1. Как вы ее решили?

    РЕШЕНО!
    Last edited by Helby; 29-01-2012 at 12:43. Reason: UPD: Решено. Прописывание белого IP, маски и шлюза руками решает проблему.

  9. #1254

    WL-500gp V2 VPN подключение

    Доброго времени суток, форумчане.
    возникла проблема с подключением к заводской сети через VPN соединение. постараюсь описать полную картину того, что происходит.
    есть подключение к интернету через заводскую сеть, через VPN соединение (работает с ноута, подключение miniport WAN (pptp) со следующими настройками:

    http://dump.ru/file/5611732
    http://dump.ru/file/5611738
    http://dump.ru/file/5611743
    http://dump.ru/file/5611835
    http://dump.ru/file/5611838

    так-же под заводскую сеть, на ноутбуке настраивается протокол tcp/ip подключения по локальной сети со следующими настройками:

    http://dump.ru/file/5611840
    http://dump.ru/file/5611844

    интернет исправно работает. далее, мне необходимо настроить wl-500gp v2 для раздачи интернета как по проводам, так и без. проблемы начались с нехотением роутера воспринимать данный заводскими специалистами IP адрес 172.20.4.51 и маску подсети 255.255.255.0, решилось перепрошивкой на ром от Олега версии WL500gpv2-1.9.2.7-10. Настройки WAN&LAN:

    http://dump.ru/file/5611849

    но интернета нет, роутер в логах пишет следующее:

    ...
    Jan 1 03:00:07 kernel: USB Mass Storage support registered.
    Jan 1 03:00:07 kernel: vlan1: Setting MAC address to 00 22 15 61 95 5a.
    Jan 1 03:00:07 kernel: VLAN (vlan1): Underlying device (eth0) has same MAC, not checking promiscious mode.
    Jan 1 03:00:09 pppd[101]: pppd 2.4.2 started by admin, uid 0
    Jan 1 03:00:09 pppd[101]: Serial connection established.
    Jan 1 03:00:09 pppd[101]: Using interface ppp0
    Jan 1 03:00:09 pppd[101]: Connect: ppp0 <--> /dev/pts/0
    Jan 1 03:00:09 pptp[109]: route_add: no route to host
    Jan 1 03:00:09 pptp[109]: connect: Network is unreachable
    Jan 1 03:00:09 pptp[109]: Cannot bind GRE socket, aborting.
    Jan 1 03:00:09 pppd[101]: Modem hangup
    Jan 1 03:00:09 pppd[101]: Connection terminated.
    Jan 1 03:00:40 pptp[124]: route_add: no route to host
    Jan 1 03:00:40 pptp[124]: connect: Network is unreachable
    Jan 1 03:00:40 pptp[124]: Cannot bind GRE socket, aborting.
    Jan 1 03:00:40 pppd[101]: Serial connection established.
    Jan 1 03:00:40 pppd[101]: Failed to set PPP kernel option flags: Inappropriate ioctl for device
    Jan 1 03:00:40 pppd[101]: Using interface ppp0
    Jan 1 03:00:40 pppd[101]: Connect: ppp0 <--> /dev/pts/0
    Jan 1 03:00:40 pppd[101]: Modem hangup
    Jan 1 03:00:40 pppd[101]: Connection terminated.

    и последнее, что считаю необходимым сказать, после установленного подключения ноут имеет статический внешний IP адрес (на картинке http://dump.ru/file/5611844, закрыл звездочками, попросили не раскидываться им) обственно вопрос, что нужно нажать, что б все заработало? за помощь, в своем геофизическом пространстве поставлю пиво

    upd. на все вопросы постараюсь максимально быстро и оперативно ответить.
    Last edited by vectorm; 20-02-2012 at 11:58. Reason: При такой WAN маске работать не будет. Должно быть например 255.255.0.0

  10. #1255

    Post

    по скриншотам,
    address: 172.20.4.251
    netmask: 255.255.255.0
    gateway: 172.20.240.1

    это значит, что роутер в сети 172.20.4.0/24, где возможны адреса 172.20.4.1 - 172.20.4.254, 0 и 255 зарезервированы.
    адрес шлюза находится вне этой подсети, поэтому и ругается и не работает, что абсолютно верно.
    варианты:
    1. настучать по голове админам кто так криво настроил, ориентируясь только на то, что под windows это почему то работает
    2. запросить у них же верный шлюз для подсети
    3. использовать бОльшую маску, например 255.255.0.0, чтобы шлюз оказался внутри подсети (но тогда могут оказаться недоступны другие внутрисетевые ресурсы, т.к шлюз будет использоваться только для доступа ко всему вне 172.20.*.*)
    4. прописать MAN маршрут к 172.20.240.1 маска 255.255.255.255

    для DHCP/Static костыль для шлюза вне подсети есть, для VPN - нет и не думаю, что вообще необходим.
    Last edited by theMIROn; 20-02-2012 at 13:16.

  11. #1256
    Quote Originally Posted by theMIROn View Post
    по скриншотам,
    ...
    варианты:
    1. настучать по голове админам кто так криво настроил, ориентируясь только на то, что под windows это почему то работает
    2. запросить у них же верный шлюз для подсети
    3. использовать бОльшую маску, например 255.255.0.0, чтобы шлюз оказался внутри подсети (но тогда могут оказаться недоступны другие внутрисетевые ресурсы, т.к шлюз будет использоваться только для доступа ко всему вне 172.20.*.*)
    4. прописать MAN маршрут к 172.20.240.1 маска 255.255.255.255
    1. боюсь вызову международный скандал командирован в Иран, хотя попробовать можно
    2. реализуемо, но сложно фарси не мой родной язык, + на вызов специалиста из местного IT отдела надо писать заявку и ждать какое-то время (уже вызвал) если ничего не поможет, пойду к ним. пока попробуем следующие пункты.
    3. поставил в соединении на нуте маску 255.255.0.0 инет заработал, далее, переставил на роутере, инета - нет, в логах пишет:

    Jan 1 03:03:34 pppd[101]: Using interface ppp0
    Jan 1 03:03:34 pppd[101]: Connect: ppp0 <--> /dev/pts/0
    Jan 1 03:03:38 pppd[101]: CHAP authentication failed: bad username or password
    Jan 1 03:03:38 pppd[101]: Connection terminated

    аккуратнно, внимательно и точно ввел заново верные логин и пароль, снова не помогло.
    4. где этот маршрут прописывать? (я, по большей части дилетант в делах подобного плана, тыкните пальцем куда циферки забить надо)
    Last edited by Pitkini; 20-02-2012 at 13:35.

  12. #1257
    Quote Originally Posted by Pitkini View Post
    3. поставил в соединении на нуте маску 255.255.0.0 инет заработал, далее, переставил на роутере, инета - нет, в логах пишет:

    Jan 1 03:03:34 pppd[101]: Using interface ppp0
    Jan 1 03:03:34 pppd[101]: Connect: ppp0 <--> /dev/pts/0
    Jan 1 03:03:38 pppd[101]: CHAP authentication failed: bad username or password
    Jan 1 03:03:38 pppd[101]: Connection terminated
    или неправильный логин пароль, или это не уникальное соединение, или сервер считает, что предыдущее соединение еще живое, или там есть какой-то таймаут на повторное соединение.

    Quote Originally Posted by Pitkini View Post
    4. где этот маршрут прописывать? (я, по большей части дилетант в делах подобного плана, тыкните пальцем куда циферки забить надо)
    http://192.168.1.1/Advanced_GWStaticRoute_Content.asp
    Enable static routes? Yes

    Quote Originally Posted by Pitkini View Post
    4. где этот маршрут прописывать? (я, по большей части дилетант в делах подобного плана, тыкните пальцем куда циферки забить надо)
    или завтра взять 1.9.2.7-rtn-3816 (или новее) тут => http://asus.vectormm.net/rtn/

    Quote Originally Posted by tempik View Post
    Quote Originally Posted by gorvic
    Сообщение от gorvic
    ip adress: 176.XX.0.XX
    маска: 255.255.255.255
    шлюз: 176.xx.0.1
    при маске 255.255.255.255 в сети может быть только один адрес ... ИМХО Бред
    и это тоже поддерживается
    Last edited by Omega; 20-02-2012 at 20:29. Reason: fixed

Page 84 of 84 FirstFirst ... 3474828384

Similar Threads

  1. Проблемы с l2tp и pptp в Корбилайне
    By Lore in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 332
    Last Post: 18-02-2016, 07:35
  2. Asus WL-500W - проблемы с VPN (PPTP, L2TP)
    By Roland777 in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 40
    Last Post: 23-09-2014, 20:41
  3. 2 PPPoE подключения на роутере
    By gr0k in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 251
    Last Post: 20-03-2014, 08:29
  4. Кто-нибудь настраивал PPtP поверх PPPoE?
    By LSD in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 59
    Last Post: 17-03-2013, 18:13
  5. PPPoE authentication question
    By outlaw11 in forum WL-500gP Q&A
    Replies: 1
    Last Post: 13-12-2012, 19:30

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •