Page 4 of 6 FirstFirst ... 23456 LastLast
Results 46 to 60 of 79

Thread: wl 500g and ipv6

  1. #46
    Quote Originally Posted by Oleg
    well, it works fine for me. btw, I've put new toolchain here: (2 MB)
    extract it and change the symbolic link in the /opt/brcm, try to cleanup your code then.
    indeed, it works. now even ping6 is working.
    i did some cleaning up in my code and removed all the stuff regarding my ipv6-library, since uClibC now handles it.

    the file i attached is the result of my work.
    Attached Files Attached Files
    Last edited by phedny; 12-02-2005 at 19:39.

  2. #47
    Join Date
    Dec 2003
    Russian Federation
    Please check your PM...

  3. #48

    Dynamic IPv6 Tunnel

    Is there any update Client for my WL500g to update my freenet6 tunnelendpoint?
    Or for any other Tunnelbroker?
    Last edited by alpha5; 25-07-2005 at 16:07.

  4. #49

  5. #50
    Join Date
    Dec 2004
    The Netherlands

    IPV6 completion wishlist?


    How hard is it to get 'traceroute6' and 'ip6tables' into the firmware? No need for fancy webby and nvram things, good old post-boot and a config file on the nvram fs suffice.

    These two things would make ipv6 just a little more usable.

  6. #51
    Join Date
    Dec 2003
    Russian Federation
    traceroute6 is not available in the busybox, ip6tables requires kernel support - bunch of space.
    Have you considered using openwrt?

  7. #52
    Join Date
    Dec 2004
    The Netherlands
    Considered yes, tried no. I'm a bit reluctant because of the install procedure and all the manual configuration. The advantage of openwrt ofcourse is that you only install what you need.

    Anyway, if that is my best bet, I'll give it a try. I consider myself an experienced user so I should be able to figure things out.

  8. #53

    Dynamic IPv6 Tunnel?

    Is here anyone who uses his wl500g with a dynamic ipv4 adress and a ipv6 tunnel? for exabmle freenet6?

  9. #54

    Dual stack?

    Can the wl500gx with the latest firmware operate as an IPv4/IPv6 dual stack machine? Thanks in advance.

  10. #55

    IPV6 with not working

    Hey I am running the latest version of Oleg his firmware, but somehow can't get IPV6 to run. Any tips on how to troubleshoot this?

    I did all the steps in the following guide:


  11. #56
    Join Date
    Feb 2006
    Maryland, U.S.A.

    Disable IPv6?

    I am using Olegs (I think.) on a wl500gx

    Is there a way to disable IPv6? I notice running ifconfig that there are IPv6 entries, even though I do not have IPv6 configured or enabled via the Webpage configuration. I see in the syslog that a daemon for IPv6 v0.8 for NET4.0 is loaded. I will like to disable it from starting. I like to keep things trim.
    So my main question is where is the config file to disble/not start?
    I beleive it is Inet or something like that, I am a half noob half itermiddiate user.
    Anyone thing there will be any disadvantages to disabling?


  12. #57

    Question DHCPv6

    Has anyone cross-compiled dhcpv6 for the wl500gx? An ipkg package would be wonderful, but google tells me that there is none.

    I am trying to use a wl500gx with Oleg's firmware to connect natively to IPv6 on Wanadoo here in France, and dncpv6 is required.

    Thanks in advance.

  13. #58

    IPv6 Neighbor Discovery Problem

    My conclusion is that a wl500gx running Oleg's firmware does not handle an ICMPv6 Neighbor Solicitation correctly. Another, peripheral conclusion is that my Fedora Core 4 box does not handle neighbor discovery 100% correctly. Let me explain.

    My setup is as follows:

    ADSL2+ Modem
    wl500gx as router
    Wired Ethernet LAN
    / | \
    PC running wl500gP as a PC running
    Windows XP wireless access Linux
    point Fedora C4

    A laptop with Two wl500gxs
    Windows XP as wireless access
    connected point clients
    wirelessly to
    the wl500gP

    All the wl500gs are running Olegs latest firmware.

    Remark: The wl500gP works correctly as a wireless bridge, and the wl500gx router appears ok, too.

    Remark: In the following experiments the order in which tests are conducted is important: tests cause state changes.

    Experiment 1: The Windows PC ping6s the Windows laptop. Everything works according to the text book. In particular, one can see all the ICMPv6 packets going back and forth. The first and most important one is the neighbor solicitation packet going from the PC to the laptop.

    Experiment 2: ping6ing in the reverse direction works perfectly, too.

    Remark: All these ICMPv6 packets had to go through wl500gx router and the wl500gP wireless bridge.

    Experiment 3: The Windows PC tries to ping6 one of the wl500gx wireless access point clients. Since the address of this access point client is not in the PCs neighbor cache, the PC sends out a neighbor solicitation packet which is not answered, and it is supposed to be answered.

    Experiment 4: The wl500gx wireless access point client ping6s the Windows PC. This is Experiment 3 in the reverse direction. It works because the Windows PC replies, as it should, to the neighbor solicitation packet which it receives from the wl500gx.

    Remark: It is only the neighbor solicitation packets that are not be treated correctly. Echo request and echo reply always work. (I ran no experiment regarding ICMPv6 router packets.)

    Experiment 5: The Windows PC again tries to ping6 the wl500gx wireless access point client. THIS TIME IT WORKS. It works because the Windows PC put the address of the wl500gx in its neighbor cache during Experiment
    4. It knows the address now, and it does not have to send out a neighbor solicitation packet.

    Experiment 6: Now conduct the same sequence of experiments with the Linux PC substituted for the Windows PC. The wl500gx can ping6 the Linux PC because the PCs version of Linux accepts neighbor solicitation packets; however, it, the PC, still cannot ping6 the wl500gx because the wl500gxs address was not entered into the neighbor cache of the PC. In other words, there is a different bug here.

    Remark: There are no problems when IPv4 is used.

    Remark: I realize that I could make things work by manually entering addresses here and there, but that is asking for trouble later.

    Of course, I may have missed some obvious point, and all this may be nonsense.

  14. #59

    Follow up to IPv6 Neighbor Discovery Problem

    My careful editing got garbled after submission.

    On the wired Ethernet LAN are a PC running Windows XP, a wl500gP acting as a wireless access point, and a PC running Linux.

    Wirelessly connected to the wl500gP access point are a laptop running Windows XP, and two wl500gx's acting as wireless access point clients.

  15. #60

    More on IPv6 Neighbor Solicitation

    I now know a bit more about ipv6 neighbor solicitation in systems using wl500gxs and wl500gPs. I will refer here to my system setup which I described a couple of messages ago.

    First consider the wl500gx router. It works correctly, that is, it accepts all NSs (neighbor solicitations). I had entered an ipv6 address in the LAN Internet Interface, and ifconfig showed this address in br0. In addition, br0, eth0, eth1, vlan0, and vlan1 showed the automatically generated fe80 link-layer address. (Only one because there is only one MAC address.) NSs to both these addresses were accepted.

    Remark: I was a bit surprised that I did not see an automatically configured address based on the prefix and the MAC address. However, I finally decided that this is intended. Later I saw that in the Access mode as opposed to Home Gateway mode this address is generated.

    The file dev_mcast in /proc/net shows the MAC addresses that each interface is listening for. These addresses look a bit strange because they are derived from solicited-node addresses and some standard multicast addresses. Without going into detail, one could see that br0, eth0, eth1, vlan0, and vlan1 were listening for the fe80 link-layer address and br0 was additionally listening for the ipv6 address that I had entered manually. That this latter address is in br0 only is important.

    The NSs arrived over a wired connection, and they were responded to correctly. I underlined the word wired because wired versus wireless seems to be the problem.

    Second, consider the wl500gx access point clients which are the extremities of my set up. They have a wireless connection to the rest of the system. Their addresses and dev_mcast are similar to the router discussed above. Now, however, some NSs are accepted and some are not.

    If an NS is sent to the fe80 address, it is accepted. If it is sent to the address which appears in br0 only it is not accepted. This latter address is the problem address. I think that the fe80 address is accepted because it is associated with every interface in dev_mcast and, therefore, has many possibilities whereas the problem address is associated with br0 only. Although brctl says that eth1, the wireless interface, is in br0, the behavior is as if it were not. To check I added the problem address to eth1, and all NSs were then accepted.

    So I have a theory: there is something wrong with the br0 in the wl500gx access point clients. I will now attack this beautiful theory with an ugly fact.

    Third, now consider the wl500gP which is acting as an access point. It is between the router and the access point clients. Its addresses and dev_mast are similar to those of the preceding devices. The ugly fact is that it works correctly whether the connection is wired or wireless. For example, an NS with a problem address going wirelessly from an access point client to the access point is accepted. In other words, in the wl500gP br0 has no problem with a wireless connection. I dont understand.

    I can think of two possibilities. Perhaps the set ups of the wl500gxs and the wl500gP differ in some way that affects br0; Ive looked, of course. Or, perhaps, there is a difference in the software between the two boxes, the Deluxe and the Premium, which explains this behavior. I just dont know.

    In any event, I can make things work by adding the problem address to eth1, which is obviously not elegant.

Page 4 of 6 FirstFirst ... 23456 LastLast

Similar Threads

  1. HOWTO use your WL-500g as IPv6 router
    By phedny in forum WL-500g/WL-500gx Tutorials
    Replies: 8
    Last Post: 17-02-2008, 07:19
  2. tcpdump with --enable-ipv6
    By sodb in forum WL-500g Q&A
    Replies: 2
    Last Post: 25-05-2005, 18:50

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts