Results 1 to 15 of 15

Thread: Serial to Ethernet

  1. #1

    Serial to Ethernet

    I found a way to connect a serial device (my domotics system) to the WL500g deluxe and remotly control the domotics system over the ethernet.
    I downloaded the ser2net program from and cross compiled it for the Oleg firmware. Thanks to the very good tutorial from macsat. The ser2net program makes it possible to connect a serial device to the ethernet. It is all configurable by a .conf file. The serial device is connected to an USB to RS232 converter. I found here on this forum a driver for my converter that works with the Asus. The PL2303 driver.
    You can install the necessary drivers with the following commands :
    insmod usbserial.o
    insmod pl2303.o
    mknod /dev/ttyUSB0 c 188 0
    chmod 666 /dev/ttyUSB0
    In the ser2net config file you have to change the tty device to /dev/ttyUSB0
    I attached the neccessary files for who is interested in it.
    Attached Files Attached Files

  2. #2
    This sounds very intresting!!! I will try it as soon as possible.

  3. #3
    The file seems to big to be able to flash?

    [admin@(none) sbin]$ ls
    post-boot  ser2net
    [admin@(none) sbin]$ flashfs save
    tar: Removing leading '/' from member names
    flashfs commit
    -rw-r--r--    1 admin    root        69779 Feb 21 20:14 /tmp/flash.tar.gz
    Check saved image and type "/sbin/flashfs commit" to commit changes
    [admin@(none) sbin]$ flashfs commit
    /tmp/flash.tar.gz: File is to big (69779, max 65536)
    [admin@(none) sbin]$
    What can I do about it?

  4. #4

    file to big to flash

    I had the same problem but I have an USB flash disk where I installed the complete /OPT directory. See the tutorial from macsat for this.
    So ser2net program runs on the USB flash disk.

  5. #5
    dwienie, is it possible to reduce the size of the file?

  6. #6
    I will try to compile an older version of Ser2Net, it seems that this is smaller.

  7. #7
    $ file ser2net 
    ser2net: ELF 32-bit LSB MIPS-I executable, MIPS, version 1 (SYSV), dynamically linked (uses shared libs), not stripped
    Please strip the file, then it should fit to flashfs.

  8. #8
    Can you explain how I can strip that file ?

  9. #9
    I could finally strip the executable. The file is now much smaller.
    Attached Files Attached Files

  10. #10
    Join Date
    Nov 2005

    many thanks for your Work!

    How can I test this system after installation without a RS-232-Device?

    Many Thanks!

  11. #11
    Join Date
    Sep 2007
    great job!

    is there a way to do the same with USB devices?

  12. #12

    usb-server does the job

    usb-server works as a remote usb device but runs only in 2.6 kernel.

  13. #13

    ser2net RTS DTR config parameter?

    I'm testing the ser2net (version 2.3) in wl500gp and its works fair for me.
    I'm using taltech tcp-com as windows client but I have noticed that RTS and DTR pins are always ON for any connection.

    I have tried all knew parameters in the ser2net.conf:

    1) 32032:raw:600:remctl

    2) 32032:raw:600:19200 8DATABITS NONE 1STOPBIT -RTSCTS -XONXOFF

    I need to control a serial device with DTR and RTS pins, but, till now, no lucky... The ser2net linux manual referes a DTRHI, DTRLO and RTSHI, RTSLO parameters in Control Port parameters...

    Any ideas?

  14. #14

    Howto control RTS CTS status?


    I have replaced ser2net with remserial daemon but still the same problem with RTS and DTR signals.

    I think the problem is not in serial over net deamons but in the nix stty definitions.
    When we send an "echo" data or even only a "cat" command to /dev/tts/1 the RST and DTR signal turns allways ON.

    How can I configure stty devices to disable RST and DTR status?

  15. #15

    How to upload

    Hey people,

    I'm new with the WL-500g, and I would like to use it to have my DMX (light control) setup working wireless.
    I was thinking about libartnet to do this (, but serial over ethernet would to the job as well.

    I managed to get the FT232 usb/rs485 converter attached to /dev/ttyUSB0. Now I would like to use the ser2net lib as noticed in this topic.
    Can somebody help me how to get the file on the router?

    Another thing, I need a windows (yeah I know... but thats the only OS my lighting software runs on) client to generate a virtual comport.

    Last edited by joepurlings; 25-09-2010 at 16:00.

Similar Threads

  1. Howto add serial port to WL-500gx/gp
    By Josephus in forum WL-500g/WL-500gx Tutorials
    Replies: 50
    Last Post: 05-11-2012, 11:32
  2. Make an expansion board with a serial port(s) for WL-500b/g
    By Technik in forum WL-500g/WL-500gx Tutorials
    Replies: 73
    Last Post: 07-02-2008, 20:29

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts