Results 1 to 4 of 4

Thread: Samba/Network drive stops working

  1. #1

    Question Samba/Network drive stops working

    Hello,

    I have installed the latest firmware by Oleg (1.9.2.7-7b) but unfortunately I still get a problem where my shared network drive stops working every few days. Usually the rest of the WL-HDD is still up and running as the problem is fixed by Telnet'ing into the WL-HDD and giving it a reboot command. Occasionally though I must pull the power to kick it back into life.

    The problem seems intermittent although it can also occur when I copy mutliple medium sized files to the drive e.g. a few albums worth of MP3's. The actually number of MB's copied does not seem to be the problem though as copying a dozen or so 350MB Div-X's is quite reliable. Copying files also appears to get more unreliable the longer it is since the last reboot of the NAS.

    For reference I am using the WL-HDD as a NAS and a print server and it is permamently attached via wired ethernet to an ADSL router/modem (D-Link). I am not using the wireless function at all and it is disabled. Originally the file system was FAT-32 but I switched to Ext-3 in an attempt to stop the problem but unfortunately there was no improvement. Any help with this matter is greatly appreciated,

    Thanks

    Roger

    ps Thanks for the custom FW dev Oleg, it's great stuff and much more useful than the original FW.

  2. #2
    Are you still using the default mount point of /tmp/harddisk in your Samba setup?

    I had a similar problem where this mount would just disappear and I lost all access to the shares. When this next occurs telnet in and type 'mount' to see if the harddisk is still connected.
    This usually took a week or so to occur though.
    I've just gone down the route of changing the mount to /opt to see if that makes any difference.

    Ade

  3. #3
    Hello Ade,

    Yes I am still using the default mount point. I'll try the mount command next time it falls over and I'll post a reply to let you know how it went. I last rebooted it just before I began this thread so I should be able to get a more accurate estimate of how long it takes before she blows.

    Maybe the timescale between failures is driven by the amount of activity. I run my outlook pst file on this drive so I can access my mail from two different PC's, so I'm accessing it quite frequently. Copying lots of files seems to hasten its demise too.

    Thanks

    Roger

  4. #4

    Shared Network drive disappears

    Hi Roger,
    check the /tmp/syslog.log for entries that indicate that you have an out-of-memory problem. My Twonkyvision media server uses so much RAM when running it with my entire music library so that eventually the kernel kicks out some processes. It happens to hit the Samba processes (smbd and nmbd) especially when I try to write onto the disk. I now have a "Samba-only" configuration that I use for those instances I'm updating my music library. Just reading from the disk is usually not a problem. Rebooting the server periodically, e.g. every 24h could be another cure to the problem.

    Andreas

Similar Threads

  1. linuxrc bug? - WL-500g not booting from usb drive with hub
    By daniel632 in forum WL-500g Custom Development
    Replies: 5
    Last Post: 14-03-2012, 16:28
  2. Internet is good, then stops
    By Recall in forum WL-500g Q&A
    Replies: 2
    Last Post: 29-12-2005, 12:57
  3. Replies: 3
    Last Post: 18-12-2005, 02:07
  4. Replies: 1
    Last Post: 09-12-2005, 23:29
  5. Trying to get IDE working on Oleg's Firmware
    By hugo in forum WL-HDD Custom Development
    Replies: 34
    Last Post: 01-11-2004, 19:06

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •