Results 1 to 12 of 12

Thread: WOL from WAN without telnet, ssh or web-interface

  1. #1
    Join Date
    Jan 2006
    Location
    Germany, near Hamburg
    Posts
    1

    Exclamation WOL from WAN without telnet, ssh or web-interface

    As short as possible :

    Web-Interface:
    ---------------
    NAT Setting -> Virtual Server
    Port Range: 9
    Local IP: 192.168.1.10 (use your own ip-address)
    Local Port: 9
    Protocol: UDP
    Description: WOL xy computer

    Console:
    --------
    ipkg install net-tools

    add
    arp -s 192.168.1.10 01:02:03:04:05:06 (use your own ip- and mac-address)
    to
    /tmp/local/sbin/post-mount

    flashfs save
    flashfs commit
    flashfs enable
    reboot

    Then wake up your PC using this web-page (or other):
    http://stephan.mestrona.net/wol/

    Good luck Eike

  2. #2
    Join Date
    Aug 2005
    Location
    Denmark
    Posts
    30
    No need to install net-tools:

    Isuue the following commands during startup of the wl500:
    ip neigh change 192.168.1.254 lladdr ff:ff:ff:ff:ff:ff nud permanent dev br0
    ip neigh add 192.168.1.254 lladdr ff:ff:ff:ff:ff:ff nud permanent dev br0

    Next forward UDP port 9 to 192.168.1.254
    and do wol to your ext ip udp port 9 mask 255.255.255.255 macadr 00-01-02-03-04-05 (mac of the machine you want to wake).

  3. #3
    my goal is to WOL my pc, and after that be able to use the FTP server on the PC.

    I tried the procedure described by "pfugl" to WOL , but I found the following problem.

    after entering the commands :

    ip neigh change 192.168.1.254 lladdr ff:ff:ff:ff:ff:ff nud permanent dev br0
    ip neigh add 192.168.1.254 lladdr ff:ff:ff:ff:ff:ff nud permanent dev br0
    and off course forwarding port 9 to my WOL PC.

    using a WOL website, the computer wakes up.

    however, I can not make a FTP connection after that (port21 is fowarded to my PC)
    after rebooting the WL500g, FTP is possible, but WOL does not work any more.

    any ideas ?

  4. #4

    Question wol

    If the integrated ether-wake doesn't seem to work, try the following command:

    ether-wake -i br0 00:26:54:0B:EE:50

    Of course, with your MAC-Adress!

    Good Luck

    EDIT: ether-wake -i vlan1 00:26:54:0B:EE:50 also worked for me.

    Which one is better?

  5. #5

    post-mount and wol

    Hello. I would like to be able to send Wake On LAN packets to a PC on my network from the internet. I have created a /usr/local/sbin/post-mount file, which looks like this:

    Code:
    #!/bin/sh
    ip neigh change 192.168.1.254 lladdr ff:ff:ff:ff:ff:ff nud permanent dev br0
    ip neigh add 192.168.1.254 lladdr ff:ff:ff:ff:ff:ff nud permanent dev br0
    The file is executeable, and if I run it manually, it seems to work fine.

    But when I save the changes, and reboot the router, it seems like the commands in the post-mount file has not been executed. What am I doing wrong?

    Is the post-mount file the wrong place to execute these commands??

  6. #6
    Join Date
    Oct 2008
    Location
    Bulgaria
    Posts
    13

    Question wol

    Are you executing

    Code:
    flashfs save && flashfs commit && flashfs enable && reboot
    upon saving the file ?

  7. #7
    Quote Originally Posted by jr0 View Post
    Are you executing

    Code:
    flashfs save && flashfs commit && flashfs enable && reboot
    upon saving the file ?
    Yes, and the file /usr/local/sbin/post-mount stil exists after I reboot, and permission to the file is -rwxr-xr-x.

    Code:
    [admin@WL-001A927E6303 sbin]$ ls -la
    drwxr-xr-x    1 admin    root            0 Aug 19 22:57 .
    drwxr-xr-x    1 admin    root            0 Jan  1  2000 ..
    -rwxr-xr-x    1 admin    root          203 Aug 20 16:41 post-mount
    [admin@WL-001A927E6303 sbin]$
    For debugging I just tried to change the post-mount file to:

    Code:
    [admin@WL-001A927E6303 sbin]$ more post-mount
    
    #!/bin/sh
    #ip neigh change 192.168.1.254 lladdr ff:ff:ff:ff:ff:ff nud permanent dev br0
    #ip neigh add 192.168.1.254 lladdr ff:ff:ff:ff:ff:ff nud permanent dev br0
    echo "Test" >> /usr/local/sbin/test.txt
    
    [admin@WL-001A927E6303 sbin]$
    and reboot with
    Code:
    flashfs save && flashfs commit && flashfs enable && reboot
    After reboot the changes I made to post-mount are still there, but the file /usr/local/sbin/test.txt does not exist.

    What is going on?? Do I need to enable the use of the post-mount file somewhere?

  8. #8
    Just for info:

    I am using Oleg firmware 1.9.2.7-10, and my router is a WL500GP, and I do not have an external USB disk connected.

  9. #9
    Join Date
    Oct 2008
    Location
    Bulgaria
    Posts
    13
    Funny , mine is working just fine :

    Code:
    [root@Box sbin]$ vi post-mount
    #!/bin/sh
    
    /opt/etc/init.d/rc.unslung start
    echo "Hello" >> /usr/local/sbin/hello.msg
    and upon flashfs save && flashfs commit && flashfs enable && reboot I got
    Code:
    [root@Box sbin]$ ls -l
    -rwxr-xr-x    1 root     root           38 Oct 17  2008 ez-setup
    -rw-r--r--    1 root     root            6 Aug 21 12:24 hello.msg
    -rwxr-xr-x    1 root     root           38 Oct 17  2008 post-backup
    -rwxr-xr-x    1 root     root          251 Aug 20 09:32 post-boot
    -rwxr-xr-x    1 root     root          168 Feb 22 19:22 post-firewall
    -rwxr-xr-x    1 root     root           86 Aug 21 12:23 post-mount
    -rwxr-xr-x    1 root     root           38 Oct 17  2008 pre-backup
    -rwxr-xr-x    1 root     root           38 Oct 17  2008 pre-boot
    -rwxr-xr-x    1 root     root           39 Oct 17  2008 pre-mount
    -rwxr-xr-x    1 root     root          266 Mar 19 21:52 pre-shutdown
    -rwxr-xr-x    1 root     root           38 Oct 17  2008 resetpressed
    I got wl500gp v2 and koppel's firmware.

    Maybe you can try with the post-boot file ?

  10. #10
    Quote Originally Posted by jokkemokke View Post
    Just for info:

    I am using Oleg firmware 1.9.2.7-10, and my router is a WL500GP, and I do not have an external USB disk connected.
    If there are no USB disks connected, there is nothing to mount...
    So probably post-mount doesn't get called.

    try putting it in post-firewall, or post-boot

  11. #11
    Quote Originally Posted by DrChair View Post
    If there are no USB disks connected, there is nothing to mount...
    So probably post-mount doesn't get called.

    try putting it in post-firewall, or post-boot
    You were right. I tried putting it in the post-boot file instead, and now it works.

    Thanks for the help.

  12. #12

    Question wol

    It's possible with a simple url that contains

    http://external url of router/apply.cgi?current_page=Main_AdmStatus_Content.asp& next_page=Main_AdmStatus_Content.asp&next_host=&si d_list=FirewallConfig%3B&group_id=&modified=0&acti on_mode=+Refresh+&first_time=&action_script=&Syste mCmd=ether-wake+MAC

    (remove spaces if any... the forum seems to add few spaces(3) in my post ...I don't know why)
    MAC must be a station address (00:11:22:33:44:55) or a hostname with a known 'ethers' entry.

    You will be asked for user/pass to acess the router


    i saved it on a stick that i always have with me and i start my computer with a simple double click on that url

    or you can put the link on your personal web page
    Last edited by gabimartinescu; 14-01-2011 at 11:03. Reason: spaces that does not exist in edit box appeard in post

Similar Threads

  1. Web interface
    By Alanjan in forum Dutch Discussion - Nederlands
    Replies: 0
    Last Post: 21-12-2005, 12:41
  2. disable telnet but want ssh access from WAN
    By wl500grocks in forum WL-500g Q&A
    Replies: 2
    Last Post: 01-08-2005, 00:04
  3. Replies: 0
    Last Post: 05-05-2005, 21:20
  4. How to enable telnet or ssh into router from WAN ?
    By BigOooze in forum WL-500g Q&A
    Replies: 1
    Last Post: 13-12-2004, 23:42
  5. web interface loads only occasionally during boot
    By oferlaor in forum WL-500g Q&A
    Replies: 5
    Last Post: 18-10-2004, 11:48

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •