Page 3 of 4 FirstFirst 1234 LastLast
Results 31 to 45 of 53

Thread: AP scan utility

  1. #31
    Thanks a lot. Will you provide the sources also ?
    Maybe we can share some knowledge about thread programming...
    I like your tool and have some idea to add some enhanced features.

    What do think about it ?

    Best regards

  2. #32

    Cannot connect to host

    Can anyone help me with this problem?

    I have a wl500g with oleg's and i receive always this message
    "cannot connect to host".

    I've tryed to access by telnet and all ok. My host isn't in the
    is on

    i thinks thats no the problem, but... i don't know.


  3. #33
    Switch on logging and check the log file. If it doesn't help send the log file to me.

  4. #34

    about wl-scan

    Excelent !

    Great job !

  5. #35
    I tried it with my WL-500W and it says "can't connect", there is no log.

  6. #36


    The same here, I got Wl-500gP (Oleg's FW (2007-10-30)), and wl scan is of version from 9 March 2006. I use WinXP.

    I enter correct information:
    user name: admin
    password: (my pwd, cannot tell you that, but it is not long and I am sure I am typing it correctly)

    After a few seconds from clicking "Connect" I get: "Wrong username or password" and the password disappears from the box!!! If I use another IP, the password stays in.

    Telnet with mentioned credentials works OK, I successfully log in.

    Liszka, dont you know where the problem could be? The program doesn't generate any log even if I set it up to make one.

    Maybe Delphi 2005 is the best choice, but probably not in this case...
    Last edited by Jack_Brody; 08-12-2007 at 15:59. Reason: notice about telnet

  7. #37

    To Jack_Brody and others...

    I must answer that the problem is not in Delphi itself but in the code . I know about it already some time but only few people sent their complaints. Now, already 3 people reported the problem and I decided to fix it. Give me several days please and you will get an improved version.

  8. #38
    OK, looking forward to your next version. I'll test it immediately then.

  9. #39

    New version available

    Please find the new version on the previous page. Let me know if it works better than before. Thanks.

  10. #40
    Ok, so I have just tried new version (WL SCAN 1.1) from 2008 . I put in correct IP adress, username and password, after clicking on Connect I can see in the lower bar:


    and then a window pops up with "ERROR: Could not get AP mode."

    That's all for now.

    Hmmm...I've also checked the "log to file" checkbox, but no log has been created. If you somehow get it to work, I will give you the log in the future. It would be probably much more of help for you.

    I still have the same version of Oleg's FW as I wrote a few posts ago. And WinXP SP2.

  11. #41
    The same happens no matter whether or not I check the "passive" checkbox.

  12. #42


    The log file is saved to "log.txt" after closing the tool. I can't test with firmware now. The log usually looks like this if AP mode is off:

    Asus login:

    [username@Asus root]$
    wl ap
    ap is 0 (off)
    [username@Asus root]$
    wl scan -t passive
    [username@Asus root]$
    wl scanresults
    SSID: "\x00\x00\x00\x00\x00\x00"
    Mode: Managed RSSI: -57 dBm noise: -99 dBm Channel: 1
    BSSID: 00:17:3F:07:C9:24 Capability: ESS WEP ShortSlot
    Supported Rates: [ 1(b) 2(b) 5.5(b) 11(b) 6 9 12 18 24 36 48 54 ]
    multicast cipher: TKIP
    unicast ciphers(1): TKIP
    AKM Suites(1): WPA-PSK
    No WPA Capabilities advertised

    Please send the log file to me or connect manually over Telnet and send the log of the session. Thanks

  13. #43
    OK, after two connection tries the log contain following:

    asus login: 
    [admin@asus root]$ 
    l ap
    [admin@asus root]$ 
    asus login: 
    [admin@asus root]$ 
    wl ap
    [admin@asus root]$

    When I connect manually via Telnet, I know how to obtain the list of neighbor wi-fi networks. I use these commands:

    wl ap 0 (switch off the AP mode)
    wl scan -t passive
    wl scanresults
    wl ap 1 (switching on the AP mode)

    So I think if wlscan used the "wl ap 0" command first, it wouldn't have those problems. Just an idea.

  14. #44


    There is a new version on the previous page that should support the latest firmware (I hope). The difference is a more tolerant rule for reading AP mode (setting 'wl ap 0' had been included already earlier, the problem was caused by different format of the reply to 'wl ap' in different versions of firmware).
    Last edited by Liszka; 13-01-2008 at 16:45.

  15. #45

    Thumbs up Works!

    Yes!!!! Now it is working like a charm!! It connects in and then repeatedly scans the air and updates the table.

    Perfect. Thank you Liszka, good work!

Page 3 of 4 FirstFirst 1234 LastLast

Similar Threads

  1. Security Scan: Port 80 Closed, Not Blocked
    By tomilius in forum WL-500g Q&A
    Replies: 10
    Last Post: 28-02-2005, 15:27
  2. Replies: 4
    Last Post: 15-12-2004, 15:54
  3. ASUS WL-1x0g Cardbus Card utility English, version
    By Antiloop in forum WL-100g/WL-100gDeluxe/WL-103b/WL-120b/WL-120g [Broadcom Chipset]
    Replies: 1
    Last Post: 29-09-2004, 17:53
  4. ASUS WL-100g Cardbus Card utility version
    By FIB in forum WL-100g/WL-100gDeluxe/WL-103b/WL-120b/WL-120g [Broadcom Chipset]
    Replies: 0
    Last Post: 09-02-2004, 21:39

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts