Page 3 of 4 FirstFirst 1234 LastLast
Results 31 to 45 of 47

Thread: [HowTo] Streaming audio from Winamp/XMMS/etc.

  1. #31
    Hey there! =)

    Actually, I'm not 100% positive, but I do believe this happened using the waveserver as well.

    I managed to get esd running on OS X using this guide:

    But how would I go about to post a kernel log? (Do I have to mention that I'm a total linux noob - I've put quite a few hours into this already just to get this far ;-P)

    I've had some progress troubleshooting; So far, I've kind of ruled out the possibility that this has something to do with ESD, because i'm getting the same problems when using madplay+netcast to play mp3 streams. It's nothing that happens on my macbook, cause i get it both when streaming directly from my computer (ethernet/wlan no difference) and when streaming off an internet radio station. And it happens when totally disconnected from the net with just a cable connecting my comp to the router.

    I've been watching the cpu usage on the router using the top command, and there's nothing going on there. When the dropouts occur, madplay is just about the only process using up cpu, and it's using about 15%. So the problem isn't lack of cpu power. Nor have I found any individual process that peaks during the dropouts; I've killed off as many as possible but to no avail.

    I'm thinking it'd be good to have a program on the router that could buffer like a second or two before sending it out to the usb card. Any idea how this could be done?

    Or maybe I need to use another audio driver? How would I go about doing that? =)

    Any clues?

  2. #32
    OK, after monitoring the syslog, it turns out the problem seems to be related to the usb-uhci.c. The log gets filled with these messages, just about one per minute, and some of them, although not all of them, result in the audio blanking out for a second or so.

    Jan 1 01:06:02 kernel: usb-uhci.c: iso_find_start: gap in seamless isochronous scheduling
    Jan 1 01:07:02 kernel: usb-uhci.c: iso_find_start: gap in seamless isochronous scheduling
    Jan 1 01:08:02 kernel: usb-uhci.c: iso_find_start: gap in seamless isochronous scheduling

    When I had the USB stick connected to the first port and then switched it to the second (lower) port, i got gap-free playback for about 30 minutes. But the error messages above still kept filling the log. Then, out of nowhere, it blanked out at 01:37:02. And then at 01:44:02, '46, '48, '54, '58 and '00. Then I shut it down.

    This problem was also described in this thread:

    Alas, they didn't seem to find a truly satisfying solution; simply switching the ports doesn't do it for me.


  3. #33
    What is the problem with the unslung esound package? After installation esd is not found. The downloaded binary provide from the OP works, but I'd like to use the 'official' stuff.

  4. #34
    Found it finally.

  5. #35

    esound supporting audio streaming over the internet?

    I would like to stream the audio input from an USB microphone (attached on WL500gP) over the internet to an appropriate client. Is that possible with esound? If not, how would that work? any working ideas welcome.

    many thanks in advance!

  6. #36
    Join Date
    Aug 2004

    Esd ist for output only to what i know.
    If you find some linux commandline aplication that does the job you want, its sure possible to compile it for the asus.

    My Stuff: WL-500g, Mapower H31x 10GB HD, Philips Webcam Vesta PRO, TerraTec Webcam PRO, USB Hub

  7. #37

    Lightbulb Running esound without usb-stick

    This weekend I installed Vista with the new WMP 11. Apperently there is a problem with the asus speaker plugin, so I decided to use the esound daemon with winamp instead. The usb-flash boot procedure didn't work for me, I guess a powered usbhub is required, so I decided to build a custom firmware instead. It's a very simple hack, and works perfectly for me:

    First build the oleg firmware as explained in the wiki:

    Enter the broadcom/src/gateway/others folder and get esd:
    $ wget
    $ chmod +x esd
    Delete or rename the binary file waveserver in others.

    Create a new file named waveserver with this content:
    /usr/sbin/esd -d /dev/sound/dsp -tcp -public &
    Make it executable:
    $ chmod +x waveserver
    Finally, open the Makefile in the gateway folder and search for the string waveserver. There will be a comment saying something like: Asus binary crap . Copy the line with "waveserver" and insert a new line where "esd" replaces "waveserver".

    Compile with make image-WL500g.

    Ofcourse esd will not be disabled when you select disable waveserver from webgui and apply (you will have to reboot to get that effect). But you wouldn't do this trick if you want to disable esd.

    Hope someone find this useful. Cheers

  8. #38
    Join Date
    Nov 2005

    What is the main idee for this project?


    what is the main idee for this project?

    Do you connect a USB-Sound-Card on your Router?
    And than connect analog Sound-Cable from the PC-Sound-Card-Line-Out to the USB-Soud-Card-Line-In?

    I habe build this Project HowTo WL-HDD + USB-Sound-Hub als MP3-Player mit PDA-Fernbedinung
    Can you make a picture of your Hardware?
    Is it the same like yours?

    Attached Images Attached Images  

  9. #39
    Hi there,

    I have set up esd on my router as per instructions. Downloaded the winamp plugin etc. Start up esd on the router etc and all is fine, no errors etc and the router tells me that it is running at 48 kHz, 16bit etc.

    When I play music in winamp it sends it to my wl-500g router and my USB sound card / adapter starts flashing but there is no sound!

    I know that the sound card works because I can plug it into the USB ports on the PC and play winamp through it. It only doesn't seem to work when attached to the router.

    Any ideas? I will try any suggestions as this is driving me nuts!


  10. #40
    Join Date
    Nov 2005
    Quote Originally Posted by ChessMaster View Post
    I have set up esd on my router as per instructions. Downloaded the winamp plugin etc.
    What is esd? Have you a Link?

    You will controll with winamo from your PC the Sound of the USB Soundkarte who is connected on your Router?

    Have you installed the USB-Libary?


  11. #41
    Hi there,

    What is esd? Have you a Link?
    I just followed the instructions on this link:

    Have you installed the USB-Libary?
    Not sure if there is a USB library that I need to install as I would assume that all of what I need is in the latest firmware which I have installed. I assumed that all I needed to install is EsounD daemon.

    I am using a 3D USB sound card (PD552). I wonder if there is a problem with the compatibility of the chipset here?

    Has anyone managed to use this p0articular USB sound card in this way? As I said in an earlier post, all I get is a long, high pitched tone when I play the audio player through my router.

    How do I check what chipset it is using?


  12. #42
    Join Date
    Nov 2005

    Enlightened Sound Daemon EsounD esd


    Quelle: Enlightened Sound Daemon EsounD esd
    Der Enlightened Sound Daemon, kurz EsounD oder esd, ist ein Soundserver der von den Fenstermanagern Enlightenment und GNOME verwendet wird.

    Zweck eines Soundservers ist es dafür zu sorgen dass mehrere Anwendungen gleichzeitig Audiosignale ausgeben können. Dazu greifen die Anwendungen selbst nicht mehr direkt auf das Audiogerät, beziehungsweise deren Treiber, zu, sondern senden statt dessen den wiederzugebenden Audiostrom an den Soundserver. Dieser mischt die Ströme und gibt das Ergebnis dann über das Audiogerät wieder.

    EsounD verfügt auch über einfache Sequenzerfähigkeiten, so können Samples geladen und später wiedergegeben werden. Weiterhin ist EsounD netzwerktransparent, ein Programm muss also nicht auf dem selben Host wie der Soundserver laufen um Audioströme an diesen zu senden.
    By WLAN-Fan.

  13. #43
    Quote Originally Posted by cunami View Post
    Well sometimes it matters I guess :-) I have tried to install WinESD on my WinXP SP2. After couple of times I succeeded. Then I have tried to make it work. In the beginning I was just getting annoying sounds, which are error messages (as it is written in website of WinESD creator). Then somehow I got it working, but I could not call it "really working" - cause sound is coming somehow with slowdowns, the speed of music is varying all the time and I am hearing terrible effect :-). Even my windows couple of times was also running so slow... What could be the problem? I am sure this is not a network problem as my home network is almost empty, not other computers are using it. Could this be somehow related that I have SP2 installed?

    could you direct me to the place where I ma supposed to add the driver in WinXP SP2 ?


  14. #44
    Hi guys.

    I have installed esd on the router (WL500gp) and the plugin in winamp and everything works great.

    But it only works when i start ESd manually. If I try to add it to post-boot it doesn't work.

    Here is what i have:

    insmod ipt_TTL.o
    iptables -t mangle -I PREROUTING -i vlan1 -j TTL --ttl-set 128
    killall waveservermain
    killall waveserver
    /usr/local/esd -d /dev/sound/dsp -tcp -public &
    Any thoughts ?

    LE: FW Oleg's
    Last edited by gogusclipici; 11-09-2008 at 23:37.

  15. #45

    It works now. I don't know what the heck was going on.

    Thanks anyway.

Page 3 of 4 FirstFirst 1234 LastLast

Similar Threads

  1. USB audio - from Linux
    By mangodan in forum WL-500g Custom Development
    Replies: 5
    Last Post: 10-04-2007, 12:25
  2. Wie funktioniert das Audio Streaming auf dem WL-500G Deluxe?
    By nosilent in forum German Discussion - Deutsch (DE)
    Replies: 3
    Last Post: 21-11-2005, 14:33
  3. Audio Video streaming problem
    By jeemedia in forum WL-500g Custom Development
    Replies: 1
    Last Post: 23-06-2005, 14:36
  4. Wireless audio setup - advice pls
    By Graldensblud in forum WL-500g Q&A
    Replies: 2
    Last Post: 27-04-2005, 23:51
  5. New Specs from Asus - Audio Streaming and Traffic Shaping
    By ghaspias in forum WL-500g Pics & Specs
    Replies: 18
    Last Post: 25-04-2005, 06:58

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts