Page 1 of 19 12311 ... LastLast
Results 1 to 15 of 271

Thread: Firmware v1.9.2.7 CR7 now 7g [Oleg]

  1. #1
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353

    Firmware v1.9.2.7 CR7 now 7g [Oleg]

    New firmware is now available for download. Changes since 1.9.2.7-6b:

    • Fixed issues with samba writes using large buffers
    • pppoe ac name and service name are now in effect
    • Add a workaround for default gateway with non-local address
    • Updated to busybox-1.1.0-pre1 (new applets, including nice nohup stty ether-wake)
    • Updated to dropbear-0.47
    • Added flashfs backup (done by engy)
    • Fixed firewall internal 80 wan accept (done by engy)
    • PPPoE connections are now forced to be nomppe nomppc
    • Proper NAT handling for different netmasks (techno report)
    • Poweroff is working now
    • Hidden page enter key fix (engy)
    • Added System Setup | Services Page
    • Added support for samba cp1251
    • Url filter page is removed, as it was not functional
    • kernel-syn-recv.patch (ported by oleo)
    • New firewall rules layout (done by unaiur)
    • WL300g is now working in Home Gateway mode too (reset to defaults is required after upgrading)
    • Apply button is now does not jump to next page
    • Added L2TP WAN connection type support (demand dialing/idle timeouts are not supported)


    Update in the -7a: fixed a tar bug

    Updates in the -7b: rolled back to busybox-1.01. Added http_lanport patch (credits to Leon Kos), SoundBlaster Audigy 2 NX soundcard support (credits to Daniel Pustka) and enabled serial ports IRQ sharing.

    Updates in the -7c release:
    • All Save/Finish buttons are functional again
    • Small lease time should not cause problems with dhcp client anymore
    • PPTP peer address could now be the same as PtP address


    Updates in the -7d release:
    • Wi-Fi module updated to 3.90.37
    • MTU clamping is fixed once again (should solve lags problems)
    • USB updates (should improve stability)
    • PPTP/PPPoE allows now DHCP to be used on the WAN port - just specify 0.0.0.0 as static address
    • Built-in SSH server should now correctly call sftp installed using ipkg
    • Webcam drivers update: ov51x-1.65-1.12, pwc 9.0.2 (incl. compression and 640x480)
    • Kernel support for IPSec NAT-T
    • WL550gE is supported now


    Updates in -7e release: PPPoE with empty WAN IP address issue fixed.

    Updates in -7f release:
    • Switched to Busybox 1.1.3
    • VT6212 USB 2.0 patch (10-15% speedup)
    • USB sticks without MBR should be also now mounted
    • Storage devices are using async options by default
    • WL500g Premium support (MirrorBit Flash support, nvram validation, 32mb enabled) !!! The firmware is totally different from the stock one: no DM, different FTP server and Samba! Do not flash if in doubt - you would miss some features !!!
    • Additional pppd options field is now 255 chars long
    • PPP now defaults to unlimited number of connection attempts
    • PPTP connections now use MTU 1400 by default
    • DHCP+PPTP (0.0.0.0 gateway support in the MAN routes, DNS and default gateway options now could be acquired from DHCP too, symbolic PPTP name support, PPTP client now adds route to the server)
    • Fixed MAN->LAN firewall issue (be sure to enable WAN to LAN filter and set default action to DROP!)
    • Fixed some firewall defaults (WAN->LAN is now enabled and DROPs)
    • "Apply to routing table" option is now in effect
    • Default gateway is no longer appears in the nameserver list in the AP mode
    • WL550gE radio on/off feature should work better now (added missing nvram variables)
    • SIGALRM is no longer blocked in the post-mount


    Updates in -7g release:
    • New Busybox applets (env, cmp, wc, md5sum sha-1)
    • IGMP proxy added (multicast routing [IPTV]) (IP Config | Route > Enable multicast routing?)
    • Added an option to specify 802.11 multicast rate (Wireless | Advanced > Multicast rate)
    • New kernel features (incl. advanced router, new iptables targets)
    • Fixed compile problems with newer Linux ditributions
    • Web interface should no longer show Cable Disconnected status
    • There is now an option to enable/disable DoS protection (Internet Firewall | Basic Config > Enable DoS protection?)
    • Built-in ftp server should now work fine in PASV mode
    • Updated Dropbear to 0.49
    • Updated WiFi to 3.90.38.00
    • Added support for the 128MB of onboard RAM
    • hiddev support
    • FPU emulator fixes
    • WL-HDD IDE fixes - SMART should work now
    • Onboard flash type diagnostic messages
    • Fixed flashfs to respect comment signs
    • flash command now has progress indicator
    • Station/Ethernet Bridge mode should now associate faster to AP after reboot
    • WL500g Deluxe/Premium/WL550gE now rescpect WAN port settings from the web
    • WL500g Premium/WL550gE now better handles OFDM transmitter power setting
    • Added support for /etc/fstab before automount
    • Fixed problems then upgradinf via WiFi using WPA/WPA-PSK
    • Disabled "power off" for all units except WL-HDD
    • Pressing EZ SETUP button for 3 seconds would cause /usr/local/sbin/ez-setup to be executed


    Download using this link.
    Last edited by Oleg; 02-05-2007 at 10:22.

  2. #2

    Freeze!

    Hi!, great work on the firmware.

    When i:

    [admin@asus root] flashfs save
    tar: Removing leading '/' from member names
    etc/smb.conf
    tmp/local/
    tmp/local/.files
    tmp/local/etc/
    tmp/local/etc/dropbear/
    tmp/local/etc/dropbear/dropbear_rsa_host_key
    tmp/local/etc/dropbear/dropbear_dss_host_key
    tmp/local/sbin/
    tmp/local/sbin/post-firewall
    tmp/local/sbin/post-boot
    tmp/local/root/

    It just freezes here...

    after: ctr+c

    [admin@asus root]$ cat /.version
    1.9.2.7-7

  3. #3
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Quote Originally Posted by muldy
    It just freezes here...
    Thank you for report. Fixed now, I would upload 7a shortly.

    Update: uploaded, links updated.
    Last edited by Oleg; 06-01-2006 at 08:48.

  4. #4
    Join Date
    Jun 2005
    Location
    Slovenia
    Posts
    736
    Diffs from 6c-pre5 from my quick peek into it:
    1. etherwake (WOL) tool removed
    2. L2TP protocol support (L2TP is the protocol used by some ISPs)
    3. busybox & dropbear upstream upgrade
    4. www.tzo.com -> www.zoneedit.com change
    5. Apply button and added letter e to Mangement

  5. #5
    Hey Oleg,
    thanks!

    With the last FW I had some problems with bittorrent which are solved now.


    Problems which are solveed now:

    - Slowdown of connection-speed
    - impossible to surf in the net while downloading and so on...


    Same settings used and nothing changed except of the firmware.

  6. #6
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Quote Originally Posted by TinyRK
    With the last FW I had some problems with bittorrent which are solved now.
    Magic, nothing is changed...

  7. #7
    Quote Originally Posted by Oleg
    Magic, nothing is changed...

    Who cares,
    but now it works.

  8. #8
    Hi,

    juss upgraded my ASUS, and all scripts uses BUSYBOX_HTTPD stoped work

    WiZi

  9. #9
    Quote Originally Posted by Oleg
    New firmware is now available for download. Changes since 1.9.2.7-6b:

    • Add a workaround for default gateway with non-local address
    there is a bug here.
    If i set default gateway to host from LAN, WAN interface uses netmask 0.0.0.0 instead of entered.

    vlan1 Link encap:Ethernet HWaddr 00:00:1C:XX:XX:XX
    inet addr:10.33.0.100 Bcast:255.255.255.255 Mask:0.0.0.0

    when a leave dfault gateway blank or put 10.33.0.1 mask sets correctly to 255.255.255.0

    default gateway sets correctly anyway - it is good.
    Last edited by OlegI; 07-01-2006 at 03:08.

  10. #10
    I just upgrade this new version firmware
    but not really smooth in setup part as before
    1. the first is "Quick setup" can't really write the information back to ROM, when I push the finish buttom, it will repair to first page, and run again and again, I can't get out the circle

    2. when I want to rename admin to other new name, and change new password, the same thin happened again, it's also show the page want me to keyin new name or new password, OF CURSE...it still as old name and password admin/admin.....do NOT change it...

    So...I downgrade to 6b now...

    and please forgive my poor english...

  11. #11
    Works great on a Belkin F5D7230 v1222 ! Scheduled shell scripts executed with crond still not working though. (already had the same problem with 6a-pre5)

    Thanks Oleg !

  12. #12
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Quote Originally Posted by OlegI
    If i set default gateway to host from LAN, WAN interface uses netmask 0.0.0.0 instead of entered.
    This is not supported.

  13. #13
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Quote Originally Posted by WiziPok
    Hi,

    juss upgraded my ASUS, and all scripts uses BUSYBOX_HTTPD stoped work

    WiZi
    Looks like new busybox is buggy as hell...

  14. #14
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Quote Originally Posted by cu112
    Works great on a Belkin F5D7230 v1222 ! Scheduled shell scripts executed with crond still not working though. (already had the same problem with 6a-pre5)

    Thanks Oleg !
    That's strange. Just tried crond and it works fine. My simple crontab looks like this:
    Code:
    [root@wl500gx root]$ cat /var/spool/cron/crontabs/root
    */1 * * * * date >> /tmp/cron.log
    [root@wl500gx root]$
    Try launching crond with -f switch to see if it has any problems...

  15. #15
    Join Date
    Oct 2004
    Location
    Portugal
    Posts
    145
    Sorry for spam, but i want to tell thanks to Oleg.
    We need you!

    Thanks for your hard work, and share with all of us.
    Home Page
    Marco Sousa from PORTUGAL
    [ WL-500g - fw: 1.9.2.7-7e [Oleg] | WL-500gP - fw: 1.9.2.7-7f-USB-1.63 [Oleg&koppel.cz] ]

Page 1 of 19 12311 ... LastLast

Similar Threads

  1. Firmware v1.9.2.7 CR6, updated to CR6a ... now CR6b [Oleg]
    By Oleg in forum WL-500g Firmware Releases
    Replies: 241
    Last Post: 09-02-2006, 10:19
  2. Firmware v1.9.2.7 CR5, updated: v1.9.2.7 CR5a [Oleg]
    By Oleg in forum WL-500g Firmware Releases
    Replies: 189
    Last Post: 18-06-2005, 13:07
  3. Firmware v1.9.2.7 CR3c [Oleg]
    By Oleg in forum WL-500g Firmware Releases
    Replies: 115
    Last Post: 12-03-2005, 10:07
  4. Firmware v1.9.2.7 CR3 - Now CR3b [Oleg]
    By Oleg in forum WL-500g Firmware Releases
    Replies: 115
    Last Post: 01-02-2005, 15:31
  5. Firmware v1.8.1.7 CR2 [Oleg] - updated ( CR2a )
    By Oleg in forum WL-500g Firmware Releases
    Replies: 69
    Last Post: 08-12-2004, 11:01

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •