Page 2 of 2 FirstFirst 12
Results 16 to 21 of 21

Thread: Compiling [need HowTo]

  1. #16
    Quote Originally Posted by Oleg View Post
    JF, I'm now working on Perhaps there would be or something, which would be based (but includes fixes), as moving to is a big pain...
    JF, actually you should consider switching to OpenWRT, as it has web interface now.

    created a toolchain for native compilation use:
    ipkg install optware-devel

    as advised by al37919


    i get the following errors

    [admin@oo /opt]$ mipsel-uclibc-gcc -o helloworld
    -sh: mipsel-uclibc-gcc: not found
    [admin@oo /opt]$ /opt/broadcom/opt/brcm/hndtools-mipsel-uclibc-0.9.19/bin/mipsel-uclibc-gcc
    /opt/broadcom/opt/brcm/hndtools-mipsel-uclibc-0.9.19/bin/mipsel-uclibc-gcc: /opt/broadcom/opt/brcm/hndtools-mipsel-uclibc-0.9.19/bin/mipsel-uclibc-gcc: 1: Syntax error: "(" unexpected
    [admin@oo /opt]$ /opt/broadcom/opt/brcm/hndtools-mipsel-uclibc-0.9.19/bin/mipsel-uclibc-gcc --help
    /opt/broadcom/opt/brcm/hndtools-mipsel-uclibc-0.9.19/bin/mipsel-uclibc-gcc: /opt/broadcom/opt/brcm/hndtools-mipsel-uclibc-0.9.19/bin/mipsel-uclibc-gcc: 1: Syntax error: "(" unexpected
    [admin@oo /opt]$

    Any sollution for syntax error "(" ?

    And what directory is/was correct to save optware-devel
    and how to make


    running as
    only ?

    What is your solution ?

    Tried to install
    mkdir /opt
    cd /opt < enter >
    wget < enter >
    tar zxf ./ < enter >
    cp -R /opt/broadcom/opt/brcm /opt < enter >

    cd /var/tmp
    tar xjf wl500g-
    cd wl500g-
    make uClibc

    but was low on memory (2GB pendrive)
    and -j option didn't work.


    generates syntax error.

    I need Linux dialog to test some shell scripts.

    What's wrong, any help ?


  2. #17

    Strange problem!!

    I did many and many test looking at your guides and tutorial... I waste a lot of time but... the situation is that:

    1) Compiling helloworld.c with mipsel-uclibc-gcc -o hello hello.c
    I can obtain hello executable.
    If I run hello on the router I get
    "./hello: can't load library 'AP'"

    2) If after compiling I write mipsel-uclibc-ld hello
    I can obtain an a.out executable that works on the router.
    If I rename the file a.out -> hello on my PC then I go back to error shown on point 1.
    If I copy a.out to the router and then rename it as hello all works well!

    3) Compiling helloworld.c with mipsel-uclibc-gcc -static -o hello hello.c
    I can get hello executable but when I run it on the router I get segmentation fault...

    Please help! I'm becoming mad!

  3. #18
    Hi everyone,

    I tried already native compilation, but I didn't succed, so I gave cross compiling a try. I've booted my laptop with ubuntu intrepid and I followed Jean-Fabrice's tutorial, but it doesn't seem to be complete. I noticed, that on Oleg posted a new toolchain (uClibc 0.9.19), so I installed it as well. What I have so far is the following:
    1. The following extracted directories under /opt
    hndtools-mipsel-uClibc (this one is created by the new toolchain)

    2. The following extracted directories under /var/tmp

    I have a feeling that after the command "make uClibc" there are still things to do before we execute "mipsel-uclibc-gcc -o helloworld helloworld.c".
    When I ran the command "make uClibc", I got these errors:
    PHP Code:
    dp79@Perro:/var/tmp/wl500g- make uClibc
    tar xjf uClibc
    -0.9.19.tar.bz2 -/var/tmp
    for last applied patch
    ./patch.shline 19patchcommand not found
    ./patch.shline 19patchcommand not found
    ./patch.shline 19patchcommand not found
    ./patch.shline 19patchcommand not found
    ./patch.shline 19patchcommand not found
    /var/tmp/uClibc-0.9.19 with  uClibc-0.9.19-trunc64.patch uClibc-0.9.19-timezones.patch uClibc-0.9.19-dn_expand.patch uClibc-0.9.19-resolv.patch uClibc-0.9.19.diff
    ./patch.shline 33patchcommand not found
    ./patch.shline 37patchcommand not found
    Can not apply uClibc
    -0.9.19.diff cleanly
    : *** [/var/tmp/uClibcError 1 
    This "make" command created the "uClibc-0.9.19" directory, but nothing has been installed, because the system doesn't recognize the "mipsel-uclibc-gcc" command.

    Could somebody finish this tutorial and show us how to compile helloworld from the beginning to the end?



  4. #19

  5. #20

    Waoh...Fast answer...

    I've seen this site, but it is a tutorial for custom firmware and not a tutorial for installing software from source for the existing firmware...
    Or you meant, that the process is the same, but instead of the firmware tarball, I use the tarball of the target software?


  6. #21

    It would really help if there was some updated easy-to-understand how-to for cross-compiling own software.

    All of the current how-to instructions seem to be outdated or not complete.

Page 2 of 2 FirstFirst 12

Similar Threads

  1. Compiling firmware
    By unaiur in forum WL-500g Q&A
    Replies: 9
    Last Post: 30-09-2005, 09:24
  2. Compiling MusicPD
    By muffl0n in forum WL-500g Q&A
    Replies: 0
    Last Post: 20-07-2005, 20:03
  3. Compiling ggrab...
    By gwl in forum WL-500g Custom Development
    Replies: 11
    Last Post: 19-03-2005, 21:45
  4. Error while compiling ppp in
    By Ifaistos in forum WL-500g Custom Development
    Replies: 2
    Last Post: 12-01-2005, 17:03
  5. Compiling on/for the WL-500g
    By dsf260 in forum WL-500g Q&A
    Replies: 8
    Last Post: 12-12-2004, 10:54

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts