Results 1 to 11 of 11

Thread: 530 This FTP server is anonymous only.

  1. #1

    530 This FTP server is anonymous only.

    i have installed vsftpd (mascat)
    When i try to connect with smartftp to my ftp server(local ip 192.168.x.x)
    I get this message

    220 Welcome to the NSLU2 vsftp daemon.
    USER wilco
    530 This FTP server is anonymous only.
    Active Help: http://www.smartftp.com/support/kb/index.php/51
    QUIT
    221 Goodbye.
    Client closed the connection.

    This is my vsftpd.conf


    anonymous_enable=YES
    ftp_username=wilco
    # All Anonmyous Logins Are treated as Guests
    guest_enable=NO
    guest_username=wilco
    # User Control
    #no_anon_password=NO
    local_enable=NO
    write_enable=NO
    local_umask=022
    #anon_upload_enable=YES
    #anon_mkdir_write_enable=YES
    dirmessage_enable=YES
    # Activate logging of uploads/downloads.
    xferlog_enable=YES
    connect_from_port_20=YES
    #chown_uploads=YES
    #chown_username=wilco
    vsftpd_log_file=/opt/var/log/vsftpd.log
    # If you want, you can have your log file in standard ftpd xferlog format
    #xferlog_std_format=YES
    #idle_session_timeout=600
    # You may change the default value for timing out a data connection.
    #data_connection_timeout=120
    #nopriv_user=ftpsecure
    #async_abor_enable=YES
    #ascii_upload_enable=YES
    #ascii_download_enable=YES
    ftpd_banner=Welcome to the NSLU2 vsftp daemon.
    #deny_email_enable=YES
    #banned_email_file=/opt/etc/vsftpd.banned_emails
    #chroot_list_enable=NO
    #chroot_list_file=/opt/etc/vsftpd.chroot_list
    #ls_recurse_enable=YES
    #chroot_local_user=YES
    secure_chroot_dir=/opt/usr/share/empty/
    local_root=/tmp/harddisk/ftp/
    #listen=YES


    this is my nano /opt/etc/xinetd.d/vsftp


    # description: The vsftpd FTP server serves FTP connections.
    # it uses normal, unencrypted usernames and passwords for auth
    service ftp
    {
    disable = no
    socket_type = stream
    user = wilco
    server = /opt/sbin/vsftpd
    server_args = /opt/etc/vsftpd.conf
    wait = no
    nice = 10
    only_from = 0.0.0.0/0
    }

    What to do now??

    Thanks.

    Wilco,

  2. #2
    Join Date
    Feb 2005
    Location
    Zeist, Netherlands
    Posts
    47
    Hoi Wilco,

    van de MacSat vsftp-page:
    One of my readers have brought to my attention, that after following the guide, the ftp server kept rejecting him to login. He then reconnected his harddrive, and after that it worked. Maby worth a try if you are having problems getting it to work. Thanks to William de Wit for this input !
    Is een poging waard als je dat nog niet gedaan had.

    Maar eerst bij wijze van RTFM wat rondgezocht, en op
    http://www.vsftpdrocks.org/faq/ het volgende gevonden:
    Q) Help! Local users cannot log in.
    A) There are various possible problems.
    A1) By default, vsftpd disables any logins other than anonymous logins. Put
    local_enable=YES in your /etc/vsftpd.conf to allow local users to log in.
    A2) vsftpd tries to link with PAM. (Run "ldd vsftpd" and look for libpam to
    find out whether this has happened or not). If vsftpd links with PAM, then
    you will need to have a PAM file installed for the vsftpd service. There is
    a sample one for RedHat systems included in the "RedHat" directory - put it
    under /etc/pam.d
    A3) If vsftpd didn't link with PAM, then there are various possible issues. Is
    the user's shell in /etc/shells? If you have shadowed passwords, does your
    system have a "shadow.h" file in the include path?
    A4) If you are not using PAM, then vsftpd will do its own check for a valid
    user shell in /etc/shells. You may need to disable this if you use an invalid
    shell to disable logins other than FTP logins. Put check_shell=NO in your
    /etc/vsftpd.conf.
    Punt A4 kan ook van toepassing zijn.

    Uit diezelfde faq:
    Q) Help! Does vsftpd support virtual users?
    A) Yes, via PAM integration. Set "guest_enable=YES" in /etc/vsftpd.conf. This
    has the effect of mapping every non-anonymous successful login to the local
    username specified in "guest_username". Then, use PAM and (e.g.) its pam_userdb
    module to provide authentication against an external (i.e. non-/etc/passwd)
    repository of users.
    Note - currently there is a restriction that with guest_enable enabled, local
    users also get mapped to guest_username.
    There is an example of virtual users setup in the "EXAMPLE" directory.

    Q) Help! Does vsftpd support different settings for different users?
    A) Yes - in a very powerful way. Look at the setting "user_config_dir" in the
    manual page.
    Ik ben benieuwd!

    Groet, Jaap.
    0'14/22
    Last edited by jaaput; 25-09-2005 at 10:03.

  3. #3
    Heb check_shell=NO toegevoegd aan de vsftpd.config.
    Nu kan ik inloggen met mijn username en wachtwoord van mijn router.
    Nu wil ik alleen nog ander gebruikers en rechten toevoegen.

    heb al een vsftpd.user_list aangemaakt.

    userlist_enable

    If enabled, vsftpd will load a list of usernames, from the file-
    name given by userlist_file. If a user tries to log in using a
    name in this file, they will be denied before they are asked for
    a password. This may be useful in preventing cleartext passwords
    being transmitted. See also userlist_deny

    Heb in vsftpd.user_list een usernaam test een gemaakt, maar kan ik hier geen wachtwoord opgeven dan? Snap niet precies wat de ze bedoel als je de userlist_enable leest. Lijkt er bijna op dat de namen die er in staan worden geblocked? Dit is het effect.

    220 Welcome to the NSLU2 vsftp daemon.
    USER test
    331 Please specify the password.
    PASS (hidden)
    530 Login incorrect

    dit is trouwens mijn vsftpd.conf


    anonymous_enable=NO
    ftp_username=wilco
    # All Anonmyous Logins Are treated as Guests
    guest_enable=NO
    guest_username=wilco
    userlist_enable=YES
    userlist_deny=NO
    userlist_file=/opt/etc/vsftpd.user_list
    # User Control
    #no_anon_password=NO
    local_enable=YES
    write_enable=YES
    local_umask=022
    anon_upload_enable=YES
    anon_other_write_enable=NO
    #anon_mkdir_write_enable=YES
    dirmessage_enable=YES
    # Activate logging of uploads/downloads.
    xferlog_enable=YES
    connect_from_port_20=YES
    #chown_uploads=YES
    #chown_username=wilco
    chmod_enable=NO
    download_enable=YES
    #vsftpd_log_file=/opt/var/log/vsftpd.log
    # If you want, you can have your log file in standard ftpd xferlog
    #format
    #xferlog_std_format=YES
    #idle_session_timeout=600
    # You may change the default value for timing out a data connection.
    #data_connection_timeout=120
    #nopriv_user=ftpsecure
    #async_abor_enable=YES
    #ascii_upload_enable=YES
    #ascii_download_enable=YES
    ftpd_banner=Welcome to the NSLU2 vsftp daemon.
    #deny_email_enable=YES
    #banned_email_file=/opt/etc/vsftpd.banned_emails
    #chroot_list_enable=NO
    #chroot_list_file=/opt/etc/vsftpd.chroot_list
    #ls_recurse_enable=YES
    chroot_local_user=YES
    secure_chroot_dir=/tmp/harddisk/ftp/
    local_root=/tmp/harddisk/ftp/
    #listen=YES
    check_shell=NO

    Thanks.

  4. #4
    http://www.linuxquestions.org/questi...27#post1793427


    dit verklaart volgens mij al meer, maar ja de tijd is weer op.

    mzzl.

  5. #5
    een username en wachtwoord aanmaken is gelukt hoor.
    Lees dit maar.
    http://wl500g.info/showthread.php?t=...light=add+user
    Later even kijken of we een username en wacht woord in een directorie kunnen opsluiten.

    mzzl.

    wilco,

  6. #6
    Hmm, vreemd genoeg kan ik met mijn standaard wachtwoord niet meer inloggen. Moest alles reseten?!?!?
    Denk dat het te maken heeft met het getal 1000 volgens mij is dat iets van Debian, misschien weet iemand dat.

    Toen heb ik adduser geinstalleer.

    ipkg install adduser

    Dan kun je eenvoudig een username aanmaken.

    adduser -h /tmp/harddisk/part1/XXXX/download wilcoX

    wilcoX is dan de username daarna wordt direct gevraagd voor een wachtwoord.

    username en wachtwoord zijn dan actief.
    Dan vsftpd.conf verandert

    chroot_list_enable=YES
    chroot_list_file=/opt/etc/vsftpd.chroot_list
    chroot_local_user=NO
    #local_root=/tmp/harddisk/

    Alle gebruikers die in de lijst van vsftpd.chroot_list voor komen, worden vast gezet in hun home dir. Zodat ze niet in ander dir kunnen komen.

    Dus ik heb wilcoX er in gezet als je dan inlogt met ftp dan wordt je naar
    /tmp/harddisk/part1/XXXX/download
    gebracht perfect dus.

    Je moet alleen zorgen dat alle gebruikers hier instaan.
    Nu alleen nog even kijken hoe je write en read toekent, volgens mij moet je
    dan de bestanden met chmod bewerken.
    Het zou mooi zijn als je per gebruiker dan kan bepalen.
    Is dat mogelijk ? Lijkt mij wel met chmod.

    thanks.

  7. #7
    Die nieuwe gebruiker werkt, maar die kan alleen maar downloaden.
    Kan iemand mij vertellen hoe ik hem upload permissie kan geen.
    Execute, write??

    HELP!!!!!!!!

    wilco,

  8. #8
    Join Date
    Feb 2005
    Location
    Zeist, Netherlands
    Posts
    47
    Hoi Wilco,

    voor upload-bevoegdheid is het zeer waarschijnlijk vereist dat je
    user wilcoX write-permissie geeft op de directories waarin je
    hem bestanden wilt laten plaatsen, dus in dit geval de dir
    /tmp/harddisk/part1/XXXX/download
    Nu is dat ook zijn homedir, en als die dir is aangemaakt
    door het adduser-command is het zeer waarschijnlijk dat dit
    al goed staat, maar als die directory reeds bestond ten tijde van
    de adduser kan het heel wel zijn dat wilcoX niet de owner is,
    en daarmee dan waarschijnlijk hooguit leesrechten heeft.
    Het handigst is dan om hem maar owner te maken van die directory
    en alle bestanden hierbinnen, m.b.v.
    Code:
    chown -R wilcoX /tmp/harddisk/part1/XXXX/download
    Check daarna even of de owner daadwerkelijk schrijfrechten heeft.
    En als je die rechten gaat wijzigen, wees er dan op bedacht dat
    je om directories te mogen benaderen het execute-recht nodig hebt.
    Bij chmod kun je dat directory-recht opgeven als een hoofdletter X,
    zodat je niet perse ook alle bestanden executable hoeft te maken
    en toch met 1 opdracht alles in een directory kunt zetten:
    Code:
    chmod -R u=rwX,g=rX,o= /tmp/harddisk/part1/XXXX/download
    Uiteraard kun je na de o= ook wat rechten toekennen, deze gelden voor
    other users, dus alle users anders dan de owner en de users uit de owning group.
    Ben benieuwd....

    Groet, Jaap
    9'1/180
    Last edited by jaaput; 03-10-2005 at 21:08.

  9. #9
    He jaaput,

    Dit had ik al voor elkaar gekregen.
    Op een en ander manier kan ik de /tmp/etc fat32
    niet aanpassen met chown en chmod.
    De /opt/etc ext2 lukt wel?
    Heb nu vsftdp aangepast dat de directories op /opt/etc staan.
    Kan nu rechten toewijzen.
    Maar ik wil nu een gebruiker alleen read acces geven en hij mag dan ook nog uploaden. Maar dat krijg ik niet voor elkaar.
    Upload wil wel, maar dan kan hij ook direct mappen wissen etc.

    heb dus chmod -R 770 /opt/share/ftp/upload gedaan maar ja dan kan
    de gebruiker alles en dat wil ik eigenlijk niet.

    Toen dacht ik dat ik ik het misschien zo kan doen.
    chmod u=rWX /opt/share/ftp/upload zodat de directorie alleen write en executble is.
    chmod: invalid mode: u=rWX
    maar dat wil dus niet.

    Enige idee hoe ik nou een gebruiker rechten geeft tot het aanmaken dir.
    en het uploaden van bestanden. Maar hij mag beslist niks wissen.

    thanks.

    wilco,

  10. #10
    Join Date
    Feb 2005
    Location
    Zeist, Netherlands
    Posts
    47
    Hoi Wilco,

    dat je de bestanden en directories op de vfat-partitie niet kunt
    wijzigen qua bestandsrechten kan kloppen, vfat ondersteunt
    dat niet. ext3 wel, en daarom lukt het daar wel. vfat kent
    enkel de aanduiding read-only, maar geen owner/group
    en gescheiden rechten daarbij. ntfs is wat dat betreft een
    stuk uitgebreider, en dat kent ook de combinatie die jij wilt
    toekennen, maar helaas, de ntfs-support onder linux geldt
    nog als experimenteel, en ik weet niet of de Asus hem
    uberhaupt ondersteunt.
    Als je je met ext3 moet redden, is de enige mogelijkheid
    denk ik dat je de beperking via vsftp uitoefent. Ik geloof dat
    je daarin ergens kunt opgeven welke commando's een gebruiker
    mag uitvoeren, en als je de delete-commando's (rm / rmdir?)
    niet toestaat bereik je in ieder geval dat een gebruiker via ftp
    niet kan deleten.

    De invalid mode voor rWX komt overigens door de hoofdletter W,
    enkel de x kent onderscheid tussen hoofd- en kleine letter,
    de r en de w niet. Als je geen read-access wilt toekennen
    moet je de r gewoon weglaten. Idem voor de write.
    En het write-recht impliceert het delete-recht.
    Dus de combinatie die je wilt bereiken kan met enkel de ext3
    mogelijkheden gewoonweg niet...

    Maar zoals gezegd, je kunt in vsftp wat beperkingen op de
    commando-set leggen.

    Groet, Jaap.
    10'2/236

  11. #11
    Thanks,

    Zal hier is verder inzoekken, wel jammer.
    had verwacht dat je het iets makkelijker kon regelen.
    "even" snel een ander gebruiker aanmaken zit er niet echt in.
    Hopelijk komt er nog een een gui voor die vanuit windows kan gebruiken. lol.

    mzzl.

    wilco,

Similar Threads

  1. Disable anonymous FTP access
    By herve81 in forum WL-HDD Q&A
    Replies: 4
    Last Post: 14-12-2007, 10:55
  2. Replies: 10
    Last Post: 11-04-2005, 23:09
  3. Replies: 0
    Last Post: 20-05-2004, 17:57
  4. Setting access rights for anonymous FTP user
    By Styno in forum WL-500g Custom Development
    Replies: 1
    Last Post: 09-04-2004, 23:02

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •