Results 1 to 8 of 8

Thread: NFS Server not working

  1. #1

    Unhappy NFS Server not working

    Hi, I wanted to mount my WL-HDD (Latest Oleg) with my dBox but it didn't work. So I started up my knoppix and tried, but again no response. I always get RPC Timed Out.
    In another thread I read that NFS mounting only works with Gateway Mode, but this didn't work for me, so I switched back to Access Point Mode because I want to use my WL-HDD as a brigde.

    I also made a tcpdump with my knoppix during a mount (Knoppix =, WLHDD = 0.7)

    14:20:20.219088 IP > S 1583149472:1583149472(0) win 5840 <mss 1460,sackOK,timestamp 2237106 0,nop,wscale 2>
    14:20:20.359677 IP > S 2746440209:2746440209(0) ack 1583149473 win 5792 <mss 1460,sackOK,timestamp 30187 2237106,nop,wscale 0>
    14:20:20.359808 IP > . ack 1 win 1460 <nop,nop,timestamp 2237111 30187>
    14:20:20.219629 IP > P 1:45(44) ack 1 win 1460 <nop,nop,timestamp 2237115 30187> [|msdp]
    14:20:20.223432 IP > . ack 45 win 5792 <nop,nop,timestamp 30188 2237115>
    14:20:20.225321 IP > P 1:293(292) ack 45 win 5792 <nop,nop,timestamp 30188 2237115> [|msdp]
    14:20:20.225402 IP > . ack 293 win 1728 <nop,nop,timestamp 2237120 30188>
    14:20:20.225627 IP > F 45:45(0) ack 293 win 1728 <nop,nop,timestamp 2237121 30188>
    14:20:20.225983 IP > UDP, length: 96
    14:20:20.232409 IP > F 293:293(0) ack 46 win 5792 <nop,nop,timestamp 30189 2237121>
    14:20:20.232472 IP > . ack 294 win 1728 <nop,nop,timestamp 2237128 30189>
    14:20:23.226129 IP > UDP, length: 96
    14:20:26.226612 IP > UDP, length: 96
    14:20:29.227161 IP > UDP, length: 96
    14:20:32.227712 IP > UDP, length: 96
    14:20:35.228247 IP > UDP, length: 96
    14:20:38.228796 IP > UDP, length: 96


    # automagically generated from web settings
    /tmp/harddisk/filme *(rw,async,no_root_squash)
    Module                  Size  Used by
    nfsd                   92992   1
    lockd                  64196   1 [nfsd]
    sunrpc                 83456   1 [nfsd lockd]
    usb-storage            62144   0 (unused)
    sd_mod                 13268   0 (unused)
    scsi_mod               70176   1 [usb-storage sd_mod]
    audio                  50120   0 (unused)
    soundcore               5280   0 [audio]
    printer                12652   0 (unused)
    usb-ohci               21764   0 (unused)
    usbcore                77224   1 [usb-storage audio printer usb-ohci]
    wl                    420904   0 (unused)
    et                     34912   0 (unused)
    ide-disk               13524   2
    ide-probe-mod          11468   0
    ide-mod               109568   2 [ide-disk ide-probe-mod]
      PID  Uid     VmSize Stat Command
        1 admin       508 S   /sbin/init
        2 admin           SW  [keventd]
        3 admin           SWN [ksoftirqd_CPU0]
        4 admin           SW  [kswapd]
        5 admin           SW  [bdflush]
        6 admin           SW  [kupdated]
        7 admin           SW  [mtdblockd]
       39 admin       244 S   telnetd
       43 admin       376 S   httpd
       48 admin       300 S   klogd
       49 admin       344 S   syslogd -m 0 -O /tmp/syslog.log -S -l 7
       50 admin           SW  [khubd]
       56 admin       276 S   lpd
       58 admin       240 S   p9100d -f /dev/usb/lp0 0
       61 admin       296 S   waveservermain
       71 1           344 S   /usr/sbin/portmap
       73 admin           SW  [nfsd]
       75 admin           SW  [lockd]
       76 admin           SW  [rpciod]
       77 admin       528 S   /usr/sbin/mountd
       80 admin       276 S   infosvr br0
       81 admin       460 S   watchdog
       83 admin       284 S   ntp
       91 admin       388 S   dropbear
       92 admin       728 S   dropbear
       96 admin           SW  [kjournald]
       98 admin       336 S   stupid-ftpd
      100 admin       828 S   /usr/sbin/nmbd -D
      102 admin       524 S   -sh
      104 admin       688 S   /usr/sbin/smbd -D
      109 admin       736 S   dropbear
      111 admin       556 S   -sh
      117 admin       392 R   ps
    I use this command for mounting on Knoppix and dbox:
    root@1[knoppix]# mount -t nfs /mnt
    mount: RPC: Wartezeit abgelaufen (Timed out)

  2. #2
    Join Date
    Dec 2003
    Russian Federation
    Do you've portmap running on the knoppix system?
    NFS should work fine in the AP mode too. Also, check that
    works on the wl500g - no timeouts, etc.

  3. #3
    nslookup gives me after some time:
    [admin@wl-hdd root]$ nslookup
    *** Unknown host
    *** Unknown host
    portmap is running on knoppix, but it doesn't work on the dbox either...

  4. #4
    After reseting to factory defaults, it is working now.

    Thanks for your help!

  5. #5

    JOCKYW's NFS with r/wsize > 8192?


    i use the WL-HDD together with my DBOX2 for streaming video.
    Therefore i set up the WL-HDD like described at except, that i only use
    the NFS server part (the parts '# start FTP daemon' and '# start Samba 3.0.9 daemon' are completely commented out).
    Everything works fine as i expected with one little exception:
    if i mount the NFS directory on the WL-HDD from my DBOX2, the WL-HDD seems to refuse rsize and wsize greater than 8192.
    Is there a version of the NFS available supporting these sizes greater than 8192? If yes, which files has to be replaced?

    Thanks in advance...

  6. #6

    NFS not working anymore after subnet changed

    Hi everyone who reads this!

    I have an Yakumumo aka Asus WL-HDD with Olegs Firmware on it running as a DHCP client in AP Mode, it only has one IP and though it gets the IP via DHCP it is always the same IP.

    I had Samba and NFS running fine on this little bugger, until i changed from a Fritz!Box router to a DLINK router.

    The Subnet has changed: Was 192.186.178.* and now is 192.168.0.* , so i changed the clients IP in the NFS exports. But since i am running the new network, i could not mount the NFS share once. It worked nicely and mounted much quicker than smb before i changed routers.

    Also, when i connect via telnet the time to login has become much longer.

    smb, ftp, ssh and twonkymedia still work, only nfs is not present anymore.

    I don’t know too much about NFS so i did some searching and tried the following:

    Claudia:~ jottzeh$ showmount -e
    RPC: Timed out: Can't do Exports rpc
    Claudia is the Mac running 10.4.9 Tiger and is the WL-HDD.


    [admin@Nirvana root]$ showmount -e
    mount clntudp_create: RPC: Port mapper failure - RPC: Timed out
    Nirvana is the WL-HDD.


    [admin@Nirvana root]$ showmount -e
    rpc mount export: RPC: Timed out

    [admin@Nirvana root]$ showmount -e    
    rpc mount export: RPC: Timed out
    I have searched every config-file and etc-directory i could find on the Asus, but there is nothing that is related to the old subnet.

    So what can i do? Do i need to configure RPC? I can’t remeber having done that the first time it worked. I can’t find WL-HDD related information about RCP either.

    I have tried tons of options to do the export, but non worked.

    /opt/Nirvana *(rw,insecure,all_squash,sync,anonuid=0)
    etc etc
    So what could be wrong or what could i do to check what is wrong?


  7. #7
    Same problem here.

    I have wl-hdd and I was installed stuff on it (flash with wl500g-clear-nvram.trx then with WLHDD- at work (net
    I did not have a chance to test nfs at work but everithing else was ok (ssh, enhanced-ctorrent + sctcs, ftp ...).
    At home i have subnet and nfs is not working (I'm trying to mount from dreambox dm500).
    The export is:/opt/dream *(rw,async,no_root_squash)
    Last edited by vladut; 30-05-2007 at 14:01.

  8. #8
    I have discovered one thing:
    For nfs mounting to work, portmap must be started on the NFS client.
    If you don't start it (or if you can not start it because it is not there - like in dreambox dm500) mounting will hung for few minutes or more.
    NFS without portmap can be done using nolock option (mount -o nolock ....)
    It works with busybox as well.
    I have not test it yet at home (it works with wl-hdd and linux client without portmap started) but I will do that this evening.
    In some cases the mount thing may work if you have a line in your /etc/hosts file for each computer/device involved.
    Btw, in this file it is one record that is wrong and remain there even if the wl-hdd IP is in other subnet!!!

Similar Threads

  1. Nylon socks server compiled and working
    By Jean-Fabrice in forum WL-500g Custom Development
    Replies: 19
    Last Post: 28-05-2009, 22:37
  2. WWW virtual server working but FTP not why?
    By Satleecher in forum WL-500g Q&A
    Replies: 5
    Last Post: 25-09-2004, 21:46
  3. Replies: 0
    Last Post: 16-09-2004, 10:46
  4. Replies: 0
    Last Post: 20-05-2004, 17:57
  5. Port Forwarding cq Virtual Server not working?
    By Antiloop in forum WL-500g Q&A
    Replies: 1
    Last Post: 09-12-2003, 09:04

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts