Page 2 of 5 FirstFirst 1234 ... LastLast
Results 16 to 30 of 68

Thread: Huawei E3121(320s)/E3131(420s/d)/E303(Hi-Link) от МТС/Билайн и роутер Asus

  1. #16

    2 lhog

    В прошивке Энтузиастов можно указать своё правило для usbmodeswitch в zero cd configuration
    Это решит проблему переключения, остальное должно сработать на автомате.
    В прошивке от Асус модем используется как резервное соединение, и если он правильно переключается, но не поднимает драйвера, то скорее всего либо в настройках заблокировано резервное соединение, либо что то есть в ван порту.
    ASUS RT-N66U <RT-N66U_3.0.0.4_260.21.trx>
    ASUS RT-N16 <RT-N16-1.9.2.7-rtn-r4643.trx>
    D-Link DIR-320, Huawei E1820, E392 <DIR320-1.9.2.7-rtn-r4667M.trx>

    Как я настраивал Макет нового WEB интерфейса Для iPhone/iPad

  2. #17
    Какая версия прошивки от энтузиастов использовалась на wl500gp и rt-n10u?

  3. #18
    Добрый день!

    Спасибо за ответы.

    2 dlukanidin)

    Это решит проблему переключения, остальное должно сработать на автомате.
    usb_modeswitch на прошивке энтузиастов у меня отработал как раз на отлично. Об этом свидетельствует то, что модем переключился в режим 12d1:1506 (zero-cd режим - 12d1:155b). Т.е. правило http://code.google.com/p/wl500g/sour...svn4751&r=4732 сработало. Вот что не сработало так это появление ttyUSB нодов, которые автоматически появлялись в десктопном линуксе и в родной прошивке ASUS RT-N10U после выполнения
    Code:
    usb_modeswitch -v 12d1 -p 155b -P 1506 -V 12d1 -M "55534243123456780000000000000011062000000100000000000000000000"

    В прошивке от Асус модем используется как резервное соединение, и если он правильно переключается, но не поднимает драйвера, то скорее всего либо в настройках заблокировано резервное соединение, либо что то есть в ван порту.
    С оригинальной прошивкой другая беда. usb_modeswitch там есть, но скриптов по автоматическому переключению нету. То есть нету самомго переключения из Zero-CD в модем. Приходится делать переключение вручную, после чего соединение (3G) устанавливается автоматически и всё работает хорошо до следующего выключения питания роутера.

    2 dimez)

    Я в оригинальном посте написал, но наверное не четко:
    • 1.9.2.7-rtn-4772/WL500gP
    • 3.0.0.4.260/RT-N10U


    Upd. RT-N10U вместе с модемом сегодня уехал на дачу, вместе с инструкцией как "запустить" модем первый раз после включения питания, поэтому мои возможности по тестированию теперь ограничены. Тем не менее я бы хотел избавиться от полу-автоматического режима в штатной прошивке, для чего открыл кейс у разработчиков firmware-mod-kit http://code.google.com/p/firmware-mo...s/detail?id=82

    Как только станет ясно почему перепакованную их тулзами прошивку отказывается воспринимать роутер, я попробую чуть подпатчить оригинальный firmware. Или как вариант может совсем под дурачка попробовать написать в службу поддержки ASUS может они добавят все правила usb_modeswitch и скрипт hotplug сами в следующей прошивке?
    Last edited by lhog; 28-12-2012 at 19:12.

  4. #19
    Quote Originally Posted by lhog
    С оригинальной прошивкой другая беда. usb_modeswitch там есть, но скриптов по автоматическому переключению нету. То есть нету самомго переключения из Zero-CD в модем. Приходится делать переключение вручную, после чего соединение (3G) устанавливается автоматически и всё работает хорошо до следующего выключения питания роутера.

    2 dimez)

    Я в оригинальном посте написал, но наверное не четко:
    • 1.9.2.7-rtn-4772/WL500gP
    • 3.0.0.4.260/RT-N10U


    Upd. RT-N10U вместе с модемом сегодня уехал на дачу, вместе с инструкцией как "запустить" модем первый раз после включения питания, поэтому мои возможности по тестированию теперь ограничены. Тем не менее я бы хотел избавиться от полу-автоматического режима в штатной прошивке, для чего открыл кейс у разработчиков firmware-mod-kit http://code.google.com/p/firmware-mo...s/detail?id=82
    Как только станет ясно почему перепакованную их тулзами прошивку отказывается воспринимать роутер, я попробую чуть подпатчить оригинальный firmware. Или как вариант может совсем под дурачка попробовать написать в службу поддержки ASUS может они добавят все правила usb_modeswitch и скрипт hotplug сами в следующей прошивке?
    попробуй после подключения модема сделать

    Code:
    mdev -s
    должно помочь

  5. #20
    Quote Originally Posted by staticroute View Post
    попробуй после подключения модема сделать

    Code:
    mdev -s
    должно помочь
    Прошу прощения, а на каком из роутеров? И даст ли указанная команда постоянный эффект, т.е. сохраниться ли эффект после power cycle? Просто временное решение уже есть: usb_modeswitch с параметрами как в прошлом сообщении.

  6. #21
    Quote Originally Posted by lhog View Post
    Прошу прощения, а на каком из роутеров? И даст ли указанная команда постоянный эффект, т.е. сохраниться ли эффект после power cycle? Просто временное решение уже есть: usb_modeswitch с параметрами как в прошлом сообщении.
    разумеется на wl-500gP

    нет конечно, придется каждый раз при втыкании / вытыкании - делать эту команду - вообще подобный глюк с непоявлением устройств у меня был (правда просто флешек, а не /dev/ttyUSB0) - я его вылечил полным сбросом роутера и настройкой с нуля.

  7. #22
    Quote Originally Posted by staticroute View Post
    разумеется на wl-500gP

    нет конечно, придется каждый раз при втыкании / вытыкании - делать эту команду - вообще подобный глюк с непоявлением устройств у меня был (правда просто флешек, а не /dev/ttyUSB0) - я его вылечил полным сбросом роутера и настройкой с нуля.
    Ок, в следующий раз возьму домашний роутер (500gp) с собой и попробую. Хотя всё это "ручное управление" не дело конечно.

    Вот кстати что-то похожее http://www.draisberghof.de/usb_modes...opic.php?t=794 Только там у человека заработало после перевтыкания физического, у меня же вообще никак. Я в целом конечно знаю линукс крайне плохо, может кто в курсе кто именно создает ttyUSB устройство при его включении?

    Как я понял за день гугления это либо скрипты udev на ББ, либо скрипты(?) hotplug на embedded systems. По крайней мере в прошивке ASUS в файле hotplug2.rules (пишу по пямяти) наблюдал что-то похожее на процесс создания нодов ttyUSB. Перезагружусь по-позже в линукс сделаю апдейт в пост.

  8. #23
    Quote Originally Posted by lhog View Post
    Ок, в следующий раз возьму домашний роутер (500gp) с собой и попробую. Хотя всё это "ручное управление" не дело конечно.


    Вот кстати что-то похожее http://www.draisberghof.de/usb_modes...opic.php?t=794 Только там у человека заработало после перевтыкания физического, у меня же вообще никак. Я в целом конечно знаю линукс крайне плохо, может кто в курсе кто именно создает ttyUSB устройство при его включении?

    Как я понял за день гугления это либо скрипты udev на ББ, либо скрипты(?) hotplug на embedded systems. По крайней мере в прошивке ASUS в файле hotplug2.rules (пишу по пямяти) наблюдал что-то похожее на процесс создания нодов ttyUSB. Перезагружусь по-позже в линукс сделаю апдейт в пост.
    вы новую прошивку накатывали на асусовскую или после олеговской 2.4.20 ?

    советую сделать резет всех настроек и настроить с нуля - мне лично помогло.

    на конкретно прошивке энтузиастов udev нету, там mdev.

    кроме того, есть возможность использовать свой скрипт hotplug, расположенный в /usr/local/sbin/hotplug.sh

    для этого нужно будет сделать при старте:
    Code:
    /bin/echo "/usr/local/sbin/hotplug.sh" >> /proc/sys/kernel/hotplug
    Last edited by staticroute; 28-12-2012 at 21:30.

  9. #24
    Quote Originally Posted by staticroute View Post
    вы новую прошивку накатывали на асусовскую или после олеговской 2.4.20 ?

    советую сделать резет всех настроек и настроить с нуля - мне лично помогло.

    на конкретно прошивке энтузиастов udev нету, там mdev.

    кроме того, есть возможность использовать свой скрипт hotplug, расположенный в /usr/local/sbin/hotplug.sh

    для этого нужно будет сделать при старте:
    Code:
    /bin/echo "/usr/local/sbin/hotplug.sh" >> /proc/sys/kernel/hotplug
    У меня два роутера:
    • Один - старый домашний wl500gp, там уже 100 лет как работает "Олег", в связи с тем что там не заработал 3G модем я его обновил до последней энтузиастской прошивки 4772.
    • Второй - совсем новый rt-n10u (уже уехал к тёще на дачу). Там была штатная прошивка 2.x.x.x.x которую я обновил до последней 3.y.y.y.y с сайта ASUS. Прошивки энтузиастов там никогда не было, испугался брикнуть девайс и не успеть к моменту отъезда с починкой, хотя конечно надо было рискнуть и попробовать...


    Т.е. советуете прошить новый rt-n10u энтузиастами, сбросить настройки и посмотреть взлетит ли?

    Меня что смущает, я ведь почти тоже самое и сделал, только со старым роутером (500gp). Там нет проблемы с flip-flop 3G модема в этом я уверен на 99%. Из трех линукс устройств (мой десктоп debian, wl500gp, rt-n10u) автоматический переворот не сработал только на rt-n10u и то только потому что там нету соответствующих скриптов из комплекта usb_modswitch-data. На остальных устройствах, включая wl500gp+энтузиасты, всё перевернулось - сужу по правильному USB Product ID - 1506. Засада состоит в том, что опять же из трех устройствах Linux только на "энтузиастах" автоматом не создались ноды,- в которые можно слать модемные AT команды - ttyUSB.

    P.S. Насчет mdev спасибо. Я читал, что udev слишком тяжелый для встраеваемых систем, но чем его заменили не знал. А скрипты udev типа этого http://code.google.com/p/wl500g/sour...h.rules?r=4528 совместимы с mdev?

    Еще вопрос. А что тогда есть hotplug2. В описании сказано что это lightweight замена udev. То есть, по сути mdev и hotplug2 это два разных решения одной и той же проблемы (условно говоря "udev для бедных")?

  10. #25
    Погуглил тут на тему mdev и ttyUSB, действительно пишут что помогает mdev -s, то есть пересканирование устройств. Не понятно в этой ситуации, почему установка других модемов успешно порождает ttyUSB и соответственно всё работает, а у меня какой-то затык. В чем собственно состоит разница? Или может быть в прошивке энтузиастов коммуникация идет не через ttyUSB?

    Вот еще тема от какого-то китайца. У него та же самая проблема, только он переворачивает вручную, а у меня на энтузиастской это происходит автоматом. http://www.draisberghof.de/usb_modes...opic.php?t=695

  11. #26
    Quote Originally Posted by lhog View Post
    У меня два роутера:
    • Один - старый домашний wl500gp, там уже 100 лет как работает "Олег", в связи с тем что там не заработал 3G модем я его обновил до последней энтузиастской прошивки 4772.
    • Второй - совсем новый rt-n10u (уже уехал к тёще на дачу). Там была штатная прошивка 2.x.x.x.x которую я обновил до последней 3.y.y.y.y с сайта ASUS. Прошивки энтузиастов там никогда не было, испугался брикнуть девайс и не успеть к моменту отъезда с починкой, хотя конечно надо было рискнуть и попробовать...


    Т.е. советуете прошить новый rt-n10u энтузиастами, сбросить настройки и посмотреть взлетит ли?

    Меня что смущает, я ведь почти тоже самое и сделал, только со старым роутером (500gp). Там нет проблемы с flip-flop 3G модема в этом я уверен на 99%. Из трех линукс устройств (мой десктоп debian, wl500gp, rt-n10u) автоматический переворот не сработал только на rt-n10u и то только потому что там нету соответствующих скриптов из комплекта usb_modswitch-data. На остальных устройствах, включая wl500gp+энтузиасты, всё перевернулось - сужу по правильному USB Product ID - 1506. Засада состоит в том, что опять же из трех устройствах Linux только на "энтузиастах" автоматом не создались ноды,- в которые можно слать модемные AT команды - ttyUSB.

    P.S. Насчет mdev спасибо. Я читал, что udev слишком тяжелый для встраеваемых систем, но чем его заменили не знал. А скрипты udev типа этого http://code.google.com/p/wl500g/sour...h.rules?r=4528 совместимы с mdev?

    Еще вопрос. А что тогда есть hotplug2. В описании сказано что это lightweight замена udev. То есть, по сути mdev и hotplug2 это два разных решения одной и той же проблемы (условно говоря "udev для бедных")?
    На wl500gp сбросьте настройки и перенастройте заново - возможно взлетит модем.

    Вообще rtn для 500gX не желательно юзать, так как при нагрузке тупо локальной сети начинаются проблемы (читайте тред о проблемах R1 роутеров на -rtn прошивке). Проблемы возникают, если качаете со скоростью > 5-6 mbyte/sec с локальной сети или интернета это в общем-то неважно.

    Насчет mdev и его хотплага не подскажу, надо рыть гугл, но существует возможность задать свой хотплаг обработчик, выше я уже описал как.

    RT-N10U поддерживается энтузиастами, см. http://code.google.com/p/wl500g/wiki/Devices

  12. #27
    Купил данный роутер, поставил прошивку RT-N10-1.9.2.7-rtn-r4772, но не хочет работать 3г модем МТС huawei e3121 (он же 320S).
    Хотелось бы узнать, решаема ли эта проблема?)))

  13. #28
    Приветствую сообщество!
    Расскажу о своей войне с девайсами Asus rt-n10u_b + Huawei E3131 (MTS 420D).
    Столкнулся с той-же проблемой, что и автор поста, а конкретнее - отсутствие устройств /dev/ttyUSB*
    Прошел весь путь от изучения usb_modswitch (не требовалось) до граблей с modprobe, который искал модуль usbserial в отсутствующем каталоге /opt/lib/modules/$kernel.
    Мопед успешно переключался из режима ZeroCD самостоятельно, а дальше нулевой эффект.
    Пытался ремаунтить корень в режим записи, чтоб вручную добавить модули из modules-1.9.2.7-rtn-r4923-MIPS32r2.tgz, но бестолку.
    Предполагая, что разрабы забыли положить необходимые модули в /opt, самостоятельно скомпилил из сорцов билд 5010, и там те-же грабли - /opt пуст.
    Уже в сотый раз разглядывая вывод `mount`
    Code:
    rootfs on / type rootfs (rw)
    /dev/root on / type squashfs (ro)
    proc on /proc type proc (rw)
    sysfs on /sys type sysfs (rw)
    devfs on /dev type tmpfs (rw,noatime)
    devpts on /dev/pts type devpts (rw)
    tmpfs on /tmp type tmpfs (rw,noatime)
    usbfs on /proc/bus/usb type usbfs (rw)
    и `df -h`
    Code:
    Filesystem                Size      Used Available Use% Mounted on
    rootfs                    4.5M      4.5M         0 100% /
    /dev/root                 4.5M      4.5M         0 100% /
    devfs                   100.0K      4.0K     96.0K   4% /dev
    tmpfs                    14.3M    192.0K     14.1M   1% /tmp
    меня осенило воспользоваться следующими командами:
    Code:
    mount -o bind /tmp /opt
    mkdir -p /opt/lib/modules
    mount -o bind /lib/modules /opt/lib/modules
    insmod usbserial vendor=0x12d1 product=0x1506
    И чудо свершилось:
    Code:
    $ ls -1 /dev/ttyUSB*
    /dev/ttyUSB0
    /dev/ttyUSB1
    /dev/ttyUSB2
    Дальше из вебморды кнопку "Connect" и пинги побежали до 8.8.8.8
    Тут бы успокоиться и лечь спать, но требовалось закрепить результат.
    Делаю ребут роутеру, и оказываюсь в легком шоке - соединение поднялось без доп.пинков.
    Делаю ребут на холодную - соединение как феникс воскрешается.
    Откатываюсь на прошивку r4923, делаю сброс на "заводские настройки".., та-же комедия.
    Во время последних процедур я только настраивал WAN и строку инициализации с номером дозвона, и ни каких танцев с бубном для появления ttyUSB.
    И если ранее я понимал почему оно не работает, то теперь ухожу спать с непониманием как оно работает, и мыслями как его "убить" )). (не пробовал окирпичить, мож поможет)
    Как-бы думал, что придется собственный скриптик написать с волшебными командами для воскрешения ttyUSB после ребутов, а приходится ваять это сообщение.
    И мое приветствие разрабам... Мужики, как по-вашему надо добавлять отсутствующие модули в тот момент когда весь корень ридонли и ремаунту не поддается? (при условии, что USB-port в единственном количестве и занят модемом, а соответственно о внешних носителях можно не вспоминать)

  14. #29
    Join Date
    Mar 2009
    Location
    Russia, Moscow
    Posts
    2,116
    Blog Entries
    33

    Huawei E3131 & CDC Ethernet

    Quote Originally Posted by karavan View Post
    Расскажу о своей войне с девайсами Asus rt-n10u_b + Huawei E3131 (MTS 420D).
    Должен заработать в режиме "CDC Ethernet", во всяком случае вот так на RT-N56U:
    PHP Code:
    Jan  1 00:00:11 kernelInitializing USB Mass Storage driver...
    Jan  1 00:00:11 kernelusbcoreregistered new interface driver usb-storage
    Jan  1 00
    :00:11 kernelUSB Mass Storage support registered.
    Jan  1 00:00:12 kernelbr0port 3(rai0entering forwarding state
    Jan  1 00
    :00:12 kernelbr0port 2(ra0entering forwarding state
    Jan  1 00
    :00:12 kernelcdc_ether 1-1:1.0usb0register 'cdc_ether' at usb-rt3xxx-ehci-1'CDC Ethernet Device'58:2c:80:13:92:63
    Jan  1 00
    :00:12 kernelbr0port 1(eth2.1entering forwarding state
    Jan  1 00
    :00:12 kernelusbcoreregistered new interface driver 'cdc_ether'
    Jan  1 00:00:12 kernelusbcoreregistered new interface driver 'rndis_host'
    Jan  1 00:00:12 kernelusbcoreregistered new interface driver 'cdc_wdm'
    Jan  1 00:00:12 kernelusbcoreregistered new interface driver 'qmi_wwan'
    Jan  1 00:00:17 usb modem hotplug: try autorun modem wan connection...
    Jan  1 00:00:17 pppd[450]: Unable to complete PPPoE Discovery
    Jan  1 00
    :00:17 pppd[450]: Terminating on signal 15
    Jan  1 00
    :00:17 pppd[450]: Exit.
    Jan  1 00:00:18 Hardware NAT/RoutingDisabled
    Jan  1 00
    :00:19 miniupnpd[588]: version 1.8 started
    Jan  1 00
    :00:19 miniupnpd[588]: HTTP listening on port 21265
    Jan  1 00
    :00:19 DHCP WAN Clientstarting wan dhcp ('usb0') ...
    Jan  1 00:00:19 wan up ('usb0')
    Jan  1 00:00:19 dnsmasq[409]: read /etc/hosts 4 addresses
    Jan  1 00
    :00:19 dnsmasq[409]: read /etc/storage/hosts 0 addresses
    Jan  1 00
    :00:19 dnsmasq[409]: using nameserver 192.168.1.1#53
    Jan  1 00:00:19 DHCP WAN Clientbound ('usb0'), IP192.168.1.100GW192.168.1.1lease time86400
    Jan  1 00
    :00:21 NTP SchedulerSynchronizing time to pool.ntp.org ...
    Apr  8 22:12:06 NTP SchedulerSystem time changed
    Quote Originally Posted by Padavan
    По сути сейчас в NDIS 3 драйвера -

    • CDC_NCM + CDC_ETHER + OPTIONS,
    • QMI_WWAN + CDC_WDM,
    • CDC_MBIM + CDC_WDM.

    Ну и классический RNIDS.
    Code:
    qmi_wwan => QMI over /dev/cdc-wdmY
    
    cdc_mbim => MBIM over /dev/cdc-wdmY
    
    (cdc_ncm or cdc_ether) and Huawei => AT^NDISDUP etc over /dev/ttyUSBY
    
    (cdc_ncm or cdc_ether) and Ericsson => AT*ENAP etc over /dev/cdc-wdmY or /dev/ttyACMY
    https://mail.gnome.org/archives/netw.../msg00152.html
    Last edited by Omega; 14-05-2013 at 23:06. Reason: добавление

  15. #30
    Quote Originally Posted by Omega View Post
    Должен заработать в режиме "CDC Ethernet"
    Лог подробно изучал, но ничего подобного не видел.
    К стати, до команды 'insmod usbserial vendor=0x12d1 product=0x1506' пробовал 'modprobe usbserial vendor=0x12d1 product=0x1506', но он ругнулся на отсутствие modprobe.dep.
    Это для поста я "причесал" все команды, чтоб другие не наступали на грабли, которые я уже опробовал.
    Last edited by karavan; 11-04-2013 at 03:19.

Page 2 of 5 FirstFirst 1234 ... LastLast

Similar Threads

  1. Роутер Asus + Huawei E156G/E160G/E173/E352/E367/E1550/E1750/E1820
    By AndySN in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 180
    Last Post: 26-06-2016, 13:13
  2. Huawei E150/E171/E173/E367/E369 от МТС и роутер Asus
    By parchak in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 159
    Last Post: 18-05-2016, 18:59
  3. Проблема с Huawei E392 от Мегафон/МТС/Yota на роутере Asus
    By bagira in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 75
    Last Post: 05-11-2013, 13:29
  4. ASUS WL500gPv2 vs D-Link DIR-615
    By valentyn in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 74
    Last Post: 22-11-2011, 19:26
  5. Asus WL-500W и Intel(R) Wireless WiFi Link 4965AGN
    By joker79 in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 114
    Last Post: 22-03-2010, 17:49

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •