Results 1 to 4 of 4

Thread: [SMB]Samba werkt zeer traag tot niet

  1. #1
    Join Date
    Jun 2005
    Location
    Hogwarts
    Posts
    8

    [SMB]Samba werkt zeer traag tot niet

    Misschien een beetje rare topic titel, maar ik wist niet hoe ik het verder kon omschrijven.

    Ik heb naar aanleiding van de tutorial van Hezik een Samba server opgezet in ons netwerk.
    Ik heb hier alle stappen gevolgd van deze tutorial, zo ook de partities etc. Ik heb een 13GB harde schijf als slachtoffer gevonden en heb die helemaal gepartitioneerd

    fat32 : 2001MB
    ext3: : 9800MB
    Ik heb daarna de gehele samba tutorial verder gevolgd en heb inderdaad me samba server werkend, enige nadeel is dat ik alleen mijn fat32 kan aanspreken. De ext3 partitie kan ik niet aanspreken, deze is correct geformateerd met de door linux ondersteunde FDISK en formatter.

    Ik heb dus nu 2GB ruimte die ik kan aan spreken, dit werkt perfect icm kleine bestanden tot 100KB, als ik een mp3 kopieer dan loopt de server vast en dien ik de router handmatig te resetten. Als ik daarna connect dan kan ik wederom de fat32 alleen bereiken.

    Als ik erin slaag een document van 8MB ( Lees PDF stageverslag) wil opslaan dan gaat dit ook nog goed, het gaat met een snelheid van 200KB/sec, maar ik ben geduldig dus wacht af. Als ik het bestand wil downloaden van de server dan duurt het wisselend van 1 sec tot 2 uur totdat deze word gedownload.

    Mijn vraag is daarom ook, wat doe ik fout, waarom kan ik geen ext3 aanspreken en waarom loopt alles zo vast. Dien ik gewoon een nieuwe hdd aan te schaffen of is er nog hoop

    SS

  2. #2

    Ik voel met je mee...

    Ik heb exact hetzelfde probleem. Wel de FAT32 partitie bereikbaar en schrijfbaar. De EXT3-partitie wordt wel gezien, maar ik heb geen toegang.
    Mocht je inmiddels een oplossing gevonden, hoor ik het graag...

    Groeten

  3. #3
    Join Date
    Apr 2004
    Location
    Netherlands
    Posts
    1,308
    Heb je de tutorial op Mascat.com ook gezien? http://www.macsat.com/samba.php

    Afaik, wordt alleen de eeste partitie automatisch gemount door de firmware. Wile je meer paritities mounten dan moet kun je een symlink op de eerste aanmaken naar de overige paritities (dan kun je de tweede paritie benaderen via een subdirectory op de eerste) of de tweede parititie mounten in het post-boot script.

    De slechte performance is vaag, dit zou aan de USB <-> ide controller kunnen liggen, maar ook aan andere dingen zoals processor belasting en geheugen gebruik. Gebruik je bijvoorbeeld ook een webcam? Post anders eens de syslog en welke router je hebt (WL-500g of Deluxe)...

    Ik heb gister mijn corrupte schijf weer gefixed (en omgezet naar ext3) en 5 GB aan mp3's erop gekopieerd. Geen problemen gehad. Het kopieren van zeer grote bestanden (lees DVD's) ging ook een aantal keren goed, maar werd 1 keer afgebroken. De schrijfperformance gaat nogal schokkerig (tussen 0 en 2 MB/s), maar ik schat dat mijn WL-500g ongeveer 500kb/s gemiddeld haalt. Dit is tevens zo'n beetje de limiet van de USB 1.1 verbinding.
    Last edited by Styno; 27-09-2005 at 10:01.

  4. #4

    Lightbulb Mogelijke oplossing gevonden

    De instructie is niet helemaal correct. Het 'mounten' van de partities hoort ongeveer alsvolgt te gebeuren:

    Code:
    [mobile_fat32]
    	path=/tmp/harddisk
    	writeable = yes
    	browseable = yes
    	force user = admin
    [mobile_ext3]
    	path=/tmp/harddisk/part1
    	writeable = yes
    	browseable = yes
    	force user = admin
    Last edited by joranq; 28-09-2005 at 10:09.

Similar Threads

  1. Security Feature / Welke Webcam werkt?
    By Cemmie in forum Dutch Discussion - Nederlands
    Replies: 7
    Last Post: 30-12-2005, 23:22
  2. wl 500g deluxe ftp werkt niet.
    By wilco02 in forum Dutch Discussion - Nederlands
    Replies: 28
    Last Post: 06-10-2005, 18:22
  3. Webserver is niet extern bereikbaar
    By psychonetics in forum Dutch Discussion - Nederlands
    Replies: 10
    Last Post: 27-09-2005, 22:54
  4. Kan WAN ip niet vinden
    By gsmrat in forum Dutch Discussion - Nederlands
    Replies: 18
    Last Post: 15-08-2005, 23:37
  5. laptop ziet pc niet en andersom
    By sharky123 in forum Dutch Discussion - Nederlands
    Replies: 16
    Last Post: 17-06-2005, 11:12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •