Results 1 to 12 of 12

Thread: wget update

  1. #1

    wget update

    How could wget be updated? Automatically or manually?

    Manually the up-to-date file could be downloaded from

    http://ipkg.nslu2-linux.org/feeds/op...2-2_mipsel.ipk

    but this is compressed file wget_1.12-2_mipsel.gz. How could this file be installed? If I extract it with

    tar xfvz wget_1.12-2_mipsel.gz

    three new files appear: data.tar.gz, control.tar.gz, debian-binary. No ipk.

    I need it for the installation of optware-devel which has the problem with downloading the libidn.so.11 library.

  2. #2
    ^The Link is already the ipk just use ipkg install

    Btw we don't recommend compiling on the router itself anymore.

    As you posted in Wl500gP Sektion, I assume you have that device. Then you could give Entware a try and crosscompile your software via the Entware/Openwrt buildroot.
    (the new repo contains wget 1.13.4 )


    http://code.google.com/p/wl500g/
    and
    http://code.google.com/p/wl500g-repo/

    check out the wiki there

    and our thread here: http://wl500g.info/showthread.php?28...7-rtn-firmware
    RT-N66U TomatoUSB 1.28.0000 MIPSR2-135 K26AC USB AIO-64K running Entware-NG
    pyload 0.4.9
    minidlna 1.1.2
    samba 3.6.5
    openvpn 2.3.10
    ̶W̶L̶5̶0̶0̶g̶P̶ ̶1̶.̶9̶.̶2̶.̶7̶-̶r̶t̶n̶-̶r̶4̶7̶5̶0 retired

  3. #3
    Yes, the link seems to be directly the ipk but if you click on it the file with extension .gz shows up (wget_1.12-2_mipsel.gz).
    I have Asus Wl-500gp with Oleg firmware 1.9.2.7-10. I am not sure if wget 1.13.4 is compatible with this firmware. I would like to keep this firmware if possible because of a possible incompatibility and reinstalling the packages.
    The compilation in the router is easier for me since I am a beginner. I already installed several packages quite without big problems.
    I assume that the installation from. gz files is quite easy for Linux users but I have not clue how to do it and I have not found a manual for it yet.

  4. #4
    this:
    Code:
    wget http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/wget_1.12-2_mipsel.ipk
    ipkg install wget_1.12-2_mipsel.ipk
    doesn't work? (do this via ssh on the Premium)

    sure, ipk's are just tarballs - but no need to untar them, the packet manager (ipkg) does this on his own

    btw. as wget is in the optware repo, you can just do a

    Code:
    ipkg install wget
    Last edited by !gm; 01-07-2012 at 17:16.
    RT-N66U TomatoUSB 1.28.0000 MIPSR2-135 K26AC USB AIO-64K running Entware-NG
    pyload 0.4.9
    minidlna 1.1.2
    samba 3.6.5
    openvpn 2.3.10
    ̶W̶L̶5̶0̶0̶g̶P̶ ̶1̶.̶9̶.̶2̶.̶7̶-̶r̶t̶n̶-̶r̶4̶7̶5̶0 retired

  5. #5
    There is something wrong:

    Code:
    [admin@AP2 root]$ ipkg install wget
    Installing wget (1.12-2) to /opt/...
    Nothing to be done
    An error ocurred, return value: 1.
    Collected errors:
    ERROR: The following packages conflict with wget:
             wget-ssl
    [admin@AP2 root]$ wget http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stab
    le/wget_1.12-2_mipsel.ipk
    wget: can't load library 'libidn.so.11'
    [admin@AP2 root]$ ipkg install wget_1.12-2_mipsel.ipk
    ipkg: wget_1.12-2_mipsel.ipk: No such file or directory
    Nothing to be done
    An error ocurred, return value: 4.
    Collected errors:
    Cannot find package wget_1.12-2_mipsel.ipk.
    Check the spelling or perhaps run 'ipkg update'
    [admin@AP2 root]$

  6. #6
    we see you have wget-ssl already running and this seems to be corrupt because of missing libidn.... (that's causing all downloads to fail)
    you have to remove wget-ssl to get ipgk working again

    Code:
    ipkg remove wget-ssl
    ipkg update
    ipkg install libidn
    if libidn installation succeeds, you can go on installing wget-ssl again... if not ....

    optware is a pain - unreliable, outdated
    Last edited by !gm; 01-07-2012 at 23:53.
    RT-N66U TomatoUSB 1.28.0000 MIPSR2-135 K26AC USB AIO-64K running Entware-NG
    pyload 0.4.9
    minidlna 1.1.2
    samba 3.6.5
    openvpn 2.3.10
    ̶W̶L̶5̶0̶0̶g̶P̶ ̶1̶.̶9̶.̶2̶.̶7̶-̶r̶t̶n̶-̶r̶4̶7̶5̶0 retired

  7. #7
    Thank you! It looks promising! When trying to install the optware-devel package there is still a problem with wget; could it be the missing wget-ssl?

    Code:
    [admin@AP2 root]$ ipkg remove wget-ssl
    Removing package wget-ssl from /opt/...
    Successfully terminated.
    [admin@AP2 root]$ ipkg update
    Downloading http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/Packages
    .gz
    Inflating http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/Packages.g
    z
    Updated list of available packages in /opt/lib/ipkg/lists/optware
    Successfully terminated.
    [admin@AP2 root]$ ipkg install libidn
    Installing libidn (1.25-1) to /opt/...
    Downloading http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/libidn_1
    .25-1_mipsel.ipk
    Configuring libidn
    Successfully terminated.
    [admin@AP2 root]$ ipkg install wget
    Installing wget (1.12-2) to /opt/...
    Downloading http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/wget_1.1
    2-2_mipsel.ipk
    Configuring wget
    Successfully terminated.
    [admin@AP2 root]$ wget http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stab
    le/wget_1.12-2_mipsel.ipk
    --2012-07-02 06:56:28--  http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/st
    able/wget_1.12-2_mipsel.ipk
    Resolving ipkg.nslu2-linux.org... 140.211.169.161
    Connecting to ipkg.nslu2-linux.org|140.211.169.161|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 186020 (182K) [text/plain]
    Saving to: `wget_1.12-2_mipsel.ipk'
    
    100%[======================================>] 186,020     73.1K/s   in 2.5s
    
    2012-07-02 06:56:31 (73.1 KB/s) - `wget_1.12-2_mipsel.ipk' saved [186020/186020]
    
    [admin@AP2 root]$ ipkg install wget_1.12-2_mipsel.ipk
    Installing wget (1.12-2) to /opt/...
    Configuring wget
    Successfully terminated.
    [admin@AP2 root]$ ipkg install buildroot optware-devel unzip
    Package buildroot (4.1.1-13) installed in /opt/ is up to date.
    Installing optware-devel (6.8-10) to /opt/...
    Downloading http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/optware-
    devel_6.8-10_mipsel.ipk
    Installing wget-ssl (1.12-2) to /opt/...
    Package unzip (6.0-2) installed in /opt/ is up to date.
    Nothing to be done
    Successfully terminated.
    Collected errors:
    ERROR: The following packages conflict with wget-ssl:
             wget
    [admin@AP2 root]$

  8. #8
    As I said:
    Quote Originally Posted by !gm View Post
    ... can go on installing wget-ssl again...
    interpret:
    Code:
    ERROR: The following packages conflict with wget-ssl:
             wget
    by yourself
    RT-N66U TomatoUSB 1.28.0000 MIPSR2-135 K26AC USB AIO-64K running Entware-NG
    pyload 0.4.9
    minidlna 1.1.2
    samba 3.6.5
    openvpn 2.3.10
    ̶W̶L̶5̶0̶0̶g̶P̶ ̶1̶.̶9̶.̶2̶.̶7̶-̶r̶t̶n̶-̶r̶4̶7̶5̶0 retired

  9. #9
    Something is broken inside your firmware (either /opt/etc/ipkg.conf or probably you have messed with libs).

    I'm using Oleg's optware and I have both wget and wget-ssl installed:

    Code:
    $ ipkg list|grep wget
    wget - 1.12-2 - A network utility to retrieve files from the Web
    wget-ssl - 1.12-2 - A network utility to retrieve files from the Web
    Could you maybe try to start from the scratch (i.e. reinstall everything in the /opt)
    Last edited by staticroute; 02-07-2012 at 12:56.

  10. #10
    Quote Originally Posted by staticroute View Post
    I have both wget and wget-ssl installed:
    Thats not true and impossible, as wget and wget-ssl conflict each other.
    use
    Code:
    ipkg list_installed
    to show the packages, that are on your device - list just shows all available packages
    RT-N66U TomatoUSB 1.28.0000 MIPSR2-135 K26AC USB AIO-64K running Entware-NG
    pyload 0.4.9
    minidlna 1.1.2
    samba 3.6.5
    openvpn 2.3.10
    ̶W̶L̶5̶0̶0̶g̶P̶ ̶1̶.̶9̶.̶2̶.̶7̶-̶r̶t̶n̶-̶r̶4̶7̶5̶0 retired

  11. #11
    Quote Originally Posted by !gm View Post
    Thats not true and impossible, as wget and wget-ssl conflict each other.
    use
    Code:
    ipkg list_installed
    to show the packages, that are on your device - list just shows all available packages
    Yeah, was my error (deeply in the night).

    Code:
    $ ipkg list_installed|grep wget
    wget-ssl - 1.12-2 -

  12. #12
    I managed it! I uninstalled wget and installed wget-ssl and after that it worked!
    Thank you!

Similar Threads

  1. NOD32 update server
    By idmitry in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 795
    Last Post: 08-03-2017, 15:51
  2. Проблема с установкой wget и wget-ssl
    By Jekl in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 89
    Last Post: 21-04-2013, 20:59
  3. ipkg update error too
    By rosemarie321 in forum WL-500gP Q&A
    Replies: 0
    Last Post: 21-04-2012, 16:14
  4. newly installed openwrt, ipkg update error...
    By mutejute in forum WL-HDD Q&A
    Replies: 2
    Last Post: 13-02-2006, 10:23

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •