Page 2 of 5 FirstFirst 1234 ... LastLast
Results 16 to 30 of 62

Thread: [Announce] New EntWare package repository for 1.9.2.7-rtn firmware

  1. #16
    Quote Originally Posted by ryzhov_al View Post
    [CODE]...
    or mipsel-uclibc-gcc
    /opt/brcm/hndtools-mipsel-uclibc/bin/mipsel-uclibc-gcc: cannot execute binary file

    hm, what should I do? I checked the link and the executable - it was right
    RT-N66U TomatoUSB 1.28.0000 MIPSR2-135 K26AC USB AIO-64K running Entware-NG
    pyload 0.4.9
    minidlna 1.1.2
    samba 3.6.5
    openvpn 2.3.10
    ̶W̶L̶5̶0̶0̶g̶P̶ ̶1̶.̶9̶.̶2̶.̶7̶-̶r̶t̶n̶-̶r̶4̶7̶5̶0 retired

  2. #17
    Try to add /opt/brcm/hndtools-mipsel-uclibc/bin to PATH variable on your virtual machine:
    Code:
    $ export PATH=$PATH:/opt/brcm/hndtools-mipsel-uclibc/bin

  3. #18
    after the export it's still the same...

    could this be a problem?
    Code:
    checking build system type... i486-pc-linux-gnu
    as I'm running a i686 Debian..
    Last edited by !gm; 30-01-2012 at 15:01.
    RT-N66U TomatoUSB 1.28.0000 MIPSR2-135 K26AC USB AIO-64K running Entware-NG
    pyload 0.4.9
    minidlna 1.1.2
    samba 3.6.5
    openvpn 2.3.10
    ̶W̶L̶5̶0̶0̶g̶P̶ ̶1̶.̶9̶.̶2̶.̶7̶-̶r̶t̶n̶-̶r̶4̶7̶5̶0 retired

  4. #19
    ok, now double-checked... and using Ubuntu 11.10
    hndtools-mipsel-uclibc-4.4.6-K26-r3458.tar.bz2 != hndtools-mipsel-uclibc-4.4.6-K26-x86_64-r3458.tar.bz2

    ^ I'm using 32-Bit vm...

    switched toolchain, but cyassl still won't compile:

    config.log
    Code:
    /opt/brcm/hndtools-mipsel-uclibc/lib/libc.so: undefined reference to `_dl_app_init_array'
    /opt/brcm/hndtools-mipsel-uclibc/lib/libc.so: undefined reference to `__tls_get_addr'
    /opt/brcm/hndtools-mipsel-uclibc/lib/libc.so: undefined reference to `_dl_loaded_modules'
    /opt/brcm/hndtools-mipsel-uclibc/lib/libc.so: undefined reference to `_dl_app_fini_array'
    collect2: ld returned 1 exit status
    RT-N66U TomatoUSB 1.28.0000 MIPSR2-135 K26AC USB AIO-64K running Entware-NG
    pyload 0.4.9
    minidlna 1.1.2
    samba 3.6.5
    openvpn 2.3.10
    ̶W̶L̶5̶0̶0̶g̶P̶ ̶1̶.̶9̶.̶2̶.̶7̶-̶r̶t̶n̶-̶r̶4̶7̶5̶0 retired

  5. #20
    If you changed toolchain, then better start compilation from very first step. Delete ./trunk directory and start again.

  6. #21
    that's what I did
    RT-N66U TomatoUSB 1.28.0000 MIPSR2-135 K26AC USB AIO-64K running Entware-NG
    pyload 0.4.9
    minidlna 1.1.2
    samba 3.6.5
    openvpn 2.3.10
    ̶W̶L̶5̶0̶0̶g̶P̶ ̶1̶.̶9̶.̶2̶.̶7̶-̶r̶t̶n̶-̶r̶4̶7̶5̶0 retired

  7. #22
    Quote Originally Posted by !gm View Post
    that's what I did
    It seems toolchain is still broken. You may check it by compiling firmware.

  8. #23

    Thumbs down

    Quote Originally Posted by ryzhov_al View Post
    compiling stops at busybox

    Code:
    /opt/brcm/hndtools-mipsel-uclibc/bin/../lib/gcc/mipsel-linux-uclibc/4.4.6/../../../../mipsel-linux-uclibc/bin/ld: warning: ld-uClibc.so.0, needed by /opt/brcm/hndtools-mipsel-uclibc/bin/../lib/gcc/mipsel-linux-uclibc/4.4.6/../../../../mipsel-linux-uclibc/lib/libc.so, not found (try using -rpath or -rpath-link)
    /opt/brcm/hndtools-mipsel-uclibc/bin/../lib/gcc/mipsel-linux-uclibc/4.4.6/../..//../../mipsel-linux-uclibc/lib/libc.so: undefined reference to `_dl_app_init_array'
    /opt/brcm/hndtools-mipsel-uclibc/bin/../lib/gcc/mipsel-linux-uclibc/4.4.6/../../ ../../mipsel-linux-uclibc/lib/libc.so: undefined reference to `__tls_get_addr'
    /opt/brcm/hndtools-mipsel-uclibc/bin/../lib/gcc/mipsel-linux-uclibc/4.4.6/../../ ../../mipsel-linux-uclibc/lib/libc.so: undefined reference to `_dl_loaded_modules'
    /opt/brcm/hndtools-mipsel-uclibc/bin/../lib/gcc/mipsel-linux-uclibc/4.4.6/../../../../mipsel-linux-uclibc/lib/libc.so: undefined reference to `_dl_app_fini_array'
    I'll set up a x64 vm according to your build-machine, as toolchain is working there.

    edit:
    ^not possible, as my CPU doesn't support hardware virtualization


    edit2: ok, cleaned up everything again (on the 32bit vm)... linked toolchain with -snf option!
    cyassl didn't gave an error
    it seems to work now - waiting....
    Last edited by !gm; 01-02-2012 at 17:47.
    RT-N66U TomatoUSB 1.28.0000 MIPSR2-135 K26AC USB AIO-64K running Entware-NG
    pyload 0.4.9
    minidlna 1.1.2
    samba 3.6.5
    openvpn 2.3.10
    ̶W̶L̶5̶0̶0̶g̶P̶ ̶1̶.̶9̶.̶2̶.̶7̶-̶r̶t̶n̶-̶r̶4̶7̶5̶0 retired

  9. #24
    Quote Originally Posted by !gm View Post
    it seems to work now - waiting....
    Our OpenWRT repo includes ~30% of packages from original OpenWRT. Building takes about ~3.5 hours on my PC.

  10. #25
    Join Date
    Dec 2007
    Location
    The Netherlands - Eindhoven
    Posts
    1,767
    Quote Originally Posted by ryzhov_al View Post
    Our OpenWRT repo includes ~30% of packages from original OpenWRT. Building takes about ~3.5 hours on my PC.
    if you require some build power, I have a intel sandy bridge 2600k clocked at 4GHz
    I do build the toolchain myself, instead of downloading a pre-build one from googlecode.

    btw, I'm just messing around with opkg on my second router. in the end I'd like to move from ipkg to opkg

    I came accros this:
    mysql: can't load library 'libncursesw.so.5'
    $ opkg install libncurses
    Package libncurses (5.7-5) installed in root is up to date.
    and /opt/lib/libncurses.so.5 seems to be available

  11. #26
    Quote Originally Posted by ryzhov_al View Post
    Our OpenWRT repo includes ~30% of packages from original OpenWRT. Building takes about ~3.5 hours on my PC.
    was out for watching football
    it stopped somewhere at ipset...
    hm but I don't really care.. I just want minidlna and pyload....

    now I use a minimal config via
    Code:
    make menuconfig
    to get those two packages
    RT-N66U TomatoUSB 1.28.0000 MIPSR2-135 K26AC USB AIO-64K running Entware-NG
    pyload 0.4.9
    minidlna 1.1.2
    samba 3.6.5
    openvpn 2.3.10
    ̶W̶L̶5̶0̶0̶g̶P̶ ̶1̶.̶9̶.̶2̶.̶7̶-̶r̶t̶n̶-̶r̶4̶7̶5̶0 retired

  12. #27

    Talking

    I was successful...

    minidlna disappeared during menuconfig (dunno why)..
    but pyload got the version-bump as desired

    here is the diff to be integrated to googlecode and the ipk, for the fast-ones

    http://dl.dropbox.com/u/13972492/pyload_0.4.9-1_rtn.ipk

    the MD5 is calculated on my own, as pyload.org doesn't provide it somehow

    it's working

    Code:
    gm@ubuntu:~/openwrt/trunk/feeds/packages/net/pyload$ svn diff Makefile
    Index: Makefile
    ===================================================================
    --- Makefile    (revision 29955)
    +++ Makefile    (working copy)
    @@ -8,12 +8,12 @@
     include $(TOPDIR)/rules.mk
    
     PKG_NAME:=pyload
    -PKG_VERSION:=0.4.8
    +PKG_VERSION:=0.4.9
     PKG_RELEASE:=1
    
     PKG_SOURCE:=$(PKG_NAME)-src-v$(PKG_VERSION).zip
     PKG_SOURCE_URL:=http://download.pyload.org/
    -PKG_MD5SUM:=5bcf8411ef9e48ef6e9ade55bc697900
    +PKG_MD5SUM:=9b2e5a7c884871a5489cb5141d5c704b
    
     PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)/
    
    @@ -38,12 +38,12 @@
     endef
    
     define Package/pyload/install
    -       $(INSTALL_DIR) $(1)/usr/share/python
    -       $(CP) $(PKG_BUILD_DIR)/pyload $(1)/usr/share/python/
    -       $(INSTALL_DIR) $(1)/etc/init.d
    -       $(INSTALL_BIN) ./files/pyload.init $(1)/etc/init.d/pyload
    -       $(INSTALL_DIR) $(1)/usr/bin
    -       $(LN) ../share/python/pyload/pyLoadCore.py $(1)/usr/bin/pyload
    +       $(INSTALL_DIR) $(1)/opt/share/python
    +       $(CP) $(PKG_BUILD_DIR)/pyload $(1)/opt/share/python/
    +#      $(INSTALL_DIR) $(1)/etc/init.d
    +#      $(INSTALL_BIN) ./files/pyload.init $(1)/etc/init.d/pyload
    +       $(INSTALL_DIR) $(1)/opt/bin
    +       $(LN) ../share/python/pyload/pyLoadCore.py $(1)/opt/bin/pyload
     endef
    
     $(eval $(call BuildPackage,pyload))
    additionally I also altered packages.index to match version and filename - don't know, if this is really needed...

    good night guys
    RT-N66U TomatoUSB 1.28.0000 MIPSR2-135 K26AC USB AIO-64K running Entware-NG
    pyload 0.4.9
    minidlna 1.1.2
    samba 3.6.5
    openvpn 2.3.10
    ̶W̶L̶5̶0̶0̶g̶P̶ ̶1̶.̶9̶.̶2̶.̶7̶-̶r̶t̶n̶-̶r̶4̶7̶5̶0 retired

  13. #28

    Additional packages

    Hello. I want to ask if you will also add additional packages from OpenWRT repository? I miss the mercurial, pure-ftpd, vim ...

    Thanx.

  14. #29
    Hello together!

    Can someone please explain more detailed, how the switch from a ipkg system to opkg is supposed to work?

    It is a change, isn't it? Can/Should one use ipkg and opkg together?

    If so, how am I supposed to install opkg after removing ipkg?
    Just tried to move all the content from /opt to a backup location and run the install script afterwards, but was confronted with some file not found errors (which seems to be logical, if all ipkg-files are removed...).

    Is there a small guidance for me?

    Thanks,
    pheidrias - 1.9.2.7-rtn-r3825 on WL500gpv2

  15. #30
    hmmm....before I try this...I can't find the acutal list of packages supported? Is there any online? Or can someone who has installed opkg post its list?

    Do I have to remove ipkg itself (ipkg.sh remove ipkg --> does this work?)?

    Please help a beginner with this! Thanks!

Page 2 of 5 FirstFirst 1234 ... LastLast

Similar Threads

  1. Entware - новый репозиторий для роутеров (MIPS)
    By ryzhov_al in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 1390
    Last Post: 29-04-2017, 22:40
  2. Установка rTorrent + ruTorrent из репозитория Entware
    By ryzhov_al in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 174
    Last Post: 11-02-2016, 15:29
  3. Samba 3.6 EntWare - установка и настройка
    By voidshah in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 50
    Last Post: 02-12-2014, 11:37
  4. Optware oder Entware?
    By newbiefan in forum German Discussion - Deutsch (DE)
    Replies: 9
    Last Post: 20-12-2012, 17:51
  5. Torrentflux mod, controls Transmission - can someone package it?
    By nant15 in forum WL-500g Custom Development
    Replies: 5
    Last Post: 14-11-2006, 20:49

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •