Results 1 to 7 of 7

Thread: Possible solution to p2p problem? (Prob nš1 in FAQ)

  1. #1
    Join Date
    Jun 2005
    Location
    Portugal
    Posts
    21

    Possible solution to p2p problem? (Prob nš1 in FAQ)

    Hi all.
    The no 1 problem in the FAQ is :
    1. P2P networks causing lost of connectivity due to limited number of connections which firewall is keeps tracking (1024 by default)
    The problem has been fixed but its still possible to improve emule downloads by changing 2 parameters.

    The first solutiuon is to increase ip_conntrack_max in proc.

    Also to improve speed change the tcp_fin_timeout parameter:

    echo 2048 > /proc/sys/net/ipv4/ip_conntrack_max
    echo 120 > /proc/sys/net/ipv4/tcp_fin_timeout

    Add this to post-boot

    Try it and drop a line here!

    Kind Regards,

    João Seabra
    Last edited by jseabra; 14-07-2005 at 15:12.
    Asus Wl500g + Homebrew bi-quad antenna + 80 G 3.5" seagate H.D + Philips ToUCam II - 1.9.2.7-6b-seabra

  2. #2
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Quote Originally Posted by jseabra
    1. P2P networks causing lost of connectivity due to limited number of connections which firewall is keeps tracking (1024 by default)
    4096 in my firmwares, could be adjusted via web interface.

  3. #3
    Oleg,
    Won't the router choke with 4K connections? Also if I'll update it to say 8 or 16K then will it be able to handle it?
    Right now it is at its' default of 1024 and during hot days the router reboots like there is no tommorow... (semi hot days it manages to stay more or less alive...)

    Max.

  4. #4
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    4K is set by default in my firmwares. 16K should also work.

    "Hot days" - you mean high temperature around?

  5. #5
    Quote Originally Posted by jseabra
    Also to improve speed change the tcp_fin_timeout parameter:

    echo 2048 > /proc/sys/net/ipv4/ip_conntrack_max
    echo 120 > /proc/sys/net/ipv4/tcp_fin_timeout
    Just a second. I could be way off here, but shouldn't those two lines make things worse?

    As Oleg stated, firmwares default now with 4096, so 2048 is half as many connections being tracked...

    More to my point, the tcp_fin_timeout value you've used is 4 times the default value for the router, isn't it? I read the default value was 60, but when I checked on my router before I changed it I thought it said 30. Anyway, doesn't that mean such things have to be tracked longer, or something? One would assume so, since they'd take longer to timeout... Please tell me how INCREASING tcp_fin_timeout will speed up p2p, because I'm interested in knowing.
    Last edited by tomilius; 17-07-2005 at 05:58. Reason: clarification

  6. #6
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    hm... right. it's set to 60, so 120 could make things worse.

  7. #7
    Yeah hot days as in high temperature - around 40c celcius with say 75-95% moisture.. (makes a human feel like it is about 55c )

Similar Threads

  1. UnionFS, a solution for wl500g Ramdisk ?
    By WlanMan in forum WL-500g Custom Development
    Replies: 0
    Last Post: 10-03-2005, 15:38
  2. [VPN] PoPToP Implementing? or other VPN solution
    By tomaz in forum WL-500g Custom Development
    Replies: 2
    Last Post: 27-07-2004, 07:14
  3. Router does not reconnect - Solution?
    By Csali in forum WL-500g Q&A
    Replies: 4
    Last Post: 01-07-2004, 14:23
  4. [WIRELESS] wep 128 bit shared key solution?
    By Wisi in forum WL-500g Q&A
    Replies: 3
    Last Post: 02-04-2004, 11:02

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •