Page 83 of 93 FirstFirst ... 33738182838485 ... LastLast
Results 1,231 to 1,245 of 1392

Thread: Entware - новый репозиторий для роутеров Asus (MIPS)

  1. #1231
    Quote Originally Posted by tyllo View Post
    У меня ushare тоже ругался на библиотеку из этого пакета. remove и install не помог, пришлось сделать удаленный линк на фаил на который ругался, а именно из лога:
    А причем тут удаленный линк?
    У меня 55 версия бибиотеки в /opt/lib присутствует вполне.
    Code:
    lrwxrwxrwx    1 admin    root            23 Oct 16 13:55 libavcodec.so.55 -> libavcodec.so.55.69.100
    -rwxr-xr-x    1 admin    root       6550452 Oct 15 12:57 libavcodec.so.55.69.100
    Или имеется в виду что обмануть minidlna путем подсовывания 54 версии библиотеки, которую скачать вручную и слинковать под видом 55-ой?

  2. #1232
    Quote Originally Posted by ryzhov_al View Post
    В этих случаях проще выкачать заново перелинкованный пакет:
    Code:
    opkg remove wget
    opkg install wget
    Вчера закончил синхронизацию с OpenWRT, приостановленную в мае, изменению подверглись более половины пакетов репозитория. Ближе к вечеру (по MSK) опишу подробнее все изменения.
    Может я что-то делаю не так, но все равно:
    Code:
    [###@router lib]$ opkg remove unrar
    [###@router lib]$ opkg install unrar
    Installing unrar (5.1.7-1a) to root...
    Downloading http://entware.wl500g.info/binaries/entware/unrar_5.1.7-1a_entware.ipk.
    Configuring unrar.
    [###@router lib]$
    [###o@router lib]$
    [###@router lib]$
    [###@router lib]$ /opt/etc/nod32upd2/upd-nod32-mirror.sh
    ......................
    ......................
    [01:27:36] Unpacking version file.. unrar: can't load library 'libuClibc++.so.0'
    Code:
    lrwxrwxrwx    1 ###    root            19 Oct 16 14:03 libc.so.0 -> libuClibc-0.9.32.so
    -rwxr-xr-x    1 ###    root        218232 May 27 21:31 libuClibc++-0.2.4.so
    lrwxrwxrwx    1 ###    root            20 Sep 24 15:49 libuClibc++.so.0 -> libuClibc++-0.2.4.so
    -rwxr-xr-x    1 ###    root        680508 Oct 15 19:11 libuClibc-0.9.32.so
    Quote Originally Posted by Supermaks View Post
    А причем тут удаленный линк?
    У меня 55 версия бибиотеки в /opt/lib присутствует вполне.
    Code:
    lrwxrwxrwx    1 admin    root            23 Oct 16 13:55 libavcodec.so.55 -> libavcodec.so.55.69.100
    -rwxr-xr-x    1 admin    root       6550452 Oct 15 12:57 libavcodec.so.55.69.100
    Или имеется в виду что обмануть minidlna путем подсовывания 54 версии библиотеки, которую скачать вручную и слинковать под видом 55-ой?
    Сорри, был невнимателен, просто у меня ushare ругался что не находил удаленный линк libavcodec.so.54
    Last edited by Omega; 17-10-2014 at 00:37.
    ASUS RT-N16 прошивка 1.9.2.7-rtn-r5607 от энтузиастов, Entware

  3. #1233
    Quote Originally Posted by tyllo View Post
    Может я что-то делаю не так, но все равно:
    Всё правильно делаете, это был косяк в линковке unrar. Поправил, обновляйтесь, проверяйте.

    Quote Originally Posted by Supermaks View Post
    После обновления minidlna до 1.1.3-1 при включенной inotify=yes демон падает с Illegal instruction после

    [2014/10/16 14:10:02] inotify.c:156: debug: Add watch to /tmp/mnt/disca_1/Movies
    [2014/10/16 14:10:02] inotify.c:156: debug: Add watch to /tmp/mnt/disca_1/Series

    При inotify=no вылета не происходит, но сканировать папки (имеется в виду при запуске конечно) демон отказывается.

    gdb ругается на

    Program received signal SIGILL, Illegal instruction.
    [Switching to LWP 1944]
    0x76e03f34 in ?? () from /opt/lib/libavcodec.so.55

    которая приходит с libffmpeg-full
    Спасибо за развёрнутый репорт, правда я не могу вопроизвести проблему. Какой у вас роутер и прошивка?
    Last edited by Omega; 17-10-2014 at 00:38. Reason: fixed

  4. #1234
    Quote Originally Posted by ryzhov_al View Post
    Спасибо за развёрнутый репорт, правда я не могу вопроизвести проблему. Какой у вас роутер и прошивка?
    Dlink-320, прошивка от vampik 3.0.6.5218 (http://vampik.ru/wl500g/rtn/5218/)

    Я "поdebugил" в меру умений, если надо что-то еще запустить для более подробных подробностей - говорите.

    Я наверняка не единственный кто использует minidlna на dir-320, отзовитесь те, у кого всё отлично работает после апдейта до
    minidlna 1.1.3-1a
    libjpeg - 9a-1
    libffmpeg-full - 2.3.3-1
    Last edited by Supermaks; 19-10-2014 at 18:23.

  5. #1235

    Red face

    Quote Originally Posted by ryzhov_al View Post
    Всё правильно делаете, это был косяк в линковке unrar. Поправил, обновляйтесь, проверяйте.
    Все отлично, спасибо за ваши труды.
    ASUS RT-N16 прошивка 1.9.2.7-rtn-r5607 от энтузиастов, Entware

  6. #1236
    Извиняюсь за наглость, а не составит ли Вам труда собрать http://www.infradead.org/openconnect? Он вроде как в OpenWRT есть. Заранее спасибо.

  7. #1237
    Quote Originally Posted by Ultras View Post
    Извиняюсь за наглость, а не составит ли Вам труда собрать http://www.infradead.org/openconnect? Он вроде как в OpenWRT есть. Заранее спасибо.
    Issue давно висит, раз пакет востребован — соберу.

    Update: пакет добавлен, прошу отписаться по его работоспособности.
    Last edited by ryzhov_al; 19-10-2014 at 10:31.

  8. #1238
    Quote Originally Posted by ryzhov_al View Post
    Update: пакет добавлен, прошу отписаться по его работоспособности.
    При установке ругается:
    Installing resolveip (2) to root...
    Downloading http://entware.wl500g.info/binaries/..._2_entware.ipk.
    Collected errors:
    * check_data_file_clashes: Package resolveip wants to install file /opt/bin/resolveip
    But that file is already provided by package * mysql-server
    * opkg_install_cmd: Cannot install package openconnect.
    И при запуске:
    openconnect: can't load library 'libssl.so.1.0.0'
    Хотя: ls /opt/lib/libssl.so.1.0.0
    -rw-r--r-- 1 admin root 360428 Oct 15 13:33 /opt/lib/libssl.so.1.0.0
    Updated: при удалении mysql-server, openconnect ставиться нормально, но потом невозможно обратно установить mysql-server:
    Collected errors:
    * check_data_file_clashes: Package mysql-server wants to install file /opt/bin/resolveip
    But that file is already provided by package * resolveip
    * opkg_install_cmd: Cannot install package mysql-server.
    Updated2: при подключении, openconnect пишет:
    Script '/opt/lib/netifd/vpnc-script' returned error 1
    Script '/opt/lib/netifd/vpnc-script' returned error 1
    и не может присвоить IP адрес интерфейсу tun. По всей видимости оригинальному скрипту не хватает дополнительных скриптов, так как на линии 136 есть такая строка:
    . /lib/netifd/netifd-proto.sh
    Updated3: помогла замена /opt/lib/netifd/vpnc-script на скрипт из пакета vpnc. Теперь всё работает. Приложил к посту.

    Спасибо за труды. Починить бы теперь только mysql-server.
    Attached Files Attached Files
    Last edited by Ultras; 19-10-2014 at 11:22.

  9. #1239
    Quote Originally Posted by Ultras View Post
    При установке ругается:
    Одноимённые бинарники resolveip имеют идентичный функционал, поэтому не будет ничего страшного в том, что один будет перезатёрт другим:
    Code:
    opkg --force-overwrite install openconnect
    Quote Originally Posted by Ultras View Post
    И при запуске:

    Хотя: ls /opt/lib/libssl.so.1.0.0
    Вот это странно. openconnect принудительно слинкован с gnutls и никак не должен зависеть от openssl:
    Code:
    admin@RT-N66U:/tmp/mnt/OPT/tmp# ldd /opt/sbin/openconnect
            libgnutls.so.28 => /opt/lib/libgnutls.so.28 (0x2aac0000)
            libz.so.1 => /opt/lib/libz.so.1 (0x2abd5000)
            libxml2.so.2 => /opt/lib/libxml2.so.2 (0x2abf9000)
            libc.so.0 => /opt/lib/libc.so.0 (0x2ad50000)
            libnettle.so.4 => /opt/lib/libnettle.so.4 (0x2ae00000)
            libhogweed.so.2 => /opt/lib/libhogweed.so.2 (0x2ae45000)
            libgmp.so.10 => /opt/lib/libgmp.so.10 (0x2ae7f000)
            libdl.so.0 => /opt/lib/libdl.so.0 (0x2af04000)
            libm.so.0 => /opt/lib/libm.so.0 (0x2af17000)
            ld-uClibc.so.0 => /opt/lib/ld-uClibc.so.0 (0x2aaa8000)
    Quote Originally Posted by Ultras View Post
    Updated3: помогла замена /opt/lib/netifd/vpnc-script на скрипт из пакета vpnc. Теперь всё работает. Приложил к посту.
    Так значит он запускается, не требуя libssl? За скрипт спасибо, поправил.
    Last edited by ryzhov_al; 19-10-2014 at 13:08. Reason: Обновил пакет с приложенным vnpc-script

  10. #1240
    Quote Originally Posted by ryzhov_al View Post
    Так значит он запускается, не требуя libssl? За скрипт спасибо, поправил.
    ну когда снёс mysql-server, и снова поставил openconnect, то запустилось уже без всяких проблем, притом второй раз уже gnutls начал ставиться.

    Спасибо за правки, как появиться время (сегодня-завтра) сразу же проверю.

    Updated: проверил, всё работает, но я дитчайше извиняюсь, тот скрипт что я дал, там синтаксическая ошибка есть, прикрепляю 100% рабочий и проверенный.
    Attached Files Attached Files
    Last edited by Ultras; 19-10-2014 at 14:10.

  11. #1241
    Quote Originally Posted by Ultras View Post
    Updated: проверил, всё работает, но я дитчайше извиняюсь, тот скрипт что я дал, там синтаксическая ошибка есть, прикрепляю 100% рабочий и проверенный.
    Я обязательно внесу в пакет поправленный скрипт, но пока ему дам отлежаться сутки-двое, на тот случай, если в нём ещё найдутся ошибки.

    Правильно ли я понимаю, что этот скрипт так же хорошо подойдёт к пакету vpnc? Если да, то это позовлит мне закрыт эту issue.

  12. #1242
    Quote Originally Posted by ryzhov_al View Post
    Правильно ли я понимаю, что этот скрипт так же хорошо подойдёт к пакету vpnc? Если да, то это позовлит мне закрыт эту issue.
    я к сожалению не могу проверить vpnc, так как он не умеет подключаться к VPN серверам с нестандартными портом, как раз таки по этой причине я и стал использовать openconnect. И на сколько я понимаю, vpnc морально устарел, его заменил openconnect, который умеет не только тоже самое, но и на порядок больше.

    Поправьте кто нибудь, если я ошибаюсь. Но думаю что скрипт подойдёт, так он был выдран из vpnc под debian и работает с openconnect. Просто он немного избыточен, в нём есть проверки на gentoo и т.д, но работает нормально.

    И еще openconnect мне внушает больше доверия, так как в исходниках есть такое:
    * Copyright © 2008-2014 Intel Corporation.
    Last edited by Ultras; 19-10-2014 at 17:58.

  13. #1243
    Очередное раз извиняюсь за наглость. Нельзя ли пересобрать nginx с этими дополнительными параметрами:
    --http-uwsgi-temp-path=/opt/var/lib/nginx/uwsgi --http-scgi-temp-path=/opt/var/lib/nginx/scgi
    ИБо сейчас при запуске nginx (думаю что это после обновления до 1.4.7, так как nginx -V не отображает эти параметры, видимо собрано было без учета новых параметров в более новой версии nginx) в папке /opt создаются 2 папки:
    /opt/scgi_temp
    /opt/uwsgi_temp
    А должны быть:
    /opt/var/lib/nginx/uwsgi
    /opt/var/lib/nginx/scgi
    Там же где и body, fastcgi, proxy

    Заранее спасибо.
    Last edited by Ultras; 19-10-2014 at 18:59.

  14. #1244
    Quote Originally Posted by Ultras View Post
    тот скрипт что я дал, там синтаксическая ошибка есть, прикрепляю 100% рабочий и проверенный.
    Обновил, плюс мои правки:
    Code:
    --- ./tmp/vpnc-script   2014-10-19 16:08:28.000000000 +0400
    +++ ./openwrt_trunk/feeds/packages/net/openconnect/files/vpnc-script    2014-10-20 12:10:00.423950471 +0400
    @@ -48,14 +48,14 @@
    
     OS="`uname -s`"
    
    -DEFAULT_ROUTE_FILE=/var/run/vpnc/defaultroute
    -RESOLV_CONF_BACKUP=/var/run/vpnc/resolv.conf-backup
    -FULL_SCRIPTNAME=@PREFIX@/sbin/vpnc
    +DEFAULT_ROUTE_FILE=/opt/var/run/vpnc/defaultroute
    +RESOLV_CONF_BACKUP=/opt/var/run/vpnc/resolv.conf-backup
    +FULL_SCRIPTNAME=/opt/sbin/vpnc
     SCRIPTNAME=`basename $FULL_SCRIPTNAME`
    
     # some systems, eg. Darwin & FreeBSD, prune /var/run on boot
    -if [ ! -d "/var/run/vpnc" ]; then
    -       mkdir -p /var/run/vpnc
    +if [ ! -d "/opt/var/run/vpnc" ]; then
    +       mkdir -p /opt/var/run/vpnc
     fi
    
     # stupid SunOS: no blubber in /usr/local/bin ... (on stdout)
    @PREFIX@ наверное остался от GNU build system.
    Quote Originally Posted by Ultras View Post
    Нельзя ли пересобрать nginx с этими дополнительными параметрами:
    Готово.

  15. #1245
    Огромное спасибо, теперь всё работает как нужно, openconnect подключается сразу же после установки (без ошибок в скрипте), nginx не создаёт левых папок в /opt.

    Ещё раз спасибо за Вашу работу.

Page 83 of 93 FirstFirst ... 33738182838485 ... LastLast

Similar Threads

  1. Replies: 85
    Last Post: 29-01-2019, 09:11
  2. Новый роутер Asus RT-N12 B1/C1/D1/HP/VP
    By Omega in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 148
    Last Post: 03-05-2015, 16:29
  3. Entware MIPS/ARM
    By Omega in forum German Discussion - Deutsch (DE)
    Replies: 3
    Last Post: 31-03-2015, 20:28
  4. Entware MIPS/ARM
    By Omega in forum English Discussion
    Replies: 0
    Last Post: 06-03-2015, 01:42
  5. Есть ли место в репозитории EntWare категории Games ?
    By MercuryV in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 53
    Last Post: 24-11-2014, 02:23

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •