Page 8 of 8 FirstFirst ... 678
Results 106 to 116 of 116

Thread: Mini PCI mod: Asus WL-500gPv1 (WL-500W) с 2.4/5 GHz DualBand

  1. #106
    Не заводится Wi-Fi на прошивке openwrt 14 и openwrt 15 с картой Broadcom 43222 на драйверах kmod-brcm-wl и kmod-b43. В web интерфейсе прошивки luci настроек Wi-Fi нету! Утилита wl не видит адаптер.

    Все драйвера встроены в прошивку, мне кажется карточка должна работать после прошивки.
    Может я чего то не понимаю или забыл? Очень хочется завести 5Ghz.

    Роутер wl500gp v1. На 1.9.2.7-rtn все работает.

  2. #107
    Quote Originally Posted by Crep View Post
    Не заводится Wi-Fi на прошивке openwrt 14 и openwrt 15 с картой Broadcom 43222 на драйверах kmod-brcm-wl и kmod-b43. В web интерфейсе прошивки luci настроек Wi-Fi нету! Утилита wl не видит адаптер.

    Все драйвера встроены в прошивку, мне кажется карточка должна работать после прошивки.
    Может я чего то не понимаю или забыл? Очень хочется завести 5Ghz.

    Роутер wl500gp v1. На 1.9.2.7-rtn все работает.
    а с чего оно должно работать? поддержка только в blob-драйвере.

    openwrt на этом роутере не особо работает, если охота openwrt лучше брать что-то на atheros/arm и помощнее.

  3. #108
    На этой и предыдущей странице Hohmach и dimmer писали что запусти dd-wrt и openwrt данную карточку на 5 ghz.

    Прошивал dd-wrt.v24-15280_NEWD-2_K2.6_mega завелось 5ghz, сканером видно было, но некорректно работало.

    Что такое blob драйвер?

  4. #109
    Quote Originally Posted by Crep View Post
    На этой и предыдущей странице Hohmach и dimmer писали что запусти dd-wrt и openwrt данную карточку на 5 ghz.
    Я собирал прошивку при помощи OpenWrt-ImageBuilder-brcm47xx-for-linux-i486, Attitude Adjustment (r36088).
    С таким профилем:
    Code:
    define Profile/WL500GPv1-test
      NAME:=ASUS WL-500g Premium v1
      PACKAGES:=-wpad-mini -kmod-b43 -kmod-b43legacy -kmod-mac80211 -kmod-cfg80211 kmod-brcm-wl wl wlc nas \
            kmod-usb-core kmod-usb-uhci kmod-usb2 \
            luci luci-i18n-russian \
            luci-app-p910nd \
            luci-app-upnp \
            luci-app-wol \
            luci-app-ddns \
            luci-app-qos
    endef
    
    define Profile/WL500GPv1-test/Description
            Package set optimized for the WL-500g Premium v1 with USB
    endef
    $(eval $(call Profile,WL500GPv1-test))
    хотя возможно профиль был такой:
    Code:
    define Profile/WL500GPv1-my
      NAME:=ASUS WL-500g Premium v1
      PACKAGES:=-wpad-mini kmod-b44 kmod-brcm-wl wlc nas kmod-usb-core kmod-usb-uhci kmod-usb2
    endef
    
    define Profile/WL500GPv1-my/Description
            Package set optimized for the WL-500g Premium v1 with USB
    endef
    $(eval $(call Profile,WL500GPv1-my))
    мой config/wireless:
    Code:
    config wifi-device 'wl0'
    	option type 'broadcom'
    	option channel '157'
    	option txpower '24'
    	option hwmode '11na'
    	option country 'BR'
    
    config wifi-iface
    	option device 'wl0'
    	option network 'lan'
    	option mode 'ap'
    	option ssid 'OpenWrt'
    	option encryption 'psk2+ccmp'
    	option key 'secret'
    config/network:
    Code:
    config switch 'eth0'
    	option name 'switch0'
    	option reset '1'
    	option enable_vlan '0'
    
    config interface 'loopback'
    	option ifname 'lo'
    	option proto 'static'
    	option ipaddr '127.0.0.1'
    	option netmask '255.0.0.0'
    
    config globals 'globals'
    	option ula_prefix 'fd64:b537:a520::/48'
    
    config interface 'lan'
    	option ifname 'eth0'
    	option type 'bridge'
    	option proto 'static'
    	option netmask '255.255.255.0'
    	option ip6assign '60'
    	option ipaddr '192.168.1.20'
    config/system:
    Code:
    config system
    	option hostname 'OpenWrt'
    	option zonename 'Europe/Moscow'
    	option timezone 'MSK-4'
    	option conloglevel '8'
    	option cronloglevel '8'
    
    config timeserver 'ntp'
    	list server '0.openwrt.pool.ntp.org'
    	list server '1.openwrt.pool.ntp.org'
    	list server '2.openwrt.pool.ntp.org'
    	list server '3.openwrt.pool.ntp.org'
    config/ucitrack:
    Code:
    config network
    	option init 'network'
    	list affects 'dhcp'
    	list affects 'radvd'
    
    config wireless
    	list affects 'network'
    
    config olsr
    	option init 'olsrd'
    
    config system
    	option init 'led'
    	list affects 'luci_statistics'
    
    config luci_splash
    	option init 'luci_splash'
    
    config ntpclient
    	option init 'ntpclient'

  5. #110
    поставил пакеты kmod-brcm-wl и wlc. Все завелось в люси появился вай фай. Другие драйвера снес не понимаю зачем они и как они не конфликтуют.

    config/wireless:
    исправил как у вас
    option hwmode '11na'
    и на всякий случай
    option country 'BR'

    Вай фай заводится на 144 мбит 5Ghz вместо 300 мбит . Подключение устройства не происходит.
    И на этом спасибо. Пока помучаю его еще.


    Спустя час:

    Дописал, и завелось на 300 мбит
    option htmode 'HT40+'

    К сожалению подключаться так и не хочет.
    Last edited by Crep; 09-10-2015 at 21:42.

  6. #111
    Пакеты wlc и nas установлены?
    Last edited by Hohmach; 12-10-2015 at 16:08.

  7. #112
    поставил nas и пакеты по ссылке. вай фай вообще пропал. разбираюсь.

  8. #113
    Ссылка была только для пояснения зачем нужен nas, другие пакеты по ссылке не предназначены для авторизации с Broadcom proprietary driver и будут конфликтовать.

  9. #114
    Quote Originally Posted by Hohmach View Post
    Ссылка была только для пояснения зачем нужен nas, другие пакеты по ссылке не предназначены для авторизации с Broadcom proprietary driver и будут конфликтовать.
    На 15 версии openwrt поправлено в лучшую сторону по сравнению с 14. Но процесс соединения по прежнему не идет, не важно в каком стандарте WiFi и частоте. Сканер сети CommView показывает на этой сети множество повторов. Полагаю клиент посылает пакеты, а роутер не отвечает потому что какая то служба не установлена или лишняя.

    Список установленных служб:


    base-files 157-r46767
    busybox 1.23.2-1
    dnsmasq 2.73-1
    dropbear 2015.67-1
    firewall 2015-07-27
    fstools 2015-05-24-09027fc86babc3986027a0e677aca1b6999a9e14
    glib2 2.43.4-1
    hostapd-common 2015-03-25-1
    ip6tables 1.4.21-1
    iptables 1.4.21-1
    iw 3.17-1
    iwinfo 2015-06-01-ade8b1b299cbd5748db1acf80dd3e9f567938371
    jshn 2015-06-14-d1c66ef1131d14f0ed197b368d03f71b964e45f8
    jsonfilter 2014-06-19-cdc760c58077f44fc40adbbe41e1556a67c1b9a9
    kernel 3.18.20-1-f99713dcf1203f329e3362507d296364
    kmod-b43 3.18.20+2015-03-09-3
    kmod-b43legacy 3.18.20+2015-03-09-3
    kmod-brcm-wl 3.18.20+5.10.56.27.3-8
    kmod-cfg80211 3.18.20+2015-03-09-3
    kmod-crypto-aes 3.18.20-1
    kmod-crypto-arc4 3.18.20-1
    kmod-crypto-core 3.18.20-1
    kmod-gpio-button-hotplug 3.18.20-1
    kmod-ip6tables 3.18.20-1
    kmod-ipt-conntrack 3.18.20-1
    kmod-ipt-core 3.18.20-1
    kmod-ipt-nat 3.18.20-1
    kmod-ipv6 3.18.20-1
    kmod-leds-gpio 3.18.20-1
    kmod-ledtrig-default-on 3.18.20-1
    kmod-ledtrig-netdev 3.18.20-1
    kmod-ledtrig-timer 3.18.20-1
    kmod-lib-crc-ccitt 3.18.20-1
    kmod-mac80211 3.18.20+2015-03-09-3
    kmod-nf-conntrack 3.18.20-1
    kmod-nf-conntrack6 3.18.20-1
    kmod-nf-ipt 3.18.20-1
    kmod-nf-ipt6 3.18.20-1
    kmod-nf-nat 3.18.20-1
    kmod-nf-nathelper 3.18.20-1
    kmod-ppp 3.18.20-1
    kmod-pppoe 3.18.20-1
    kmod-pppox 3.18.20-1
    kmod-slhc 3.18.20-1
    libattr 20150220-1
    libblkid 2.25.2-4
    libblobmsg-json 2015-06-14-d1c66ef1131d14f0ed197b368d03f71b964e45f8
    libc 0.9.33.2-1
    libffi 3.0.13-1
    libgcc 4.8-linaro-1
    libip4tc 1.4.21-1
    libip6tc 1.4.21-1
    libiwinfo 2015-06-01-ade8b1b299cbd5748db1acf80dd3e9f567938371
    libiwinfo-lua 2015-06-01-ade8b1b299cbd5748db1acf80dd3e9f567938371
    libjson-c 0.12-1
    libjson-script 2015-06-14-d1c66ef1131d14f0ed197b368d03f71b964e45f8
    liblua 5.1.5-1
    libmount 2.25.2-4
    libncurses 5.9-2
    libnl-tiny 0.1-4
    libpthread 0.9.33.2-1
    librpc 2015-04-10-308e9964bfb623773dc0dcc99ef9d18d1551d6ae
    libubox 2015-06-14-d1c66ef1131d14f0ed197b368d03f71b964e45f8
    libubus 2015-05-25-f361bfa5fcb2daadf3b160583ce665024f8d108e
    libubus-lua 2015-05-25-f361bfa5fcb2daadf3b160583ce665024f8d108e
    libuci 2015-04-09.1-1
    libuci-lua 2015-04-09.1-1
    libuuid 2.25.2-4
    libxtables 1.4.21-1
    lua 5.1.5-1
    luci git-15.245.46763-b179283-1
    luci-app-firewall git-15.245.46763-b179283-1
    luci-base git-15.245.46763-b179283-1
    luci-lib-ip git-15.245.46763-b179283-1
    luci-lib-nixio git-15.245.46763-b179283-1
    luci-mod-admin-full git-15.245.46763-b179283-1
    luci-proto-ipv6 git-15.245.46763-b179283-1
    luci-proto-ppp git-15.245.46763-b179283-1
    luci-theme-bootstrap git-15.245.46763-b179283-1
    mc 4.8.14-1.3
    mtd 21
    nas 5.10.56.27.3-8
    netifd 2015-06-08-8795f9ef89626cd658f615c78c6a17e990c0dcaa
    nvram 9
    odhcp6c 2015-07-13-024525798c5f6aba3af9b2ef7b3af2f3c14f1db8
    odhcpd 2015-05-21-2ebf6c8216287983779c8ec6597d30893b914a7c
    opkg 9c97d5ecd795709c8584e972bfdf3aee3a5b846d-7
    otrx 1
    ppp 2.4.7-6
    ppp-mod-pppoe 2.4.7-6
    procd 2015-08-16-0da5bf2ff222d1a499172a6e09507388676b5a08
    rpcd 2015-05-17-3d655417ab44d93aad56a6d4a668daf24b127b84
    swconfig 10
    terminfo 5.9-2
    ubox 2015-07-14-907d046c8929fb74e5a3502a9498198695e62ad8
    ubus 2015-05-25-f361bfa5fcb2daadf3b160583ce665024f8d108e
    ubusd 2015-05-25-f361bfa5fcb2daadf3b160583ce665024f8d108e
    uci 2015-04-09.1-1
    uhttpd 2015-08-17-f91788b809d9726126e9cf4384fedbbb0c5b8a73
    uhttpd-mod-ubus 2015-08-17-f91788b809d9726126e9cf4384fedbbb0c5b8a73
    usign 2015-05-08-cf8dcdb8a4e874c77f3e9a8e9b643e8c17b19131
    wireless-tools 29-5
    wlc 5.10.56.27.3-8
    wpad-mini 2015-03-25-1
    zlib 1.2.8-1
    Last edited by Crep; 16-10-2015 at 20:04.

  10. #115
    wpad-mini и hostapd-common явно лишние.

  11. #116
    Удаление wpad-mini решило проблему. Спасибо за помощь.

    А hostapd-common удаляется вместе и kmod-mac80211 и еще каким то пакетом, без него ни как.

    Соединение происходит на новой 5Ghz частоте работает. Но скорость 3,5 мегабайта максимум ( , повторы в сети WiFi идут, но их меньше.

    Подведем итоги: необходимо установить драйвер kmod-brcm-wl, его управляющую утилиту wlc. wpad-mini удалить и заменить пакетом nas.

Page 8 of 8 FirstFirst ... 678

Similar Threads

  1. Блок питания Asus WL-500gPv1/W - ремонт и замена
    By alexanderm in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 374
    Last Post: 25-09-2019, 16:06
  2. Mini PCI-e mod: Asus RT-N16 с 256MB RAM и 2.4/5 GHz DualBand
    By Omega in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 66
    Last Post: 15-09-2018, 08:21
  3. Mini PCI mod: делаем из WL-500gPv1 WL-500W и получаем Wi-Fi N !
    By slava in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 294
    Last Post: 17-06-2017, 19:37
  4. Replies: 141
    Last Post: 08-04-2014, 10:32
  5. Asus PCE-AC66 802.11ac PCIe Adapter & RT-AC66U Router
    By Omega in forum German Discussion - Deutsch (DE)
    Replies: 4
    Last Post: 26-08-2013, 08:58

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •