Results 1 to 3 of 3

Thread: Problem with 1.9.2.7-d-r2624 and FTP server

  1. #1

    Question [SOLVED] Problem with 1.9.2.7-d-r2624 and FTP server access from WAN

    Hello!
    I'm using a WL-500gP V2 with 1.9.2.7-d-r2624 custom firmware. My problem is: I cannot access the FTP server from the WAN (connection refused to port 21).

    I read a lot of posts here in the forum about problem accessing the FTP server from the WAN, but with no luck.

    First of all, my configuration:
    - FTP server enabled
    - FTP port 21
    I can correctly access the FTP server from LAN, while I cannot from WAN: connection refused. Using port checking services like canyouseeme.org and checking port 21, it seems to be closed. Connecting to an external server (that is, a system I have access to which is outside of my LAN and which I connect to through the Internet) through SSH and trying a telnet to my router to port 21, I get a connection refused.
    So, this is not a problem of FTP listing or such (as I read in some messages of this forum), but the service is not reachable at all.
    Please note that with the original Asus firmware I could reach the FTP server from WAN with no problems.

    Other information:
    - I do not have any exposed address in the Virtual DMZ: I read a post here saying that having an address there makes the FTP server unreachable from the WAN - that's not my case
    - I enabled "Respond Ping Request from WAN?", since I read a message from Oleg saying that it's needed to access the FTP server from WAN
    - I disabled the brute force protection for FTP Server, just to make sure it isn't interfering in my case
    - I already tried to add some rules to my enabled virtual server, but with no luck... I tried all of the following, one by one:
    Code:
    Port Range | Local IP   | Local port | Protocol
    20:21 | 127.0.0.1 | (empty) | TCP
    20:21 | 192.168.1.1 (which is the LAN address of my WL-500gP V2) | (empty) | TCP
    20:21 | 192.168.2.2 (which is the WAN address of my WL-500gP V2) | (empty) | TCP
    - on the WAN side of my WL-500gP V2 I have another router, which is already redirecting ports 20 and 21 to the WL-500gP V2; as I already said, I had no problem with the original Asus firmware and also I have no problem if I redirect those ports to another device in my LAN (behing the WL-500gP V2) which is serving FTP; so it must be a problem in the WL-500gP V2 configuration, not in my WAN router

    Some diagnostic info from my router follows (see the first reply).

    Any help would be really appreciated.
    Thanks!
    Last edited by mauromol; 02-09-2011 at 09:06.

  2. #2
    Some diagnostic info:

    (removed)
    Last edited by mauromol; 02-09-2011 at 08:58.

  3. #3

    Thumbs up

    I solved my problem!

    Looking at the "Port Forwarding" page of the "Status & Log" section of the web interface, I noticed that port 21 was redirected to the NAS I have on my LAN. However, no Virtual Server entry was supplying that port forwarding. So, I checked my NAS (which, by the way, had the FTP server disabled) and I discovered that the following option was enabled: use UPnP for web and FTP access. After I disabled that option, port 21 was not redirected to the NAS anymore in my WL-500gP V2 and I could finally connect to my router own FTP server from the WAN too.

    So, the UPnP was supplying a port forwarding rule which was in some way overriding what I was configuring through the Virtual Server.

    By the way, right now my FTP access is working without the need to have any entry in the Virtual Server configuration page (so enabling the FTP server in the WL-500gP V2 is enough to make it accessible from both LAN & WAN).

    I hope this could be of help to anyone.

    Mauro

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •