Results 1 to 5 of 5

Thread: dnsmasq running, and caching...how do I disable that?

  1. #1

    dnsmasq running, and caching...how do I disable that?

    Hi

    I have been looking around in my settings, and I see no reason why dnsmasq is running on the server.

    It is caching DNS entries way too long and my internal LAN seems not to be able to bypass this cache..

    How do I make sure it is not started upon boot ?

    /macsat
    macsat
    http://www.macsat.com - Tutorials and information on using ASUS WL-500G and family.

  2. #2
    In /usr/local/sbin/post-boot put the line:
    killall dnsmasq

    But the dnsmasq program is also functioning as DHCP server, so if you want DHCP, you should find another server for it

  3. #3
    Join Date
    Nov 2003
    Location
    Eindhoven
    Posts
    2,407
    or just enter another IP address for DNS server ?

    My little Asus Collection: Too much to fit inhere, my 2 babies:WL500w 1.9.2.7-10(OLEG) VX2SE Yellow Lamborghini notebook



    WL500g Forum Asus Files OpenDir

    Asusforum.NL -- Asusforum.DE -- Asusforum.RU -- Asusforum.PL -- Asusforum.NET -- Asusforum.EU -- Asusforum.BE -- Asusforum.ES -- Asusforum.INFO

  4. #4
    Sure - I can manually put the "correct" DNS server for my own PC's in my network....

    But what if I then bring my laptop to another location? And what if someone brings their laptop?

    What I want, is to disable the DNS function of the ASUS, or at least find a way to flush the cache of the build in DNS server.

    It sucks big time that it caches for hours and hours....

    ....and yes - as "someone" wrote, I did notice that DHCP is disabled when killing dnsmasq, that is why I didnt use that technique before :-)

    macsat
    macsat
    http://www.macsat.com - Tutorials and information on using ASUS WL-500G and family.

  5. #5
    Hi, try to read the man pages:
    http://www.thekelleys.org.uk/dnsmasq...smasq-man.html
    It is possible to adjust cache size using parameter -c XX, XX=0 means no caching. My suggestion is to tweak the wl500g to start with this param directly or make killall dnsmasq in post-boot and immediatelly start dnsmasq with parameters You want incl. -c 0

    Good Luck!

Similar Threads

  1. dnsmasq acting as DNS server?
    By frank_c_bauer in forum WL-500g Q&A
    Replies: 5
    Last Post: 03-11-2005, 01:37
  2. How do I disable the built-in caching DNS server?
    By madoka in forum WL-500g Q&A
    Replies: 3
    Last Post: 21-03-2005, 17:18
  3. 1.7.5.6-2 /init/rc.dnsmasq
    By mdounin in forum WL-500g Custom Development
    Replies: 1
    Last Post: 02-05-2004, 20:54
  4. New firmware - dnsmasq
    By Oleg in forum WL-500g Custom Development
    Replies: 6
    Last Post: 20-03-2004, 11:23

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •